bzr-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. # All package versioning is found here:
  3. # the actual version is composed from these below, including leading 0 for release candidates
  4. # bzrmajor: main bzr version
  5. # Version: bzr version, add subrelease version here
  6. # bzrrc: release candidate version, if any, line starts with % for rc, # for stable releas (no %).
  7. # release: rpm subrelease (0.N for rc candidates, N for stable releases)
  8. %define bzrmajor 2.2.2
  9. #define bzrrc rc1
  10. %define release 1
  11. # Magics to get the dots in Release string correct per the above
  12. %define subrelease %{?bzrrc:.}%{?bzrrc}
  13. Name: bzr
  14. Version: %{bzrmajor}
  15. Release: %{release}%{?subrelease}%{?_dist_release}
  16. Summary: Friendly distributed version control system
  17. Summary(ja): bzr - 分散型バージョン管理システム
  18. Group: Development/Tools
  19. License: GPLv2+
  20. URL: http://www.bazaar-vcs.org/
  21. Source0: https://launchpad.net/%{name}/%{bzrmajor}/%{version}%{?bzrrc}/+download/%{name}-%{version}%{?bzrrc}.tar.gz
  22. Source1: https://launchpad.net/%{name}/%{bzrmajor}/%{version}%{?bzrrc}/+download/%{name}-%{version}%{?bzrrc}.tar.gz.sig
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  24. BuildRequires: python-devel zlib-devel
  25. # We're using an old version of Pyrex, use the pregenerated C files instead
  26. # of rebuilding
  27. #BuildRequires: Pyrex
  28. Requires: python-paramiko
  29. # Workaround Bug #230223 otherwise this would be a soft dependency
  30. Requires: python-pycurl
  31. # ElementTree is part of python2.5 on FC7+
  32. # This is also needed for EL-5
  33. #if 0%{?fedora} <= 6
  34. #BuildRequires: python-elementtree
  35. #Requires: python-elementtree
  36. #endif
  37. %description
  38. Bazaar is a distributed revision control system that is powerful, friendly,
  39. and scalable. It is the successor of Baz-1.x which, in turn, was
  40. a user-friendly reimplementation of GNU Arch.
  41. %prep
  42. %setup -q -n %{name}-%{version}%{?bzrrc}
  43. sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/_patiencediff_py.py
  44. sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/weave.py
  45. %build
  46. CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
  47. chmod a-x contrib/bash/bzrbashprompt.sh
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. %{__python} setup.py install --skip-build --install-data %{_datadir} --root $RPM_BUILD_ROOT
  51. chmod 0644 contrib/bzr_access
  52. chmod 0644 contrib/bzr_ssh_path_limiter
  53. chmod 0755 $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/*.so
  54. install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
  55. install -m 0644 contrib/bash/bzr $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
  56. rm contrib/bash/bzr
  57. # This is included in %doc, remove redundancy here
  58. #rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/doc/
  59. # Use independently packaged python-elementtree instead
  60. rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/util/elementtree/
  61. %clean
  62. rm -rf $RPM_BUILD_ROOT
  63. %files
  64. %defattr(-,root,root,-)
  65. %doc NEWS README TODO COPYING.txt doc/ contrib/
  66. %{_bindir}/bzr
  67. %{_mandir}/man1/*
  68. %{python_sitearch}/bzrlib/
  69. %{_sysconfdir}/bash_completion.d/
  70. #if 0%{?fedora} > 8
  71. %{python_sitearch}/*.egg-info
  72. #endif
  73. %changelog
  74. * Sun Dec 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
  75. - new upstream release
  76. * Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 1.17-2
  77. - rebuilt with python-2.6
  78. * Thu Aug 6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
  79. - initial build for VineSeed
  80. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-2
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  82. * Mon Jul 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-1
  83. - Upgade to 1.17
  84. * Mon Jul 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-0.1
  85. - Update to 1.17rc1
  86. * Fri Jun 26 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16.1-1
  87. - Update to 1.16.1
  88. * Thu Jun 18 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16-1
  89. - Update to 1.16
  90. * Wed Jun 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15.1-1
  91. - Update to 1.15.1
  92. * Sat May 23 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-2
  93. - Update to 1.15final
  94. * Sat May 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-0.1
  95. - Update to 1.15rc1
  96. * Sat May 02 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14.1-1
  97. - Update to 1.14.1
  98. * Wed Apr 29 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-1
  99. - Update to 1.14
  100. * Mon Apr 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.3.rc2
  101. - Update to 1.14rc2
  102. * Sat Apr 11 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.2.rc1
  103. - Correct build dependencies
  104. * Thu Apr 09 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.1.rc1
  105. - Update to 1.14rc1
  106. * Tue Mar 24 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13.1-1
  107. - Update to 1.13.1
  108. * Mon Mar 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-1
  109. - Update to 1.13
  110. * Tue Mar 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-0.1.rc1
  111. - Update to 1.13rc1
  112. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  114. * Fri Feb 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-1
  115. - Update to 1.12
  116. * Tue Feb 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-0.1.rc1
  117. - Update to 1.12rc1
  118. * Mon Jan 19 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.11-1
  119. - Update to 1.11
  120. * Wed Dec 10 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.10-1
  121. - Update to 1.10
  122. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.9-2
  123. - Rebuild for Python 2.6
  124. * Thu Nov 13 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.9-1
  125. - Update to 1.9
  126. * Thu Sep 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-1
  127. - 1.7 Final
  128. * Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-0.1.rc2
  129. - 1.7rc2
  130. - Remove executable permission from a %%doc file
  131. * Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.6.1-0.1.rc2
  132. - New upstream bugfix release.
  133. * Thu May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
  134. - Upload tarball.
  135. * Wed May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-1
  136. - Update to 1.5.
  137. * Thu May 15 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-2
  138. - Workaround upstream Bug# 230223 by Requiring python-pycurl.
  139. * Mon May 5 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-1
  140. - Update to 1.4.
  141. * Sun Apr 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-1
  142. - Paramiko/sftp backport from 1.4.0. bz#444325
  143. - Update to 1.3.1 final.
  144. * Sat Apr 4 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-0.1.rc1
  145. - Update to 1.3.1rc1 to fix a bug when you have a pack based remote repo and
  146. knit based local branch.
  147. * Wed Mar 26 2008 Warren Togami <wtogami@redhat.com> - 1.3-1
  148. - Update to 1.3.
  149. * Mon Feb 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.2-1
  150. - Update to 1.2.
  151. * Fri Feb 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.1-2
  152. - Rebuild for new gcc.
  153. * Mon Jan 21 2008 Toshio Kuratomi <a.badger@gmail.com> - 1.1-1
  154. - Upstream 1.1 bugfix and performance enhancement release.
  155. - Enable bash completion script from the contrib directory.
  156. * Thu Dec 13 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-1
  157. - Update to 1.0 final.
  158. * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc3
  159. - Update to 1.0rc3
  160. - The new rawhide python package generates egg-info files.
  161. * Fri Nov 30 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc2
  162. - Update to 1.0rc2
  163. * Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.91-1
  164. - Update to 0.91.
  165. + Fixes some issues with using tag-enabled branches.
  166. * Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-1
  167. - Update to 0.90
  168. * Mon Aug 27 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-0.1.rc1
  169. - Update to 0.90rc1.
  170. - 0.90 contains some pyrex code to speed things up. bzr is now arch specific.
  171. - Update license tag.
  172. * Wed Jul 25 2007 Warren Togami <wtogami@redhat.com> - 0.18-1
  173. - Update to 0.18.
  174. * Tue Jun 26 2007 Warren Togami <wtogami@redhat.com> - 0.17-2
  175. - Update to 0.17.
  176. * Tue May 08 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.16-1
  177. - Update to 0.16.
  178. * Thu Mar 22 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.15-1
  179. - Update to 0.15.
  180. - Simplify the %%files list.
  181. * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.14-1
  182. - Update to 0.14
  183. * Sun Dec 10 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-2
  184. - Conditionalize the python-elementtree requires as python2.5 in FC7 includes
  185. elementtree
  186. * Wed Dec 6 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-1
  187. - Update to 0.13
  188. * Thu Oct 30 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.12-1
  189. - Update to 0.12
  190. * Thu Oct 08 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.11-1
  191. - Update to 0.11
  192. - New download location.
  193. * Sun Sep 17 2006 Warren Togami <wtogami@redhat.com> 0.10-1
  194. - 0.10
  195. * Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.9-1
  196. - Update to new upstream
  197. * Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.8.2-3
  198. - Include, don't ghost .pyo files per new guidelines
  199. * Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.8.2-2
  200. - Require python-paramiko for sftp support
  201. * Tue May 23 2006 Shahms E. King <shahms@shahms.com> 0.8.2-1
  202. - Update to new upstream version
  203. - Fix dist tag
  204. * Wed May 10 2006 Shahms E. King <shahms@shahms.com> 0.8-1
  205. - Update to new upstream version
  206. - Update bzr-sys-etree.patch for changes
  207. * Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-3
  208. - Add python-elementtree to BuildRequires
  209. * Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-2
  210. - Add dist tag
  211. * Fri Feb 10 2006 Shahms E. King <shahms@shahms.com> 0.7-1
  212. - Update to 0.7
  213. * Thu Jan 26 2006 Shahms E. King <shahms@shahms.com> 0.6.2-2
  214. - Fix system library patch
  215. * Wed Dec 07 2005 Shahms E. King <shahms@shahms.com> 0.6.2-1
  216. - Initial package