gcdemu-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %global python_module_name gcdemu
  3. Summary: A GNOME panel applet to control CDEmu daemon
  4. Summary: CDEmu daemon を制御するための GNOME パネルアプレット
  5. Name: gcdemu
  6. Version: 1.5.0
  7. Release: 1%{?_dist_release}
  8. License: GPLv2+
  9. Group: Applications/Accessories
  10. URL: http://cdemu.sourceforge.net
  11. Source: http://downloads.sourceforge.net/cdemu/%{name}-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: dbus-python-devel
  15. BuildRequires: gettext
  16. BuildRequires: glib2-devel
  17. BuildRequires: intltool >= 0.21
  18. #BuildRequires: gnome-panel-devel
  19. #BuildRequires: gnome-python-devel
  20. BuildRequires: perl-XML-Parser
  21. #BuildRequires: pygtk2-devel >= 2.6
  22. BuildRequires: python-devel
  23. #BuildRequires: gnome-doc-utils >= 0.3.2
  24. Requires: dbus-python >= 0.80
  25. Requires: pygobject3
  26. Requires: cdemu-daemon
  27. #Requires: gnome-python-applet
  28. #Requires: hicolor-icon-theme
  29. #Requires: pygtk2 >= 2.6
  30. #Requires(pre): GConf2
  31. #Requires(post): GConf2
  32. #Requires(preun): GConf2
  33. Requires(post): scrollkeeper
  34. Requires(postun): scrollkeeper
  35. %description
  36. This is gCDEmu, a GNOME applet for controlling CDEmu daemon. It is part of the
  37. userspace-cdemu suite, a free, GPL CD/DVD-ROM device emulator for linux.
  38. It provides a graphic interface that allows performing the key tasks related to
  39. controlling the CDEmu daemon, such as loading and unloading devices, displaying
  40. devices' status and retrieving/setting devices' debug masks.
  41. In addition, applet listens to the signals emitted by CDEmu daemon and provides
  42. the notification via libnotify's notifications (provided that python bindings
  43. are installed).
  44. %prep
  45. %setup -q
  46. %build
  47. %{configure}
  48. %{__make} %{?_smp_mflags}
  49. %install
  50. %{__rm} -rf $RPM_BUILD_ROOT
  51. #export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  52. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  53. #unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  54. %find_lang gcdemu --with-gnome
  55. %clean
  56. %{__rm} -rf $RPM_BUILD_ROOT
  57. %pre
  58. #if [ "$1" -gt 1 ]; then
  59. # export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  60. # gconftool-2 --makefile-uninstall-rule \
  61. # %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  62. #fi
  63. glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  64. %post
  65. scrollkeeper-update -q
  66. #export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  67. #gconftool-2 --makefile-install-rule \
  68. # %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  69. glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  70. %preun
  71. #if [ "$1" -eq 0 ]; then
  72. # export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  73. # gconftool-2 --makefile-uninstall-rule \
  74. # %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  75. #fi
  76. glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  77. %postun
  78. scrollkeeper-update -q
  79. %files -f gcdemu.lang
  80. %defattr(-,root,root,-)
  81. %doc AUTHORS ChangeLog COPYING NEWS README
  82. %{_bindir}/%{name}
  83. %{_datadir}/applications/*
  84. %{_datadir}/glib-2.0/schemas/apps.gcdemu.gschema.xml
  85. %{_datadir}/pixmaps/*
  86. #%{_datadir}/omf/gcdemu/gcdemu-C.omf
  87. #%{_libdir}/bonobo/servers/*
  88. #%{_libexecdir}/*
  89. #%dir %{python_sitelib}/%{python_module_name}/
  90. #%{python_sitelib}/%{python_module_name}/*.py*
  91. #%{_sysconfdir}/gconf/schemas/*
  92. %changelog
  93. * Sun May 06 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
  94. - new upstream release
  95. - changed atchive type gzip to bzip2
  96. - deleted unrecognized option: --disable-schemas-install
  97. * Sat Dec 24 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.0-1
  98. - new upstream release
  99. - fixed configure option
  100. - deleted --disable-scrollkeeper
  101. * Fri Nov 19 2010 IWAI, Masaharu <iwai@alib.jp> - 1.3.0-2
  102. - add BuildRequires: gnome-doc-utils >= 0.3.2
  103. * Fri Sep 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
  104. - new upstream release
  105. * Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
  106. - rebuilt with python-2.6.4
  107. * Fri Sep 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
  108. - initial build for VineSeed
  109. * Sat Jun 28 2008 Rok Mandeljc <rok.mandeljc@email.si> - 1.1.0-1
  110. - Updated to 1.1.0
  111. * Thu Dec 20 2007 Rok Mandeljc <rok.mandeljc@email.si> - 1.0.0-1
  112. - Initial RPM release.