123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548 |
- # Build options:
- #
- # --with doxygen
- # The doxygen docs are HUGE, so they are not built by default.
- %define build_apidoc %{?_with_doxygen:1}%{!?_with_doxygen:0}
- Name: llvm
- Version: 3.0
- Release: 1%{?_dist_release}
- Summary: The Low Level Virtual Machine
- Summary(ja): LLVM - 低レベルバーチャルマシン
- Group: Development/Languages
- License: NCSA
- URL: http://llvm.org/
- Source0: http://llvm.org/releases/%{version}/llvm-%{version}.tar.gz
- Source1: http://llvm.org/releases/%{version}/clang-%{version}.tar.gz
- # multilib fixes
- Source2: llvm-Config-config.h
- Source3: llvm-Config-llvm-config.h
- # Data files should be installed with timestamps preserved
- Patch0: llvm-2.6-timestamp.patch
- # workaround for http://llvm.org/bugs/show_bug.cgi?id=11177
- Patch1: llvm-3.0-fix11177.patch
- # fix bug 9798 - Linker flags fail / can't find crtbegin.o
- # http://llvm.org/bugs/show_bug.cgi?id=9798
- Patch2: clang-3.0-fix9798.patch
- # Vine Patch
- Patch3: llvm-3.0-fixLLVMgold.patch
- Patch4: clang-3.0-driver-ld.gold.patch
- Patch5: clang-3.0-driver-lib64.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: binutils-devel
- BuildRequires: bison
- BuildRequires: chrpath
- BuildRequires: flex
- BuildRequires: gcc-c++ >= 3.4
- BuildRequires: groff
- BuildRequires: libffi-devel
- BuildRequires: libtool-ltdl-devel
- BuildRequires: ocaml
- # for DejaGNU test suite
- BuildRequires: dejagnu tcl python
- %if %{build_apidoc}
- BuildRequires: doxygen graphviz
- %endif
- Requires: llvm-libs = %{version}-%{release}
- # LLVM is not supported on PPC64
- # http://llvm.org/bugs/show_bug.cgi?id=3729
- ExcludeArch: ppc64
- %description
- LLVM is a compiler infrastructure designed for compile-time,
- link-time, runtime, and idle-time optimization of programs from
- arbitrary programming languages. The compiler infrastructure includes
- mirror sets of programming tools as well as libraries with equivalent
- functionality.
- %package devel
- Summary: Libraries and header files for LLVM
- Summary(ja): LLVM のライブラリおよびヘッダファイル
- Group: Development/Languages
- Requires: %{name} = %{version}-%{release}
- Requires: libstdc++-devel
- Requires: libffi-devel
- Provides: llvm-static = %{version}-%{release}
- %description devel
- This package contains library and header files needed to develop new
- native programs that use the LLVM infrastructure.
- %package doc
- Summary: Documentation for LLVM
- Summary(ja): LLVM のドキュメント
- Group: Documentation
- Requires: %{name} = %{version}-%{release}
- %description doc
- Documentation for the LLVM compiler infrastructure.
- %package libs
- Summary: LLVM shared libraries
- Summary(ja): LLVM シェアードライブラリ
- Group: System Environment/Libraries
- %description libs
- Shared libraries for the LLVM compiler infrastructure.
- %package -n clang
- Summary: A C language family front-end for LLVM
- Summary(ja): LLVM の C 言語用フロントエンド
- License: NCSA
- Group: Development/Languages
- %description -n clang
- clang: noun
- 1. A loud, resonant, metallic sound.
- 2. The strident call of a crane or goose.
- 3. C-language family front-end toolkit.
- The goal of the Clang project is to create a new C, C++, Objective C
- and Objective C++ front-end for the LLVM compiler. Its tools are built
- as libraries and designed to be loosely-coupled and extensible.
- %package -n clang-devel
- Summary: Header files for clang
- Summary(ja): clang のヘッダファイル
- Group: Development/Languages
- Requires: clang = %{version}-%{release}
- %description -n clang-devel
- This package contains header files for the Clang compiler.
- %package -n clang-analyzer
- Summary: A source code analysis framework
- Summary(ja): ソースコー分析フレームワーク
- License: NCSA
- Group: Development/Languages
- Requires: clang = %{version}-%{release}
- # not picked up automatically since files are currently not instaled
- # in standard Python hierarchies yet
- Requires: python
- %description -n clang-analyzer
- The Clang Static Analyzer consists of both a source code analysis
- framework and a standalone tool that finds bugs in C and Objective-C
- programs. The standalone tool is invoked from the command-line, and is
- intended to run in tandem with a build of a project or code base.
- %package -n clang-doc
- Summary: Documentation for Clang
- Summary(ja): Clang のドキュメント
- Group: Documentation
- Requires: %{name} = %{version}-%{release}
- %description -n clang-doc
- Documentation for the Clang compiler front-end.
- %if %{build_apidoc}
- %package apidoc
- Summary: API documentation for LLVM
- Summary(ja): LLVM の API ドキュメント
- Group: Development/Languages
- Requires: %{name}-docs = %{version}-%{release}
- %description apidoc
- API documentation for the LLVM compiler infrastructure.
- %endif
- %package ocaml
- Summary: OCaml binding for LLVM
- Summary(ja): LLVM の OCaml バインディング
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: ocaml
- %description ocaml
- OCaml binding for LLVM.
- %package ocaml-devel
- Summary: Development files for %{name}-ocaml
- Summary(ja): %{name}-ocaml の開発ファイル
- Group: Development/Libraries
- Requires: %{name}-devel = %{version}-%{release}
- Requires: %{name}-ocaml = %{version}-%{release}
- Requires: ocaml
- %description ocaml-devel
- The %{name}-ocaml-devel package contains libraries and signature files
- for developing applications that use %{name}-ocaml.
- %package ocaml-doc
- Summary: Documentation for %{name}-ocaml
- Summary(ja): %{name}-ocaml のドキュメント
- Group: Documentation
- Requires: %{name}-ocaml = %{version}-%{release}
- %description ocaml-doc
- HTML documentation for LLVM's OCaml binding.
- %prep
- %setup -q -n llvm-%{version}.src -a1 %{?_with_gcc:-a2}
- mv clang-%{version}.src tools/clang
- # llvm patches
- %patch0 -p1 -b .timestamp
- %patch1 -p1 -b .fix11177
- %patch3 -p1 -b .fixLLVMgold
- # clang patches
- pushd tools/clang
- %patch2 -p1 -b .fix9798
- %patch4 -p1 -b .ldgold
- %ifarch x86_64
- %patch5 -p1 -b .lib64
- %endif
- popd
- # Encoding fix
- #(cd tools/clang/docs && \
- # iconv -f ISO88591 -t UTF8 BlockImplementation.txt \
- # -o BlockImplementation.txt)
- %build
- # explicitly supply CC and CXX when running 'configure'
- # http://llvm.org/bugs/show_bug.cgi?id=9472
- export CC=/usr/bin/gcc; export CXX=/usr/bin/g++
- # Disabling assertions now, rec. by pure and needed for OpenGTL
- # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
- %configure \
- --prefix=%{_prefix} \
- --libdir=%{_libdir}/%{name} \
- --datadir=%{_libdir}/%{name} \
- %if %{?_with_doxygen:1}%{!?_with_doxygen:0}
- --enable-doxygen \
- %endif
- --enable-targets=host \
- --disable-assertions \
- --enable-jit \
- --enable-libffi \
- --enable-shared \
- --with-binutils-include=%{_includedir} --enable-pic \
- # --with-c-include-dirs=%{_includedir}:$(find %{_prefix}/lib/gcc/*/* \
- # -maxdepth 0 -type d)/include \
- #%if %{__isa_bits} == 64
- # --with-cxx-include-32bit-dir=32 \
- #%endif
- # --with-cxx-include-root=$(find %{_includedir}/c++/* -maxdepth 0 -type d) \
- # --with-cxx-include-arch=%{_target_cpu}-%{_vendor}-%{_os}
-
- # FIXME file this
- # configure does not properly specify libdir
- sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config
- make %{_smp_mflags} REQUIRES_RTTI=1 \
- OPTIMIZE_OPTION="%{optflags}"
- %install
- rm -rf %{buildroot}
- make install DESTDIR=%{buildroot} \
- PROJ_docsdir=/moredocs
- # multilib fixes
- mv %{buildroot}%{_bindir}/llvm-config{,-%{__isa_bits}}
- pushd %{buildroot}%{_includedir}/llvm/Config
- mv config.h config-%{__isa_bits}.h
- cp -p %{SOURCE2} config.h
- mv llvm-config.h llvm-config-%{__isa_bits}.h
- cp -p %{SOURCE3} llvm-config.h
- popd
- # Create ld.so.conf.d entry
- mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
- cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
- %{_libdir}/llvm
- EOF
- # Static analyzer not installed by default:
- # http://clang-analyzer.llvm.org/installation#OtherPlatforms
- mkdir -p %{buildroot}%{_libdir}/clang-analyzer
- # create launchers
- for f in scan-{build,view}; do
- ln -s %{_libdir}/clang-analyzer/$f/$f %{buildroot}%{_bindir}/$f
- done
- (cd tools/clang/tools && cp -pr scan-{build,view} \
- %{buildroot}%{_libdir}/clang-analyzer/)
- # Move documentation back to build directory
- #
- pwd
- mv %{buildroot}/moredocs .
- rm -f moredocs/*.tar.gz
- rm -f moredocs/ocamldoc/html/*.tar.gz
- # and separate the apidoc
- %if %{build_apidoc}
- mv moredocs/html/doxygen apidoc
- mv tools/clang/docs/doxygen/html clang-apidoc
- %endif
- # And prepare Clang documentation
- #
- mkdir clang-docs
- for f in LICENSE.TXT NOTES.txt README.txt; do
- ln tools/clang/$f clang-docs/
- done
- rm -rf tools/clang/docs/{doxygen*,Makefile*,*.graffle,tools}
- #find %%{buildroot} -name .dir -print0 | xargs -0r rm -f
- file %{buildroot}/%{_bindir}/* | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
- file %{buildroot}/%{_libdir}/llvm/*.so | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
- #chrpath -d %%{buildroot}/%%{_libexecdir}/clang-cc
- # Get rid of erroneously installed example files.
- rm %{buildroot}%{_libdir}/%{name}/*LLVMHello.*
- # FIXME file this bug
- sed -i 's,ABS_RUN_DIR/lib",ABS_RUN_DIR/%{_lib}/%{name}",' \
- %{buildroot}%{_bindir}/llvm-config-%{__isa_bits}
- chmod -x %{buildroot}%{_libdir}/%{name}/*.a
- # remove documentation makefiles:
- # they require the build directory to work
- find examples -name 'Makefile' | xargs -0r rm -f
- %check
- make check 2>&1 | tee ../llvm-testlog.txt
- make -C tools/clang/test 2>&1 | tee ../llvm-testlog.txt
- %clean
- rm -rf %{buildroot}
- %post libs -p /sbin/ldconfig
- %post -n clang -p /sbin/ldconfig
- %postun libs -p /sbin/ldconfig
- %postun -n clang -p /sbin/ldconfig
- %posttrans devel
- # link llvm-config to the platform-specific file;
- # use ISA bits as priority so that 64-bit is preferred
- # over 32-bit if both are installed
- alternatives \
- --install \
- %{_bindir}/llvm-config \
- llvm-config \
- %{_bindir}/llvm-config-%{__isa_bits} \
- %{__isa_bits}
- %postun devel
- if [ $1 -eq 0 ]; then
- alternatives --remove llvm-config \
- %{_bindir}/llvm-config-%{__isa_bits}
- fi
- exit 0
- %files
- %defattr(-,root,root,-)
- %doc CREDITS.TXT LICENSE.TXT README.txt
- %{_bindir}/bugpoint
- %{_bindir}/llc
- %{_bindir}/lli
- %exclude %{_bindir}/llvm-config-%{__isa_bits}
- %{_bindir}/llvm*
- %{_bindir}/macho-dump
- %{_bindir}/opt
- %exclude %{_mandir}/man1/clang.1.*
- %doc %{_mandir}/man1/*.1.*
- %files devel
- %defattr(-,root,root,-)
- %{_bindir}/llvm-config-%{__isa_bits}
- %{_includedir}/%{name}
- %{_includedir}/%{name}-c
- %{_libdir}/%{name}/*.a
- %files libs
- %defattr(-,root,root,-)
- %config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
- %dir %{_libdir}/%{name}
- %exclude %{_libdir}/%{name}/libclang.so
- %{_libdir}/%{name}/*.so
- %files -n clang
- %defattr(-,root,root,-)
- %doc clang-docs/*
- %{_bindir}/clang*
- %{_libdir}/%{name}/libclang.so
- %{_prefix}/lib/clang
- %doc %{_mandir}/man1/clang.1.*
- %files -n clang-devel
- %defattr(-,root,root,-)
- %{_includedir}/clang
- %{_includedir}/clang-c
- %files -n clang-analyzer
- %defattr(-,root,root,-)
- %{_bindir}/scan-build
- %{_bindir}/scan-view
- %{_libdir}/clang-analyzer
- %files -n clang-doc
- %defattr(-,root,root,-)
- %doc tools/clang/docs/*
- %files doc
- %defattr(-,root,root,-)
- %doc examples moredocs/html
- %files ocaml
- %defattr(-,root,root,-)
- %{_libdir}/ocaml/*.cma
- %{_libdir}/ocaml/*.cmi
- %files ocaml-devel
- %defattr(-,root,root,-)
- %{_libdir}/ocaml/*.a
- %{_libdir}/ocaml/*.cmx*
- %{_libdir}/ocaml/*.mli
- %files ocaml-doc
- %defattr(-,root,root,-)
- %doc moredocs/ocamldoc/html/*
- %if 0%{?_with_doxygen}
- %files apidoc
- %defattr(-,root,root,-)
- %doc apidoc/*
- %files -n clang-apidoc
- %defattr(-,root,root,-)
- %doc clang-apidoc/*
- %endif
- %changelog
- * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
- - updated to 3.0 release
- * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
- - added patch 2-4 to support -O4 link-time optimization
- * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
- - disable -fno-var-tracking-assignments on ppc
- (seems like gcc-4.4.5 still doesn't support this)
- * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
- - new upstream release
- - add BR: libffi-devel
- - add R: libffi-devel to -devel
- * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
- - initial build for Vine Linux
- * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
- - Update to final 2.7 release
- * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
- - Update to first 2.7 pre-release
- * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
- - Update to 2.6 pre-release2
- - -devel subpackage now virtually provides -static
- * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
- - Disable var tracking assignments on PPC
- * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
- - Don't adjust clang include dir; files there are noarch (bz#521893)
- - Enable clang unit tests
- - clang and clang-analyzer renamed; no longer depend on llvm at runtime
- * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
- - Package Clang's static analyzer tools
- * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
- - PIC is now enabled by default; explicitly disable on %%{ix86}
- * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
- - First 2.6 prerelease
- - Enable Clang front-end
- - Enable debuginfo generation
- * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
- - Disable assertions (needed by OpenGTL, bz#521261)
- - Align spec file with upstream build instructions
- - Enable unit tests
- * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
- - Only disable PIC on %%ix86; ppc actually needs it
- * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
- - Disable use of position-independent code on 32-bit platforms
- (buggy in LLVM <= 2.5)
- * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
- - Remove build scripts; they require the build directory to work
- * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
- - Update to 2.5
- - Package build scripts (bug #457881)
- * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
- - Patched build process for the OCaml binding
- * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
- - Update to 2.4
- - Package Ocaml binding
- * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
- - Add dependency on groff
- * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
- - LLVM 2.3
- * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
- - fix license tags
- * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
- - Fix compilation problems with gcc 4.3
- * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
- - Autorebuild for GCC 4.3
- * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
- - Fix review comments
- * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
- - Initial version
|