mate-panel-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257
  1. Summary: The MATE Panel
  2. Name: mate-panel
  3. Version: 1.2.1
  4. Release: 1%{?_dist_release}
  5. Source0: %{name}-%{version}.tar.xz
  6. Source1: vine-mate-panel-default-setup.entries
  7. Patch0: mate-panel-1.2.1-configure.patch
  8. License: GPLv2
  9. Group: User Interface/Desktops
  10. URL: https://matsusoft.com.ar/projects/mate/
  11. BuildRequires: mate-common
  12. BuildRequires: mate-doc-utils
  13. BuildRequires: mate-conf-devel
  14. BuildRequires: mate-desktop-devel
  15. BuildRequires: mate-menus-devel
  16. BuildRequires: libmateweather-devel
  17. BuildRequires: libmatecomponentui-devel
  18. BuildRequires: gtk2-devel
  19. BuildRequires: libSM-devel
  20. BuildRequires: libcanberra-devel
  21. BuildRequires: dbus-glib-devel
  22. BuildRequires: libwnck-devel
  23. BuildRequires: librsvg2-devel
  24. BuildRequires: evolution-data-server-devel
  25. BuildRequires: NetworkManager-devel
  26. BuildRequires: gtk-doc
  27. BuildRequires: autoconf
  28. BuildRequires: automake
  29. Requires(post,pre,preun): mate-conf
  30. Requires(post,postun): desktop-file-utils
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: Takemikaduchi
  35. %description
  36. mate-panel contains the MATE panel, the libmate-panel-applet library and
  37. several applets:
  38. + the MATE panel is the area on your desktop from which you can run
  39. applications and applets, and perform other tasks.
  40. + the libmate-panel-applet library allows to develop small applications
  41. which may be embedded in the panel. These are called applets.
  42. Documentation for the API is available with gtk-doc.
  43. + the applets supplied here include the Workspace Switcher, the Window
  44. List, the Window Selector, the Notification Area, the Clock and the
  45. infamous 'Wanda the Fish'.
  46. %package devel
  47. Summary: Development tools for mate-panel
  48. Summary(ja): mate-panel の開発環境
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: pkgconfig
  52. %description devel
  53. Header files and libraries for building a extension library for the
  54. mate-panel.
  55. %package doc
  56. Summary: Documentation for mate-panel
  57. Summary(ja): mate-panel 用のドキュメント
  58. Group: Documentation
  59. Requires: %{name} = %{version}-%{release}
  60. BuildArch: noarch
  61. %description doc
  62. This package contains documentation for mate-panel.
  63. %prep
  64. %setup -q
  65. %patch0 -p1
  66. cp -f %{SOURCE1} mate-panel/panel-default-setup.entries
  67. %build
  68. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
  69. %configure \
  70. --libexecdir=%{_libexecdir}/mate \
  71. --disable-static \
  72. --disable-scrollkeeper \
  73. --enable-introspection \
  74. --enable-matecomponent
  75. %{__make} %{?_smp_mflags}
  76. %install
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. export MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  79. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  80. unset MATECONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  81. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  82. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  83. %find_lang %{name}
  84. %clean
  85. %{__rm} -rf ${RPM_BUILD_ROOT}
  86. %post
  87. /sbin/ldconfig
  88. export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
  89. SCHEMAS=" \
  90. clock.schemas \
  91. fish.schemas \
  92. panel-compatibility.schemas \
  93. panel-default-setup.entries \
  94. panel-general.schemas \
  95. panel-global.schemas \
  96. panel-object.schemas \
  97. panel-toplevel.schemas \
  98. window-list.schemas \
  99. workspace-switcher.schemas"
  100. for S in $SCHEMAS; do
  101. echo %{_sysconfdir}/mateconf/schemas/$S; done \
  102. | xargs mateconftool-2 --makefile-install-rule >& /dev/null ||:
  103. mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries > /dev/null || :
  104. mateconftool-2 --direct --config-source=$MATECONF_CONFIG_SOURCE --load %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
  105. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  106. touch --no-create %{_datadir}/icons/hicolor
  107. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  108. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  109. fi
  110. %pre
  111. if [ "$1" -gt 1 ]; then
  112. export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
  113. SCHEMAS=" \
  114. clock.schemas \
  115. fish.schemas \
  116. panel-compatibility.schemas \
  117. panel-default-setup.entries \
  118. panel-general.schemas \
  119. panel-global.schemas \
  120. panel-object.schemas \
  121. panel-toplevel.schemas \
  122. window-list.schemas \
  123. workspace-switcher.schemas"
  124. for S in $SCHEMAS; do
  125. echo %{_sysconfdir}/mateconf/schemas/$S; done \
  126. | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
  127. fi
  128. %preun
  129. if [ "$1" -eq 0 ]; then
  130. export MATECONF_CONFIG_SOURCE=`mateconftool-2 --get-default-source`
  131. SCHEMAS=" \
  132. clock.schemas \
  133. fish.schemas \
  134. panel-compatibility.schemas \
  135. panel-default-setup.entries \
  136. panel-general.schemas \
  137. panel-global.schemas \
  138. panel-object.schemas \
  139. panel-toplevel.schemas \
  140. window-list.schemas \
  141. workspace-switcher.schemas"
  142. for S in $SCHEMAS; do
  143. echo %{_sysconfdir}/mateconf/schemas/$S; done \
  144. | xargs mateconftool-2 --makefile-uninstall-rule >& /dev/null ||:
  145. fi
  146. %postun
  147. /sbin/ldconfig
  148. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  149. touch --no-create %{_datadir}/icons/hicolor
  150. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  151. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  152. fi
  153. %files -f %{name}.lang
  154. %defattr(-,root,root,-)
  155. %doc COPYING ChangeLog NEWS README
  156. %{_sysconfdir}/mateconf/schemas/clock.schemas
  157. %{_sysconfdir}/mateconf/schemas/fish.schemas
  158. %{_sysconfdir}/mateconf/schemas/panel-compatibility.schemas
  159. %{_sysconfdir}/mateconf/schemas/panel-default-setup.entries
  160. %{_sysconfdir}/mateconf/schemas/panel-general.schemas
  161. %{_sysconfdir}/mateconf/schemas/panel-global.schemas
  162. %{_sysconfdir}/mateconf/schemas/panel-object.schemas
  163. %{_sysconfdir}/mateconf/schemas/panel-toplevel.schemas
  164. %{_sysconfdir}/mateconf/schemas/window-list.schemas
  165. %{_sysconfdir}/mateconf/schemas/workspace-switcher.schemas
  166. %{_bindir}/mate-desktop-item-edit
  167. %{_bindir}/mate-panel
  168. %{_bindir}/mate-panel-test-applets
  169. %{_bindir}/panel-test-applets-matecomponent
  170. %{_libdir}/libmate-panel-applet-*.so.*
  171. %{_libdir}/girepository-1.0/MatePanelApplet-3.0.typelib
  172. %{_libdir}/mate-panel/modules/libmate-panel-applets-matecomponent.so
  173. %{_libexecdir}/mate/clock-applet
  174. %{_libexecdir}/mate/fish-applet
  175. %{_libexecdir}/mate/mate-panel-add
  176. %{_libexecdir}/mate/notification-area-applet
  177. %{_libexecdir}/mate/wnck-applet
  178. %{_datadir}/applications/mate-panel.desktop
  179. %{_datadir}/dbus-1/services/*.service
  180. %{_datadir}/icons/hicolor/*/*/*
  181. %{_datadir}/idl/mate-panel-2.0/MATE_Panel.idl
  182. %{_datadir}/mate/help
  183. %{_datadir}/mate-2.0/ui/MATE_Panel_Popup.xml
  184. %{_datadir}/mate-panel
  185. %{_datadir}/mate-panelrc
  186. %{_datadir}/omf/mate-applet-clock
  187. %{_datadir}/omf/mate-applet-fish
  188. %{_mandir}/man1/mate-panel.1.gz
  189. %files devel
  190. %defattr(-,root,root,-)
  191. %{_includedir}/mate-panel-3.0/
  192. %{_includedir}/panel-2.0/
  193. %{_libdir}/libmate-panel-applet-*.so
  194. %{_libdir}/pkgconfig/libmatepanelapplet-2.0.pc
  195. %{_libdir}/pkgconfig/libmatepanelapplet-3.0.pc
  196. %{_datadir}/gir-1.0/MatePanelApplet-3.0.gir
  197. %files doc
  198. %defattr(-,root,root,-)
  199. %{_datadir}/gtk-doc/html/mate-panel-applet
  200. %changelog
  201. * Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  202. - new upstream release
  203. - add Patch0 (mate-panel-1.2.1-configure.patch)
  204. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
  205. - change category
  206. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
  207. - initial build for Vine Linux