xnoise-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242
  1. %define XNOISE_BIN %{_libexecdir}/%{name}
  2. Name: xnoise
  3. Version: 0.2.18
  4. Release: 1%{?_dist_release}
  5. Summary: Tracklist-centric Media Player
  6. Summary(ja): トラックリストを中心とするメディアプレーヤー
  7. Group: Applications/Multimedia
  8. License: GPLv2+ with exceptions
  9. URL: http://www.xnoise-media-player.com/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.gz
  12. Source1: xnoise_ja.po
  13. Source10: xnoise.sh
  14. BuildRequires: pkgconfig
  15. BuildRequires: gettext
  16. BuildRequires: glib2-devel >= 2.30.0
  17. BuildRequires: gtk3-devel
  18. BuildRequires: gstreamer1-plugins-base-devel >= 1.0.1
  19. BuildRequires: intltool
  20. BuildRequires: libxml2-devel >= 2.6.32
  21. BuildRequires: libsoup-devel >= 2.26.0
  22. BuildRequires: libtaginfo-devel >= 0.1.6
  23. BuildRequires: perl-XML-Parser
  24. BuildRequires: sqlite3-devel >= 3.6
  25. BuildRequires: taglib-devel >= 1.6.0
  26. BuildRequires: unique-devel
  27. BuildRequires: vala-devel >= 0.16.0
  28. BuildRequires: desktop-file-utils gettext intltool
  29. Requires: hicolor-icon-theme
  30. Requires: libtaginfo >= 0.1.6
  31. # xnoise >= 0.1.14 bundles the plug-ins
  32. Provides: xnoise-plugins-core = %{version}-%{release}
  33. %description
  34. Xnoise is a Gtk+ media player with a tracklist-centric design. The
  35. tracklist is a list of video or music tracks that are played one by
  36. one without being removed (right side of window). This gives you the
  37. possibility to enqueue any track in any order, regardless if they are
  38. on the same album or not. The tracks can be reordered at any time by
  39. using drag and drop.
  40. %package devel
  41. Summary: Development files for %{name}
  42. Summary(ja): %{name} の開発ファイル
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. The %{name}-devel package contains libraries and header files for
  47. developing applications that use %{name}.
  48. %prep
  49. %setup -q
  50. %{__cp} -f %{SOURCE1} po/ja.po
  51. #sed -i s/hu/hu\\nja/g po/LINGUAS
  52. sed -i 's/Keywords=Media\;Audio\;Video\;Player\;Mediaplayer\;Movie\;MP3/&;/' \
  53. data/misc/xnoise.desktop.in.in
  54. %build
  55. %configure --enable-soundmenu2=no
  56. make %{?_smp_mflags}
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. make install DESTDIR=$RPM_BUILD_ROOT
  60. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  61. # remove invalid locale file
  62. rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
  63. ## wrapper install
  64. %__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
  65. %__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
  66. %{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  67. %find_lang %{name}
  68. %check
  69. make check
  70. desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
  71. %post
  72. /sbin/ldconfig
  73. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  74. update-desktop-database &> /dev/null || :
  75. %postun
  76. /sbin/ldconfig
  77. if [ $1 -eq 0 ] ; then
  78. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  79. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  80. fi
  81. update-desktop-database &> /dev/null || :
  82. %posttrans
  83. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  84. %files -f %{name}.lang
  85. %defattr(-,root,root,-)
  86. %doc AUTHORS COPYING README
  87. %{XNOISE_BIN}
  88. %{_bindir}/xnoise
  89. %{_bindir}/xnoise_image_extractor_service
  90. # libxnoise.so *needs* to be in main package
  91. # otherwise plugins currently don't work
  92. %exclude %{_libdir}/xnoise/libxnoisetest.so
  93. %{_libdir}/xnoise
  94. %{_libdir}/libxnoise.so*
  95. %{_mandir}/man1/xnoise.1*
  96. %{_datadir}/xnoise
  97. %{_datadir}/applications/xnoise.desktop
  98. %{_datadir}//dbus-1/services/org.gtk.xnoise.ImageExtractor.service
  99. %{_datadir}//dbus-1/services/org.gtk.xnoise.PlayerEngine.service
  100. %{_datadir}/icons/hicolor/*
  101. %{_datadir}/icons/ubuntu-mono-*/*
  102. %files devel
  103. %defattr(-,root,root,-)
  104. %{_includedir}/xnoise
  105. %{_libdir}/xnoise/libxnoise*.so*
  106. %{_libdir}/pkgconfig/xnoise-1.0.pc
  107. # make package own the vala API dir:
  108. # xnoise plugins don't have to be written in vala
  109. %dir %{_datadir}/vala
  110. %dir %{_datadir}/vala/vapi
  111. %{_datadir}/vala/vapi/xnoise-1.0.*
  112. %changelog
  113. * Sun May 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.18-1
  114. - new upstream release
  115. - updated Source1
  116. - changed BuildRequires: libtaginfo-devel >= 0.1.6
  117. - changed Rquires: libtaginfo >= 0.1.6
  118. - fixed desktop error
  119. - deleted unrecognize option: --disable-ubuntuone
  120. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.17-1
  121. - new upstream release
  122. - updated Source1
  123. - changed BuildRequires: gstreamer-plugins-base-devel >= 0.10.23 to
  124. gstreamer1-plugins-base-devel >= 1.0.1
  125. - added BuildRequires: libtaginfo-devel
  126. - added Requires: libtaginfo
  127. - fixed Source10
  128. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.15-1
  129. - new upstream release
  130. - updated Source1
  131. * Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.14-1
  132. - new upstream release
  133. - updated Source1
  134. * Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.13-1
  135. - new upstream release
  136. - updated Source1
  137. * Thu Oct 04 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.12-1
  138. - new upstream release
  139. - updated Source1
  140. - deleted BuildRequires: libnotify-devel >= 0.7.0
  141. - changed BuildRequires: vala-devel >= 0.15.0 to 0.16.0
  142. * Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.11-1
  143. - new upstream release
  144. - updated Source1
  145. - deleted %%configure option: --disable-magnatune
  146. * Sat Sep 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.9-1
  147. - new upstream release
  148. - updated Source1
  149. * Sat Aug 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.8-1
  150. - new upstream release
  151. - updated Source1
  152. - added %%configure option: --disable-magnatune
  153. * Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.5-1
  154. - new upstream release
  155. - updated Source1
  156. - added %%configure option: --disable-ubuntuone
  157. * Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
  158. - initial build for VineSeed
  159. * Wed Oct 5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
  160. - Update to 0.1.29
  161. * Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
  162. - Update to 0.1.28
  163. * Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
  164. - Update to 0.1.27
  165. * Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
  166. - Update to 0.1.26
  167. - Enable tests
  168. * Mon Apr 4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
  169. - Update to 0.1.18
  170. * Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
  171. - Update to 0.1.16
  172. - Now bundles the plugins, obsoleting xnoise-plugins-core
  173. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  175. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
  176. - Own %%{_libdir}/xnoise for plugins
  177. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
  178. - invoke ldconfig on (un)install
  179. - remove %%clean section; only targeting F-14+
  180. - re-enable deletion of invalid locale dir
  181. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
  182. - Update to 0.1.12
  183. - Specify the correct location for Vala API files in *.pc
  184. * Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
  185. - Make xnoise-devel co-own Vala's VAPI dir
  186. - Remove invalid locale file
  187. * Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  188. - Update to final 0.1.6 release
  189. * Sat Apr 3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
  190. - Initial package