pygtk2-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
  3. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  4. Summary: Python bindings for the GTK+ widget set.
  5. Summary(ja): GTK+ ウィジットセットの Python 実装
  6. Name: pygtk2
  7. Version: 2.24.0
  8. Release: 3%{?_dist_release}
  9. Group: Development/Languages
  10. License: LGPLv2
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/pygtk-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Buildrequires: python-devel >= 2.5
  14. Buildrequires: libglade2-devel >= 2.5.0
  15. BuildRequires: gtk2-devel >= 2.16.0
  16. BuildRequires: pygobject-devel >= 2.16.0
  17. BuildRequires: pycairo-devel >= 1.8.2
  18. BuildRequires: python-numeric
  19. BuildRequires: docbook-style-xsl
  20. BuildRequires: libxslt
  21. Buildrequires: automake >= 1.6.3-5
  22. Requires: pygobject
  23. Requires: pycairo
  24. Requires: python-numeric
  25. Obsoletes: pygtk
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %description
  29. PyGTK is an extension module for python that gives you access to the GTK+
  30. widget set. Just about anything you can write in C with GTK+ you can write
  31. in python with PyGTK (within reason), but with all the benefits of python.
  32. %description -l ja
  33. PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
  34. です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
  35. けます。 python のおかげでもあります。
  36. %package libglade
  37. Summary: A wrapper for the libglade library for use with PyGTK
  38. Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
  39. Group: Development/Libraries
  40. Requires: pygtk2 = %{version}
  41. %description libglade
  42. This module contains a wrapper for the libglade library. Libglade allows
  43. a program to construct its user interface from an XML description, which
  44. allows the programmer to keep the UI and program logic separate.
  45. %description -l ja libglade
  46. このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
  47. プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
  48. ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
  49. %package devel
  50. Summary: files needed to build wrappers for GTK+ addon libraries
  51. Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
  52. Group: Development/Libraries
  53. Requires: pygtk2 = %{version}
  54. Requires: pygobject-devel >= 2.12.0
  55. Requires: gtk2-devel
  56. %description devel
  57. This package contains files required to build wrappers for GTK+ addon
  58. libraries so that they interoperate with pygtk.
  59. %description -l ja devel
  60. このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
  61. みます。これらは PyGTK との仲介をします。
  62. %prep
  63. %setup -q -n pygtk-%{version}
  64. %build
  65. [ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
  66. #aclocal && automake && autoconf
  67. %configure --enable-thread --enable-numpy
  68. export tagname=CC
  69. make LIBTOOL=/usr/bin/libtool
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. export tagname=CC
  73. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
  74. find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %files
  78. %defattr(-,root,root)
  79. %doc AUTHORS NEWS README MAPPING ChangeLog
  80. %doc examples
  81. %defattr(644, root, root, 755)
  82. %dir %{python_sitearch}/gtk-2.0
  83. %dir %{python_sitearch}/gtk-2.0/gtk
  84. %{python_sitearch}/gtk-2.0/gtk/*.py*
  85. %dir %{_libdir}/pygtk
  86. %dir %{_libdir}/pygtk/2.0
  87. %{_libdir}/pygtk/2.0/*
  88. %defattr(755, root, root, 755)
  89. %{_bindir}/pygtk-demo
  90. %{python_sitearch}/gtk-2.0/atk.so
  91. %{python_sitearch}/gtk-2.0/pango.so
  92. %{python_sitearch}/gtk-2.0/gtk/_gtk.so
  93. %{python_sitearch}/gtk-2.0/gtkunixprint.so
  94. %{python_sitearch}/gtk-2.0/pangocairo.so
  95. %if %{buildglade}
  96. %files libglade
  97. %defattr(755, root, root, 755)
  98. %{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
  99. %endif
  100. %files devel
  101. %defattr(644, root, root, 755)
  102. %dir %{_includedir}/pygtk-2.0
  103. %dir %{_includedir}/pygtk-2.0/pygtk
  104. %{_includedir}/pygtk-2.0/pygtk/*.h
  105. %{_libdir}/pkgconfig/pygtk-2.0.pc
  106. %dir %{_datadir}/pygtk
  107. %dir %{_datadir}/pygtk/2.0
  108. %dir %{_datadir}/pygtk/2.0/defs
  109. %{_datadir}/pygtk/2.0/defs/*.defs
  110. %{_datadir}/pygtk/2.0/defs/pangocairo.override
  111. %{_datadir}/gtk-doc/html/pygtk
  112. %defattr(755, root, root, 755)
  113. %{_bindir}/pygtk-codegen-2.0
  114. %changelog
  115. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-3
  116. - rebuild with VineSeed environment
  117. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-2
  118. - rebuild with python-2.7.2
  119. * Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  120. - new upstream release
  121. * Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-2
  122. - add Requires: gtk2-devel (-devel package)
  123. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
  124. - new upstream release
  125. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  126. - new upstream release
  127. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  128. - new upstream release
  129. - rebuild with python-2.6
  130. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
  131. - new upstream release
  132. * Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
  133. - rebuilt with python-2.5.2
  134. * Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
  135. - rebuilt with python-2.4.5
  136. - used %%{?_dist_release} macro
  137. * Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
  138. - new upstream release
  139. * Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
  140. - new upstream release
  141. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
  142. - new upstream release
  143. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
  144. - added Requires pygobject-devel to devel package
  145. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
  146. - new upstream release
  147. - add Requires/BuildRequires pygobject,pycairo
  148. * Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
  149. - new upstream release 2.8.6
  150. * Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
  151. - new upstream release 2.8.4
  152. - added japanese summary and description
  153. * Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
  154. - new upstream release 2.8.2
  155. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
  156. - new upstream release 2.8.1
  157. - added %clean sectioin
  158. * Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
  159. - new upstream release 2.8.0
  160. * Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
  161. - new upstream release 2.6.1
  162. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
  163. - rebuild with python-2.4.1-0vl1
  164. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  165. - new upstream release
  166. * Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
  167. - updated to 2.2.0
  168. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
  169. - rebuild with python-2.3.3-0vl1
  170. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
  171. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  172. * Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
  173. - added missing %%defattr
  174. * Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
  175. - added Provides and Obsoletes pygtk
  176. * Tue Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
  177. - new upstream release (based on Redhat Rawhide 2.0.0-1)
  178. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
  179. - Fix libtool
  180. * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
  181. - part of the fixnew patch wasn't applied upstream, apply it (#99400)
  182. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
  183. - new upstream release
  184. - build for Vine Linux
  185. * Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
  186. - rebuild for multilib
  187. - use %%configure
  188. * Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
  189. - fix pixbuf leaks (#72137)
  190. - five more pixbuf leaks plugged
  191. * Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
  192. - remover Packager tag
  193. * Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
  194. - add binding for gdk_atom_intern
  195. * Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
  196. - 0.99.12
  197. * Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
  198. - new version from CVS
  199. * Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
  200. - Fix bug #65770.
  201. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  202. - automated rebuild
  203. * Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
  204. - new version from CVS
  205. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  206. - automated rebuild
  207. * Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
  208. - 1.99.10
  209. * Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
  210. - 1.99.8
  211. * Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
  212. - added atkmodule.so to file list
  213. * Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
  214. - fix devel filelist to match new header location
  215. * Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
  216. - get the headers from their new version-specific location
  217. * Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
  218. - fixed typo in devel filelist
  219. - added macro that tests to see if we have libglade2, make the
  220. filelist a condition of that
  221. - changed name to 'pygtk2' to avoid name conflict with pygtk