gmrun-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144
  1. %define pkg_name gmrun
  2. %define pkg_version 0.9.2
  3. %define pkg_release 4%{?_dist_release}
  4. Summary: Small GTK based 'Run application'
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: GPL2
  9. Group: User Interface/X
  10. URL: https://sourceforge.net/projects/gmrun/
  11. # URL: https://github.com/rtyler/gmrun
  12. Source: %{name}-%{version}.tar.gz
  13. Patch0: ci_string.h.patch
  14. Patch1: prefs.cc.patch
  15. Patch2: gtkcompletionline.cc.patch
  16. BuildRoot: %{_tmppath}/%{name}-root
  17. BuildRequires: gtk2-devel
  18. BuildRequires: popt-devel
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. # Packager: Mihai Bazon <mishoo@infoiasi.ro>
  22. Packager: ara_t
  23. %description
  24. Short GtkEntry for file autocompletion + main.cc that does the needed stuff
  25. for running programs. This is intended as a replacement to grun, which
  26. (sorry) sucks. The idea comes from the KDE Window Manager (ALT-F2 in KDE).
  27. Though, GNOME is better :)
  28. %prep
  29. %{__rm} -rf ${RPM_BUILD_ROOT}
  30. %setup -q
  31. %patch0 -p1
  32. %patch1 -p1
  33. %patch2 -p1
  34. %build
  35. %{configure}
  36. %{__make} %{?_smp_mflags}
  37. %install
  38. %{__rm} -rf ${RPM_BUILD_ROOT}
  39. %{__make} install-strip DESTDIR=${RPM_BUILD_ROOT}
  40. %clean
  41. %{__rm} -rf ${RPM_BUILD_ROOT}
  42. %files
  43. %defattr(-,root,root)
  44. %doc AUTHORS COPYING INSTALL README NEWS ChangeLog
  45. %{_bindir}/
  46. %{_datadir}/
  47. %changelog
  48. * Sun May 15 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-4
  49. - rebuild with gcc-5.4.0
  50. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-3
  51. - correct SPEC file
  52. * Mon Feb 29 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-2
  53. - change group to User Interface/X
  54. * Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-1
  55. - rebuild for Vine Linux
  56. - patch the difference with Commits on Sep 12, 2013
  57. * Sun Aug 03 2003 Mihai Bazon <mishoo@infoiasi.ro> 0.9-2
  58. - fixed a parsing bug in the "run command" function
  59. * Sun Jun 22 2003 Marius FERARU <altblue@n0i.net> 0.9-0.n0i
  60. - version 0.9
  61. * Sat Jun 14 2003 Marius FERARU <altblue@n0i.net> 0.8.1-1.n0i
  62. - rebuild on RHL9
  63. * Sat Aug 17 2002 Mihai Bazon <mishoo@infoiasi.ro>
  64. - Some bugs fixed, specifically the behavior of END/HOME keys (or C-E, C-A),
  65. and the major one: you could not run a file that has an extension handler
  66. with some other program than the extension handler :)
  67. * Fri Aug 16 2002 Mihai Bazon <mishoo@infoiasi.ro>
  68. - Fixed bug: filenames can now contain white spaces (will be backslash-ed)
  69. - New feature: can specify application handler per file extension, so you
  70. can directly type the name of some .cpp file and emacs will show up :)
  71. see config file for details.
  72. - New feature: can automatically simulate a TAB press after some timeout.
  73. Check config file for details, key "TabTimeout" (0 to disable).
  74. - New feature: you can now always use "system" for running programs
  75. (specify --enable-system at configure).
  76. * Fri Oct 19 2001 Mihai Bazon <mishoo@infoiasi.ro>
  77. - Fixed bug with sorting of completion list
  78. - Fixed bug with URL handling
  79. - New parameter: list of execs to be always run in terminal
  80. - New feature: last history line appears directly in edit line, selected
  81. * Wed Aug 01 2001 Mihai Bazon <mishoo@infoiasi.ro>
  82. - Programs are now executed using execv. We don't use system anymore, thus
  83. avoiding forking another shell.
  84. - gmrun.spec gets now generated automagically, at ./configure.
  85. * Sun Jul 22 2001 Mihai Bazon <mishoo@infoiasi.ro>
  86. - added "!" history backward search; like in bash, it finds the last command
  87. which begins with the entered text.
  88. - CTRL-R / CTRL-S don't show two identical consecutive records.
  89. * Thu Jul 19 2001 Mihai Bazon <mishoo@infoiasi.ro>
  90. - added history search capabilities (CTRL-R / CTRL-S, like in bash / Emacs)
  91. - small bug fixes
  92. * Fri Jun 29 2001 Mihai Bazon <mishoo@infoiasi.ro>
  93. - history size configurable from config file
  94. - window appears directly where it should (no more flicker)
  95. * Wed May 14 2001 Mihai Bazon <mishoo@infoiasi.ro>
  96. - added default configuration file (goes to /usr/share/gmrun)
  97. * Wed May 07 2001 Marius Feraru <altblue@n0i.net>
  98. - updated to version 0.5.3 and took over to 0.5.31
  99. * Wed May 03 2001 Marius Feraru <altblue@n0i.net>
  100. - updated to version 0.2.5 and took over to 0.2.51:
  101. * configuration file with 2 options for now:
  102. 'Terminal' and 'Width'
  103. * added some more (and hopefully more useful) documentation:
  104. README.hints, README.gmrunrc and README.icewm
  105. * Wed May 03 2001 Marius Feraru <altblue@n0i.net>
  106. - updated to version 0.2.2:
  107. * Ctrl-Enter spawns a terminal
  108. * Wed May 02 2001 Marius Feraru <altblue@n0i.net>
  109. - initial RPM build