tamago-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define _libdir %{_prefix}/lib
  4. %define origver 4.0.6
  5. %define origname tamago
  6. Summary: Tamago Version 4 -- EGG Input Method Architecture for Emacsen
  7. Summary(ja): たまご第4版
  8. Name: %{origname}
  9. Version: %{origver}
  10. Release: 8%{?_dist_release}
  11. Source0: ftp://ftp.m17n.org/pub/%{origname}/%{origname}-%{origver}.tar.gz
  12. Source1: %{origname}-install.sh
  13. Source2: %{origname}-remove.sh
  14. Source3: http://cgi18.plala.or.jp/nyy/canna/egg-canna.el
  15. Source4: egg-anthy.tar.gz
  16. %define egg_anthy_version 20060606-2
  17. Source10: vine-default-%{origname}.el
  18. Source11: %{origname}-init.el
  19. Patch0: tamago-4.0.6-cvshead.patch
  20. Patch3: tamago-4.0.6-eggrc.patch
  21. Patch4: tamago-4.0.6-makefile.patch
  22. Patch5: tamago-4.0.6-canna-unix-domain-socket.patch
  23. Patch10: tamago-emcws.patch
  24. Patch20: tamago-4.0.6-vine-romakana.patch
  25. Patch30: tamago-4.0.6-egg-helper-path.patch
  26. Patch40: tamago-4.0.6-wnn8_rev2.patch
  27. ### for emacs
  28. ### from http://www.m17n.org/mlarchive/mule-ja/200703/msg00018.html
  29. Patch50: tamago-4.0.6-emacs23.patch
  30. License: GPL
  31. Group: Applications/Editors/Emacs
  32. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  33. Requires: emacsen
  34. Requires: emacsen-common
  35. BuildPreReq: apel
  36. %prereq_ge apel
  37. Obsoletes: tamago-el
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. %description
  41. EGG Emacs20(Emacs21) Input Method Architecture.
  42. All is written only with Emacs Lisp.
  43. Egg can use FreeWnn (jserver, cserver, tserver) and Wnn6 as server doing
  44. character string conversion with the back end.
  45. And can convert mixed sentence of Japanese and Chinese into.
  46. .
  47. There is the part which is not implemented yet.
  48. %description -l ja
  49. すべてのソースが Emacs Lisp で実現されており、GNU Emacs 20.5 以降で
  50. 多言語入力環境を提供します。バックエンドサーバとしては、FreeWnn (jserver,
  51. cserver, tserver), Wnn6, SJ3 Ver.2,canna に対応しています。
  52. %prep
  53. %setup -n %{origname}-%{origver} -a 4
  54. %patch0 -p1
  55. %patch3 -p1
  56. #% patch4 -p1
  57. %patch5 -p1
  58. # cp %{SOURCE3} .
  59. %__cp -a %{SOURCE10} %{SOURCE11} .
  60. #% patch10 -p1
  61. %patch20 -p1
  62. %patch30 -p1
  63. %patch40 -p1
  64. %patch50 -p1
  65. # rename canna stuff
  66. #mv egg/canna.el egg/canna-tamago.el
  67. # copy egg-anthy stuff
  68. cp egg-anthy-%{egg_anthy_version}/*.el egg/
  69. %build
  70. %configure
  71. gcc %{optflags} -o helper/egg-helper helper/egg-helper.c
  72. %install
  73. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  74. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  75. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
  76. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  77. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  78. #
  79. # install el files
  80. #
  81. cp -r eggrc *.el egg its* Makefile \
  82. $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{origname}/
  83. #
  84. # install egg-helper
  85. #
  86. install -d $RPM_BUILD_ROOT%{_libexecdir}
  87. install -m 755 helper/egg-helper $RPM_BUILD_ROOT%{_libexecdir}
  88. #
  89. # install script( bytecompile el and install elc , remove )
  90. #
  91. %_installemacsenscript %{origname} %{SOURCE1}
  92. %_removeemacsenscript %{origname} %{SOURCE2}
  93. #
  94. # install info file
  95. #
  96. mkdir -p ${RPM_BUILD_ROOT}/usr/info
  97. %post
  98. #
  99. # bytecompile and install
  100. #
  101. if [ "$1" = 2 ]; then
  102. %_emacsenPackageRemove %{origname}
  103. fi
  104. %_addemacsenlist %{origname}
  105. %_emacsenPackageInstall %{origname}
  106. %preun
  107. if [ "$1" = 0 ]; then
  108. %_emacsenPackageRemove %{origname}
  109. %_removeemacsenlist %{origname}
  110. fi
  111. %clean
  112. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  113. %files
  114. %defattr(-,root,root)
  115. %doc README.ja.txt COPYING AUTHORS ChangeLog* PROBLEMS TODO
  116. %doc egg-anthy-%{egg_anthy_version}/egg-anthy.readme doc/
  117. %{_datadir}/emacs/site-lisp/%{origname}/
  118. %{_libdir}/emacsen-common/packages/install/%{origname}
  119. %{_libdir}/emacsen-common/packages/remove/%{origname}
  120. %{_libexecdir}/egg-helper
  121. %changelog
  122. * Sat May 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-8
  123. - update vine-default-tamago.el to support emacs >= 23.1.96
  124. * Mon Nov 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-7
  125. - update patch40 (tamago-4.0.6--wnn8_rev2.patch)
  126. - fix bugs on 64bit architecture.
  127. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-6
  128. - applied tamago-4.0.6-emacs23.patch
  129. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-5
  130. - updated tamago-install.sh
  131. - *-init.el: changed from hard copy to symbolic link
  132. on /etc/emacs-XX.YY/site-start.d
  133. * Wed Apr 22 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-4
  134. - no applied:
  135. - egg-canna.el
  136. - tamago-4.0.6-makefile.patch
  137. - tamago-emcws.patch
  138. - added vine-default-tamago.el and tamago-init.el
  139. - updated tamago-install.sh for vine-default-tamago.el
  140. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-3
  141. - change from noarch to per-arch for egg-helper.
  142. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.6-2vl5
  143. - applied new versioning policy
  144. - added %%define _libdir %%{_prefix}/lib
  145. * Sat Apr 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl26
  146. - add Patch40 to support wnn7 and wnn8 (taken from debian package)
  147. * Fri Dec 29 2006 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl25
  148. - restration(cp %{SOURCE3} .)for compilation complete(and use it for emacs-21.4)
  149. * Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl24
  150. - add Patch5
  151. tamago-canna backend connect to cannaserver using UNIX domain
  152. socket by default. (taken from debian package)
  153. - add Patch30 to change egg-helper path.
  154. * Thu Sep 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl23
  155. - modified its/hira.el to add some roma-kana conversion map.
  156. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.6-1vl22
  157. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  158. * Sat Jun 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl21
  159. - update to cvs head
  160. - add egg-anthy
  161. http://anthy.sourceforge.jp/cgi-bin/hiki/hiki.cgi?Emacs%A4%AB%A4%E9
  162. - add documents to %%files
  163. - use License: instead of Copyright:
  164. * Fri May 16 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl20
  165. - update tamago-install.sh
  166. - rm -f ${ELDIR}/*.elc, egg/*.elc, its/*.elc
  167. - rm -f ${ELCDIR}/*.el, egg/*.el, its/*.el
  168. * Fri May 9 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-1vl19
  169. - update tamago-remove.sh: delete ${SITELISP}/egg
  170. * Wed Apr 30 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.0.6-1vl18
  171. - rebuild
  172. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl17
  173. - add patch10 to use with emcws
  174. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl16
  175. - remove conflicts to emacs-dl-*
  176. - rename canna.el to canna-tamago.el (we use emcws for canna)
  177. * Wed Sep 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl14
  178. - modified patch3 for Canna-3.5b2-41
  179. * Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl13
  180. - added patch4
  181. * Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl12
  182. - update source3
  183. * Mon Jul 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl11
  184. - added patch3
  185. * Fri Jun 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl10
  186. - update patch2
  187. - added source3
  188. * Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-1vl9
  189. - tamago-el -> tamago again
  190. - spec file cleaned up
  191. * Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl8
  192. - fixed install time no-compile bug( edit tamago-{install,remove}.sh )
  193. * Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl5
  194. - support emacsen
  195. * Sun Dec 17 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl3
  196. - canna support patch upgrade.
  197. * Sat Dec 16 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl2
  198. - version 4.0.6
  199. - merge canna support patch.
  200. * Fri Jan 14 2000 Kazuhisa TAKEI<ktakei@jaist.ac.jp>
  201. - version 4.0.5