scim-bridge-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295
  1. %define name scim-bridge
  2. %define version 0.4.16
  3. %define release 8%{?_dist_release}
  4. # build qt3 immodule ("--without qt3" to disable qt3)
  5. %bcond_without qt3
  6. # ugly hack for Qt3 version auto-detection -- inagaki
  7. %define _qt3_notfound %(eval "rpm -q qt-devel > /dev/null"; echo $?)
  8. %if %{_qt3_notfound}
  9. %define _qt3_version 3.3.8
  10. %else
  11. %define _qt3_version %(rpm -q --queryformat "%%{version}" qt-devel)
  12. %endif
  13. %define _qt3_prefix %{_libdir}/qt-%{_qt3_version}
  14. %define _qt3_plugindir %{_qt3_prefix}/plugins
  15. # build qt4 immodule ("--without qt4" to disable qt4)
  16. %bcond_without qt4
  17. # ugly hack for Qt4 version auto-detection -- inagaki
  18. %define _qt4_notfound %(eval "pkg-config --exists Qt"; echo $?)
  19. %if %{_qt4_notfound}
  20. %define _qt4_version 4.6.1
  21. %define _qt4_prefix %{_libdir}/qt-%{_qt4_version}
  22. %define _qt4_plugindir %{_qt4_prefix}/plugins
  23. %else
  24. %define _qt4_version %(pkg-config --modversion --silence-errors Qt)
  25. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt)
  26. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt)
  27. %endif
  28. Summary: yet another IM client of SCIM
  29. Summary(ja): もう一つ別の SCIM IM クライアント
  30. Name: %{name}
  31. Version: %{version}
  32. Release: %{release}
  33. Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
  34. # Patch from Fedora 10
  35. Patch0: scim-bridge-0.4.15-fix-gdm.patch
  36. Patch1: scim-bridge-0.4.15-bz461373.patch
  37. # Patch from Mandriva 2009
  38. Patch2: bug-351920-should-return-retval.patch
  39. Patch3: scim-bridge-0.4.15.2-linkage.patch
  40. # Patch from Fedora development
  41. Patch4: scim-bridge-0.4.15-EOF.patch
  42. Patch5: scim-bridge-0.4.15-hotkey-help.patch
  43. URL: http://www.scim-im.org/projects/scim_bridge
  44. License: GPL/LGPL
  45. Group: System Environment/Libraries
  46. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  47. Prefix: %{_prefix}
  48. Requires: scim >= 1.4
  49. BuildRequires: scim-devel >= 1.4
  50. BuildRequires: pkgconfig >= 0.9.0
  51. BuildRequires: gtk2-devel >= 2.14.0
  52. %description
  53. Scim-bridge is yet another IM client of SCIM.
  54. The im-module of scim-bridge communicates with scim via socket.
  55. %description -l ja
  56. scim-bridge は、もう一つ別の SCIM IM クライアントです。
  57. scim-bridge の im-module はソケット経由で SCIM と通信します。
  58. %package gtk
  59. Summary: SCIM Bridge GTK IM Module
  60. Summary(ja): SCIM Bridge GTK IM モジュール
  61. Group: System Environment/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: gtk2 >= 2.14.0
  64. Requires(post): gtk2 >= 2.14.0
  65. Requires(postun): gtk2 >= 2.14.0
  66. Obsoletes: %{name} <= 0.1.7
  67. %description gtk
  68. This package provides the SCIM Bridge GTK IM module.
  69. %description -l ja gtk
  70. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  71. %if !%{without qt3}
  72. %package qt
  73. Summary: SCIM Bridge Qt IM Module
  74. Summary(ja): SCIM Bridge Qt IM モジュール
  75. Group: System Environment/Libraries
  76. Requires: %{name} = %{version}-%{release}
  77. Requires: qt = %{_qt3_version}
  78. BuildRequires: qt-devel
  79. %description qt
  80. This package provides the SCIM Bridge Qt IM module.
  81. %description -l ja qt
  82. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  83. %endif
  84. %if !%{without qt4}
  85. %package qt4
  86. Summary: SCIM Bridge Qt4 IM Module
  87. Summary(ja): SCIM Bridge Qt4 IM モジュール
  88. Group: System Environment/Libraries
  89. Requires: %{name} = %{version}-%{release}
  90. Requires: qt4 = %{_qt4_version}
  91. BuildRequires: qt4-devel
  92. %description qt4
  93. This package provides the SCIM Bridge Qt4 IM module.
  94. %description -l ja qt4
  95. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  96. %endif
  97. %prep
  98. %setup -q
  99. %patch0 -p1 -b .0-fix-gdm
  100. %patch1 -p1
  101. %patch2 -p1
  102. %patch3
  103. %patch4 -p1
  104. %patch5 -p1
  105. %build
  106. %if !%{without qt3}
  107. export QT3_PREFIX=%{_qt3_prefix}
  108. %endif
  109. %if !%{without qt4}
  110. export QT4_PREFIX=%{_qt4_prefix}
  111. %endif
  112. %configure \
  113. %if %{without qt3}
  114. --disable-qt3-immodule \
  115. %else
  116. --enable-qt3-immodule \
  117. %endif
  118. %if %{without qt4}
  119. --disable-qt4-immodule \
  120. %else
  121. --enable-qt4-immodule \
  122. %endif
  123. --enable-gtk2-immodule
  124. %__make
  125. %install
  126. %__rm -rf %{buildroot}
  127. #%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
  128. %__make DESTDIR=%{buildroot} install
  129. # remove unneeded files
  130. %__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
  131. %__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
  132. %__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
  133. %clean
  134. %__rm -rf %{buildroot}
  135. %post gtk
  136. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  137. %postun gtk
  138. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  139. %files
  140. %defattr(-,root,root)
  141. %doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
  142. %{_bindir}/scim-bridge
  143. %files gtk
  144. %defattr(-,root,root)
  145. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  146. %if !%{without qt3}
  147. %files qt
  148. %defattr(-,root,root)
  149. %{_qt3_plugindir}/inputmethods/*.so
  150. %endif
  151. %if !%{without qt4}
  152. %files qt4
  153. %defattr(-,root,root)
  154. %{_qt4_plugindir}/inputmethods/*.so
  155. %endif
  156. %changelog
  157. * Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
  158. - updated Qt version detection macros to build properly
  159. * Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
  160. - rebuilt with qt4-4.6.1
  161. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
  162. - rebuilt with qt4-4.5.3
  163. * Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
  164. - cleaned up spec
  165. - renumbered patch
  166. - added Patch5 from Fedora
  167. * Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
  168. - rebuild with qt4-4.5.2
  169. * Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
  170. - dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
  171. * Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
  172. - rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
  173. * Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
  174. - new upstream release
  175. - dropt Pacth3,4,5 (these patches are merged)
  176. * Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
  177. - spec in UTF-8
  178. - fixed description in scim-bridge-qt4
  179. - added patch6,7 (import Fedora, Mandriva patches)
  180. * Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
  181. - new upstream release
  182. - added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
  183. * Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
  184. - rebuild with qt4-4.4.2
  185. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
  186. - add qt4 immodule
  187. - build gtk,qt3,qt4 immodule by default
  188. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
  189. - rebuild with gtk+-2.14
  190. * Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
  191. - new upstream release
  192. - apply new versioning policy
  193. * Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
  194. - drop unnecessary BuildRequires for qt3-immodule package
  195. - fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
  196. * Wed Jan 9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
  197. - new upstream release
  198. - drop unnecessary Qt fix patch ( Patch0 ): upstream merged
  199. - update BuildRequires
  200. - drop doxygen
  201. - add XOrg-gl-devel for building qt3-immodule
  202. - move libmng-devel for building qt3-immodule
  203. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
  204. - rebuild for Vine Linux 4.2.
  205. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
  206. - add patch0 to fix symbol lookup error with qt3.
  207. * Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
  208. - rebuild for Vine Linux 4.2.
  209. * Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
  210. - new upstrm release
  211. - detect qt version at build time.
  212. - add --disable-qt4-immodule configure option.
  213. - add BuildRequires libmng-devel.
  214. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
  215. - rebuild with libstdc++34
  216. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
  217. - new upstream release
  218. * Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
  219. - change License to GPL/LGPL
  220. - add doc/LICENSE.* as documents
  221. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
  222. - new upstream release
  223. - add BuildRequires: doxygen, qt-devel
  224. - add new sub-packages:
  225. - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
  226. - qt: Qt IM module
  227. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
  228. - new upstream release
  229. - add documents
  230. - running gtk-query-immodules-2.0 in post and postun scripts
  231. - add PreReq: gtk2 > 2.2
  232. * Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
  233. - new upstream release
  234. * Thu Apr 6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
  235. - initial release