123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231 |
- Summary: WordPress blogging software
- Summary(ja): WordPress ブログソフトウエア
- URL: http://www.wordpress.org
- Name: wordpress
- Version: 2.9.2
- Group: Applications/Publishing
- Release: 1%{?_dist_release}
- License: GPLv2
- #Source0: http://wordpress.org/%{name}-%{version}.tar.gz
- Source0: http://ja.wordpress.org/wordpress-%{version}-ja.tar.gz
- Source1: wordpress-httpd-conf
- Source2: README.wordpress
- Source3: README.ja.wordpress
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- Requires: php5
- BuildArch: noarch
- %description
- Wordpress is an online publishing / weblog package that makes it very easy,
- almost trivial, to get information out to people on the web.
- %prep
- %setup -q -n wordpress
- # disable wp_version_check, updates are always installed via rpm
- sed -i -e "s,\(.*\)'wp_version_check'\(.*\),#\1'wp_version_check'\2,g" \
- wp-includes/update.php
- # disable update_nag() function
- sed -i -e "s,\(.*\)'update_nag'\(.*\),#\1'update_nag'\2,g; \
- s,\(.*\)\$msg .=\(.*\),\1\$msg .= '';,g;" \
- wp-admin/includes/update.php
- # fix file encoding
- sed -i -e 's/\r//' license.txt
- %install
- mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/wordpress
- mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress
- install -m 0644 -D -p %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/httpd/conf.d/wordpress.conf
- cp -pr * ${RPM_BUILD_ROOT}%{_datadir}/wordpress
- cat wp-config-sample.php | sed -e "s|dirname(__FILE__).'/'|'/usr/share/wordpress/'|g" > \
- ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress/wp-config.php
- /bin/ln -sf ../../../etc/wordpress/wp-config.php ${RPM_BUILD_ROOT}%{_datadir}/wordpress/wp-config.php
- /bin/cp %{SOURCE2} ./README.vine
- /bin/cp %{SOURCE3} ./README.ja.vine
- # Remove empty files to make rpmlint happy
- find ${RPM_BUILD_ROOT} -type f -empty -exec rm -f {} \;
- # These are docs, remove them from here, docify them later
- rm -f ${RPM_BUILD_ROOT}%{_datadir}/wordpress/{license.txt,readme.html}
- %clean
- rm -rf ${RPM_BUILD_ROOT}
- %post
- if [ "$1" -eq 1 ]; then
- if [ "$LANG"="ja_JP.UTF-8" ]; then
- echo "Wordpress: MySQL に Wordpress データベースを作成する必要があります。"
- echo "Wordpress: %{_docdir}/%{name}-%{version}/README.ja.vine を参照して"
- echo "Wordpress: 初期設定を行って下さい。"
- else
- echo "Wordpress: You may need to setup your MySQL database for Wordpress."
- echo "Wordpress: Please read \"%{_docdir}/%{name}-%{version}/README.vine\""
- echo "Wordpress: to initial setup."
- fi
- fi
- %files
- %defattr(-,root,root,-)
- %config(noreplace) %{_sysconfdir}/httpd/conf.d/wordpress.conf
- %dir %{_datadir}/wordpress
- %{_datadir}/wordpress/wp-admin
- %{_datadir}/wordpress/wp-content
- %{_datadir}/wordpress/wp-includes
- %{_datadir}/wordpress/index.php
- %doc license.txt
- %doc readme.html
- %doc README.vine
- %doc README.ja.vine
- %{_datadir}/wordpress/wp-atom.php
- %{_datadir}/wordpress/wp-app.php
- %{_datadir}/wordpress/wp-blog-header.php
- %{_datadir}/wordpress/wp-comments-post.php
- %{_datadir}/wordpress/wp-commentsrss2.php
- %{_datadir}/wordpress/wp-config-sample.php
- %{_datadir}/wordpress/wp-config.php
- %config(noreplace) %{_sysconfdir}/wordpress/wp-config.php
- %{_datadir}/wordpress/wp-cron.php
- %{_datadir}/wordpress/wp-feed.php
- %{_datadir}/wordpress/wp-links-opml.php
- %{_datadir}/wordpress/wp-load.php
- %{_datadir}/wordpress/wp-login.php
- %{_datadir}/wordpress/wp-mail.php
- %{_datadir}/wordpress/wp-pass.php
- %{_datadir}/wordpress/wp-rdf.php
- %{_datadir}/wordpress/wp-register.php
- %{_datadir}/wordpress/wp-rss.php
- %{_datadir}/wordpress/wp-rss2.php
- %{_datadir}/wordpress/wp-settings.php
- %{_datadir}/wordpress/wp-trackback.php
- %{_datadir}/wordpress/xmlrpc.php
- %dir %{_sysconfdir}/wordpress
- %changelog
- * Tue Apr 20 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.2-1
- - initial build for Vine Linux based on fedora package
- - update to 2.9.2 japanese version
- * Mon Nov 16 2009 Adrian Reber <adrian@lisas.de> - 2.8.6-2
- - updated to 2.8.6 (Security Release)
- * Wed Oct 21 2009 Adrian Reber <adrian@lisas.de> - 2.8.5-1
- - updated to 2.8.5 (Hardening Release)
- * Sun Aug 30 2009 Adrian Reber <adrian@lisas.de> - 2.8.4-1
- - updated to 2.8.4 (security fixes were already available with 2.8.3-2)
- * Tue Aug 11 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-2
- - another security update to fix "Remote admin reset password":
- http://lists.grok.org.uk/pipermail/full-disclosure/2009-August/070137.html
- * Mon Aug 03 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-1
- - updated to 2.8.3 for security fixes
- * Tue Jul 28 2009 Adrian Reber <adrian@lisas.de> - 2.8.2-1
- - updated to 2.8.2 for security fixes - BZ 512900
- - fixed "wrong-script-end-of-line-encoding" of license.txt
- - correctly disable auto update check
- - fixed an error message from 'find' during the build
- * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Fri Jul 10 2009 Adrian Reber <adrian@lisas.de> - 2.8.1-1
- - updated to 2.8.1 for security fixes - BZ 510745
- * Mon Jun 22 2009 Adrian Reber <adrian@lisas.de> - 2.8-1
- - updated to 2.8
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Wed Feb 11 2009 Adrian Reber <adrian@lisas.de> - 2.7.1-1
- - updated to 2.7.1
- * Wed Nov 26 2008 Adrian Reber <adrian@lisas.de> - 2.6.5-2
- - updated to 2.6.5
- * Fri Oct 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.3-1
- - updated to 2.6.3
- * Tue Sep 09 2008 Adrian Reber <adrian@lisas.de> - 2.6.2-1
- - updated to 2.6.2
- * Sun Aug 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.1-1
- - updated to 2.6.1
- * Mon Jul 21 2008 Adrian Reber <adrian@lisas.de> - 2.6-1
- - updated to 2.6
- * Sat Apr 26 2008 Adrian Reber <adrian@lisas.de> - 2.5.1-1
- - updated to 2.5.1 for security fixes - BZ 444396
- * Fri Feb 8 2008 John Berninger <john at ncphotography dot com> - 2.3.3-0
- - update to 2.3.3 for security fixes - BZ 431547
- * Sun Dec 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.2-1
- - updated to 2.3.2 (bz 426431, Draft Information Disclosure)
- * Tue Oct 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.1-1
- - updated to 2.3.1 (bz 357731, wordpress XSS issue)
- * Mon Oct 15 2007 Adrian Reber <adrian@lisas.de> - 2.3-1
- - updated to 2.3
- - disabled wordpress-core-update
- * Tue Sep 11 2007 Adrian Reber <adrian@lisas.de> - 2.2.3-0
- - updated to 2.2.3 (security release)
- * Wed Aug 29 2007 John Berninger <john at ncphotography dot com> - 2.2.2-0
- - update to upstream 2.2.2
- - license tag update
- * Mon Apr 16 2007 john Berninger <jwb at redhat dot com> - 2.1.3-1
- - update to 2.1.3 final - bz235912
- * Mon Mar 26 2007 John Berninger <jwb at redhat dot com> - 2.1.3-rc2
- - update to 2.1.3rc2 for bz 233703
- * Sat Mar 3 2007 John Berninger <jwb at redhat dot com> - 2.1.2-0
- - update to 2.1.2 - backdoor exploit introduced upstream in 2.1.1 - bz 230825
- * Tue Feb 27 2007 John Berninger <jwb at redhat dot com> - 2.1.1-0
- - update to 2.1.1 to fix vuln in bz 229991
- * Wed Jan 31 2007 John Berninger <jwb at redhat dot com> - 2.1-0
- - update to v2.1 to fix multiple bz/vuln's
- * Sun Dec 3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-2
- - Remove mysql-server dependency
- * Sun Dec 3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-1
- - Update to upstream 2.0.5 to fix vuln in bz 213985
- * Thu Oct 26 2006 John Berninger <jwb at redhat dot com> - 2.0.4-1
- - Doc fix for BZ 207822
- * Sat Aug 12 2006 John Berninger <jwb at redhat dot com> - 2.0.4-0
- - Upstream security vulns - bz 201989
- * Sun Jul 23 2006 John Berninger <jwb at redhat dot com> - 2.0.3-4
- - Fix broken upgrade path from FE4
- * Tue Jul 4 2006 John Berninger <jwb at redhat dot com> - 2.0.3-3
- - Add a README.fedora file
- - Add php-mysql requires
- * Tue Jun 20 2006 John Berninger <jwb at redhat dot com> - 2.0.3-2
- - Remove use of installprefix macro
- - %%{_datadir}/wordpress/wp-config.php is not a config file
- - Symlink is relative
- * Mon Jun 19 2006 John Berninger <jwb at redhat dot com> - 2.0.3-1
- - Changes from Jarod Wilson as below
- - Update to 2.0.3
- - Rearrange to use /usr/share/wordpress and /etc/wordpress
- - Remove patch (included upstream)
- - Remove empty files to make rpmlint happy
- * Tue May 30 2006 John Berninger <jwb at redhat dot com> - 2.0.2-1
- - Added patch for \n cache injection - upstream changeset #3797
- * Sat May 27 2006 John Berninger <jwb at redhat dot com> - 2.0.2-0
- - Initial build
|