irrlicht-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. %global irrxml_version 1.2
  2. Name: irrlicht
  3. Summary: A high performance realtime 3D engine
  4. Version: 1.7.2
  5. Release: 1%{?_dist_release}
  6. License: zlib
  7. Group: System Environment/Libraries
  8. Source0: http://downloads.sourceforge.net/irrlicht/%{name}-%{version}.zip
  9. # Various fixes, optflags, system libraries/headers
  10. # http://irrlicht.sourceforge.net/phpBB2/viewtopic.php?t=24076&highlight=
  11. Patch0: irrlicht-1.7.1-optflags.patch
  12. # Get the code compiling
  13. Patch1: irrlicht-1.5.1-glext.patch
  14. # Use system libaesgm
  15. Patch2: irrlicht-1.7.1-libaesgm.patch
  16. # Use improved fastatof from assimp
  17. Patch3: irrlicht-1.7.2-fastatof-improvements.patch
  18. # Make libIrrXML.so
  19. Patch4: irrlicht-1.7.2-irrXML-shared-library.patch
  20. URL: http://irrlicht.sourceforge.net/
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  22. BuildRequires: libXxf86vm-devel, mesa-libGL-devel, mesa-libGLU-devel
  23. BuildRequires: libjpeg-devel, zlib-devel, libaesgm-devel
  24. BuildRequires: libpng-devel, bzip2-devel, unzip
  25. %description
  26. The Irrlicht Engine is an open source high performance realtime 3D engine
  27. written and usable in C++ and also available for .NET languages. It is
  28. completely cross-platform, using D3D, OpenGL and its own software renderer,
  29. and has all of the state-of-the-art features which can be found in
  30. commercial 3d engines.
  31. %package devel
  32. Summary: Development headers and libraries for irrlicht
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: mesa-libGL-devel, mesa-libGLU-devel, libXxf86vm-devel
  35. Requires: libjpeg-devel, zlib-devel, libpng-devel
  36. Requires: irrXML-devel = %{irrxml_version}
  37. Group: Development/Libraries
  38. %description devel
  39. Development headers and libraries for irrlicht.
  40. %package -n irrXML
  41. Summary: Simple and fast XML parser for C++
  42. Group: System Environment/Libraries
  43. Version: %{irrxml_version}
  44. %description -n irrXML
  45. irrXML is a simple and fast open source xml parser for C++.
  46. %package -n irrXML-devel
  47. Summary: Development headers and libraries for irrXML
  48. Version: %{irrxml_version}
  49. Requires: irrXML = %{irrxml_version}-%{release}
  50. Group: Development/Libraries
  51. %description -n irrXML-devel
  52. Development headers and libraries for irrXML.
  53. %prep
  54. %setup -q
  55. %patch0 -p1 -b .optflags
  56. %patch1 -p1 -b .glext
  57. %patch2 -p1 -b .libaesgm
  58. %patch3 -p1 -b .fastatof
  59. %patch4 -p1 -b .irrXML
  60. sed -i 's/\r//' readme.txt
  61. iconv -o readme.txt.iso88591 -f iso88591 -t utf8 readme.txt
  62. mv readme.txt.iso88591 readme.txt
  63. # We don't use any of this. Deleting it so the debuginfo doesn't pick it up.
  64. rm -rf source/Irrlicht/jpeglib source/Irrlicht/zlib source/Irrlicht/libpng source/Irrlicht/aesGladman
  65. for i in include/*.h doc/upgrade-guide.txt source/Irrlicht/*.cpp source/Irrlicht/*.h; do
  66. sed -i 's/\r//' $i
  67. chmod -x $i
  68. touch -r changes.txt $i
  69. done
  70. %build
  71. cd source/Irrlicht
  72. make %{?_smp_mflags} sharedlib
  73. %install
  74. rm -rf %{buildroot}
  75. mkdir -p %{buildroot}%{_libdir}
  76. mkdir -p %{buildroot}%{_includedir}/%{name}
  77. make -C source/Irrlicht INSTALL_DIR=%{buildroot}%{_libdir} install
  78. cp -a include/* %{buildroot}%{_includedir}/%{name}/
  79. cd %{buildroot}%{_libdir}
  80. ln -s libIrrlicht.so.%{version} libIrrlicht.so.1
  81. %clean
  82. rm -rf %{buildroot}
  83. %post -p /sbin/ldconfig
  84. %postun -p /sbin/ldconfig
  85. %post -n irrXML -p /sbin/ldconfig
  86. %postun -n irrXML -p /sbin/ldconfig
  87. %files
  88. %defattr(-,root,root,-)
  89. %doc readme.txt
  90. %{_libdir}/libIrrlicht*.so.*
  91. %{_libdir}/libIrrXML*.so.*
  92. %files devel
  93. %defattr(-,root,root,-)
  94. %doc doc/upgrade-guide.txt
  95. %{_includedir}/%{name}/
  96. %exclude %{_includedir}/%{name}/fast_atof.h
  97. %exclude %{_includedir}/%{name}/heapsort.h
  98. %exclude %{_includedir}/%{name}/irrArray.h
  99. %exclude %{_includedir}/%{name}/irrString.h
  100. %exclude %{_includedir}/%{name}/irrTypes.h
  101. %exclude %{_includedir}/%{name}/irrXML.h
  102. %{_libdir}/libIrrlicht*.so
  103. %{_libdir}/libIrrXML*.so
  104. %files -n irrXML
  105. %defattr(-,root,root,-)
  106. %doc readme.txt
  107. %{_libdir}/libIrrXML*.so.*
  108. %files -n irrXML-devel
  109. %defattr(-,root,root,-)
  110. %dir %{_includedir}/%{name}/
  111. %{_includedir}/%{name}/fast_atof.h
  112. %{_includedir}/%{name}/heapsort.h
  113. %{_includedir}/%{name}/irrArray.h
  114. %{_includedir}/%{name}/irrString.h
  115. %{_includedir}/%{name}/irrTypes.h
  116. %{_includedir}/%{name}/irrXML.h
  117. %{_libdir}/libIrrXML*.so
  118. %changelog
  119. * Wed Mar 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 1.7.2-1
  120. - initial build for Vine Linux based of fedora development
  121. * Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-4
  122. - add post/postun scripts for irrXML
  123. * Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-3
  124. - fix versioning on irrXML-devel
  125. * Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-2
  126. - make subpackages for irrXML
  127. - use assimp patch for performance improvement in IrrXML
  128. * Wed Nov 17 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-1
  129. - update to 1.7.2
  130. * Mon May 24 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.1-2
  131. - rebuild against fixed libaesgm
  132. * Thu Feb 18 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.1-1
  133. - update to 1.7.1
  134. * Thu Jan 14 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-1
  135. - update to 1.6.1
  136. * Wed Sep 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6-1
  137. - update to 1.6
  138. * Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5.1-1
  139. - update to 1.5.1
  140. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-4
  141. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  142. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-3
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  144. * Sat Jan 10 2009 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-2
  145. - fix libpng calls so we can use system libpng (thanks to tom lane)
  146. - fix license tag
  147. * Thu Jan 8 2009 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-1
  148. - build against system libpng
  149. - update to 1.5 final
  150. * Thu Dec 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-0.2.beta
  151. - fix optflags patch so that ldconfig isn't called during make install
  152. * Wed Dec 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-0.1.beta
  153. - Initial package for Fedora