libwebp-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. %define ver 0.2.1
  2. %define rel 1
  3. Name: libwebp
  4. Version: %{ver}
  5. Release: %{rel}%{?_dist_release}
  6. Group: Development/Libraries
  7. URL: http://webmproject.org/
  8. Summary: Library and tools for the WebP graphics format
  9. Summary(ja): WebP 画像フォーマットのためのライブラリとツール
  10. # Additional IPR is licensed as well. See PATENTS file for details
  11. License: BSD
  12. Source0: http://webp.googlecode.com/files/%{name}-%{version}.tar.gz
  13. Source1: libwebp_jni_example.java
  14. BuildRequires: libjpeg-devel libpng-devel libtool swig
  15. BuildRequires: java-devel
  16. BuildRequires: jpackage-utils
  17. %description
  18. WebP is an image format that does lossy compression of digital
  19. photographic images. WebP consists of a codec based on VP8, and a
  20. container based on RIFF. Webmasters, web developers and browser
  21. developers can use WebP to compress, archive and distribute digital
  22. images more efficiently.
  23. %package tools
  24. Group: Development/Tools
  25. Summary: The WebP command line tools
  26. Summary(ja): WebP コマンドラインツール
  27. %description tools
  28. WebP is an image format that does lossy compression of digital
  29. photographic images. WebP consists of a codec based on VP8, and a
  30. container based on RIFF. Webmasters, web developers and browser
  31. developers can use WebP to compress, archive and distribute digital
  32. images more efficiently.
  33. %package devel
  34. Group: Development/Libraries
  35. Summary: Development files for libwebp, a library for the WebP format
  36. Summary(ja): WebP フォーマットのためのライブラリ libwebp の開発ファイル
  37. Requires: %{name} = %{version}-%{release}
  38. %description devel
  39. WebP is an image format that does lossy compression of digital
  40. photographic images. WebP consists of a codec based on VP8, and a
  41. container based on RIFF. Webmasters, web developers and browser
  42. developers can use WebP to compress, archive and distribute digital
  43. images more efficiently.
  44. %package java
  45. Group: Development/Libraries
  46. Summary: Java bindings for libwebp, a library for the WebP format
  47. Summary(ja): WebP フォーマットのためのライブラリ libwebp の Java バインディング
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: java
  50. Requires: jpackage-utils
  51. %description java
  52. Java bindings for libwebp.
  53. Vendor: Project Vine
  54. Distribution: Vine Linux
  55. Packager: iwaim
  56. %prep
  57. %setup -q
  58. %build
  59. mkdir -p m4
  60. ./autogen.sh
  61. %configure --disable-static
  62. make %{?_smp_mflags}
  63. # swig generated Java bindings
  64. cp %{SOURCE1} .
  65. cd swig
  66. rm -rf libwebp.jar libwebp_java_wrap.c
  67. mkdir -p java/com/google/webp
  68. swig -ignoremissing -I../src -java \
  69. -package com.google.webp \
  70. -outdir java/com/google/webp \
  71. -o libwebp_java_wrap.c libwebp.i
  72. gcc %{optflags} -shared -fPIC -fno-strict-aliasing \
  73. -I/usr/lib/jvm/java/include \
  74. -I/usr/lib/jvm/java/include/linux \
  75. -I../src \
  76. -L../src/.libs -lwebp libwebp_java_wrap.c \
  77. -o libwebp_jni.so
  78. cd java
  79. javac com/google/webp/libwebp.java
  80. jar cvf ../libwebp.jar com/google/webp/*.class
  81. %install
  82. make install DESTDIR=%{buildroot}
  83. find "%{buildroot}/%{_libdir}" -type f -name "*.la" -delete
  84. # swig generated Java bindings
  85. mkdir -p %{buildroot}/%{_libdir}/%{name}-java
  86. cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
  87. %post -n %{name} -p /sbin/ldconfig
  88. %postun -n %{name} -p /sbin/ldconfig
  89. %files tools
  90. %{_bindir}/*
  91. %{_mandir}/man*/*
  92. %files -n %{name}
  93. %doc README PATENTS COPYING NEWS AUTHORS
  94. %{_libdir}/%{name}*.so.*
  95. %files devel
  96. %{_libdir}/%{name}*.so
  97. %{_includedir}/*
  98. %{_libdir}/pkgconfig/*
  99. %files java
  100. %doc libwebp_jni_example.java
  101. %{_libdir}/%{name}-java/
  102. %changelog
  103. * Sat Jan 12 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
  104. - initial build for Vine Linux
  105. * Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
  106. - new upstream release 0.2.1
  107. * Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
  108. - rebuild against new libjpeg
  109. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  111. * Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
  112. - Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
  113. * Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
  114. - Initial spec. Based on openSUSE one