clutter-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391
  1. %define clutter_version 1.22.4
  2. %define clutter_release 1%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.22/%{name}-%{version}.tar.xz
  12. Patch0: clutter-fixdso.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gobject-introspection
  15. # FIXME to remove when all the bits have been merged into their
  16. # libraries
  17. BuildRequires: glib2-devel
  18. BuildRequires: mesa-libGL-devel
  19. BuildRequires: mesa-libEGL-devel
  20. BuildRequires: gdk-pixbuf2-devel
  21. BuildRequires: atk-devel
  22. BuildRequires: pkgconfig
  23. BuildRequires: pango-devel
  24. BuildRequires: libXdamage-devel
  25. BuildRequires: libXcomposite-devel
  26. BuildRequires: libXi-devel
  27. BuildRequires: gettext
  28. BuildRequires: gtk-doc
  29. BuildRequires: gobject-introspection-devel >= 0.9.5
  30. BuildRequires: json-glib-devel
  31. BuildRequires: cogl-devel >= 1.20.0
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: Takemikaduchi
  35. %description
  36. Clutter is an open source software library for creating fast,
  37. visually rich graphical user interfaces. The most obvious example
  38. of potential usage is in media center type applications.
  39. We hope however it can be used for a lot more.
  40. %description -l ja
  41. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  42. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  43. しかしながら、我々はいろいろな分野で使用されることを願っています。
  44. %package devel
  45. Summary: Clutter development environment
  46. Summary(ja): Clutterの開発環境
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  50. Requires: mesa-libGL-devel
  51. Requires: mesa-libEGL-devel
  52. Requires: gobject-introspection-devel
  53. Requires: json-glib-devel
  54. Requires: libXcomposite-devel
  55. Requires: libXi-devel
  56. %description devel
  57. Header files and libraries for building a extension library for the
  58. clutter
  59. %package docs
  60. Summary: Documentation for %{name}
  61. Summary(ja): %{name}用のドキュメント
  62. Group: Documentation
  63. Provides: %{name}-doc = %{version}-%{release}
  64. BuildArch: noarch
  65. %description docs
  66. Clutter is an open source software library for creating fast,
  67. visually rich graphical user interfaces. The most obvious example
  68. of potential usage is in media center type applications.
  69. We hope however it can be used for a lot more.
  70. This package contains documentation for clutter.
  71. %prep
  72. %setup -q
  73. %patch0 -p1 -b .dso
  74. %build
  75. #%configure --enable-gtk-doc \
  76. # --enable-introspection=yes \
  77. # --disable-silent-rules \
  78. # --enable-xinput \
  79. # --disable-static
  80. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  81. %configure $CONFIGFLAGS \
  82. --enable-introspection=yes \
  83. --disable-silent-rules \
  84. --enable-xinput \
  85. --disable-static \
  86. --enable-egl-backend=yes
  87. # clutter git ships with some magic to put the git log in shipped tarballs
  88. # which gets listed in files; don't blow up if it's missing
  89. if ! test -f ChangeLog; then
  90. echo "Created from snapshot" > ChangeLog
  91. fi
  92. )
  93. make V=0
  94. %install
  95. rm -rf $RPM_BUILD_ROOT
  96. #make DESTDIR=$RPM_BUILD_ROOT install
  97. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  98. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  99. %find_lang %{name}-1.0
  100. %clean
  101. rm -rf $RPM_BUILD_ROOT
  102. %post -p /sbin/ldconfig
  103. %postun -p /sbin/ldconfig
  104. %files -f %{name}-1.0.lang
  105. %defattr(-,root,root,-)
  106. %doc AUTHORS COPYING NEWS README
  107. %{_libdir}/*.so.*
  108. %{_libdir}/girepository-1.0/*.typelib
  109. %files devel
  110. %defattr(-, root, root)
  111. %doc ChangeLog
  112. %{_includedir}/clutter-1.0
  113. %{_libdir}/*.so
  114. %{_libdir}/pkgconfig/*.pc
  115. %{_datadir}/gir-1.0/*.gir
  116. %files docs
  117. %defattr(-, root, root)
  118. %{_datadir}/gtk-doc/html/clutter
  119. %{_datadir}/gtk-doc/html/cally
  120. %changelog
  121. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.4-1
  122. - new upstream release
  123. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.2-1
  124. - new upstream release
  125. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
  126. - new upstream release
  127. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
  128. - new upstream release
  129. - add BuildRequires: mesa-libEGL-devel
  130. * Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
  131. - new upstream release
  132. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
  133. - new upstream release
  134. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
  135. - new upstream release
  136. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
  137. - new upstream release
  138. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
  139. - new upstream release
  140. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
  141. - new upstream release
  142. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  143. - new upstream release
  144. * Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  145. - new upstream release
  146. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  147. - new upstream release
  148. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  149. - new upstream release
  150. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  151. - new upstream release
  152. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  153. - new upstream release
  154. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
  155. - new upstream release
  156. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  157. - new upstream release
  158. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
  159. - new upstream release
  160. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  161. - new upstream release
  162. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  163. - new upstream release
  164. - add Requires: libXcomposite-devel, libXi-devel (-devel package)
  165. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
  166. - new upstream release
  167. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
  168. - new upstream release
  169. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
  170. - new upstream release
  171. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  172. - new upstream release
  173. - add BuildRequires: cogl-devel
  174. - add "BuildArch: noarch" to doc sub package
  175. - add Patch0 (clutter-fixdso.patch)
  176. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  177. - new upstream release
  178. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  179. - new upstream release
  180. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  181. - new upstream release
  182. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  183. - new upstream release
  184. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  185. - new upstream release
  186. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  187. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  188. - drop Patch0
  189. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  190. - new upstream release
  191. - drop Patch1
  192. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  193. - new upstream release
  194. - add BuildRequires: json-glib-devel
  195. - delete Requires: gir-repository
  196. - delete BuildRequires: gir-repository-devel
  197. - add Requires: json-glib-devel (devel package)
  198. - add Patch0, Patch1
  199. - fix %build
  200. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  201. - rebuild with rpm-4.8.1 for pkg-config file
  202. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  203. - new upstream release
  204. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  205. - new upstream release
  206. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  207. - new upstream release
  208. - add configure option (--enable-xinput)
  209. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  210. - new upstream release
  211. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  212. - new upstream release
  213. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  214. - new upstream release
  215. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  216. - new upstream release
  217. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  218. - new upstream release
  219. - build for Vine Linux
  220. - add Summary(ja)
  221. - fix BuildRoot
  222. - remove Obsolete and Provides
  223. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  224. - Update to 1.0.6
  225. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  226. - Update to 1.0.4, update gobject-introspection requirement
  227. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  228. - Update to 1.0.2
  229. * Sat Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  230. - Move ChangeLog to -devel to save some space
  231. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  232. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  233. onto the live cd
  234. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  235. - Update to 1.0.0
  236. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  237. - fix bz #507389
  238. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  239. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  240. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  241. - Update to 0.9.8
  242. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  243. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  244. introspection support to clutter (#512260)
  245. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  246. - Update to 0.9.6
  247. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  248. - Update to 0.9.4
  249. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  250. - Update to 0.9.2
  251. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  252. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  253. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  254. - Remove noarch from doc subpackage
  255. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  256. - Added gtk-doc for cogl
  257. - Created doc subpackage
  258. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  259. - Update to 0.8.6
  260. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  261. - Update to 0.8.2
  262. - Removed clutter-0.8.0-clutter-fixed.patch
  263. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  264. - Update to 0.8.0
  265. - Added clutter-0.8.0-clutter-fixed.patch
  266. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  267. - Update to 0.6.4
  268. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  269. - Update to 0.6.2
  270. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  271. - Update to 0.6.0
  272. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  273. - Autorebuild for GCC 4.3
  274. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  275. - Update to 0.4.2
  276. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  277. - Update to 0.4.1
  278. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  279. - Update to 0.3.1
  280. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  281. - Update to 0.2.3
  282. * Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  283. - Changed buildrequires and requires
  284. * Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  285. - Fix .spec
  286. * Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  287. - Fix .spec
  288. * Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  289. - Initial RPM release