wxGTK-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229
  1. %define name wxGTK
  2. %define wxconfig gtk2-unicode-release-2.8
  3. %define wx_ver 2.8
  4. Summary: The GTK+ 2 port of the wxWidgets library
  5. Summary(ja): wxWidgets ライブラリーの GTK+ 2 ポート
  6. Name: %{name}
  7. Version: %{wx_ver}.12
  8. Release: 1%{?_dist_release}
  9. License: wxWindows License
  10. Group: System Environment/Libraries
  11. URL: http://www.wxwidgets.org/
  12. Source0: wxGTK-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cppunit-devel
  15. #BuildRequires: gstreamer-devel >= 0.10
  16. #BuildRequires: gstreamer-plugins-base-devel >= 0.10
  17. BuildRequires: gtk2-devel
  18. BuildRequires: expat-devel
  19. BuildRequires: libgnomeprintui-devel
  20. BuildRequires: libjpeg-turbo-devel
  21. BuildRequires: libpng-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libtiff-devel
  24. BuildRequires: mesa-libGL-devel
  25. BuildRequires: mesa-libGLU-devel
  26. BuildRequires: pkgconfig
  27. BuildRequires: SDL-devel
  28. BuildRequires: zlib-devel
  29. Obsoletes: wx-gtk2
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. %description
  33. wxWidgets is a free C++ library for cross-platform GUI development.
  34. With wxWidgets, you can create applications for different GUIs (GTK+,
  35. Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
  36. %package devel
  37. Summary: The GTK+ 2 port of the wxWidgets library
  38. Summary(ja): wxWidgets ライブラリーの開発用ファイル
  39. Group: Development/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. Requires: wxBase = %{version}-%{release}
  42. Requires: gtk2-devel
  43. Requires: mesa-libGL-devel, mesa-libGLU-devel
  44. Obsoletes: wx-gtk2-devel
  45. %description devel
  46. The GTK+ 2 port of the wxWidgets library, header files.
  47. %package -n wxBase
  48. Summary: Non-GUI support classes from the wxWidgets library
  49. Group: System Environment/Libraries
  50. %description -n wxBase
  51. Every wxWidgets application must link against this library. It contains
  52. mandatory classes that any wxWidgets code depends on (like wxString) and
  53. portability classes that abstract differences between platforms. wxBase can
  54. be used to develop console mode applications -- it does not require any GUI
  55. libraries or the X Window System.
  56. %prep
  57. %setup -qn wxGTK-%{version}
  58. sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
  59. # fix plugin dir for 64-bit
  60. sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
  61. # fix permissions for sources
  62. chmod a-x include/wx/{msgout.h,dcgraph.h,graphics.h}
  63. chmod a-x src/common/msgout.cpp
  64. %build
  65. %configure --enable-shared \
  66. --enable-unicode \
  67. --enable-sound \
  68. --enable-intl \
  69. --enable-display \
  70. --enable-geometry \
  71. --enable-graphics_ctx \
  72. --disable-rpath \
  73. --with-expat \
  74. --with-gtk \
  75. --with-libpng \
  76. --with-libjpeg \
  77. --with-libtiff \
  78. --with-libxpm \
  79. --with-opengl \
  80. --with-regex \
  81. --with-sdl \
  82. --with-zlib
  83. %{__make} %{?_smp_mflags}
  84. %install
  85. %__rm -rf %{buildroot}
  86. %makeinstall
  87. ln -sf %{_libdir}/wx/config/%{wxconfig} %{buildroot}%{_bindir}/wx-config
  88. %makeinstall -C contrib
  89. %clean
  90. %__rm -rf %{buildroot}
  91. %post -p /sbin/ldconfig
  92. %postun -p /sbin/ldconfig
  93. %post -n wxBase -p /sbin/ldconfig
  94. %postun -n wxBase -p /sbin/ldconfig
  95. %files
  96. %defattr(-,root,root,-)
  97. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  98. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  99. %{_libdir}/libwx_gtk2u_adv-*.so.*
  100. %{_libdir}/libwx_gtk2u_aui-*.so.*
  101. %{_libdir}/libwx_gtk2u_core-*.so.*
  102. %{_libdir}/libwx_gtk2u_fl-*.so.*
  103. %{_libdir}/libwx_gtk2u_gizmos-*.so.*
  104. %{_libdir}/libwx_gtk2u_gizmos_xrc*.so.*
  105. %{_libdir}/libwx_gtk2u_gl-*.so.*
  106. %{_libdir}/libwx_gtk2u_html-*.so.*
  107. %{_libdir}/libwx_gtk2u_ogl-*.so.*
  108. %{_libdir}/libwx_gtk2u_plot-*.so.*
  109. %{_libdir}/libwx_gtk2u_qa-*.so.*
  110. %{_libdir}/libwx_gtk2u_richtext-*.so.*
  111. %{_libdir}/libwx_gtk2u_stc-*.so.*
  112. %{_libdir}/libwx_gtk2u_svg-*.so.*
  113. %{_libdir}/libwx_gtk2u_xrc-*.so.*
  114. %files devel
  115. %defattr(-,root,root,-)
  116. %{_bindir}/wx-config
  117. %{_bindir}/wxrc*
  118. %{_includedir}/wx-2.8
  119. %{_libdir}/libwx_*.so
  120. %dir %{_libdir}/wx
  121. %dir %{_libdir}/wx/include
  122. %{_libdir}/wx/include/gtk2*
  123. %dir %{_libdir}/wx/config
  124. %{_libdir}/wx/config/gtk2*
  125. %{_datadir}/aclocal/*
  126. %{_datadir}/bakefile/presets/*
  127. %files -n wxBase
  128. %defattr(-,root,root,-)
  129. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  130. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  131. %{_libdir}/libwx_baseu-*.so.*
  132. %{_libdir}/libwx_baseu_net-*.so.*
  133. %{_libdir}/libwx_baseu_xml-*.so.*
  134. %changelog
  135. * Sun Jul 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
  136. - redefined name, package structure and configure
  137. * Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
  138. - new upstream version
  139. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-2
  140. - built with rpm-4.8.1-1 for pkg-config file
  141. - changed libjpeg-devel to libjpeg-turbo-devel
  142. - added BuildRequires: libSM-devel, cppunit-devel, libgnomeprintui-devel
  143. * Tue Jun 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-1
  144. - new upstream version
  145. - dropt all patches
  146. * Tue Feb 23 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.10-4
  147. - added Patch10: wxGTK-2.8.10-gsockgtk.patch
  148. - added conrib libraries
  149. - rebuilt with new toolchain
  150. * Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.10-3
  151. - add patch100 for fix CVE-2009-2369 (Interger OF) from fc10
  152. * Mon Jun 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-2vl5
  153. - spec in UTF-8
  154. * Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-1vl5
  155. - new upstream version
  156. - built with gtk2-2.16.0
  157. * Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.9-1vl5
  158. - new upstream version
  159. - modified BuildPreReq: mesa-libGL-devel mesa-libGLU-devel (instead of XOrg-gl-devel)
  160. * Tue Feb 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.8.7-0vl5
  161. - rebuild with expat-2.0.1
  162. - add BuildPreReq: expat-devel pkgconfig
  163. * Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.7-0vl4
  164. - rebuilt with gtk2-2.12.5
  165. * Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl3
  166. - rebuilt for VineSeed
  167. * Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl2
  168. - add --enable-unicode configure option
  169. * Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> - 2.8.7-0vl1
  170. - new upstream version
  171. * Fri Jun 1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl2
  172. - rebuilt with new toolchain
  173. * Thu May 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl1
  174. - new upstream version
  175. - fixed Obsoletes tag
  176. * Fri Oct 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.2-0vl1
  177. - new upstream version
  178. - added Obsoletes: %{name}-gl %{name}-samples
  179. * Sun Jul 10 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.6.1-0vl1
  180. - new upstream version
  181. - remove private symbol patch
  182. - remove wx-gtk2-gl, wx-gtk2-samples subpackage
  183. * Tue May 25 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.4.2-0vl1
  184. - Initial build.