golang-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573
  1. # temporalily ignore test failures
  2. %ifarch %{ix86} x86_64
  3. %bcond_without ignore_tests
  4. %else
  5. %bcond_with ignore_tests
  6. %endif
  7. # Define arches for PA and SA
  8. %global golang_arches %{ix86} x86_64
  9. %global go_arches %{golang_arches}
  10. # Where to set GOPATH for builds
  11. %global gopath %{_datadir}/gocode
  12. # build ids are not currently generated:
  13. # https://code.google.com/p/go/issues/detail?id=5238
  14. #
  15. # also, debuginfo extraction currently fails with
  16. # "Failed to write file: invalid section alignment"
  17. %global debug_package %{nil}
  18. # we are shipping the full contents of src in the data subpackage, which
  19. # contains binary-like things (ELF data for tests, etc)
  20. %global _binaries_in_noarch_packages_terminate_build 0
  21. %if 0
  22. # Do not check any files in doc or src for requires
  23. %global __requires_exclude_from ^(%{_datadir}|/usr/lib)/%{name}/(doc|src)/.*$
  24. %endif
  25. # Don't alter timestamps of especially the .a files (or else go will rebuild later)
  26. # Actually, don't strip at all since we are not even building debug packages and this corrupts the dwarf testdata
  27. %global __strip /bin/true
  28. # rpmbuild magic to keep from having meta dependency on libc.so.6
  29. %global __requires_exclude_from ^.*$
  30. %global __spec_install_post /usr/lib/rpm/check-rpaths \
  31. /usr/lib/rpm/check-buildroot \
  32. /usr/lib/rpm/brp-compress
  33. # Golang build options.
  34. # Buid golang using external/internal(close to cgo disabled) linking.
  35. %global external_linker 1
  36. # Build golang with cgo enabled/disabled(later equals more or less to internal linking).
  37. %global cgo_enabled 1
  38. # Use golang/gcc-go as bootstrap compiler
  39. %global golang_bootstrap 1
  40. # boostrap(with internal linking) using gcc-go fails due to bug in tests(https://github.com/golang/go/issues/12629)
  41. # make check not to fail due to it
  42. # Controls what ever we fail on failed tests
  43. %if %{with ignore_tests}
  44. %global fail_on_tests 0
  45. %else
  46. %global fail_on_tests 1
  47. %endif
  48. # TODO get more support for shared objects
  49. # Build golang shared objects for stdlib
  50. %ifarch x86_64
  51. %global shared 1
  52. %else
  53. %global shared 0
  54. %endif
  55. # Fedora GOROOT
  56. %global goroot /usr/lib/%{name}
  57. %ifarch x86_64
  58. %global gohostarch amd64
  59. %endif
  60. %ifarch %{ix86}
  61. %global gohostarch 386
  62. %endif
  63. Summary: The Go Programming Language
  64. Summary(ja): プログラミング言語 Go
  65. Name: golang
  66. Version: 1.17
  67. Release: 1%{?_dist_release}
  68. Group: programming
  69. Vendor: Project Vine
  70. Distribution: Vine Linux
  71. # source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
  72. License: BSD and Public Domain
  73. URL: https://golang.org/
  74. # pre-processed by source.sh to make Mark.Twain-Tom.Sawyer.txt free again
  75. Source0: https://dl.google.com/go/go%{version}.src.tar.gz
  76. Source100: golang-gdbinit
  77. Source101: golang-prelink.conf
  78. Source102: macros.golang
  79. %global go_api %(echo "%{version}" | cut -d . -f 1,2)
  80. # These are the only RHEL/Fedora architectures that we compile this package for
  81. ExclusiveArch: %{golang_arches}
  82. # The compiler is written in Go. Needs go(1.4+) compiler for build.
  83. BuildRequires: golang > 1.4
  84. BuildRequires: net-tools
  85. # for tests
  86. BuildRequires: pcre-devel, glibc-static
  87. Provides: go = %{version}-%{release}
  88. Requires: %{name}-bin
  89. Requires: %{name}-src = %{version}-%{release}
  90. %description
  91. %{summary}.
  92. %package docs
  93. Summary: Golang compiler docs
  94. Group: documentation
  95. Requires: %{name} = %{version}-%{release}
  96. #BuildArch: noarch
  97. Obsoletes: %{name}-docs < 1.1-4
  98. %description docs
  99. %{summary}.
  100. %package misc
  101. Summary: Golang compiler miscellaneous sources
  102. Group: programming
  103. Requires: %{name} = %{version}-%{release}
  104. #BuildArch: noarch
  105. %description misc
  106. %{summary}.
  107. %package tests
  108. Summary: Golang compiler tests for stdlib
  109. Group: programming
  110. Requires: %{name} = %{version}-%{release}
  111. #BuildArch: noarch
  112. %description tests
  113. %{summary}.
  114. %package src
  115. Summary: Golang compiler source tree
  116. Group: programming
  117. #BuildArch: noarch
  118. %description src
  119. %{summary}
  120. %package bin
  121. Summary: Golang core compiler tools
  122. Group: programming
  123. Requires: go = %{version}-%{release}
  124. Requires(post): %{_sbindir}/update-alternatives
  125. Requires(postun): %{_sbindir}/update-alternatives
  126. # We strip the meta dependency, but go does require glibc.
  127. # This is an odd issue, still looking for a better fix.
  128. Requires: glibc
  129. Requires: gcc
  130. %description bin
  131. %{summary}
  132. # Workaround old RPM bug of symlink-replaced-with-dir failure
  133. %pretrans -p <lua>
  134. for _,d in pairs({"api", "doc", "include", "lib", "src"}) do
  135. path = "%{goroot}/" .. d
  136. if posix.stat(path, "type") == "link" then
  137. os.remove(path)
  138. posix.mkdir(path)
  139. end
  140. end
  141. %if %{shared}
  142. %package shared
  143. Summary: Golang shared object libraries
  144. Group: system
  145. %description shared
  146. %{summary}.
  147. %endif
  148. %debug_package
  149. %prep
  150. %setup -q -n go
  151. %build
  152. # bootstrap compiler GOROOT
  153. %if !%{golang_bootstrap}
  154. export GOROOT_BOOTSTRAP=/
  155. %else
  156. export GOROOT_BOOTSTRAP=%{goroot}
  157. %endif
  158. # set up final install location
  159. export GOROOT_FINAL=%{goroot}
  160. export GOHOSTOS=linux
  161. export GOHOSTARCH=%{gohostarch}
  162. pushd src
  163. # use our gcc options for this build, but store gcc as default for compiler
  164. export CFLAGS="$RPM_OPT_FLAGS"
  165. export LDFLAGS="$RPM_LD_FLAGS"
  166. export CC="gcc"
  167. export CC_FOR_TARGET="gcc"
  168. export GOOS=linux
  169. export GOARCH=%{gohostarch}
  170. %if !%{external_linker}
  171. export GO_LDFLAGS="-linkmode internal"
  172. %endif
  173. %if !%{cgo_enabled}
  174. export CGO_ENABLED=0
  175. %endif
  176. ./make.bash --no-clean
  177. popd
  178. # build shared std lib
  179. %if %{shared}
  180. GOROOT=$(pwd) PATH=$(pwd)/bin:$PATH go install -buildmode=shared std
  181. %endif
  182. %install
  183. rm -rf $RPM_BUILD_ROOT
  184. # create the top level directories
  185. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  186. mkdir -p $RPM_BUILD_ROOT%{goroot}
  187. # install everything into libdir (until symlink problems are fixed)
  188. # https://code.google.com/p/go/issues/detail?id=5830
  189. cp -apv api bin doc lib pkg src misc test VERSION \
  190. $RPM_BUILD_ROOT%{goroot}
  191. # bz1099206
  192. find $RPM_BUILD_ROOT%{goroot}/src -exec touch -r $RPM_BUILD_ROOT%{goroot}/VERSION "{}" \;
  193. # and level out all the built archives
  194. touch $RPM_BUILD_ROOT%{goroot}/pkg
  195. find $RPM_BUILD_ROOT%{goroot}/pkg -exec touch -r $RPM_BUILD_ROOT%{goroot}/pkg "{}" \;
  196. # generate the spec file ownership of this source tree and packages
  197. cwd=$(pwd)
  198. src_list=$cwd/go-src.list
  199. pkg_list=$cwd/go-pkg.list
  200. shared_list=$cwd/go-shared.list
  201. misc_list=$cwd/go-misc.list
  202. docs_list=$cwd/go-docs.list
  203. tests_list=$cwd/go-tests.list
  204. rm -f $src_list $pkg_list $docs_list $misc_list $tests_list $shared_list
  205. touch $src_list $pkg_list $docs_list $misc_list $tests_list $shared_list
  206. pushd $RPM_BUILD_ROOT%{goroot}
  207. find src/ -type d -a \( ! -name testdata -a ! -ipath '*/testdata/*' \) -printf '%%%dir %{goroot}/%p\n' >> $src_list
  208. find src/ ! -type d -a \( ! -ipath '*/testdata/*' -a ! -name '*_test*.go' \) -printf '%{goroot}/%p\n' >> $src_list
  209. find bin/ pkg/ -type d -a ! -path '*_dynlink/*' -printf '%%%dir %{goroot}/%p\n' >> $pkg_list
  210. find bin/ pkg/ ! -type d -a ! -path '*_dynlink/*' -printf '%{goroot}/%p\n' >> $pkg_list
  211. find doc/ -type d -printf '%%%dir %{goroot}/%p\n' >> $docs_list
  212. find doc/ ! -type d -printf '%{goroot}/%p\n' >> $docs_list
  213. find misc/ -type d -printf '%%%dir %{goroot}/%p\n' >> $misc_list
  214. find misc/ ! -type d -printf '%{goroot}/%p\n' >> $misc_list
  215. %if %{shared}
  216. find pkg/*_dynlink/ -type d -printf '%%%dir %{goroot}/%p\n' >> $shared_list
  217. find pkg/*_dynlink/ ! -type d -printf '%{goroot}/%p\n' >> $shared_list
  218. %endif
  219. find test/ -type d -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  220. find test/ ! -type d -printf '%{goroot}/%p\n' >> $tests_list
  221. find src/ -type d -a \( -name testdata -o -ipath '*/testdata/*' \) -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  222. find src/ ! -type d -a \( -ipath '*/testdata/*' -o -name '*_test*.go' \) -printf '%{goroot}/%p\n' >> $tests_list
  223. # this is only the zoneinfo.zip
  224. find lib/ -type d -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  225. find lib/ ! -type d -printf '%{goroot}/%p\n' >> $tests_list
  226. popd
  227. # remove the doc Makefile
  228. rm -rfv $RPM_BUILD_ROOT%{goroot}/doc/Makefile
  229. # put binaries to bindir, linked to the arch we're building,
  230. # leave the arch independent pieces in %{goroot}
  231. mkdir -p $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}
  232. ln -sf %{goroot}/bin/go $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}/go
  233. ln -sf %{goroot}/bin/gofmt $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}/gofmt
  234. # ensure these exist and are owned
  235. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/github.com
  236. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/bitbucket.org
  237. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/code.google.com/p
  238. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/golang.org/x
  239. # make sure these files exist and point to alternatives
  240. rm -f $RPM_BUILD_ROOT%{_bindir}/go
  241. ln -sf /etc/alternatives/go $RPM_BUILD_ROOT%{_bindir}/go
  242. rm -f $RPM_BUILD_ROOT%{_bindir}/gofmt
  243. ln -sf /etc/alternatives/gofmt $RPM_BUILD_ROOT%{_bindir}/gofmt
  244. # gdbinit
  245. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gdbinit.d
  246. cp -av %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/gdbinit.d/golang.gdb
  247. # prelink blacklist
  248. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/prelink.conf.d
  249. cp -av %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/prelink.conf.d/golang.conf
  250. # rpm macros
  251. mkdir -p %{buildroot}
  252. mkdir -p $RPM_BUILD_ROOT%{_rpmmacrodir}
  253. cp -av %{SOURCE102} $RPM_BUILD_ROOT%{_rpmmacrodir}/
  254. %check
  255. export GOROOT=$(pwd -P)
  256. export PATH="$GOROOT"/bin:"$PATH"
  257. cd src
  258. export CC="gcc"
  259. export CFLAGS="$RPM_OPT_FLAGS"
  260. export LDFLAGS="$RPM_LD_FLAGS"
  261. %if !%{external_linker}
  262. export GO_LDFLAGS="-linkmode internal"
  263. %endif
  264. %if !%{cgo_enabled} || !%{external_linker}
  265. export CGO_ENABLED=0
  266. %endif
  267. # make sure to not timeout
  268. export GO_TEST_TIMEOUT_SCALE=2
  269. %if %{fail_on_tests}
  270. ./run.bash --no-rebuild -v -v -v -k
  271. %else
  272. ./run.bash --no-rebuild -v -v -v -k || :
  273. %endif
  274. cd ..
  275. %post bin
  276. %{_sbindir}/update-alternatives --install %{_bindir}/go \
  277. go %{goroot}/bin/go 90 \
  278. --slave %{_bindir}/gofmt gofmt %{goroot}/bin/gofmt
  279. %preun bin
  280. if [ $1 = 0 ]; then
  281. %{_sbindir}/update-alternatives --remove go %{goroot}/bin/go
  282. fi
  283. %files
  284. %license LICENSE
  285. %doc AUTHORS CONTRIBUTORS PATENTS
  286. # VERSION has to be present in the GOROOT, for `go install std` to work
  287. %doc %{goroot}/VERSION
  288. %dir %{goroot}/doc
  289. %doc %{goroot}/doc/*
  290. # go files
  291. %dir %{goroot}
  292. %exclude %{goroot}/bin/
  293. %exclude %{goroot}/pkg/
  294. %exclude %{goroot}/src/
  295. %exclude %{goroot}/doc/
  296. %exclude %{goroot}/misc/
  297. %{goroot}/*
  298. # ensure directory ownership, so they are cleaned up if empty
  299. %dir %{gopath}
  300. %dir %{gopath}/src
  301. %dir %{gopath}/src/github.com/
  302. %dir %{gopath}/src/bitbucket.org/
  303. %dir %{gopath}/src/code.google.com/
  304. %dir %{gopath}/src/code.google.com/p/
  305. %dir %{gopath}/src/golang.org
  306. %dir %{gopath}/src/golang.org/x
  307. # gdbinit (for gdb debugging)
  308. %{_sysconfdir}/gdbinit.d
  309. # prelink blacklist
  310. %{_sysconfdir}/prelink.conf.d
  311. %{_rpmmacrodir}/macros.golang
  312. %files -f go-src.list src
  313. %files -f go-docs.list docs
  314. %files -f go-misc.list misc
  315. %files -f go-tests.list tests
  316. %files -f go-pkg.list bin
  317. %{_bindir}/go
  318. %{_bindir}/gofmt
  319. %if %{shared}
  320. %files -f go-shared.list shared
  321. %endif
  322. %changelog
  323. * Wed Aug 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17-1
  324. - new upstream release.
  325. * Sat Jul 31 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.6-1
  326. - new upstream release.
  327. * Tue Jun 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.5-1
  328. - new upstream release.
  329. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.2-1
  330. - new upstream release.
  331. * Wed Feb 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.7-1
  332. - new upstream release.
  333. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.6-1
  334. - new upstream release.
  335. * Thu Nov 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.5-1
  336. - new upstream release.
  337. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.1-1
  338. - new upstream release.
  339. * Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15-1
  340. - new upstream release.
  341. * Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.6-1
  342. - new upstream release.
  343. * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-1
  344. - new upstream release.
  345. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.5-1
  346. - new upstream release.
  347. * Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.4-1
  348. - new upstream release.
  349. * Tue Jun 26 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.10.3-1
  350. - update to 1.10.3
  351. - drop patches (Patch0, 212, 215)
  352. - export 'GO_TEST_TIMEOUT_SCALE=2' in %%check
  353. - add bcond for tests
  354. * Tue Jun 06 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.3-1
  355. - update to 1.8.3
  356. * Mon Jun 5 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.1-1
  357. - update to 1.8.1
  358. - remove BuildArch tags
  359. - drop Source1
  360. - drop patches
  361. - remove ECC p224 patch (Patch1)
  362. - X.509 patch (Patch2): upstream merged
  363. - disable TestGdbPython patch (Patch213)
  364. - disable TestCloneNEWUSERAndRemapNoRootDisableSetgroups patch (Patch214)
  365. - drop Patch216: upstream fixed
  366. - update bootstrap binary path patch (Patch212)
  367. * Mon Dec 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
  368. - new upstream release.
  369. * Sun Mar 8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-1
  370. - new upstream release.
  371. * Mon Dec 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2-2
  372. - added Group tag
  373. * Sat Feb 1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.2
  374. - initial build for Vine Linux
  375. - drop emacs and vim package
  376. * Fri Jan 24 2014 Vincent Batts <vbatts@redhat.com> 1.2-4
  377. - skip a flaky test that is sporadically failing on the build server
  378. * Thu Jan 16 2014 Vincent Batts <vbatts@redhat.com> 1.2-3
  379. - remove golang-godoc dependency. cyclic dependency on compiling godoc
  380. * Wed Dec 18 2013 Vincent Batts <vbatts@redhat.com> - 1.2-2
  381. - removing P224 ECC curve
  382. * Mon Dec 2 2013 Vincent Batts <vbatts@fedoraproject.org> - 1.2-1
  383. - Update to upstream 1.2 release
  384. - remove the pax tar patches
  385. * Tue Nov 26 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-8
  386. - fix the rpmspec conditional for rhel and fedora
  387. * Thu Nov 21 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-7
  388. - patch tests for testing on rawhide
  389. - let the same spec work for rhel and fedora
  390. * Wed Nov 20 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-6
  391. - don't symlink /usr/bin out to ../lib..., move the file
  392. - seperate out godoc, to accomodate the go.tools godoc
  393. * Fri Sep 20 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-5
  394. - Pull upstream patches for BZ#1010271
  395. - Add glibc requirement that got dropped because of meta dep fix
  396. * Fri Aug 30 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-4
  397. - fix the libc meta dependency (thanks to vbatts [at] redhat.com for the fix)
  398. * Tue Aug 27 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-3
  399. - Revert incorrect merged changelog
  400. * Tue Aug 27 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-2
  401. - This was reverted, just a placeholder changelog entry for bad merge
  402. * Tue Aug 20 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-1
  403. - Update to latest upstream
  404. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-7
  405. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  406. * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 1.1.1-6
  407. - Perl 5.18 rebuild
  408. * Wed Jul 10 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-5
  409. - Blacklist testdata files from prelink
  410. - Again try to fix #973842
  411. * Fri Jul 5 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-4
  412. - Move src to libdir for now (#973842) (upstream issue https://code.google.com/p/go/issues/detail?id=5830)
  413. - Eliminate noarch data package to work around RPM bug (#975909)
  414. - Try to add runtime-gdb.py to the gdb safe-path (#981356)
  415. * Wed Jun 19 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-3
  416. - Use lua for pretrans (http://fedoraproject.org/wiki/Packaging:Guidelines#The_.25pretrans_scriptlet)
  417. * Mon Jun 17 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-2
  418. - Hopefully really fix #973842
  419. - Fix update from pre-1.1.1 (#974840)
  420. * Thu Jun 13 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-1
  421. - Update to 1.1.1
  422. - Fix basically useless package (#973842)
  423. * Sat May 25 2013 Dan Horák <dan[at]danny.cz> - 1.1-3
  424. - set ExclusiveArch
  425. * Fri May 24 2013 Adam Goode <adam@spicenitz.org> - 1.1-2
  426. - Fix noarch package discrepancies
  427. * Fri May 24 2013 Adam Goode <adam@spicenitz.org> - 1.1-1
  428. - Initial Fedora release.
  429. - Update to 1.1
  430. * Thu May 9 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.3.rc3
  431. - Update to rc3
  432. * Thu Apr 11 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.2.beta2
  433. - Update to beta2
  434. * Tue Apr 9 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.1.beta1
  435. - Initial packaging.