123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224 |
- Summary: CD-ROM input and control library
- Summary(ja): CD-ROM 入力・制御ライブラリ
- Name: libcdio
- Version: 0.93
- Release: 1%{?_dist_release}
- Group: System Environment/Libraries
- License: GPLv3+
- URL: http://www.gnu.org/software/libcdio/
- Vendor: Project Vine
- Distribution: Vine Linux
- Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
- Source2: libcdio-no_date_footer.hml
- Patch1: libcdio-0.80-paranoia-fix.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: pkgconfig doxygen
- BuildRequires: ncurses-devel
- BuildRequires: libcddb-devel
- BuildRequires: help2man
- BuildRequires: gcc-c++
- Requires(post): /sbin/install-info
- Requires(preun): /sbin/install-info
- %description
- This library provides an interface for CD-ROM access. It can be used
- by applications that need OS- and device-independent access to CD-ROM
- devices.
- %package devel
- Summary: Development files for %{name}
- Summary(ja): %{name} の開発用ファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- This package contains development files for %{name}.
- %prep
- %setup -q
- f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
- iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
- %build
- %configure \
- --disable-vcd-info \
- --disable-dependency-tracking \
- --disable-rpath \
- --enable-cddb \
- --disable-static
- make %{?_smp_mflags}
- cd doc/doxygen
- sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
- cp %{SOURCE2} .
- ./run_doxygen
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- rm -f $RPM_BUILD_ROOT%{_infodir}/dir
- find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
- rm -rf examples
- mkdir -p examples/C++
- cp -a example/{*.c,README} examples
- cp -a example/C++/{*.cpp,README} examples/C++
- %check
- # disable test using local CDROM
- %{__sed} -i -e "s,testiso9660\$(EXEEXT),,g" \
- -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
- test/Makefile
- make check
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/ldconfig
- /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
- %preun
- if [ $1 = 0 ]; then
- /sbin/install-info --delete %{_infodir}/%{name}.info \
- %{_infodir}/dir 2>/dev/null || :
- fi
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
- %{_bindir}/*
- %{_libdir}/*.so.*
- %{_infodir}/*
- %{_mandir}/man1/*
- %files devel
- %defattr(-,root,root,-)
- %doc doc/doxygen/html examples
- %{_includedir}/cdio
- %{_includedir}/cdio++
- %{_libdir}/*.so
- %{_libdir}/pkgconfig/*.pc
- %changelog
- * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.93-1
- - updated to 0.93.
- * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92-1
- - update to 0.92
- * Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-2
- - rebuilt with rpm-4.8.1 for pkg-config
- - added --enable-cddb
- * Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
- - new upstream release
- - dropt Patch1
- - removed static libraries from devel package
- * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
- - initial build for Vine Linux
- * Wed Jun 4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
- - added patch enabling libcdio_paranoia.pc
- * Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
- - updated to 0.80
- - removed upstreamed patches
- - last GPLv2+ release
- * Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
- - added patch to compile with gcc43
- * Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
- - fixed security fix (was off by two)
- * Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
- - updated to 0.79
- - fixes #427197 (Long Joliet file name overflows cdio's buffer)
- - fixes #341981 (multiarch conflicts in libcdio)
- * Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
- - rebuilt
- * Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
- - updated to 0.78.2 (#221359) (this time for real)
- * Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
- - updated to 0.78.2 (#221359)
- * Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
- - disabled iso9660 test case (fails for some reason with date problems)
- this seems to be a known problem according to the ChangeLog
- * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
- - rebuilt for unwind info generation, broken in gcc-4.1.1-21
- * Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
- - Updated to 0.77
- * Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
- - Rebuilt
- * Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
- - Rebuilt
- * Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
- - Updated to 0.76.
- - Included doxygen generated documentation into -devel
- - Included examples into -devel
- * Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
- - disable test accessing local CDROM drive (#164266)
- * Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
- - Rebuilt without libcddb dependency (#164270)
- * Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
- - Rebuilt
- * Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
- - Updated to 0.75.
- * Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
- - Updated to 0.74.
- * Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
- - BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
- - Run test suite during build.
- - Install Japanese man pages.
- * Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
- - Updated to 0.73.
- * Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
- - Fix FC4 build (#151468).
- - Build with dependency tracking disabled.
- * Sun Sep 5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
- - Updated to 0.70.
- * Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
- - Updated to 0.69.
- - Removed broken iso-read.
- - Split Requires(pre,post).
- - Added BuildReq pkgconfig.
- * Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
- - Initial RPM release.
|