123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175 |
- Name: libkdcraw
- Summary: A C++ interface around LibRaw library
- Summary(ja): LibRaw ライブラリ向けの C++ インターフェース
- Version: 4.14.3
- Release: 2%{?_dist_release}
- # libkdcraw is GPLv2+,
- License: GPLv2+
- URL: https://projects.kde.org/projects/kde/kdegraphics/libs/libkdcraw
- Group: System Environment/Libraries
- Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.xz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: kdelibs-devel >= %{version}
- BuildRequires: lcms-devel
- BuildRequires: libjpeg-devel
- BuildRequires: LibRaw-devel
- Requires: kdelibs >= %{version}
- # when split occurred
- Conflicts: kdegraphics-libs < 4.6.95-10
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- Libkdcraw is a C++ interface around LibRaw library used to decode RAW
- picture files. More information about LibRaw can be found at
- http://www.libraw.org.
- %package devel
- Summary: Development files for %{name}
- Summary(ja): %{name} の開発用ファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: kdelibs-devel
- %description devel
- %{summary}.
- %prep
- %setup -q
- %build
- mkdir -p %{_target_platform}
- pushd %{_target_platform}
- %cmake \
- -DCMAKE_BUILD_TYPE=release \
- -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
- -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
- -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
- -DLIB_INSTALL_DIR:PATH=%{_libdir} \
- -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
- -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
- ..
- popd
- make %{?_smp_mflags} -C %{_target_platform}
- %install
- rm -rf %{buildroot}
- make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
- %check
- export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
- pkg-config --modversion libkdcraw
- make -C %{_target_platform}/tests
- %post
- /sbin/ldconfig
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
- %posttrans
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
- %postun
- /sbin/ldconfig
- if [ $1 -eq 0 ] ; then
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
- fi
- %files
- %doc AUTHORS ChangeLog COPYING NEWS README TODO
- %{_libdir}/libkdcraw.so.*
- %{_datadir}/kde4/apps/libkdcraw/
- %{_datadir}/icons/hicolor/*/*/*
- %files devel
- %{_libdir}/libkdcraw.so
- %{_libdir}/pkgconfig/libkdcraw.pc
- %{_includedir}/kde4/libkdcraw/
- %changelog
- * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.14.3-2
- - rebuilt with LibRaw-0.17.2.
- * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
- - new upstream release
- * Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
- - new upstream release
- * Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
- - new upstream release
- - add BuildRequires: LibRaw-devel
- * Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
- - new upstream release
- * Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
- - new upstream release
- * Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
- - new upstream release
- * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
- - new upstream release
- * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
- - new upstream release
- * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
- - new upstream release
- * Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
- - new upstream release
- * Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
- - new upstream release
- * Sun Dec 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
- - new upstream release
- * Sat Oct 15 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
- - new upstream release
- * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
- - Initial build for Vine Linux
- * Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
- - 4.7.0
- * Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
- - 4.6.95
- * Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-5
- - License: GPLv2+ and LGPLv2 and GPLv3+
- - Provides: bundled(LibRaw)
- * Sun Jul 10 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-4
- - fix URL
- - fix scriptlets
- * Sun Jul 10 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-3
- - License: GPLv2+
- - %%doc: +ChangeLog NEWS
- - add %%check section
- * Wed Jul 06 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-2
- - fix Source0 URL
- - Conflicts: kdegraphics < 7:4.6.90-10
- * Tue Jul 05 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-1
- - first try
|