123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131 |
- %global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
- %global cpan_changes_available %(expr 0%{?fedora} + 0%{?rhel} '>' 6)
- Name: perl-Module-Implementation
- Version: 0.06
- Release: 1%{?_dist_release}
- Summary: Loads one of several alternate underlying implementations for a module
- Group: Development/Libraries
- License: Artistic 2.0
- URL: http://search.cpan.org/dist/perl-Module-Implementation/
- Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Module-Implementation-%{version}.tar.gz
- Patch1: Module-Implementation-0.05-old-Test::More.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
- BuildArch: noarch
- BuildRequires: perl(ExtUtils::MakeMaker)
- BuildRequires: perl(Carp)
- BuildRequires: perl(Module::Runtime) >= 0.012
- BuildRequires: perl(Try::Tiny)
- BuildRequires: perl(strict)
- BuildRequires: perl(warnings)
- BuildRequires: perl(lib)
- BuildRequires: perl(Test::Fatal)
- BuildRequires: perl(Test::More)
- BuildRequires: perl(Test::Requires)
- BuildRequires: perl(Test::Taint)
- %if %{cpan_changes_available}
- BuildRequires: perl(Test::CPAN::Changes)
- %endif
- BuildRequires: perl(Test::EOL)
- BuildRequires: perl(Test::NoTabs)
- BuildRequires: perl(Test::Pod)
- BuildRequires: perl(Test::Spelling), aspell-en
- Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
- Requires: perl(Carp)
- %description
- This module abstracts out the process of choosing one of several underlying
- implementations for a module. This can be used to provide XS and pure Perl
- implementations of a module, or it could be used to load an implementation
- for a given OS or any other case of needing to provide multiple
- implementations.
- This module is only useful when you know all the implementations ahead of
- time. If you want to load arbitrary implementations then you probably want
- something like a plugin system, not this module.
- %prep
- %setup -q -n Module-Implementation-%{version}
- %if %{old_test_more}
- %patch1 -p1
- %endif
- %build
- perl Makefile.PL INSTALLDIRS=vendor
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make pure_install DESTDIR=%{buildroot}
- find %{buildroot} -type f -name .packlist -exec rm -f {} \;
- find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
- %{_fixperms} %{buildroot}
- %check
- make test RELEASE_TESTING=1
- %clean
- rm -rf %{buildroot}
- %files
- %defattr(-,root,root,-)
- %doc Changes LICENSE README
- %{perl_vendorlib}/Module/
- %{_mandir}/man3/Module::Implementation.3pm*
- %changelog
- * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.06-1
- - initial build for Vine Linux
- * Sun Feb 12 2012 Paul Howarth <paul@city-fan.org> - 0.06-1
- - Update to 0.06
- - Require Module::Runtime 0.012, which has a number of useful bug fixes
- * Fri Feb 10 2012 Paul Howarth <paul@city-fan.org> - 0.05-1
- - Update to 0.05
- - Make Test::Taint an optional dependency; it requires XS, and requiring a
- compiler for Module::Implementation defeats its purpose (CPAN RT#74817)
- - BR: perl(Test::Requires)
- - Update patch for building with old Test::More versions
- * Thu Feb 9 2012 Paul Howarth <paul@city-fan.org> - 0.04-1
- - Update to 0.04
- - This module no longer installs an _implementation() subroutine in callers;
- instead, you can call Module::Implementation::implementation_for($package)
- to get the implementation used for a given package
- - Update patch for building with old Test::More versions
- * Wed Feb 8 2012 Paul Howarth <paul@city-fan.org> - 0.03-3
- - Incorporate feedback from package review (#788258)
- - Correct License tag, which should be Artistic 2.0
- - BR: perl(lib) for test suite
- - Explicitly require perl(Carp), not automatically detected
- * Tue Feb 7 2012 Paul Howarth <paul@city-fan.org> - 0.03-2
- - Sanitize for Fedora submission
- * Tue Feb 7 2012 Paul Howarth <paul@city-fan.org> - 0.03-1
- - Initial RPM version
|