1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889 |
- %global srcname pip
- Summary: Pip installs Python packages. An easy_install replacement
- Summary(ja): Pip は easy_install を置き換える Python パッケージインストーラです。
- Name: python-%{srcname}
- Version: 1.5.6
- Release: 1%{?_dist_release}
- Group: Development/Libraries
- License: MIT
- URL: http://pip.openplans.org
- Source0: http://pypi.python.org/packages/source/p/pip/%{srcname}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildArch: noarch
- BuildRequires: python-devel
- BuildRequires: python-setuptools
- Requires: python-setuptools
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- Pip is a replacement for `easy_install
- <http://peak.telecommunity.com/DevCenter/EasyInstall>`_. It uses mostly the
- same techniques for finding packages, so packages that were made
- easy_installable should be pip-installable as well.
- pip is meant to improve on easy_install.bulletin boards, etc.).
- %prep
- %setup -q -n %{srcname}-%{version}
- %{__sed} -i '1d' pip/__init__.py
- %build
- %{__python} setup.py build
- %install
- %{__rm} -rf %{buildroot}
- %{__python} setup.py install -O1 --skip-build --root %{buildroot}
- %{__rm} -rf %{buildroot}%{_bindir}/pip-*
- #mv %{buildroot}%{_bindir}/pip %{buildroot}%{_bindir}/pip-python
- %clean
- %{__rm} -rf %{buildroot}
- %files
- %defattr(-,root,root,-)
- %doc PKG-INFO docs
- %attr(755,root,root) %{_bindir}/pip
- %attr(755,root,root) %{_bindir}/pip2*
- %{python_sitelib}/pip*
- %changelog
- * Sat Jul 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.6-1
- - new upstream release
- - didn't rename pip to python-pip
- * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-3
- - rebuild with VineSeed environment
- * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-2
- - rebuild with python-2.7.2
- * Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
- - updated pip to 0.8.1
- * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8-1
- - initial build for Vine Linux
- * Mon Aug 30 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.8-1
- - update to 0.8 of pip
- * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.7.2-5
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Wed Jul 7 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.7.2-1
- - update to 0.7.2 of pip
- * Sun May 23 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.7.1-1
- - update to 0.7.1 of pip
- * Fri Jan 1 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1.4
- - fix dependency issue
- * Fri Dec 18 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1-2
- - fix spec file
- * Thu Dec 17 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1-1
- - upgrade to 0.6.1 of pip
- * Mon Aug 31 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.4-1
- - Initial package
|