gnutls-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %global guile_shortver %(guile-config --version 2>&1 | sed -e 's/^guile-config.*version //' -e ' s/\.[0-9]*$//')
  3. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  4. Summary: GNU TLS Library
  5. Summary(ja): GNU TLS ライブラリ
  6. Name: gnutls
  7. Version: 3.6.13
  8. Release: 1%{?_dist_release}
  9. # The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
  10. Group: System Environment/Libraries
  11. License: GPLv3+ and LGPLv2+
  12. URL: http://www.gnutls.org/
  13. %global shortver %(echo "%{version}" | sed -e 's/\.[0-9]*$//')
  14. Source0: https://www.gnupg.org/ftp/gcrypt/gnutls/v%{shortver}/%{name}-%{version}.tar.xz
  15. Source1: libgnutls-config
  16. #patches from fedora development
  17. Patch1: gnutls-3.2.7-rpath.patch
  18. Patch2: gnutls-3.6.7-no-now-guile.patch
  19. # Vine Patches
  20. # Nothing...
  21. # Security fixes
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: libtasn1-devel >= 4.13
  24. Requires: libtasn1 >= 4.13
  25. BuildRequires: libunistring-devel
  26. BuildRequires: datefudge >= 1.22
  27. BuildRequires: gmp-devel
  28. BuildRequires: gettext readline-devel libtool
  29. BuildRequires: guile-devel >= 1.8.6
  30. BuildRequires: p11-kit-devel >= 0.21.3
  31. BuildRequires: nettle-devel >= 3.4
  32. Requires: nettle >= 3.4
  33. BuildRequires: texinfo, autogen
  34. BuildRequires: unbound-devel unbound-libs
  35. BuildRequires: zlib-devel
  36. Requires: zlib
  37. # for tests
  38. BuildRequires: net-tools
  39. Requires(post): ldconfig
  40. Requires(postun): ldconfig
  41. Vendor: Project Vine
  42. Distribution: Vine Linux
  43. %description
  44. GnuTLS is a project that aims to develop a library which provides a secure
  45. layer, over a reliable transport layer. Currently the GnuTLS library implements
  46. the proposed standards by the IETF's TLS working group.
  47. #'
  48. %package devel
  49. Summary: Development files for the GnuTLS package.
  50. Summary(ja): GnuTLS の開発用ファイル
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: libgcrypt-devel, zlib-devel, pkgconfig
  54. Requires: libtasn1-devel, nettle-devel
  55. Provides: pkgconfig(gnutls) = %{version}
  56. Provides: pkgconfig(gnutls-dane) = %{version}
  57. Requires(post,preun): /sbin/install-info
  58. %description devel
  59. GnuTLS is a project that aims to develop a library which provides a secure
  60. layer, over a reliable transport layer. Currently the GnuTLS library implements
  61. the proposed standards by the IETF's TLS working group.
  62. This package contains files needed for developing applications with the GnuTLS
  63. library.
  64. #'
  65. %package utils
  66. Summary: Command line tools for TLS protocol.
  67. Summary(ja): GnuTLS のコマンドラインツール
  68. Group: Applications/System
  69. Requires: %{name} = %{version}-%{release}
  70. %description utils
  71. GnuTLS is a project that aims to develop a library which provides a secure
  72. layer, over a reliable transport layer. Currently the GnuTLS library implements
  73. the proposed standards by the IETF's TLS working group.
  74. This package contains command line TLS client and server and certificate
  75. manipulation tools.
  76. #'
  77. %package guile
  78. Summary: Guile bindings for the GNUTLS library
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: guile
  82. %description guile
  83. GnuTLS is a project that aims to develop a library which provides a secure
  84. layer, over a reliable transport layer. Currently the GnuTLS library implements
  85. the proposed standards by the IETF's TLS working group.
  86. This package contains Guile bindings for the library.
  87. #'
  88. %package c++
  89. Summary: The C++ interface to GnuTLS
  90. Group: System Environment/Libraries
  91. Requires: %{name} = %{version}-%{release}
  92. %description c++
  93. GnuTLS is a project that aims to develop a library which provides a secure
  94. layer, over a reliable transport layer. Currently the GnuTLS library implements
  95. the proposed standards by the IETF's TLS working group.
  96. This package contains the C++ interface for the GnuTLS library.
  97. #'
  98. %package -n compat32-%{name}
  99. Summary: GNU TLS Library
  100. Summary(ja): GNU TLS ライブラリ
  101. Group: System Environment/Libraries
  102. Requires: %{name} = %{version}-%{release}
  103. %description -n compat32-%{name}
  104. GnuTLS is a project that aims to develop a library which provides a secure
  105. layer, over a reliable transport layer. Currently the GnuTLS library implements
  106. the proposed standards by the IETF's TLS working group.
  107. #'
  108. %package -n compat32-%{name}-devel
  109. Summary: Development files for the GnuTLS package.
  110. Summary(ja): GnuTLS の開発用ファイル
  111. Group: Development/Libraries
  112. Requires: compat32-%{name} = %{version}-%{release}
  113. Requires: %{name}-devel = %{version}-%{release}
  114. Requires: compat32-libgcrypt-devel, compat32-zlib-devel
  115. Requires(post,preun): /sbin/install-info
  116. %description -n compat32-%{name}-devel
  117. GnuTLS is a project that aims to develop a library which provides a secure
  118. layer, over a reliable transport layer. Currently the GnuTLS library implements
  119. the proposed standards by the IETF's TLS working group.
  120. This package contains files needed for developing applications with the GnuTLS
  121. library.
  122. #'
  123. %package -n compat32-%{name}-guile
  124. Summary: Guile bindings for the GNUTLS library
  125. Group: Development/Libraries
  126. Requires: compat32-%{name} = %{version}-%{release}
  127. Requires: %{name}-guile = %{version}-%{release}
  128. %description -n compat32-%{name}-guile
  129. GnuTLS is a project that aims to develop a library which provides a secure
  130. layer, over a reliable transport layer. Currently the GnuTLS library implements
  131. the proposed standards by the IETF's TLS working group.
  132. This package contains Guile bindings for the library.
  133. #'
  134. %prep
  135. %autosetup -p1
  136. sed -i -e 's|sys_lib_dlsearch_path_spec="/lib /usr/lib|sys_lib_dlsearch_path_spec="/lib /usr/lib %{_libdir}|g' configure
  137. rm -f lib/minitasn1/*.c lib/minitasn1/*.h
  138. rm -f src/libopts/*.c src/libopts/*.h src/libopts/compat/*.c src/libopts/compat/*.h
  139. echo "SYSTEM=NORMAL" >> tests/system.prio
  140. %build
  141. export LDFLAGS="-Wl,--no-add-needed"
  142. # autoreconf -fi
  143. %configure \
  144. --enable-sha1-support \
  145. --disable-static \
  146. --disable-openssl-compatibility \
  147. --disable-non-suiteb-curves \
  148. --enable-guile \
  149. --with-unbound-root-key-file=/var/lib/unbound/root.key \
  150. --enable-dane \
  151. --disable-rpath \
  152. %{nil}
  153. # --with-libgcrypt
  154. # --with-lzo \
  155. # --with-included-libcfg \
  156. # --with-libtasn1-prefix=%{_prefix} \
  157. # --with-included-libtasn1 \
  158. # --with-included-opencdk \
  159. # --with-included-lzo \
  160. make %{?_smp_mflags}
  161. # cp lib/COPYING COPYING.LIB
  162. %install
  163. %__rm -rf %{buildroot}
  164. # makeinstall macro causes build error, why?
  165. make install DESTDIR=%{buildroot}
  166. rm -f %{buildroot}%{_infodir}/dir
  167. rm -f %{buildroot}%{_libdir}/*.la
  168. rm -f %{buildroot}%{_libdir}/libguile*.a
  169. rm -f %{buildroot}%{_libdir}/guile/%{guile_shortver}/*.la
  170. rm -f %{buildroot}%{_libdir}/guile/%{guile_shortver}/extensions/*.la
  171. rm -f %{buildroot}%{_libdir}/gnutls/libpkcs11mock1.*
  172. rm -rf %{buildroot}%{_docdir}/gnutls
  173. %find_lang gnutls
  174. %check
  175. make check %{?_smp_mflags}
  176. %clean
  177. rm -rf %{buildroot}
  178. %post -p /sbin/ldconfig
  179. %postun -p /sbin/ldconfig
  180. %post devel
  181. if [ -f %{_infodir}/gnutls.info.gz ]; then
  182. /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
  183. fi
  184. %preun devel
  185. if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
  186. /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
  187. fi
  188. %post guile -p /sbin/ldconfig
  189. %postun guile -p /sbin/ldconfig
  190. %post -n compat32-%{name} -p /sbin/ldconfig
  191. %postun -n compat32-%{name} -p /sbin/ldconfig
  192. %post -n compat32-%{name}-guile -p /sbin/ldconfig
  193. %postun -n compat32-%{name}-guile -p /sbin/ldconfig
  194. %files -f gnutls.lang
  195. %defattr(-,root,root,-)
  196. %{_libdir}/libgnutls.so.30*
  197. %{_libdir}/libgnutls-dane.so.*
  198. # %{_libdir}/libgnutls-xssl.so.0*
  199. %doc README* AUTHORS NEWS THANKS
  200. %files devel
  201. %defattr(-,root,root,-)
  202. %{_includedir}/*
  203. %{_libdir}/libgnutls*.so
  204. %{_libdir}/pkgconfig/*.pc
  205. %{_mandir}/man3/*
  206. %{_infodir}/gnutls*
  207. %{_infodir}/pkcs11-vision.png.gz
  208. %files utils
  209. %defattr(-,root,root,-)
  210. %{_bindir}/certtool
  211. %{_bindir}/danetool
  212. %{_bindir}/psktool
  213. %{_bindir}/p11tool
  214. %{_bindir}/ocsptool
  215. %{_bindir}/srptool
  216. %{_bindir}/gnutls*
  217. %{_mandir}/man1/*
  218. %doc doc/certtool.cfg
  219. %files guile
  220. %defattr(-,root,root,-)
  221. %{_libdir}/guile/%{guile_shortver}/extensions/guile*.so*
  222. %{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls.go
  223. %{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls/extra.go
  224. %{_datadir}/guile/site/%{guile_shortver}/gnutls
  225. %{_datadir}/guile/site/%{guile_shortver}/gnutls.scm
  226. %files c++
  227. %{_libdir}/libgnutlsxx.so.*
  228. %if %{build_compat32}
  229. %files -n compat32-%{name}
  230. %defattr(-,root,root,-)
  231. %{_libdir}/libgnutls.so.30*
  232. %{_libdir}/libgnutls-dane.so.*
  233. # %{_libdir}/libgnutls-xssl.so.0*
  234. %files -n compat32-%{name}-devel
  235. %defattr(-,root,root,-)
  236. #%{_libdir}/libgnutls*.a
  237. %{_libdir}/libgnutls*.so
  238. %{_libdir}/pkgconfig/*.pc
  239. %files -n compat32-%{name}-guile
  240. %defattr(-,root,root,-)
  241. %{_libdir}/guile/%{guile_shortver}/extensions/guile*.so*
  242. %{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls.go
  243. %{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls/extra.go
  244. %endif
  245. %changelog
  246. * Tue Apr 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.13-1
  247. - new upstream release.
  248. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.9-1
  249. - new upstream release.
  250. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.7-1
  251. - new upstream release.
  252. - updated Patch2.
  253. - dropped Patch3.
  254. * Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.4-1
  255. - new upstream release.
  256. - dropped Patch2-3,1001 and 2001.
  257. - imported Patch2-3 from rawhide.
  258. - enabled DANE support.
  259. * Sat Jan 28 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.4.14-3
  260. - fix CVE-2017-5337, CVE-2017-5334, CVE-2017-5336, CVE-2017-5335
  261. - add Patch3001 from Fedora 24 gnutls-3.4.17-2.fc24
  262. * Thu Jan 12 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.4.14-2
  263. - fix CVE-2016-7444; OCSP validation issue
  264. - add Patch2001
  265. - add BR: net-tools; for test
  266. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.14-1
  267. - new upstream release 3.4.14.
  268. - dropped Patch100.
  269. - added BR: datefudge.
  270. * Mon Jul 4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.13-1
  271. - new upstream release 3.4.13.
  272. - added Patch100: workaround of failing cert-test (The certificate was expired).
  273. * Sun Feb 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.9-1
  274. - new upstream release 3.4.9
  275. * Fri Jan 1 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-2
  276. - rebuilt to marge changelog
  277. * Tue Dec 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-1
  278. - new upstream release 3.4.7
  279. * Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.17-3
  280. - rebuild with nettls-3.1.1
  281. * Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-2
  282. - BR: libtasn1-devel >= 3.9
  283. * Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-1
  284. - built for release
  285. * Tue Aug 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.2
  286. - rm libgnutls-xssl.so.0* in files list
  287. * Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.1
  288. - for test
  289. * Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
  290. - add patch1000 for fix SA-2015-3
  291. * Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
  292. - rebuilt with guile 2.0.11
  293. * Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
  294. - new upstream release with security fix
  295. * Thu Jun 5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
  296. - new upstream release with security fix
  297. * Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
  298. - new upstream release with security fix
  299. * Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
  300. - new upstream release with security fix
  301. * Sun Feb 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
  302. - fix R: in compat32
  303. * Wed Feb 5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
  304. - fix BR:, R: (drop unneeded dependency)
  305. * Mon Feb 3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
  306. - new upstream release 3.2.10
  307. - update patches / drop old patches
  308. - add BR: nettle
  309. * Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
  310. - added Patch100 from upstream to fix CVE-2013-2116
  311. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
  312. - new upstream release
  313. - fixed a day of the week in %%changelog
  314. * Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
  315. - new upstream release
  316. * Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
  317. - new upstream release
  318. * Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
  319. - new upstream release
  320. * Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
  321. - new upstream release
  322. * Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
  323. - new upstream release
  324. - changed BuildRequires: p11-kit-devel >= 0.11
  325. * Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
  326. - new upstream release
  327. * Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
  328. - new upstream release
  329. * Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
  330. - added BuildRequires: p11-kit-devel
  331. * Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
  332. - deleted BuildRequires: nettle-devel
  333. - mistake.. fixed.
  334. * Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
  335. - new upstream release
  336. - synced Fedora development package
  337. - add new sub-package: c++
  338. * Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
  339. - add Requires: libtasn1-devel for devel subpackage
  340. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
  341. - new upstream release
  342. * Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
  343. - new upstream release
  344. * Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
  345. - new upstream release
  346. - dropt patch1
  347. * Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
  348. - new upstream release
  349. - added patch1,2,3,4 from Fedora development
  350. - added BuildRequires: gettext readline-devel libtool
  351. - added configure option
  352. --disable-static,--disable-srp-authentication
  353. - dropt *.a files from -devel package again
  354. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
  355. - build with rpm-4.8.1-1 for pkg-config file
  356. * Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
  357. - new upstream release
  358. - applied new naming policy to spec
  359. * Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
  360. - new upstream release
  361. * Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
  362. - new upstream release
  363. * Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
  364. - new upstream release
  365. * Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
  366. - new upstream release with security fix (handling X.509 CN or SAN fields)
  367. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
  368. - added compat32 package for x86_64 arch support
  369. * Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
  370. - new upstream release
  371. - added autoreconf
  372. - deleted libguile*.a
  373. - dropt Patch3
  374. - added %post guile, %postun guile
  375. * Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
  376. - drop *.a files from -devel package
  377. - build with system lzo
  378. * Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
  379. - new upstream release with security fixes (CVE-2009-1415,1416,1417)
  380. * Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
  381. - update to 2.6.5
  382. * Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
  383. - spec in UTF-8
  384. * Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
  385. - update to 2.6.4
  386. - modifeid Source0
  387. * Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
  388. - add BuildRequires: guile-devel >= 1.8.6
  389. * Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
  390. - update to 2.6.3
  391. - import from fedora developing's 2.6.3
  392. - License tag fixed
  393. - dropped patch0, patch1, patch2
  394. - added patch3
  395. - added BuildRequires: gmp-devel
  396. - add new sub-package: guile
  397. - added %package guile, %description guile, %files guile
  398. * Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
  399. - used %%{?_dist_release} macro
  400. * Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
  401. - update to 1.6.3 (use no-SRP source)
  402. - import from fedora core's 1.6.3-2
  403. - nosrc.tar.bz2 (source0)
  404. - license tag fix
  405. - build with system libtasn1
  406. * Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  407. - update to 1.4.5 (use no-SRP source)
  408. - import from fedora core's 1.4.5-1
  409. - nosrc.tar.bz2 (source0)
  410. - drop obsolete cve-2006-4790.patch (patch3)
  411. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
  412. - [SECURITY] update to 1.4.1 (use no-SRP source)
  413. - import from fedora core's 1.4.1-2
  414. - nosrp.tar.bz2 (source0)
  415. - libgnutls-config (source1)
  416. - nosrc.patch (patch0)
  417. - enable-psk.patch (patch1)
  418. - cve-2006-4790.patch (patch3)
  419. - update required version of libgcrypt (>= 1.2.2)
  420. - add Requires: pkgconfig to -devel package
  421. - add %%check section
  422. - update %%files
  423. - add new sub-package: utils
  424. * Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
  425. - [SECURITY FIX] upstream release
  426. - record packet parsing denial of service (CAN-2005-1431)
  427. * Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
  428. - initial build for Vine Linux
  429. - upstream release
  430. * Wed Mar 2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
  431. - gcc4 rebuild
  432. * Tue Jan 4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
  433. - add gnutls Requires zlib-devel (#144069)
  434. * Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
  435. - Make gnutls-devel Require libgcrypt-devel
  436. * Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
  437. - rebuild with release++, otherwise unchanged.
  438. * Tue Sep 7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
  439. - patent tainted SRP code removed.
  440. * Sun Sep 5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
  441. - update to 1.0.20.
  442. - add --with-included-opencdk --with-included-libtasn1
  443. - add --with-included-libcfg --with-included-lzo
  444. - add --disable-srp-authentication.
  445. - do "make check" after build.
  446. * Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
  447. - upgrade to 0.9.2
  448. * Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
  449. - update to 0.4.4.
  450. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  451. - automated rebuild
  452. * Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
  453. - update to 0.4.3.
  454. * Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
  455. - update to 0.4.2.
  456. - change license to LGPL.
  457. - include splint annotations patch.
  458. * Tue Apr 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
  459. - update to 0.4.0
  460. * Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
  461. - update to 0.3.2
  462. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
  463. - add a URL
  464. * Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
  465. - initial package