hostapd-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189
  1. %define base_name hostapd
  2. %define pkg_version 2.6
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
  5. Summary(ja): IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
  6. Name: %{base_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. Source0: %{base_name}-%{version}.tar.gz
  10. Source1: %{base_name}-init.sh
  11. Source2: %{base_name}-%{version}.config
  12. Patch11: 0001-hostapd-Avoid-key-reinstallation-in-FT-handshake.patch
  13. Patch12: 0002-Prevent-reinstallation-of-an-already-in-use-group-ke.patch
  14. Patch13: 0003-Extend-protection-of-GTK-IGTK-reinstallation-of-WNM-.patch
  15. Patch14: 0004-Prevent-installation-of-an-all-zero-TK.patch
  16. Patch15: 0005-Fix-PTK-rekeying-to-generate-a-new-ANonce.patch
  17. Patch16: 0006-TDLS-Reject-TPK-TK-reconfiguration.patch
  18. Patch18: 0008-FT-Do-not-allow-multiple-Reassociation-Response-fram.patch
  19. License: GPL2
  20. Group: System Environment/Daemons
  21. URL: http://hostap.epitest.fi/hostapd/
  22. Requires: openssl, libnl >= 1.1
  23. Requires(post): %{_syssbindir}/chkconfig
  24. Requires(preun): %{_syssbindir}/chkconfig
  25. BuildRequires: openssl-devel, libnl-devel
  26. BuildRoot: %{_tmppath}/%{base_name}-%{version}-root
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: miyabi
  30. %description
  31. hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
  32. IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
  33. The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
  34. %description -l ja
  35. hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
  36. IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
  37. 最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
  38. %prep
  39. %setup -q
  40. %patch11 -p1 -b .0001-hostapd-Avoid-key-reinstallation-in-FT-handshake
  41. %patch12 -p1 -b .0002-Prevent-reinstallation-of-an-already-in-use-group-ke
  42. %patch13 -p1 -b .0003-Extend-protection-of-GTK-IGTK-reinstallation-of-WNM
  43. %patch14 -p1 -b .0004-Prevent-installation-of-an-all-zero-TK
  44. %patch15 -p1 -b .0005-Fix-PTK-rekeying-to-generate-a-new-ANonce
  45. %patch16 -p1 -b .0006-TDLS-Reject-TPK-TK-reconfiguration
  46. %patch18 -p1 -b .0008-FT-Do-not-allow-multiple-Reassociation-Response-fram
  47. cp %{SOURCE1} .
  48. cp %{SOURCE2} ./%{base_name}/.config
  49. %build
  50. cd %{base_name}
  51. %{__make} %{?_smp_mflags}
  52. %install
  53. [ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
  54. pushd %{base_name}
  55. %{__make} install DESTDIR="${RPM_BUILD_ROOT}" BINDIR="%{_sbindir}"
  56. popd
  57. %{__install} -D %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
  58. %{__install} -D %{base_name}/hostapd.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
  59. %{__install} -D %{base_name}/hostapd.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/hostapd.8
  60. %{__install} -D %{base_name}/hostapd_cli.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/hostapd_cli.1
  61. %post
  62. if ! /sbin/chkconfig %{base_name}; then
  63. /sbin/chkconfig --add %{base_name}
  64. fi
  65. if [ "$1" -eq "2" ]; then
  66. %{_initdir}/%{base_name} condrestart
  67. fi
  68. %preun
  69. if [ "$1" -eq "0" ]; then
  70. %{_initdir}/%{base_name} stop
  71. /sbin/chkconfig --del %{base_name}
  72. fi
  73. %clean
  74. [ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %files
  76. %defattr(-, root, root)
  77. # Directory
  78. %dir %{_sysconfdir}/%{base_name}/
  79. # Program Files
  80. %attr(0755, root, root) %{_sbindir}/hostapd
  81. %attr(0755, root, root) %{_sbindir}/hostapd_cli
  82. %attr(0755, root, root) %{_initdir}/%{base_name}
  83. # Config Files
  84. %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
  85. # Document Files
  86. %doc %{base_name}/ChangeLog COPYING README
  87. %{_mandir}/man8/%{base_name}.8.gz
  88. %{_mandir}/man1/hostapd_cli.1.gz
  89. %changelog
  90. * Fri Oct 20 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6-2
  91. - add patch11-18 for fix "KRACK" issue
  92. * Sat Feb 04 2017 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.6-1
  93. - new upstream release
  94. * Sat Jan 02 2016 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.5-1
  95. - new upstream release
  96. * Sat Mar 21 2015 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.4-1
  97. - new upstream release
  98. - change hostapd_cli install path /usr/bin -> /usr/sbin
  99. * Sat Dec 06 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.3-1
  100. - new upstream release
  101. * Wed Jul 09 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.2-1
  102. - new upstream release
  103. * Wed Apr 23 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-2
  104. - add patch - hostapd-2.1.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
  105. - fix segfault
  106. * Sat Mar 15 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-1
  107. - new upstream release
  108. - change .config
  109. - add ACS support(Supported ACS drivers: ath5k, ath9k, ath10k)
  110. * Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
  111. - new upstream release
  112. - change filename hostapd.conf -> hostapd.conf.sample
  113. - change .config
  114. - add WPS support
  115. * Sun Dec 2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
  116. - new upstream release
  117. * Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
  118. - new upstream release
  119. - add Summary(ja)
  120. - add section - %description -l ja
  121. - add parameter noreplace to %config
  122. - change spec file
  123. * Tue Oct 9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
  124. - add patch100 for fix CVE-2012-4445 (EPA-TLS message)
  125. * Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
  126. - fix daemon script
  127. - change spec file
  128. - separation from patch file
  129. - daemon script
  130. - .config
  131. - add Source1 - hostapd-init.sh
  132. - add Source2 - hostapd-0.7.3.config
  133. - add Requires(post) - chkconfig
  134. - add Requires(preun) - chkconfig
  135. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
  136. - rebuild with openssl-1.0.0c
  137. * Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
  138. - new upstream release
  139. * Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
  140. - new upstream release
  141. * Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
  142. - new upstream release
  143. * Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
  144. - new upstream release
  145. * Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
  146. - initial build for Vine Linux