orc-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: orc
  3. Summary: The Oil Run-time Compiler
  4. Summary(ja): Oil ランタイムコンパイラ
  5. Version: 0.4.24
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: BSD
  9. URL: http://code.entropywave.com/orc/
  10. Source0: http://gstreamer.freedesktop.org/src/orc/orc-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gtk-doc, libtool
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. %description
  16. Orc is a library and set of tools for compiling and executing
  17. very simple programs that operate on arrays of data. The "language"
  18. is a generic assembly language that represents many of the features
  19. available in SIMD architectures, including saturated addition and
  20. subtraction, and many arithmetic operations.
  21. %package doc
  22. Summary: Documentation for Orc
  23. Summary(ja): Orc のドキュメント
  24. Group: Documentation
  25. Requires: %{name} = %{version}-%{release}
  26. BuildArch: noarch
  27. %description doc
  28. Documentation for Orc.
  29. %package devel
  30. Summary: Development files and static libraries for Orc
  31. Summary(ja): Orc の開発用ファイル及び静的ライブラリ
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: %{name}-compiler
  35. Requires: pkgconfig
  36. %description devel
  37. This package contains the files needed to build packages that depend
  38. on orc.
  39. %package compiler
  40. Summary: Orc compiler
  41. Summary(ja): Orc コンパイラ
  42. Group: Development/Languages
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: pkgconfig
  45. %description compiler
  46. The Orc compiler, to produce optimized code.
  47. %package -n compat32-%{name}
  48. Summary: The Oil Run-time Compiler
  49. Summary(ja): Oil ランタイムコンパイラ
  50. Group: System Environment/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n compat32-%{name}
  53. Orc is a library and set of tools for compiling and executing
  54. very simple programs that operate on arrays of data. The "language"
  55. is a generic assembly language that represents many of the features
  56. available in SIMD architectures, including saturated addition and
  57. subtraction, and many arithmetic operations.
  58. %package -n compat32-%{name}-devel
  59. Summary: Development files and static libraries for Orc
  60. Summary(ja): Orc の開発用ファイル及び静的ライブラリ
  61. Group: Development/Libraries
  62. Requires: compat32-%{name} = %{version}-%{release}
  63. Requires: compat32-pkgconfig
  64. %description -n compat32-%{name}-devel
  65. This package contains the files needed to build packages that depend
  66. on orc.
  67. %prep
  68. %setup -q
  69. autoreconf -vif
  70. %build
  71. export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
  72. export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
  73. %configure --disable-static --enable-gtk-doc
  74. make %{?_smp_mflags}
  75. %install
  76. rm -rf %{buildroot}
  77. make install DESTDIR=%{buildroot} INSTALL="install -p"
  78. # Remove unneeded files.
  79. find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
  80. rm -rf %{buildroot}/%{_libdir}/orc
  81. touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h
  82. %clean
  83. rm -rf %{buildroot}
  84. %check
  85. make check || true
  86. %post -p /sbin/ldconfig
  87. %postun -p /sbin/ldconfig
  88. %post -n compat32-%{name} -p /sbin/ldconfig
  89. %postun -n compat32-%{name} -p /sbin/ldconfig
  90. %files
  91. %defattr(-,root,root,-)
  92. %doc COPYING README
  93. %{_bindir}/orc-bugreport
  94. %{_libdir}/liborc-*.so.*
  95. %files doc
  96. %defattr(-,root,root,-)
  97. %doc %{_datadir}/gtk-doc/html/orc/
  98. %files devel
  99. %defattr(-,root,root,-)
  100. %doc examples/*.c
  101. %{_includedir}/%{name}-0.4/
  102. %{_libdir}/liborc-*.so
  103. %{_libdir}/pkgconfig/orc-0.4.pc
  104. %{_datadir}/aclocal/orc.m4
  105. %files compiler
  106. %defattr(-,root,root,-)
  107. %{_bindir}/orcc
  108. %if %{build_compat32}
  109. %defattr(-,root,root,-)
  110. %files -n compat32-%{name}
  111. %{_libdir}/liborc-*.so.*
  112. %files -n compat32-%{name}-devel
  113. %defattr(-,root,root,-)
  114. %{_libdir}/liborc-*.so
  115. %endif
  116. %changelog
  117. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.24-1
  118. - new upstream release
  119. * Tue Apr 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.23-1
  120. - new upstream release
  121. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.22-1
  122. - new upstream release
  123. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.19-1
  124. - new upstream release
  125. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-2
  126. - rebuild with VineSeed environment
  127. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-1
  128. - new upstream release
  129. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-1
  130. - new upstream release
  131. - create compat32 sub packages
  132. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.14-1
  133. - new upstream release
  134. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
  135. - new upstream release
  136. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
  137. - rebuilt with rpm-4.8.1 for pkg-config
  138. * Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
  139. - build with -O1 (not -O2) to fix build failure on ppc
  140. (like as the Debian package does)
  141. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
  142. - Initial build for Vine Linux
  143. * Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
  144. - Added removed testing libraries to package.
  145. * Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
  146. - Updated to 0.4.5.
  147. - Removed testing libraries from package.
  148. * Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
  149. - Docs as noarch.
  150. - Sanitize timestamps of header files.
  151. - orcc in -compiler subpackage.
  152. * Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
  153. - Updated to 0.4.4: Includes bugfixes for x86_64.
  154. * Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
  155. - Running autoreconf to prevent building problems.
  156. - Added missing files to docs.
  157. - Added examples to devel docs.
  158. * Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
  159. - Updated to 0.4.3
  160. * Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
  161. - Removed unused libdir
  162. * Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
  163. - Specfile cleanup
  164. - Removed tools subpackage
  165. - Added docs subpackage
  166. * Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
  167. - Use orc as pakage name
  168. - spec-file cleanup
  169. - Added devel requirements
  170. - Removed an rpath issue
  171. * Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
  172. - Initial release