GeoIP-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. %define geoipupadte_ver 2.2.1
  2. Name: GeoIP
  3. Summary: C library for country/city/organization to IP address or hostname mapping
  4. Summary(ja): 国/都市/組織と IP アドレス/ホスト名とのマッピングを取るための C ライブラリ
  5. Version: 1.6.7
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://www.maxmind.com/app/c
  10. Source0: https://github.com/maxmind/geoip-api-c/releases/download/v%{version}/GeoIP-%{version}.tar.gz
  11. Source1: https://github.com/maxmind/geoipupdate/releases/download/v%{geoipupadte_ver}/geoipupdate-%{geoipupadte_ver}.tar.gz
  12. Source2: LICENSE.txt
  13. Source3: fetch-geoipdata-city.pl
  14. Source4: fetch-geoipdata.pl
  15. Source5: README.Fedora
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: curl-devel
  18. BuildRequires: zlib-devel
  19. Obsoletes: geoip < %{version}-%{release}
  20. Provides: geoip = %{version}-%{release}
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: tomop
  24. %description
  25. GeoIP is a C library that enables the user to find the country that any IP
  26. address or hostname originates from. It uses a file based database that is
  27. accurate as of March 2003. This database simply contains IP blocks as keys, and
  28. countries as values. This database should be more complete and accurate than
  29. using reverse DNS lookups.
  30. %package devel
  31. Summary: Development headers and libraries for GeoIP
  32. Summary(ja): GeoIP の開発用ヘッダファイル及びライブラリ
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Provides: geoip-devel = %{version}-%{release}
  36. Obsoletes: geoip-devel < %{version}-%{release}
  37. %description devel
  38. Development headers and libraries for building GeoIP-based applications
  39. %prep
  40. %setup -q -a 1
  41. install -D -m644 %{SOURCE2} LICENSE.txt
  42. install -D -m644 %{SOURCE3} fetch-geoipdata-city.pl
  43. install -D -m644 %{SOURCE4} fetch-geoipdata.pl
  44. install -D -m644 %{SOURCE5} README.fedora
  45. %build
  46. autoreconf -ivf
  47. %configure --disable-static --disable-dependency-tracking
  48. make %{?_smp_mflags}
  49. pushd geoipupdate-%{geoipupadte_ver}
  50. ./bootstrap
  51. %configure
  52. make %{?_smp_mflags}
  53. popd
  54. %install
  55. rm -rf %{buildroot}
  56. make DESTDIR=%{buildroot} install
  57. # nix the stuff we don't need like .la files.
  58. rm -f %{buildroot}%{_libdir}/*.la
  59. mkdir -p %{buildroot}%{_datadir}/GeoIP
  60. pushd geoipupdate-%{geoipupadte_ver}
  61. make DESTDIR=%{buildroot} install
  62. popd
  63. mkdir -p geoipupdate
  64. cp -f geoipupdate-%{geoipupadte_ver}/{ChangeLog.md,LICENSE,README.*} ./geoipupdate/
  65. %clean
  66. rm -rf %{buildroot}
  67. %post -p /sbin/ldconfig
  68. %postun -p /sbin/ldconfig
  69. %files
  70. %defattr(-,root,root,-)
  71. %doc AUTHORS COPYING ChangeLog NEWS.md README.* INSTALL LICENSE* geoipupdate
  72. %{_libdir}/libGeoIP.so.*
  73. %{_bindir}/geoiplookup6
  74. %{_bindir}/geoiplookup
  75. %{_bindir}/geoipupdate
  76. %config(noreplace) %{_sysconfdir}/GeoIP.conf.default
  77. %config(noreplace) %{_sysconfdir}/GeoIP.conf
  78. %{_datadir}/GeoIP
  79. %{_mandir}/man1/geoiplookup.1*
  80. %{_mandir}/man1/geoiplookup6.1*
  81. %{_mandir}/man1/geoipupdate.1*
  82. %{_mandir}/man5/GeoIP.conf.5.*
  83. %files devel
  84. %defattr(-,root,root,-)
  85. %{_libdir}/pkgconfig/geoip.pc
  86. %{_includedir}/GeoIP.h
  87. %{_includedir}/GeoIPCity.h
  88. %{_libdir}/libGeoIP.so
  89. %changelog
  90. * Thu Nov 5 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
  91. - new upstream release.
  92. - updated geoipupdate to 2.2.1.
  93. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.6.0-2
  94. - added Japanese summary
  95. - moved main package to System Environment/Libraries
  96. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.0-1
  97. - new upstream release.
  98. * Mon Oct 08 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-3
  99. - initial build for Vine Linux.
  100. * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-2.1
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  102. * Tue Sep 6 2011 Michael Fleming <mfleming+rpm@thatfleminggent.com> - 1.4.8-1.1
  103. - Remove -ipv6 path
  104. - Bump to 1.4.8 release
  105. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-0.2.20090931cvs
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  107. * Mon Aug 31 2009 Matt Domsch <mdomsch@fedoraproject.org> - 1.4.7.0.1.20090931
  108. - apply CVS HEAD 20090931 which includes IPv6 functions
  109. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-2
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  111. * Sun Mar 08 2009 Michael Fleming <mfleming+rpm@enlartenment.com> - 1.4.6-1
  112. - Add geoiplookup6 man page
  113. - Update to 1.4.6
  114. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.5-3
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  116. * Sat Nov 29 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.5-2
  117. - Update to 1.4.5
  118. - Fix database URL locations in Perl helper scripts
  119. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-2
  120. - Autorebuild for GCC 4.3
  121. * Mon Jan 28 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.4-1
  122. - New upstream release.
  123. * Wed Sep 5 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.3-1
  124. - New upstream release.
  125. - Fix GeoIPCity fetcher script
  126. - Update License tag
  127. * Mon Feb 12 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.2-1
  128. - New upstream release.
  129. * Mon Jan 8 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-2
  130. - License is actually LGPL now.
  131. * Sun Jan 7 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-1
  132. - New upstream release
  133. - Add fetch-geoipdata* scripts to pull free databases automatically if
  134. desired (bz #198137)
  135. - README.fedora added to briefly explain above.
  136. * Mon Nov 27 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-4
  137. - Fix %%install scripts to satisfy newer mock builds
  138. * Sun Sep 3 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-3
  139. - Upstream upgrade
  140. - Added LICENSE.txt file to %%doc, covering GeoIP country/city data license
  141. (bz #198137)
  142. * Mon May 15 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.17-1
  143. - New upstream release (minor fixes)
  144. * Mon May 1 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.16-1
  145. - New upstream release
  146. - Add INSTALL document to package.
  147. * Sat Feb 18 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-3
  148. - Fix Obsoletes/Provides for old "geoip"-convention packages
  149. - Move .so symlinks to -devel where they should be
  150. * Fri Feb 10 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-2
  151. - Remamed to match upstream tarball name
  152. - Removed static libraries
  153. - Added symlinks to packages
  154. - Mark config file noreplace
  155. * Sun Feb 5 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-1
  156. - Initial review package for Extras