Judy-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. Name: Judy
  2. Version: 1.0.5
  3. Release: 2%{?_dist_release}
  4. Summary: General purpose dynamic array
  5. Summary(ja): 汎用の動的配列ライブラリ
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://sourceforge.net/projects/judy/
  9. Source0: http://downloads.sourceforge.net/judy/Judy-%{version}.tar.gz
  10. Source1: README.Fedora
  11. # Make tests use shared instead of static libJudy.
  12. Patch0: Judy-1.0.4-test-shared.patch
  13. # The J1* man pages were incorrectly being symlinked to Judy, rather
  14. # than Judy1. This patch corrects that. Submitted upstream 2008/11/27.
  15. Patch1: Judy-1.0.4-fix-Judy1-mans.patch
  16. # Fix some code with undefined behavior, commented on and removed by gcc
  17. Patch2: Judy-1.0.5-undefined-behavior.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. %description
  20. Judy is a C library that provides a state-of-the-art core technology
  21. that implements a sparse dynamic array. Judy arrays are declared
  22. simply with a null pointer. A Judy array consumes memory only when it
  23. is populated, yet can grow to take advantage of all available memory
  24. if desired. Judy's key benefits are scalability, high performance, and
  25. memory efficiency. A Judy array is extensible and can scale up to a
  26. very large number of elements, bounded only by machine memory. Since
  27. Judy is designed as an unbounded array, the size of a Judy array is
  28. not pre-allocated but grows and shrinks dynamically with the array
  29. population.
  30. %package devel
  31. Summary: Development libraries and headers for Judy
  32. Summary(ja): Judy の開発用ライブラリとヘッダファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. This package contains the development libraries and header files
  37. for developing applications that use the Judy library.
  38. %prep
  39. %setup -q -n judy-%{version}
  40. %patch0 -p1 -b .test-shared
  41. %patch1 -p1 -b .fix-Judy1-mans
  42. %patch2 -p1 -b .behavior
  43. cp -p %{SOURCE1} .
  44. %build
  45. export CFLAGS="%{optflags} -fno-strict-aliasing -fno-tree-ccp -fno-tree-dominator-opts -fno-tree-copy-prop -fno-tree-vrp"
  46. %configure --disable-static
  47. make
  48. # fails to compile properly with parallel make:
  49. # http://sourceforge.net/tracker/index.php?func=detail&aid=2129019&group_id=55753&atid=478138
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. make install DESTDIR=$RPM_BUILD_ROOT
  53. # get rid of static libs and libtool archives
  54. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{a,la}
  55. # clean out zero length and generated files from doc tree
  56. rm -rf doc/man
  57. rm -f doc/Makefile* doc/ext/README_deliver
  58. [ -s doc/ext/COPYRIGHT ] || rm -f doc/ext/COPYRIGHT
  59. [ -s doc/ext/LICENSE ] || rm -f doc/ext/LICENSE
  60. %check
  61. cd test
  62. ./Checkit
  63. %clean
  64. rm -rf $RPM_BUILD_ROOT
  65. %post -p /sbin/ldconfig
  66. %postun -p /sbin/ldconfig
  67. %files
  68. %defattr(-,root,root,-)
  69. %doc AUTHORS ChangeLog COPYING README README.Fedora examples/
  70. %{_libdir}/*.so.*
  71. %files devel
  72. %defattr(-,root,root,-)
  73. %doc doc
  74. %{_libdir}/*.so
  75. %{_includedir}/*
  76. %{_mandir}/man3/*
  77. %changelog
  78. * Wed Feb 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.5-2
  79. - rebuilt on current VineSeed
  80. - added patch2 from Fedora
  81. * Tue Feb 18 2014 Paul Howarth <paul@city-fan.org> - 1.0.5-8
  82. - Fix some code with undefined behavior
  83. * Sat Feb 11 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 1.0.5-1
  84. - updated to 1.0.5
  85. * Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.4-7
  86. - Initial build for Vine Linux
  87. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-6
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  89. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-5
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  91. * Sat Dec 13 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-4
  92. - for Judy1 man page fix, patch Makefile.{am,in} instead of
  93. relying on autotools to regenerate the latter.
  94. - Add README.Fedora with upstream's license explanation.
  95. * Thu Nov 30 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-3
  96. - fix Judy1 man page symlinks
  97. - use valid tag License: LGPLv2+ confirmed with upstream
  98. - use version macro in Source0
  99. - remove Makefiles from installed doc tree
  100. * Thu Nov 27 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-2
  101. - patch tests to run with shared library
  102. - run tests in check section
  103. * Sun Oct 05 2008 Charles R. Anderson <cra@wpi.edu> 1.0.4-1
  104. - Initial package for Fedora