OpenEXR-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290
  1. %bcond_with check
  2. Name: OpenEXR
  3. Summary: A high dynamic-range (HDR) image file format
  4. Summary(ja): 高ダイナミックレンジ(HDR)画像ファイルフォーマット
  5. Version: 2.5.7
  6. Release: 1%{?_dist_release}
  7. Group: graphics
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: http://www.openexr.com/
  12. Source0: https://github.com/openexr/openexr/archive/v%{version}.tar.gz#/openexr-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: cmake
  15. BuildRequires: zlib-devel
  16. BuildRequires: pkgconfig
  17. # https://github.com/openexr/openexr/issues/130
  18. BuildConflicts: OpenEXR-devel < 2.2.0
  19. Requires: %{name}-libs = %{version}-%{release}
  20. Obsoletes: openexr < %{version}-%{release}
  21. Provides: openexr = %{version}-%{release}
  22. %description
  23. OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial
  24. Light & Magic for use in computer imaging applications. This package contains
  25. sample applications for handling the format.
  26. %package libs
  27. Summary: %{name} runtime libraries
  28. Summary(ja): %{name} のランタイムライブラリ
  29. Group: system
  30. %description libs
  31. %{summary}.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Summary(ja): %{name} の開発用ファイル
  35. Group: programming
  36. Requires: %{name}-libs = %{version}-%{release}
  37. Requires: ilmbase-devel
  38. Obsoletes: openexr-devel < %{version}-%{release}
  39. Provides: openexr-devel = %{version}-%{release}
  40. %description devel
  41. %{summary}.
  42. %package -n ilmbase
  43. Summary: Abraction/convenience libraries
  44. Group: system
  45. BuildRequires: libGL-devel
  46. BuildRequires: libGLU-devel
  47. %description -n ilmbase
  48. Half is a class that encapsulates the ilm 16-bit floating-point format.
  49. IlmThread is a thread abstraction library for use with OpenEXR
  50. and other software packages.
  51. Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
  52. and other useful 2D and 3D math functions.
  53. Iex is an exception-handling library.
  54. %package -n ilmbase-devel
  55. Summary: Headers and libraries for building apps that use ilmbase
  56. Summary(ja): ilmbaseを使うアプリケーションをビルドするためのヘッダファイル及びライブラリ
  57. Group: programming
  58. Requires: ilmbase = %{version}-%{release}
  59. Requires: pkgconfig
  60. Requires: libGL-devel
  61. Requires: libGLU-devel
  62. %description -n ilmbase-devel
  63. Headers and libraries for building apps that use ilmbase.
  64. %debug_package
  65. %prep
  66. %setup -q -n openexr-%{version}
  67. %build
  68. %cmake \
  69. -DPYILMBASE_ENABLE=no \
  70. -DOPENEXR_VIEWERS_ENABLE=no \
  71. %{nil}
  72. %cmake_build
  73. %install
  74. rm -rf %{buildroot}
  75. %cmake_install
  76. # prepare docs
  77. rm -rf rpmdocs
  78. mkdir -p rpmdocs
  79. cp -a %{buildroot}%{_docdir}/OpenEXR/* rpmdocs/
  80. rm -rf %{buildroot}%{_docdir}/OpenEXR
  81. %if %{with check}
  82. %check
  83. %ifarch %{ix86}
  84. %ctest ||:
  85. %else
  86. %ctest
  87. %endif
  88. %endif
  89. %clean
  90. rm -rf %{buildroot}
  91. %files
  92. %defattr(-,root,root,-)
  93. %license LICENSE.md
  94. %doc README.md
  95. %{_bindir}/*
  96. %files libs
  97. %defattr(-,root,root,-)
  98. %license LICENSE.md
  99. %doc OpenEXR/README.md
  100. %doc rpmdocs/*
  101. %{_libdir}/libIlmImf*.so.*
  102. %files devel
  103. %defattr(-,root,root,-)
  104. %{_includedir}/OpenEXR/Imf*.h
  105. %{_includedir}/OpenEXR/OpenEXRConfig.h
  106. %{_libdir}/lib*.so
  107. %dir %{_libdir}/pkgconfig
  108. %{_libdir}/pkgconfig/OpenEXR.pc
  109. %dir %{_libdir}/cmake
  110. %{_libdir}/cmake/OpenEXR
  111. %files -n ilmbase
  112. %doc IlmBase/README.md
  113. %license LICENSE.md
  114. %{_libdir}/lib*.so.*
  115. %exclude %{_libdir}/libIlmImf*.so.*
  116. %files -n ilmbase-devel
  117. %dir %{_includedir}/OpenEXR/
  118. %{_includedir}/OpenEXR/Iex*.h
  119. %{_includedir}/OpenEXR/Ilm*.h
  120. %{_includedir}/OpenEXR/Imath*.h
  121. %{_includedir}/OpenEXR/half*.h
  122. %{_libdir}/lib*.so
  123. %exclude %{_libdir}/libIlmImf*.so
  124. %dir %{_libdir}/pkgconfig
  125. %{_libdir}/pkgconfig/IlmBase.pc
  126. %dir %{_libdir}/cmake
  127. %{_libdir}/cmake/IlmBase
  128. %changelog
  129. * Sat Jun 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.7-1
  130. - new upstream release.
  131. * Tue Apr 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.5-1
  132. - new upstream release.
  133. - dropped ldconfig scriptlets.
  134. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.3-1
  135. - new upstream release.
  136. * Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-1
  137. - new upstream release.
  138. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  139. - new upstream release.
  140. * Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-1
  141. - new upstream release.
  142. - unified IlmBase into OpenEXR.
  143. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-2
  144. - rebuild with gcc-5.4.0
  145. * Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.0-1
  146. - new upstream release
  147. - removed Patch100 and 101
  148. - built with ilmbase 2.2.0
  149. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
  150. - new upstream release
  151. - remove Patch1,2,102
  152. - update Patch100 (openexr-2.1.0-CVE-2009-1720-1.patch)
  153. - update Patch101 (openexr-2.1.0-CVE-2009-1720-2.patch)
  154. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
  155. - rebuilt with rpm-4.8.1 for pkg-config
  156. * Wed Aug 5 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.1-2
  157. - add Patch100,101 for fix CVE-2009-1720 (Integer BOF)
  158. - add Patch102 for fix CVE-2009-1721
  159. - Patch100-102 are from FC11
  160. * Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-1
  161. - initial build for Vine Linux
  162. * Fri May 09 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-4
  163. - drop: Obsoletes: OpenEXR-utils (see OpenEXR_Viewers review, bug #428228c3)
  164. * Fri Feb 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-3
  165. - gcc43 patch
  166. - purge rpaths
  167. * Wed Jan 09 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-2
  168. - hack to omit unused-direct-shlib-dependencies
  169. - conditionalize -libs (f8+)
  170. * Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-1
  171. - openexr-1.6.1
  172. * Tue Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-5
  173. - multiarch conflicts in OpenEXR (#342781)
  174. - don't own %%_includedir/OpenEXR (leave that to ilmbase)
  175. * Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-4
  176. - -libs: %%post/%%postun -p /sbin/ldconfig
  177. * Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-2
  178. - openexr-1.6.0
  179. * Mon Sep 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-6
  180. - libs: -Requires: %%name
  181. * Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-5
  182. - -libs: new subpkg to be multilib friendly
  183. - -utils: package exrdisplay separately (separate fltk dep)
  184. * Sat Oct 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-4
  185. - Obsoletes/Provides: openexr(-devel) (rpmforge compatibility)
  186. * Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-3
  187. - pkgconfig patch to use Libs.private
  188. * Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-2
  189. - -devel: +Requires: pkgconfig
  190. * Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-1
  191. - openexr-1.4.0a
  192. * Sat Feb 18 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-7
  193. - Further zlib fixes (#165729)
  194. * Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-6
  195. - Rebuild for Fedora Extras 5
  196. * Wed Aug 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-5
  197. - Remove *.a from %%files devel
  198. * Tue Aug 16 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-4
  199. - Removed -devel dep on zlib-devel (#165729)
  200. - Added --disable-static to %%configure
  201. - Fixed build with GCC 4.0.1
  202. - Added .so links to -devel
  203. * Wed May 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-3
  204. - Add zlib-devel to BR
  205. - Delete all .la files (#157652)
  206. * Mon May 9 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
  207. - Add disttag
  208. * Sun May 8 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
  209. - Fix BuildRequires
  210. - Fix Requires on -devel
  211. - Add %%post[un] scriptlets
  212. - Fix ownership in -devel
  213. - Don't have .deps files in %%doc
  214. * Wed Mar 30 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-1
  215. - Initial RPM release