R-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690
  1. %define pkg_name R
  2. %define pkg_version 3.6.3
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: A language for data analysis and graphics
  5. Summary(ja): データ解析・グラフィック化の言語
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv2
  10. Group: Applications/Edutainment
  11. URL: http://www.r-project.org
  12. Source0: https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
  13. Source1: Rprofile.site
  14. # Patch0: R-release.diff.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. %if %{?_dist_release} >= "vl7"
  17. %ifarch x86_64
  18. BuildRequires: clang
  19. %endif
  20. %endif
  21. BuildRequires: gcc-gfortran libgfortran
  22. BuildRequires: texinfo
  23. %if %{?_dist_release} == "vl6"
  24. BuildRequires: R-pcre-devel
  25. BuildRequires: tcl85-devel tk85-devel
  26. %endif
  27. %if %{?_dist_release} >= "vl7"
  28. BuildRequires: pcre2-devel
  29. BuildRequires: tcl-devel tk-devel
  30. %endif
  31. BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
  32. BuildRequires: readline-devel ncurses-devel
  33. BuildRequires: zlib-devel bzip2-devel xz-devel
  34. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  35. BuildRequires: cairo-devel pango-devel
  36. BuildRequires: libicu-devel
  37. BuildRequires: curl-devel
  38. BuildRequires: blas-devel
  39. BuildRequires: texlive-common
  40. BuildRequires: texlive-collection-basic
  41. BuildRequires: texlive-collection-latexextra
  42. BuildRequires: texlive-collection-fontsextra
  43. %if %{?_dist_release} == "vl6"
  44. BuildRequires: texlive-collection-texinfo
  45. %endif
  46. %if %{?_dist_release} >= "vl7"
  47. BuildRequires: texlive-collection-plaingeneric
  48. BuildRequires: texlive-collection-fontsrecommended
  49. %endif
  50. BuildRequires: java-devel
  51. %if %{?_dist_release} >= "vl7"
  52. %ifarch x86_64
  53. Requires: clang
  54. %endif
  55. %endif
  56. Requires: gcc-gfortran
  57. Requires: libgfortran
  58. Requires: libicu
  59. %if %{?_dist_release} == "vl6"
  60. Requires: tcl85 tk85
  61. Requires: R-pcre
  62. %endif
  63. %if %{?_dist_release} >= "vl7"
  64. Requires: tcl tk
  65. Requires: pcre2
  66. Obsoletes: tcl85 tk85
  67. Obsoletes: R-pcre
  68. %endif
  69. Requires: blas
  70. Requires: openblas-Rblas
  71. Obsoletes: R-devel < %{version}-%{release}
  72. Vendor: Project Vine
  73. Distribution: Vine Linux
  74. Packager: ara_t
  75. %description
  76. 'GNU S' - A language and environment for statistical computing and
  77. graphics. R is similar to the award-winning S system, which was
  78. developed at Bell Laboratories by John Chambers et al. It provides
  79. a wide variety of statistical and graphical techniques (linear and
  80. nonlinear modelling, statistical tests, time series analysis,
  81. classification, clustering, ...).
  82. R is designed as a true computer language with control-flow
  83. constructions for iteration and alternation, and it allows users to
  84. add additional functionality by defining new functions.
  85. For computationally intensive tasks, C, C++ and Fortran code
  86. can be linked and called at run time.
  87. %description -l ja
  88. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  89. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  90. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  91. 幅広い統計解析・視覚化手法を提供する。
  92. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  93. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  94. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  95. 使用することができる。
  96. %package -n libRmath
  97. Summary: standalone math library from the R project
  98. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  99. Group: System Environment/Libraries
  100. %description -n libRmath
  101. A standalone library of mathematical and statistical functions derived
  102. from the R project. This packages provides the shared libRmath library.
  103. %description -l ja -n libRmath
  104. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  105. 共有ライブラリを提供する。
  106. %package -n libRmath-devel
  107. Summary: standalone math library from the R project
  108. Summary(ja): libRmathの開発ライブラリ
  109. Group: Development/Libraries
  110. Requires: libRmath = %{version}-%{release}
  111. %description -n libRmath-devel
  112. A standalone library of mathematical and statistical functions derived
  113. from the R project. This packages provides the header files.
  114. %description -l ja -n libRmath-devel
  115. libRmathのヘッダファイル(Rmath.h)
  116. %package -n libRmath-static
  117. Summary: Static R Standalone math library
  118. Summary(ja): libRmath の静的ライブラリ
  119. Group: Development/Libraries
  120. Requires: libRmath-devel = %{version}-%{release}
  121. %description -n libRmath-static
  122. A standalone library of mathematical and statistical functions derived
  123. from the R project. This package provides the static libRmath library.
  124. %prep
  125. %{__rm} -rf ${RPM_BUILD_ROOT}
  126. %setup -q
  127. # %patch0 -p1
  128. cat > R.desktop <<EOF
  129. [Desktop Entry]
  130. Name=GNU R
  131. Comment=A language for data analysis and graphics
  132. TryExec=/usr/bin/R
  133. Exec=/usr/bin/R
  134. Icon=/usr/share/icons/logo.jpg
  135. Terminal=true
  136. Type=Application
  137. Categories=Education;Science;
  138. StartupNotify=false
  139. EOF
  140. %build
  141. export R_PDFVIEWER="%{_bindir}/xdg-open"
  142. export R_PRINTCMD="lpr"
  143. export R_BROWSER="%{_bindir}/xdg-open"
  144. %if %{?_dist_release} == "vl6"
  145. export LD_LIBRARY_PATH=%{_libdir}/R/lib
  146. %endif
  147. %if %{?_dist_release} >= "vl7"
  148. %ifarch x86_64
  149. export CFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
  150. export CXXFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
  151. %endif
  152. %endif
  153. # Add PATHS to Renviron for R_LIBS_SITE
  154. echo 'R_LIBS_SITE=${R_LIBS_SITE-'"'/usr/local/lib/R/site-library:%{_libdir}/R/site-library:%{_libdir}/R/library'"'}' \
  155. >> etc/Renviron.in
  156. %{configure} --enable-R-shlib --with-tcltk \
  157. --with-blas="-lblas" \
  158. %if %{?_dist_release} >= "vl7"
  159. %ifarch x86_64
  160. CC=clang CXX=clang++ \
  161. %endif
  162. %endif
  163. %if %{?_dist_release} == "vl6"
  164. --with-tcl-config=%{_libdir}/tclConfig85.sh \
  165. --with-tk-config=%{_libdir}/tkConfig85.sh \
  166. CPPFLAGS="-I%{_libdir}/R/include" \
  167. LDFLAGS="-L%{_libdir}/R/lib"
  168. %endif
  169. %{__make} %{?_smp_mflags}
  170. pushd src/nmath/standalone
  171. %{__make} %{?_smp_mflags}
  172. popd
  173. %{__make} pdf
  174. %install
  175. %{make_install}
  176. %{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
  177. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  178. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  179. # Remove libRblas.so
  180. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/R/lib/libRblas.so
  181. # Install libRmath files
  182. pushd src/nmath/standalone
  183. %{make_install}
  184. popd
  185. %{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  186. echo "%{_libdir}/R/lib" > \
  187. ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  188. # Fix lication of R_HOME_DIR in shell wrapper
  189. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  190. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  191. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  192. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  193. > ${RPM_BUILD_ROOT}%{_bindir}/R
  194. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  195. # add R into menu
  196. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
  197. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
  198. %{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
  199. %{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
  200. # move manuals
  201. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  202. %{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
  203. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
  204. # make symlink for libblas.so.3 (No need to use blas-devel)
  205. pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
  206. %{__ln_s} %{_libdir}/libblas.so.3 libblas.so
  207. popd
  208. # Add folders for R_LIBS_SITE
  209. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_libdir}/R/site-library
  210. # install Rprofile.site
  211. %{__install} %{SOURCE1} ${RPM_BUILD_ROOT}%{_libdir}/R/etc
  212. %check
  213. %{__make} check
  214. %clean
  215. %{__rm} -rf ${RPM_BUILD_ROOT}
  216. %post
  217. %{_syssbindir}/ldconfig
  218. %{__mkdir_p} %{_prefix}/local/lib/R/site-library
  219. %preun
  220. if [ "$1" = "0" ]
  221. then
  222. %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
  223. %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
  224. fi
  225. %postun -p %{_syssbindir}/ldconfig
  226. %post -n libRmath -p %{_syssbindir}/ldconfig
  227. %postun -n libRmath -p %{_syssbindir}/ldconfig
  228. %files
  229. %defattr(-, root, root)
  230. %{_bindir}/R
  231. %{_bindir}/Rscript
  232. %{_libdir}/R
  233. %{_datadir}/applications/*
  234. %{_datadir}/icons/*
  235. %{_mandir}/man1/*
  236. %{_docdir}/%{name}-%{version}
  237. %{_sysconfdir}/ld.so.conf.d/*
  238. %files -n libRmath
  239. %defattr(-, root, root)
  240. %{_libdir}/libRmath.so
  241. %files -n libRmath-devel
  242. %defattr(-, root, root)
  243. %{_libdir}/pkgconfig/*.pc
  244. %{_includedir}/Rmath.h
  245. %files -n libRmath-static
  246. %defattr(-, root, root)
  247. %{_libdir}/libRmath.a
  248. %changelog
  249. * Sun Mar 01 2020 Toshiaki Ara <ara_t@384.jp> 3.6.3-1
  250. - update to 3.6.3
  251. * Thu Dec 12 2019 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
  252. - update to 3.6.2
  253. * Sun Oct 13 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-4
  254. - rebuild with icu-65
  255. * Sat Oct 05 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-3
  256. - rebuild with tcl-8.6/tk-8.6
  257. * Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-2
  258. - rebuild with readline-8.0
  259. * Sat Jul 06 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-1
  260. - update to 3.6.1
  261. * Thu May 09 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-2
  262. - drop "-fno-schedule-insns2" option for clang/clang++ in VineSeed (x86_64)
  263. * Fri Apr 26 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-1
  264. - update to 3.6.0
  265. - build using clang/clang++ for VineSeed (x86_64)
  266. - change install path for external library
  267. - add PATHS to Renviron for R_LIBS_SITE
  268. - set default CRAN mirror
  269. * Mon Mar 11 2019 Toshiaki Ara <ara_t@384.jp> 3.5.3-1
  270. - update to 3.5.3
  271. * Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
  272. - rebuild with gfortran-8.2.0
  273. * Thu Dec 20 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-1
  274. - update to 3.5.2
  275. * Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
  276. - update to 3.5.1
  277. * Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
  278. - add Requires: openblas-Rblas
  279. - change using system blas
  280. * Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
  281. - update to 3.5.0
  282. - drop Patch 1 and 2
  283. * Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
  284. - updated to 3.4.4
  285. - add Obsoletes: tcl85 tk85 R-pcre for VineSeed
  286. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
  287. - rebuild under icu-60.2
  288. * Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
  289. - Updated to 3.4.3
  290. * Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
  291. - Updated to 3.4.2
  292. - change download URL
  293. * Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
  294. - left %%{_libdir}/R/doc
  295. * Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
  296. - Updated to 3.4.1
  297. - rebuild under R-pcre (pcre-8.39) for Vine6
  298. - add Requires: gcc-gfortran
  299. - change to BuildRequires: texlive-collection-plaingeneric
  300. - delete unnecessary descriptions
  301. * Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
  302. - Updated to 3.4.0
  303. - add Patch1 and Patch2 to avoid 'make check' error
  304. - add export TZ="Asia/Tokyo" to avoid 'make check' error
  305. - delete descrption about info
  306. * Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
  307. - Updated to 3.3.3
  308. * Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
  309. - use tcl-8.5/tk-8.5 for Vine6.5
  310. - BuildRequires to tcl85-devel/tk85-devel
  311. - Requires to tcl85/tk85
  312. * Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
  313. - merge SPEC file for Vine6
  314. - drop devel package
  315. - move PDF manuals to /usr/share/doc/R-%%{version}
  316. - revert logo of menu item to logo.jpg
  317. * Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
  318. - Updated to 3.3.2
  319. * Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
  320. - Updated to 3.3.1
  321. - delete BuildRequires: texlive-collection-lang*
  322. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
  323. - add BuildRequires: texlive-collection-lang*
  324. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
  325. - Updated to 3.3.0
  326. - add BuildRequires: pcre-devel xz-devel
  327. - change logo of menu item to Rlogo.svg
  328. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
  329. - correct SPEC file
  330. * Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
  331. - Updated to 3.2.4-revised
  332. * Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
  333. - Updated to 3.2.4
  334. - fixed build error in src/extra/xz
  335. * Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
  336. - add BuildRequires: curl-devel
  337. - add BuildRequires: libgomp
  338. * Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
  339. - Updated to 3.2.3
  340. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
  341. - rebuild with icu-56.1
  342. * Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
  343. - Updated to 3.2.2
  344. * Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
  345. - add configure options: --with-tcltk
  346. - add BuildRequires: tcl-devel tk-devel
  347. - add Requires: tcl tk
  348. * Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
  349. - Updated to 3.2.1
  350. * Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
  351. - add "LIBS=-lbz2" to configure option
  352. * Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
  353. - Updated to 3.2.0
  354. * Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
  355. - Updated to 3.1.3
  356. - added BuildRequires: texlive-collection-fontsextra for Vine6
  357. - changed option "make check-all" to "make check"
  358. - to avoid error in checking of mgcv package
  359. - changed orders of BuildRequires
  360. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  361. - rebuild with icu-54.1
  362. * Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
  363. - Updated to 3.1.2
  364. * Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
  365. - Updated to 3.1.1
  366. - add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
  367. * Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
  368. - add patch (2014-04-26)
  369. * Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
  370. - Updated to 3.1.0
  371. * Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
  372. - Updated to 3.0.3
  373. * Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
  374. - rebuild current VineSeed
  375. - add patch (2014-01-06)
  376. * Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
  377. - add Requires: libicu
  378. * Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
  379. - combine spec files Vine6 and VineSeed
  380. - correct the days of the week in changelog
  381. * Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  382. - delete BuildRequires: texlive-collection-texinfo
  383. - add BuildRequires: texlive-collection-plainextra
  384. - add BuildRequires: texlive-collection-latexextra
  385. - add BuildRequires: texlive-collection-fontsrecommended
  386. - for VineSeed
  387. * Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  388. - Updated to 3.0.2
  389. * Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
  390. - Updated to 3.0.1
  391. - add BuildRequires: java-1.6.0-openjdk-devel
  392. * Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
  393. - Updated to 3.0.0
  394. * Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
  395. - Updated to 2.15.3
  396. - use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
  397. - use BuildRequires ncurses-devel instead of libtermcap-devel
  398. * Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
  399. - Updated to 2.15.2
  400. * Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
  401. - changed group to Applications/Edutainment
  402. - added R to menu
  403. * Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
  404. - Updated to 2.15.1
  405. * Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
  406. - Updated to 2.15.0
  407. * Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
  408. - Updated to 2.14.2
  409. * Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
  410. - Updated to 2.14.1
  411. * Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
  412. - Updated to 2.14.0
  413. - add BuildRequires: texlive-collection-fontsextra
  414. * Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
  415. - Updated to 2.13.2
  416. - add BuildRequires: texlive-common
  417. - use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
  418. - removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
  419. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
  420. - synchronized to VinePlus/5 package
  421. * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
  422. - Updated to 2.13.1
  423. * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
  424. - Updated to 2.13.0
  425. * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
  426. - Updated to 2.12.2
  427. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  428. - add BuildRequires: libicu-devel
  429. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  430. - synchronized to VinePlus/5 package
  431. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  432. - Updated to 2.12.1
  433. - added --enable-R-shlib option to %%configure
  434. - added static subpackage
  435. - use BR: texlive instead of tetex on VineSeed
  436. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  437. - rebuilt with rpm-4.8.1 for pkg-config
  438. * Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  439. - recompiled because tcl/tk were not linked
  440. * Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  441. - Updated to 2.11.0
  442. - added Requires: libgfortran
  443. * Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  444. - Updated to 2.10.1
  445. * Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  446. - patched to 2.10.0
  447. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  448. - spec in UTF-8
  449. * Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  450. - Updated to 2.10.0
  451. * Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  452. - Updated to 2.9.2
  453. - deleted BuildRequires: lapack-devel blas-devel
  454. - rewrote SPEC file
  455. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  456. - Updated to 2.5.1
  457. - added BuildRequires: gcc-gfortran for VineSeed
  458. - added BuildRequires: lapack-devel blas-devel
  459. - fixed %preun script
  460. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  461. - Updated to 2.4.1
  462. - Added INFO option
  463. - Exclude Japanese Rprofile.site
  464. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  465. - Updated to 2.4.0
  466. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  467. - Added optimization flags
  468. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  469. - Packaged for VineLinux3.2
  470. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  471. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  472. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  473. - Packaged for VineLinux3.2
  474. - Slipped texinfo
  475. - Fixed preun error
  476. - Preset Japanese fonts
  477. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  478. - Packaged for VineLinux3.2
  479. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  480. - Restored CAPABILITIES file lost in 2.2.1beta
  481. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  482. - Configure uses --without-blas by default.
  483. - Install pdf manuals.
  484. - All toplevel documentation files are installed into _libdir/R
  485. as they may be required by R (qv note on AUTHORS and THANKS below).
  486. - Legacy scripts for rebuilding package indices removed.
  487. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  488. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  489. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  490. - The files AUTHORS and THANKS need to be installed into _libdir/R
  491. as they are required by the function contributors(). Previously
  492. they were installed only as documentation files.
  493. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  494. - Corrected date error in SPEC file.
  495. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  496. - Dropped support for Red Hat boxed set.
  497. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  498. including support for shared R library.
  499. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  500. with the default optimization flags, so there is a temporary work-around.
  501. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  502. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  503. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  504. - Install R-data.info file as well.
  505. - Make info processing conditional on texinfo version, not platform release,
  506. so that if a new enough version is installed, we will build and install info.
  507. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  508. - Built R 2.1.0. R now supports internationalization, so the patch
  509. to set the locale to "C" is now dropped.
  510. - install.packages() exits gracefully with a helpful message if
  511. the file INSTALL is not present, so this is now included in the
  512. R-devel package.
  513. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  514. - Added support for Scientific Linux (http://www.scientificlinux.org)
  515. A distribution based on RHEL. Thanks to Jon Peatfield.
  516. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  517. - Fixed file ownership in R-devel and libRmath packages
  518. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  519. - R-devel package is now a stub package with no files, except a documentation
  520. file (RPM won't accept sub-packages with no files). R now conflicts
  521. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  522. - Created libRmath subpackage with shared library.
  523. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  524. - Created R-devel and libRmath-devel subpackages
  525. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  526. - Built R 2.0.1
  527. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  528. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  529. gives "lpr".
  530. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  531. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  532. - Info support is now conditional on the macro Rinfo, which is only
  533. defined for Fedora 1 and 2.
  534. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  535. - Built R 2.0.0
  536. - There is no longer a BUGS file, so this is not installed as a
  537. documentation file.