TrueType-sazanami-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394
  1. # Command macros
  2. %define __mkfontdir umask 133;/usr/bin/mkfontdir
  3. %define __mkfontscale umask 133;/usr/bin/mkfontscale
  4. # Use this macro to call fc-cache throughout the specfile.
  5. %define __fccache umask 133;which fc-cache &> /dev/null && fc-cache -f
  6. %define version 4.2
  7. %define release 3%{?_dist_release}
  8. %define sazanami_date 20040629-vl-20061231
  9. %define ttfjp_version 6.0
  10. %define xfontdir %{_datadir}/fonts/TrueType-sazanami
  11. %define fontpathdir %{_sysconfdir}/X11/fontpath.d
  12. Summary: Free Japanese True Type Font (Sazanami)
  13. Summary(ja): フリーの日本語 True Type フォント(さざなみ明朝/さざなみゴシック)
  14. Name: TrueType-sazanami
  15. Version: %{version}
  16. Release: %{release}
  17. BuildArch: noarch
  18. Obsoletes: TrueTypeFonts_jp < 4.1
  19. Obsoletes: TrueType-kochi <= 4.4.1
  20. Provides: TrueType-kochi = %{ttfjp_version}
  21. Requires: %{name}-mincho = %{version}-%{release}
  22. Requires: %{name}-gothic = %{version}-%{release}
  23. # This is not really required, but usefull to upgrade.
  24. Requires: TrueType-vlgothic
  25. Source: %{name}.tar.bz2
  26. Source10: 60-sazanami-mincho.conf
  27. Source11: 60-sazanami-gothic.conf
  28. Source20: cidfmap.ja.sazanami-mincho
  29. Source21: cidfmap.ja.sazanami-gothic
  30. # Sazanami Font Family
  31. Source4: sazanami-%{sazanami_date}.tar.bz2
  32. License: distributable
  33. Group: User Interface/X
  34. Buildroot: %{_tmppath}/%{name}-root
  35. Distribution: Vine Linux
  36. Vendor: Project Vine
  37. Packager: daisuke
  38. %description
  39. This is meta package for Free Japanese True Type Font 'Sazanami Font'
  40. - Sazanami-Mincho
  41. - Sazanami-Gothic
  42. %description -l ja
  43. このパッケージはフリーの日本語 True Type フォント「さざなみフォント」
  44. の明朝、ゴシック両書体をインストールするためのメタパッケージです。この
  45. パッケージで以下のフォントがインストールされます。
  46. - さざなみ明朝
  47. - さざなみゴシック
  48. %package mincho
  49. Summary: Sazanami Mincho TrueType Fonts
  50. Summary(ja): さざなみ明朝 True Type フォント
  51. Group: User Interface/X
  52. Requires(post,postun): mktcapdir >= 0.5.4
  53. Requires(post,postun): fontconfig, xorg-x11-font-utils
  54. %description mincho
  55. This package includes Sazanami Mincho TrueType fonts.
  56. %description -l ja mincho
  57. このパッケージにはさざなみ明朝フォントが含まれています。
  58. %package gothic
  59. Summary: Sazanami Gothic TrueType Fonts
  60. Summary(ja): さざなみゴシック 日本語 True Type フォント
  61. Group: User Interface/X
  62. Requires(post,postun): mktcapdir >= 0.5.4
  63. Requires(post,postun): fontconfig, xorg-x11-font-utils
  64. %description gothic
  65. This package includes Sazanami Gothic TrueType fonts.
  66. %description -l ja gothic
  67. このパッケージにはさざなみゴシックフォントがふくまれています。
  68. %prep
  69. rm -rf ${RPM_BUILD_ROOT}
  70. %setup -n %{name} -a 4
  71. mv sazanami-%{sazanami_date}/* .
  72. %install
  73. # mkdir fontdirs
  74. mkdir -p $RPM_BUILD_ROOT/%{xfontdir}-{mincho,gothic}
  75. # install ttfconf
  76. install -m644 *-mincho.ttfconf *-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho
  77. install -m644 *-gothic.ttfconf *-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic
  78. # install fonts
  79. ln -sf sazanami-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho/kochi-mincho.ttf
  80. ln -sf sazanami-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic/kochi-gothic.ttf
  81. # install fontpath.d symlink
  82. mkdir -p $RPM_BUILD_ROOT/%{fontpathdir}
  83. ln -sf %{xfontdir}-mincho $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-mincho
  84. ln -sf %{xfontdir}-gothic $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-gothic
  85. # install fontconfig files
  86. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.{avail,d}
  87. install -m644 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
  88. for i in $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/*.conf
  89. do
  90. ln -sf ../conf.avail/$(basename $i) $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
  91. done
  92. # install ghostscript8 cidfmap
  93. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
  94. install -m644 %{SOURCE20} %{SOURCE21} $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
  95. %post mincho
  96. %{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
  97. ( %__fccache %{xfontdir}-mincho ) ||:
  98. %post gothic
  99. %{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
  100. ( %__fccache %{xfontdir}-gothic ) ||:
  101. %postun mincho
  102. %{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
  103. ( %__fccache %{xfontdir}-mincho ) ||:
  104. %postun gothic
  105. %{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
  106. ( %__fccache %{xfontdir}-gothic ) ||:
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %files
  110. %defattr(-,root,root)
  111. %doc README doc/
  112. %files mincho
  113. %defattr(-,root,root)
  114. %{xfontdir}-mincho/*
  115. %{fontpathdir}/%{name}-mincho
  116. %{_sysconfdir}/fonts/conf.avail/60-sazanami-mincho.conf
  117. %config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-mincho.conf
  118. %config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-mincho
  119. %files gothic
  120. %defattr(-,root,root)
  121. %{xfontdir}-gothic/*
  122. %{fontpathdir}/%{name}-gothic
  123. %{_sysconfdir}/fonts/conf.avail/60-sazanami-gothic.conf
  124. %config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-gothic.conf
  125. %config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-gothic
  126. %changelog
  127. * Wed Jan 15 2014 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 4.2-3
  128. - build with gcc-4.8
  129. * Sun Apr 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-2
  130. - remove R: TrueType-base
  131. - remove P: TrueTypeFonts_jp
  132. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-1
  133. - add gs8 cidfmap for sazanami
  134. * Sat Jun 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  135. - split mincho and gothic to its own fontdir
  136. - add fontpath.d symlink
  137. * Thu May 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
  138. - build for xorg-x11-7.3
  139. - change font location to %{_datadir}/fonts/TrueType-sazanami
  140. - require(post,postun) fontconfig and xorg-x11-font-utils
  141. - split to TrueType-sazanami-mincho and TrueType-sazanami-gothic
  142. * Sat Sep 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0-0vl1
  143. - split out VLGothic to TrueType-vlgothic package.
  144. * Sat Sep 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
  145. - update VLGothic to 20070901
  146. - update some kanji glyphs
  147. * Thu Aug 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-0vl1
  148. - update VLGothic to 20070830
  149. - update M+1C/M+1M to CVS head
  150. - update some kanji glyphs
  151. * Mon Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8-0vl1
  152. - update VLGothic to 20070731
  153. - update M+1C/M+1M to CVS head
  154. - add new glyphs to VL-PGothic/VL-Gothic
  155. - add Roman Numeral Glyphs (some part of Number Forms)
  156. - update some glyphs
  157. * Mon May 07 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-0vl1
  158. - update VLGothic to 20070507
  159. - add new glyphs to VL-Gothic
  160. - add ISO8859-1 Glyphs (Latin-1 Supplement)
  161. - add ISO8859-15 Glyphs (some part of Latin Extended-A)
  162. * Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6-0vl1
  163. - update VLGothic to 20070506
  164. - add new glyphs to VL-PGothic
  165. - add ISO8859-1 Glyphs (Latin-1 Supplement)
  166. - add ISO8859-15 Glyphs (some part of Latin Extended-A)
  167. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
  168. - update VLGothic to 20070503
  169. - update M+1C/1M to CVS head
  170. * Wed Mar 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4-0vl1
  171. - update VLGothic to 20070328
  172. - update M+1C/1M to CVS head
  173. - fix embolden problem on freetype-2.2
  174. * Sat Mar 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-0vl1
  175. - update VLGothic to 20070317
  176. - update M+1C/1M to CVS head
  177. - include M+ Kanji glyphs
  178. - update some glyphs
  179. - add some special sign characters
  180. - fix broken glyphs
  181. * Mon Jan 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2-0vl1
  182. - update VLGothic to 20070101
  183. - fix embolden problem on freetype-2.2
  184. * Sun Dec 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-0vl1
  185. - update VLGothic to 20061231
  186. - update M+1C/M+1M to cvs head 20061231
  187. - update kanji glyphs
  188. - update Sazanami to 20040629-vl-20061231
  189. - fix broken glyphs of sazanami-mincho
  190. * Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl1
  191. - bump up version to 2.0
  192. - update VLGothic to 20061026
  193. - update greek letter glyphs
  194. - split license information file from README.
  195. - add english version of license.
  196. * Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
  197. - update VLGothic to 20061021
  198. * Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28-0vl1
  199. - update VLGothic to 20061020 (<BTS:221>)
  200. - update M+1C/M+1M to TESTFILGHT012
  201. - update some glyphs
  202. - fix outline direction
  203. - remove overlap path
  204. * Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.27-0vl1
  205. - update VLGothic to 20061005 (<BTS:221>)
  206. - update some glyphs
  207. - fix outline direction
  208. - remove overlap path
  209. * Sat Sep 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26-0vl1
  210. - update VLGothic to 20060930 (<BTS:221>)
  211. - fix outline direction
  212. - remove overlap path
  213. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.25-0vl1
  214. - update VLGothic to 20060929
  215. - update some glyphs
  216. - fix outline direction
  217. - remove overlap path
  218. * Mon Sep 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24-0vl1
  219. - update VLGothic to 20060925
  220. - update some glyphs
  221. - add minimum gsub table for vertical writing
  222. * Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.23-0vl1
  223. - update VLGothic to 20060921
  224. - update few glyphs
  225. - update M+1C/M+1M to cvs head 2006/09/21
  226. * Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-0vl1
  227. - update VLGothic to 20060913
  228. - update some glyphs
  229. - fix half width space
  230. * Mon Sep 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-0vl1
  231. - update VLGothic to 20060911
  232. - update M+1C/M+1M to cvs head 2006/09/11
  233. - use VL-PGothic for -alias-gothic-p- (legacy core font)
  234. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-0vl1
  235. - update VLGothic to 20060831
  236. - add VL-Gothic-Regular.ttf for
  237. - use M+1C for VLPGothic instead of M+1P
  238. * Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19-0vl1
  239. - fix sazanami.ttfconf
  240. * Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18-0vl1
  241. - change the fontname to VLPGothic
  242. - update VLPGothic
  243. - TODO:
  244. - split VLGothic family to new package.
  245. - add M+1M based VLGothic for monospace font.
  246. * Wed Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17-0vl1
  247. - update M+1P+Sazanami.ttf
  248. - refine more glyphs
  249. * Wed Aug 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16-0vl1
  250. - update M+1P+Sazanami.ttf
  251. - refine more glyphs
  252. - add some glyphs for windows compatibility
  253. - update sazanami.ttfconf
  254. - add -fake-kochi gothic-, -fake-kochi mincho- without TTCap
  255. for Flash Plugin. (<BTS:0100>)
  256. * Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15-0vl1
  257. - update M+1P+Sazanami.ttf
  258. - refine more glyphs
  259. - add new full-width alphabets and numeric letters based on M+1P
  260. * Mon Jul 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
  261. - update M+1P+Sazanami.ttf
  262. - refine more glyphs
  263. * Sun Jul 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13-0vl1
  264. - update M+1P+Sazanami.ttf
  265. - refine more glyphs
  266. - redesign greek letter based on M+ 1P fonts
  267. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-0vl1
  268. - update M+1P+Sazanami.ttf
  269. - refine more glyphs
  270. * Sun Jul 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11-0vl1
  271. - update M+1P+Sazanami.ttf
  272. - refine more glyphs
  273. * Fri Jul 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-0vl1
  274. - update M+1P+Sazanami.ttf
  275. - refine more glyphs
  276. - fix encoding
  277. * Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-0vl1
  278. - update M+1P+Sazanami.ttf
  279. - refine more glyphs
  280. - fix outline direction (fix corruption on emboldening)
  281. * Wed Jul 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8-0vl1
  282. - update M+1P+Sazanami.ttf
  283. - refine more glyphs
  284. - fix broken glyph
  285. - refine greek letters
  286. * Tue Jul 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-0vl1
  287. - update M+1P+Sazanami.ttf
  288. - refine more glyphs
  289. - TODO: should rename the fontname?
  290. * Sun Jul 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-0vl1
  291. - update M+1P+Sazanami.ttf
  292. - fix outline direction (fix corruption of some glyphs)
  293. - refine more glyphs
  294. * Wed Jul 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl1
  295. - update M+1P+Sazanami.ttf
  296. - refine some glyphs.. (modified 200 or more)
  297. - update sazanami.ttfconf to use M+1P+Sazanami for alias-{sans,gothic}-p
  298. * Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl1
  299. - update M+1P+Sazanami.ttf
  300. - refine some glyphs.. (modified 100 or more)
  301. * Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
  302. - update M+1P-Sazanami.ttf
  303. - fix corruption of some glyphs
  304. - refine some glyphs to make it more usable..
  305. * Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
  306. - add M+1P+Sazanami.ttf (Mplus 1P Font + Sazanami Gothic)
  307. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
  308. - new upstream release
  309. * Wed Jun 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  310. - initial build for Vine Linux based on TrueType-kochi-subst package
  311. - Provides TrueType-kochi, TrueTypeFonts_jp
  312. - include Kochi-{mincho,gothic}.ttf symlinks for compatibility