agg-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. Summary: Anti-Grain Geometry
  2. Name: agg
  3. Version: 2.5
  4. Release: 3%{?_dist_release}
  5. Group: System Environment/Libraries
  6. URL: http://www.antigrain.com
  7. License: GPL
  8. #Source: http://www.antigrain.com/%{name}-%{version}.tar.gz
  9. Source0: %{name}-free-%{version}.tar.gz
  10. # agg contains gpc.c, 'free for non-commercial use', we cannot ship.
  11. # We use this script to remove the non-free code before shipping it.
  12. # Download the upstream tarball and invoke this script while in the
  13. # tarball's directory:
  14. # sh agg-generate-tarball.sh 2.5
  15. Source1: agg-generate-tarball.sh
  16. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: automake, libtool, xorg-x11-devel, freetype2-devel, SDL-devel
  18. Patch0: agg-2.4-depends.patch
  19. Patch1: agg-2.5-pkgconfig.patch
  20. Patch2: agg-2.5-autotools.patch
  21. Patch101: 0001-Fix-non-terminating-loop-conditions-when-len-1.patch
  22. Patch102: 0002-Cure-recursion-by-aborting-if-the-co-ordinates-are-t.patch
  23. Patch103: 0003-Get-coordinates-from-previous-vertex-if-last-command.patch
  24. Patch104: 0004-Make-rasterizer_outline_aa-ignore-close_polygon-when.patch
  25. Patch105: 0005-Remove-VC-6-workaround.patch
  26. Patch106: 0006-Implement-grain-merge-blending-mode-GIMP.patch
  27. Patch107: 0007-Implement-grain-extract-blending-mode-GIMP.patch
  28. Patch108: 0008-Declare-multiplication-and-division-operators-as-con.patch
  29. Patch109: 0009-Add-a-static-identity-transformation.patch
  30. Patch110: 0010-Add-renderer_scanline_aa_alpha.patch
  31. Patch111: 0011-Avoid-division-by-zero-in-color-burn-mode.patch
  32. Patch112: 0012-Avoid-pixel-artifacts-when-compositing.patch
  33. Patch113: 0013-Modify-agg-conv-classes-to-allow-access-to-the-origi.patch
  34. Patch114: 0014-Avoid-potential-zero-division-resulting-in-nan-in-ag.patch
  35. Patch115: 0015-Ensure-first-value-in-the-gamma-table-is-always-zero.patch
  36. %description
  37. A High Quality Rendering Engine for C++
  38. %package devel
  39. Summary: Support files necessary to compile applications with agg
  40. Group: Development/Libraries
  41. Requires: agg = %{version}-%{release}
  42. %description devel
  43. Libraries, headers, and support files necessary to compile applications using agg
  44. %prep
  45. %setup -q
  46. %patch0 -p1 -b .depends
  47. %patch1 -p1 -b .pkgconfig
  48. %patch2 -p0 -b .autotools
  49. %patch101 -p1
  50. %patch102 -p1
  51. %patch103 -p1
  52. %patch104 -p1
  53. %patch105 -p1
  54. %patch106 -p1
  55. %patch107 -p1
  56. %patch108 -p1
  57. %patch109 -p1
  58. %patch110 -p1
  59. %patch111 -p1
  60. %patch112 -p1
  61. %patch113 -p1
  62. %patch114 -p1
  63. %patch115 -p1
  64. aclocal
  65. autoheader
  66. autoconf
  67. libtoolize --force
  68. automake --foreign --add-missing --ignore-deps
  69. %build
  70. %configure --disable-static --disable-gpc
  71. # parallel build fails in examples/ because the .la is in _LDFLAGS instead of
  72. # _LIBADD
  73. make
  74. %install
  75. make install DESTDIR=$RPM_BUILD_ROOT
  76. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  77. rm -rf __dist_examples __clean_examples
  78. cp -a examples __clean_examples
  79. make -C __clean_examples distclean
  80. rm -rf __clean_examples/Makefile.am __clean_examples/{win32*,macosx*,BeOS}
  81. mkdir __dist_examples
  82. mv __clean_examples __dist_examples/examples
  83. %post
  84. /sbin/ldconfig
  85. %postun
  86. /sbin/ldconfig
  87. %files
  88. %defattr(-,root,root)
  89. %doc authors copying readme
  90. %{_libdir}/lib*.so.*
  91. %files devel
  92. %{_libdir}/*.so
  93. %{_libdir}/pkgconfig/libagg.pc
  94. %{_includedir}/agg2
  95. %{_datadir}/aclocal/libagg.m4
  96. %clean
  97. rm -r $RPM_BUILD_ROOT
  98. %changelog
  99. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5-3
  100. - rebuild with gcc-5.4.0
  101. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5-2
  102. - merge with fedora rawhide package
  103. * Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-23
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  105. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.5-22
  106. - Rebuilt for GCC 5 C++11 ABI change
  107. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-21
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  109. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-20
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  111. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-19
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  113. * Sat Jun 22 2013 Tom Hughes <tom@compton.nu> - 2.5-18
  114. - Update mapnik patches
  115. * Sun May 19 2013 Tom Hughes <tom@compton.nu> - 2.5-17
  116. - Add patches from mapnik
  117. * Fri Feb 22 2013 Jon Ciesla <limburgher@gmail.com> - 2.5-16
  118. - Fix FTBFS, BZ 913873.
  119. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-15
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  121. * Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-14
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  123. * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-13
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  125. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-12
  126. - Rebuilt for glibc bug#747377
  127. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-11
  128. - Rebuilt for glibc bug#747377
  129. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-10
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  131. * Fri Jan 29 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.5-9
  132. - also remove include/agg_conv_gpc.h as it also carries a copy of the non-Free
  133. GPC license (upstream also recommends removing that file under
  134. http://www.antigrain.com/license/index.html#toc0005) (#559611)
  135. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-8
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  137. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-7
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  139. * Tue Feb 5 2008 Patrice Dumas <pertusus@free.fr> - 2.5-6
  140. - remove non free files
  141. - minor cleanups
  142. - parallel build fails
  143. * Fri Aug 03 2007 Caolan McNamara <caolanm@redhat.com> - 2.5-4
  144. - clarify license
  145. - source upstream silently changed even though version remained
  146. unchanged
  147. * Tue Jun 26 2007 Caolan McNamara <caolanm@redhat.com> - 2.5-3
  148. - Resolves: rhbz#245650 -devel Require: freetype-devel
  149. * Mon Apr 23 2007 Caolan McNamara <caolanm@redhat.com> - 2.5-2
  150. - Resolves: rhbz#237493 misapplied patch
  151. * Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.5-1vl5
  152. - applied new versioning policy
  153. - rebuilt with xorg-x11-devel
  154. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
  155. - initial build for Vine Linux
  156. * Sat Jan 06 2007 Caolan McNamara <caolanm@redhat.com> - 2.5-1
  157. - bump to 2.5
  158. * Fri Nov 10 2006 Caolan McNamara <caolanm@redhat.com> - 2.4-3
  159. - Resolves: rhbz#214970 rebuild with new 2.4 sources
  160. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4-2.1
  161. - rebuild
  162. * Mon Jul 10 2006 Caolan McNamara <caolanm@redhat.com> - 2.4-2
  163. - rh#198174# add extra links from libs to their runtime requirements
  164. * Wed May 10 2006 Caolan McNamara <caolanm@redhat.com> - 2.4-1
  165. - next version
  166. * Fri Feb 17 2006 Karsten Hopp <karsten@redhat.de> 2.3-4
  167. - add BuildRequires freetype-devel for ft2build.h
  168. * Mon Feb 13 2006 Caolan McNamara <caolanm@redhat.com> - 2.3-3
  169. - BuildRequires
  170. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3-2.1
  171. - bump again for double-long bug on ppc(64)
  172. * Wed Feb 08 2006 Caolan McNamara <caolanm@redhat.com> - 2.3-2
  173. - rh#180341# BuildRequires
  174. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3-1.1
  175. - rebuilt for new gcc4.1 snapshot and glibc changes
  176. * Wed Nov 23 2005 Caolan McNamara <caolanm@redhat.com> 2.3-1
  177. - initial import