akonadi-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347
  1. %define _qt4_ver 4.8.0
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  4. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  5. ## Can be either MYSQL(uptsream default), SQLITE, or POSTGRES(untested)
  6. %global database_backend SQLITE
  7. Name: akonadi
  8. Summary: PIM Storage Service
  9. Summary(ja): PIM ストレージサービス
  10. Version: 1.13.0
  11. Release: 4%{?_dist_release}
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://download.akonadi-project.org/
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Source0: http://download.akonadi-project.org/akonadi-%{version}.tar.bz2
  18. %define mysql_conf_timestamp 20110629
  19. # shrink default initial db size a bit (approx 140mb->28mb)
  20. Patch1: akonadi-mysql_conf.patch
  21. ## upstream patches
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: cmake >= 2.6.0
  24. BuildRequires: qt4-devel >= 4.4
  25. BuildRequires: automoc4
  26. BuildRequires: MySQL-server
  27. # for xsltproc
  28. BuildRequires: libxslt
  29. BuildRequires: shared-mime-info
  30. BuildRequires: libboost-devel libboost-program-options
  31. BuildRequires: soprano-devel >= 2.5.0
  32. BuildRequires: sqlite3-devel
  33. BuildRequires: libICE-devel libXext-devel
  34. Requires: qt4 >= %{_qt4_version}
  35. %if "%{?database_backend}" == "MYSQL"
  36. Requires: qt4-MySQL
  37. # not *strictly* required, but we need a functional default configuration
  38. Requires: MySQL-server
  39. %endif
  40. Obsoletes: akonadi-sqlite < %{version}-%{release}
  41. Requires(post): /sbin/ldconfig
  42. Requires(postun): /sbin/ldconfig
  43. %description
  44. %{summary}.
  45. %if "%{?database_backend}" == "MYSQL"
  46. Requires an available instance of mysql server at runtime.
  47. Akonadi can spawn a per-user one automatically if the mysql-server
  48. package is installed on the machine.
  49. See also: %{_sysconfdir}/akonadi/mysql-global.conf
  50. %endif
  51. %package devel
  52. Summary: Developer files for %{name}
  53. Summary(ja): %{name} の開発用ファイル
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. Requires: qt4-devel
  57. %description devel
  58. %{summary}.
  59. %prep
  60. %setup -q
  61. #%patch1 -p1 -b .mysql_conf
  62. #touch -d %{mysql_conf_timestamp} server/src/storage/mysql-global.conf
  63. %build
  64. %ifarch x86_64
  65. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  66. %endif
  67. mkdir -p %{_target_platform}
  68. pushd %{_target_platform}
  69. %cmake \
  70. -DCONFIG_INSTALL_DIR=%{_sysconfdir} \
  71. -DINSTALL_QSQLITE_IN_QT_PREFIX:PATH=%{_qt4_plugindir} \
  72. %{?database_backend:-DDATABASE_BACKEND=%{database_backend}} \
  73. ..
  74. popd
  75. make %{?_smp_mflags} -C %{_target_platform}
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  79. mkdir -p $RPM_BUILD_ROOT%{_datadir}/akonadi/agents
  80. # create "big" config (analog to -mobile.conf)
  81. install -p \
  82. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global.conf \
  83. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global-big.conf
  84. # default to small/mobile config
  85. install -p \
  86. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global-mobile.conf \
  87. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global.conf
  88. touch -d %{mysql_conf_timestamp} \
  89. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global*.conf \
  90. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-local.conf
  91. # create/own %{_libdir}/akondi
  92. mkdir -p $RPM_BUILD_ROOT%{_libdir}/akonadi
  93. #%check
  94. #make test -C %{_target_platform}
  95. #export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_datadir}/pkgconfig:$RPM_BUILD_ROOT%{_libdir}/pkgconfig
  96. #test "$(pkg-config --modversion akonadi)" = "%{version}"
  97. %clean
  98. rm -rf $RPM_BUILD_ROOT
  99. %post -p /sbin/ldconfig
  100. %posttrans
  101. update-mime-database %{_datadir}/mime &> /dev/null || :
  102. %postun
  103. /sbin/ldconfig ||:
  104. if [ $1 -eq 0 ] ; then
  105. update-mime-database %{_datadir}/mime &> /dev/null ||:
  106. fi
  107. %files
  108. %defattr(-,root,root,-)
  109. %doc AUTHORS lgpl-license
  110. %dir %{_sysconfdir}/akonadi
  111. # example conf's
  112. %{_sysconfdir}/akonadi/mysql-global-big.conf
  113. %{_sysconfdir}/akonadi/mysql-global-mobile.conf
  114. %config(noreplace) %{_sysconfdir}/akonadi/mysql-global.conf
  115. %config(noreplace) %{_sysconfdir}/akonadi/mysql-local.conf
  116. %{_bindir}/akonadi_agent_launcher
  117. %{_bindir}/akonadi_agent_server
  118. %{_bindir}/akonadi_control
  119. %{_bindir}/akonadi_rds
  120. %{_bindir}/akonadictl
  121. %{_bindir}/akonadiserver
  122. %{_bindir}/asapcat
  123. %{_libdir}/libakonadi*.so.1*
  124. %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.*.xml
  125. %{_datadir}/dbus-1/services/org.freedesktop.Akonadi.*.service
  126. %{_datadir}/mime/packages/akonadi-mime.xml
  127. %{_datadir}/akonadi
  128. %{_qt4_plugindir}/sqldrivers/libqsqlite3.so
  129. %files devel
  130. %defattr(-,root,root,-)
  131. %{_includedir}/akonadi
  132. %{_libdir}/pkgconfig/akonadi.pc
  133. %{_libdir}/libakonadi*.so
  134. %{_libdir}/cmake/Akonadi
  135. %changelog
  136. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 1.13.0-4
  137. - rebuild with libboost-1.66.0
  138. * Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.13.0-3
  139. - rebuild with gcc-5.4.0
  140. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.13.0-2
  141. - rebuilt with libboost-1.16.0.
  142. * Wed Dec 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.13.0-1
  143. - new upstream release
  144. * Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.12.1-1
  145. - new upstream release
  146. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.11.0-1
  147. - new upstream release
  148. * Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  149. - new upstream release
  150. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.9.2-1
  151. - new upstream release
  152. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  153. - new upstream release
  154. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.0-1
  155. - new upstream release
  156. * Mon Jan 9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.2-2
  157. - rebuilt with qt-4.8.0
  158. * Sun Oct 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.2-1
  159. - new upstream release
  160. * Sun Sep 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.1-1
  161. - new upstream release
  162. * Sat Aug 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.0-2
  163. - rebuilt with soprano-2.7.0-2
  164. * Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.0-1
  165. - new upstream release
  166. * Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.0-2
  167. - rebuilt with qt4-4.7.2
  168. * Mon Jan 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.0-1
  169. - new upstream release
  170. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-2
  171. - rebuilt with rpm-4.8.1
  172. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-1
  173. - new upstream release
  174. - added BR: sqlite3-devel
  175. - added sqlite subpackage
  176. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  177. - new upstream release
  178. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  179. - updated Patch1
  180. - added BR: MySQL-server
  181. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> - 1.3.1-2
  182. - added qmake path to PATH (if x86_64)
  183. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
  184. - new upstream release
  185. - built with new toolchain
  186. * Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.1-1
  187. - new upstream release
  188. * Wed Sep 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 1.2.0-4
  189. - use %%cmake macro
  190. - removed MySQL-server from BuildRequires:
  191. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-3
  192. - fixed Requires
  193. * Sat Aug 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-2
  194. - Initial build for Vine
  195. * Thu Jul 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 1.2.0-1
  196. - Akonadi 1.2.0
  197. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.95-2
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  199. * Thu Jun 25 2009 Than Ngo <than@redhat.com> - 1.1.95-1
  200. - 1.1.95
  201. * Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.90-1
  202. - akonadi-1.1.90
  203. * Tue May 26 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.85-3
  204. - akonadi.pc.cmake: s/AKONADI_LIB_VERSION_STRING/AKONADI_VERSION_STRING/
  205. * Tue May 12 2009 Than Ngo <than@redhat.com> 1.1.85-2
  206. - fix rpm file list
  207. * Wed May 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.85-1
  208. - akonadi-1.1.85
  209. * Thu Apr 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.2-1
  210. - akonadi-1.1.2
  211. - optimize scriptlets a bit
  212. * Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-6
  213. - rev startup patch
  214. - BR: cmake >= 2.6.0
  215. - preserve timestamp's on mysql*.conf's
  216. * Tue Feb 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-5
  217. - own %%_sysconfig/akonadi/mysql-local.conf
  218. - startup patch: reset conf only when needed, and clear mysql log file on update
  219. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-4
  220. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  221. * Fri Feb 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-3
  222. - shrink default db initial size a bit (approx 140mb->28mb)
  223. - drop extraneous RPATH-cmake baggage
  224. * Wed Jan 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-1
  225. - 1.1.1
  226. * Sun Jan 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.0-1
  227. - 1.1.0
  228. * Tue Dec 16 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.81-1
  229. - 1.0.81
  230. * Mon Dec 08 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.80-3
  231. - restore Requires: mysql-server
  232. * Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.80-2
  233. - own /usr/share/akonadi and /usr/share/akonadi/agents (#473595)
  234. * Wed Nov 26 2008 Than Ngo <than@redhat.com> - 1.0.80-1
  235. - 1.0.80
  236. * Wed Oct 22 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-4
  237. - drop Requires: mysql-server (for now), mention in %%description
  238. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-3
  239. - Requires: mysql-server
  240. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-2
  241. - BR: mysql-server
  242. - Requires: qt4-mysql
  243. - cleanup spec
  244. * Wed Jul 23 2008 Than Ngo <than@redhat.com> - 1.0.0-1
  245. - 1.0.0
  246. * Wed Jun 18 2008 Rex Dieter <rdieter@fedoraproject.org> 0.82.0-1
  247. - akonadi-0.82.0
  248. * Tue Jun 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.2.20080526svn812787
  249. - BR automoc, drop automoc hack
  250. * Mon May 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.1.20080526svn812787
  251. - update to revision 812787 from KDE SVN (to match KDE 4.1 Beta 1)
  252. - restore builtin automoc4 for now
  253. - update file list, require pkgconfig in -devel (.pc file now included)
  254. * Mon May 5 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-2
  255. - -devel: remove bogus Requires: pkgconfig
  256. * Sat May 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-1
  257. - first Fedora package