apr-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458
  1. %define aprver 1
  2. # Arches on which the multilib apr.h hack is needed:
  3. %define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
  4. Summary: Apache Portable Runtime library
  5. Summary(ja): Apache ポータブルランタイムライブラリ
  6. Name: apr
  7. Version: 1.7.0
  8. Release: 2%{?_dist_release}
  9. Group: system
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: Apache Software License
  13. URL: https://apr.apache.org/
  14. Source0: http://ftp.tsukuba.wide.ad.jp/software/apache//apr/%{name}-%{version}.tar.bz2
  15. Source1: apr-wrapper.h
  16. Patch4: apr-1.2.2-libdir.patch
  17. Patch5: apr-1.3.3-pkgconf.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: autoconf, libtool, python, doxygen
  20. BuildRequires: libuuid-devel
  21. # To enable SCTP support
  22. BuildRequires: lksctp-tools-devel
  23. Conflicts: subversion < 0.20.1-2
  24. Obsoletes: apache2-apr
  25. %description
  26. The mission of the Apache Portable Runtime (APR) is to provide a
  27. free library of C data structures and routines, forming a system
  28. portability layer to as many operating systems as possible,
  29. including Unices, MS Win32, BeOS and OS/2.
  30. %package devel
  31. Summary: APR library development kit
  32. Summary(ja): APR ライブラリ開発キット
  33. Group: programming
  34. Requires: %{name} = %{version}-%{release}
  35. Conflicts: subversion-devel < 0.20.1-2
  36. Obsoletes: apache2-apr-devel
  37. %description devel
  38. This package provides the support files which can be used to
  39. build applications using the APR library. The mission of the
  40. Apache Portable Runtime (APR) is to provide a free library of
  41. C data structures and routines.
  42. %prep
  43. %setup -q
  44. %patch4 -p1 -b .libdir
  45. %patch5 -p1 -b .pkgconf
  46. %build
  47. # regenerate configure script etc.
  48. ./buildconf
  49. # Forcibly prevent detection of shm_open (which then picks up but
  50. # does not use -lrt).
  51. export ac_cv_search_shm_open=no
  52. %configure \
  53. --includedir=%{_includedir}/apr-%{aprver} \
  54. --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
  55. --with-devrandom=/dev/urandom \
  56. --disable-static \
  57. CC=gcc CXX=g++
  58. make %{?_smp_mflags} && make dox
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. make install DESTDIR=$RPM_BUILD_ROOT
  62. # Move docs to more convenient location
  63. rm -rf html
  64. mkdir -p html
  65. cp -pr docs/dox/html/* html/
  66. # mv docs/dox/html html
  67. # Trim exported dependecies
  68. sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
  69. $RPM_BUILD_ROOT%{_libdir}/libapr*.la
  70. sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/ */ /g}' \
  71. $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
  72. %ifarch %{multilib_arches}
  73. # Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
  74. # packages:
  75. mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
  76. $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
  77. install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
  78. %endif
  79. # Unpackaged files:
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  82. %check
  83. # Fail if LFS support isn't present in a 32-bit build, since this
  84. # breaks ABI and the soname doesn't change: see #254241
  85. if grep 'define SIZEOF_VOIDP 4' include/apr.h \
  86. && ! grep off64_t include/apr.h; then
  87. cat config.log
  88. : LFS support not present in 32-bit build
  89. exit 1
  90. fi
  91. pushd test
  92. make %{?_smp_mflags}
  93. ./testall -v -q
  94. popd
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %post -p /sbin/ldconfig
  98. %postun -p /sbin/ldconfig
  99. %files
  100. %defattr(-,root,root,-)
  101. %license LICENSE
  102. %doc CHANGES NOTICE
  103. %{_libdir}/libapr-%{aprver}.so.*
  104. %files devel
  105. %defattr(-,root,root,-)
  106. %doc docs/APRDesign.html docs/canonical_filenames.html
  107. %doc docs/incomplete_types docs/non_apr_programs
  108. %{_bindir}/apr-%{aprver}-config
  109. #{_libdir}/libapr-%{aprver}.a
  110. %{_libdir}/libapr-%{aprver}.so
  111. %{_libdir}/pkgconfig/*.pc
  112. %dir %{_libdir}/apr-%{aprver}
  113. %dir %{_libdir}/apr-%{aprver}/build
  114. %{_libdir}/apr-%{aprver}/build/*
  115. %dir %{_includedir}/apr-%{aprver}
  116. %{_includedir}/apr-%{aprver}/*.h
  117. %changelog
  118. * Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-2
  119. - rebuilt with current environment.
  120. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-1
  121. - updated to 1.7.0.
  122. - dropped Patch1 and 3: fixed in upstream.
  123. * Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.5-1
  124. - updated to 1.6.5.
  125. - dropped Patch2.
  126. - imported Patch1 from rawhide.
  127. * Mon May 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
  128. - updated to 1.5.2.
  129. * Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-1
  130. - update to 1.5.1
  131. * Sat Oct 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
  132. - new upstream release
  133. * Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
  134. - new upstream release
  135. - built with rpm-4.8.1
  136. - removed static libraries from devel package
  137. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
  138. - rebuilt with new toolchain
  139. * Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
  140. - new upstream release
  141. * Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
  142. - new upstream release with security fix (CVE-2009-2412)
  143. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
  144. - new upstream release
  145. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
  146. - new upstream release
  147. - updated Patch5
  148. * Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
  149. - new upstream release
  150. - removed Patch1 and 6
  151. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
  152. - removed *.la files from devel package
  153. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
  154. - new upstream release
  155. - added Patch2 and 6 from Fedora
  156. * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
  157. - add fix for use of %%pI with psprintf
  158. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  159. - use RTLD_DEEPBIND in apr_dso_open by default
  160. * Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  161. - new upstream release
  162. * Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  163. - new upstream release
  164. * Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
  165. - remove Requires: gcc = %%(gcc -dumpversion)
  166. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
  167. - rebuilt with new toolchain
  168. * Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  169. - new upstream release
  170. * Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
  171. - initial build for Vine Linux based on FC package
  172. * Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
  173. - fix another multilib conflict (#192659)
  174. * Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
  175. - BR e2fsprogs-devel for libuuid
  176. * Mon May 8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
  177. - use multilib parallel-installation wrapper hack for apr.h
  178. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
  179. - fix installbuilddir in apr-1-config
  180. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
  181. - update to 1.2.7
  182. - use pkg-config in apr-1-config to make it libdir-agnostic
  183. * Thu Apr 6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
  184. - update to 1.2.6
  185. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
  186. - bump again for double-long bug on ppc(64)
  187. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
  188. - rebuilt for new gcc4.1 snapshot and glibc changes
  189. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
  190. - fix namespace pollution (r354824, r355464)
  191. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
  192. - fix build with recent glibc (#176911)
  193. * Tue Jan 3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
  194. - rebuilt again
  195. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  196. - rebuilt
  197. * Fri Dec 9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
  198. - rebuild for new gcc
  199. * Thu Dec 8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
  200. - add apr_file_seek() fixes from upstream (r326593, r326597)
  201. * Wed Dec 7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
  202. - apr-1-config: strip more exports (#175124)
  203. * Tue Dec 6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
  204. - avoid linking against -lrt
  205. - don't print -L${libdir} in --libs output
  206. - don't export -lcrypt/-luuid in .la file
  207. * Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
  208. - update to 1.2.2
  209. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  210. - use RTLD_DEEPBIND in apr_dso_open by default
  211. * Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
  212. - update to 0.9.7
  213. * Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
  214. - rebuild for new gcc
  215. * Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
  216. - don't override CFLAGS at build time
  217. - allow setting TCP_NODELAY and TCP_CORK concurrently
  218. - use _exit() not exit() in child if exec*() fails (upstream #30913)
  219. * Fri Sep 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
  220. - add from 0.9.x branch:
  221. * fix for apr_{uid,gid}_* error handling (r239592)
  222. * fix for apr_file_ write flushing (r267192)
  223. - add backport for use of readdir64_r (r265032, r265681, r265684)
  224. * Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
  225. - rebuild
  226. * Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
  227. - fix apr_procattr_child_*_set error handling
  228. * Tue Mar 1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
  229. - have apr-devel depend on specific version of gcc
  230. - add NOTICE to docdir
  231. * Wed Feb 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
  232. - update to 0.9.6
  233. * Wed Feb 2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
  234. - don't disable sendfile on s390 (IBM LTC, #146891)
  235. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
  236. - really fix apr-config --srcdir
  237. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
  238. - fix apr-config --srcdir again
  239. * Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
  240. - update to 0.9.5
  241. * Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
  242. - rebuild
  243. * Wed Sep 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
  244. - have -devel require apr of same V-R
  245. * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
  246. - backport fixes from HEAD:
  247. * correct implementation of nested mutexes
  248. * support for POSIX semaphores on LP64 platforms
  249. * Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
  250. - rebuild for another attempt at using sem_open
  251. * Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
  252. - move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
  253. * Thu Jul 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
  254. - rebuild
  255. * Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
  256. - rebuild now /dev/shm is mounted
  257. * Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
  258. - add fix for cleanup structure reuse (part of upstream #23567)
  259. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  260. - rebuilt
  261. * Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
  262. - add support for setuid/setgid/sticky bits (Andr辿 Malo)
  263. - add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
  264. * Mon Jun 7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
  265. - enable posixsem and process-shared pthread mutex support, but
  266. ensure that sysvsem remains the default mechanism
  267. * Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
  268. - entirely remove 2Gb file size limit from apr_file_copy();
  269. fixes "svnadmin hotcopy" on repos with >2Gb strings table
  270. - work around getnameinfo bugs with v4-mapped addresses
  271. - fix apr_time_exp_get() for dates in 2038 (Philip Martin)
  272. * Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
  273. - use APR_LARGEFILE in apr_file_{copy,append}
  274. * Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
  275. - add APR_LARGEFILE flag
  276. * Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
  277. - fix configure check for mmap of /dev/zero
  278. - just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
  279. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
  280. - rebuilt
  281. * Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
  282. - undocument apr_dir_read() ordering constraint and fix tests
  283. * Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
  284. - rebuilt without -Wall -Werror
  285. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
  286. - rebuilt
  287. * Tue Feb 3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
  288. - define apr_off_t as int/long/... to prevent it changing
  289. with _FILE_OFFSET_BITS on 32-bit platforms
  290. * Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
  291. - add apr_temp_dir_get fixes from HEAD
  292. * Thu Jan 8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
  293. - ensure that libapr is linked against libpthread
  294. - don't link libapr against -lnsl
  295. * Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
  296. - -devel package no longer requires libtool
  297. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
  298. - disable tests on x86_64 (#97611)
  299. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
  300. - update to 0.9.4, enable tests
  301. - ensure that libresolv is not used
  302. * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
  303. - use /dev/urandom (#103049)
  304. * Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
  305. - add back CC=gcc, CXX=g++
  306. * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
  307. - rebuild
  308. * Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
  309. - work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
  310. * Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
  311. - support --cc and --cpp arguments in apr-config
  312. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
  313. - force libtool to use CC=gcc, CXX=g++
  314. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
  315. - fix libtool location in apr_rules.mk
  316. * Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
  317. - use AI_ADDRCONFIG in getaddrinfo() support (#73350)
  318. - include a working libtool script rather than relying on
  319. /usr/bin/libtool (#97695)
  320. * Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
  321. - don't use /usr/bin/libtool
  322. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  323. - rebuilt
  324. * Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
  325. - add fix for psprintf memory corruption (CAN-2003-0245)
  326. - remove executable bit from apr_poll.h
  327. * Thu May 1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
  328. - link libapr against libpthread
  329. - make apr-devel conflict with old subversion-devel
  330. - fix License
  331. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
  332. - run ldconfig in post/postun
  333. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
  334. - patch test suite to not care if IPv6 is disabled
  335. * Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
  336. - initial build