arpwatch-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471
  1. %define arpwatch_ver 2.1a15
  2. %define _vararpwatch %{_localstatedir}/arpwatch
  3. %define PCAP_UID 77
  4. %define PCAP_GID 77
  5. Summary: Network monitoring tools for tracking IP addresses on a network.
  6. Summary(ja): ネットワークの IP アドレスを追跡する監視ツール
  7. Name: arpwatch
  8. Version: %{arpwatch_ver}
  9. Release: 0vl1
  10. Epoch: 1
  11. License: BSD
  12. Group: Applications/System
  13. Source0: ftp://ftp.ee.lbl.gov/arpwatch-%{version}.tar.gz
  14. Source3: arpwatch.init
  15. Source5: arpwatch.sysconfig
  16. Source6: arpwatch-ethercodes.dat
  17. Patch1: arpwatch-2.1a4-fhs.patch
  18. Patch2: arpwatch-2.1a10-man.patch
  19. Patch3: arpwatch-drop.patch
  20. Patch4: arpwatch-drop-man.patch
  21. Patch5: arp2ethers.patch
  22. Patch6: arpwatch-addr.patch
  23. BuildRequires: autoconf automake libpcap
  24. Requires(post): chkconfig
  25. Requires(postun): initscripts
  26. Requires(pre): shadow-utils
  27. Requires(preun): chkconfig initscripts
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %description
  32. The arpwatch package contains arpwatch and arpsnmp. Arpwatch and
  33. arpsnmp are both network monitoring tools. Both utilities monitor
  34. Ethernet or FDDI network traffic and build databases of Ethernet/IP
  35. address pairs, and can report certain changes via email.
  36. Install the arpwatch package if you need networking monitoring devices
  37. which will automatically keep track of the IP addresses on your
  38. network.
  39. %description -l ja
  40. arpwatch パッケージには arpwatch と arpsnmp が含まれます。これらは
  41. ネットワークの監視ツールです。これらのユーティリティはイーサネットや
  42. FDDI ネットワークのトラフィックを監視し、イーサネットアドレスと IP
  43. アドレスとの対応のデータベースを構築し、変化があったらメールで通知
  44. することができます。
  45. ネットワーク上の IP アドレスの変化を自動的に保持するようなデバイスを
  46. 監視したい場合、arpwatch パッケージをインストールして下さい。
  47. %prep
  48. %setup -q
  49. %patch1 -p1 -b .fhs
  50. %patch2 -p1 -b .arpsnmpman
  51. %patch3 -p1 -b .droproot
  52. %patch4 -p0 -b .droprootman
  53. #patch5 -p1 -b .arp2ether
  54. %patch6 -p1 -b .addr
  55. chmod u+w ethercodes.dat
  56. cp %SOURCE6 ethercodes.dat
  57. %build
  58. aclocal
  59. autoconf
  60. CFLAGS="$CFLAGS -I/usr/include/pcap" %configure
  61. make ARPDIR=%{_vararpwatch}
  62. %install
  63. rm -rf ${RPM_BUILD_ROOT}
  64. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  65. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{3,8}
  66. mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
  67. make DESTDIR=${RPM_BUILD_ROOT} install install-man
  68. mkdir -p ${RPM_BUILD_ROOT}%{_vararpwatch}
  69. for n in arp2ethers arpfetch massagevendor massagevendor-old; do
  70. install -m755 $n ${RPM_BUILD_ROOT}%{_vararpwatch}
  71. done
  72. for n in *.awk *.dat; do
  73. install -m644 $n ${RPM_BUILD_ROOT}%{_vararpwatch}
  74. #for n in *.awk *.dat missingcodes.txt; do
  75. # install -m644 $n ${RPM_BUILD_ROOT}%{_vararpwatch}
  76. done
  77. ( cd ${RPM_BUILD_ROOT}
  78. mkdir -p .%{_initdir}
  79. install -c -m755 $RPM_SOURCE_DIR/arpwatch.init .%{_initdir}/arpwatch
  80. mkdir -p .%{_sysconfdir}/sysconfig
  81. install -c -m644 $RPM_SOURCE_DIR/arpwatch.sysconfig .%{_sysconfdir}/sysconfig/arpwatch
  82. )
  83. %clean
  84. rm -rf ${RPM_BUILD_ROOT}
  85. %post
  86. /sbin/chkconfig --add arpwatch
  87. %pre
  88. /usr/sbin/groupadd -g %{PCAP_GID} pcap 2> /dev/null || :
  89. /usr/sbin/useradd -u %{PCAP_UID} -g %{PCAP_GID} \
  90. -s /bin/nologin -M -r -d %{_vararpwatch} pcap 2> /dev/null || :
  91. %postun
  92. if [ "$1" -ge "1" ]; then
  93. /sbin/service arpwatch condrestart >/dev/null 2>&1
  94. fi
  95. %preun
  96. if [ $1 = 0 ]; then
  97. /sbin/service arpwatch stop > /dev/null 2>&1
  98. /sbin/chkconfig --del arpwatch
  99. fi
  100. %files
  101. %defattr(-,root,root)
  102. %doc README CHANGES
  103. %{_sbindir}/arpwatch
  104. %{_sbindir}/arpsnmp
  105. %{_mandir}/man8/arpwatch.8*
  106. %{_mandir}/man8/arpsnmp.8*
  107. %config %{_initdir}/arpwatch
  108. %config(noreplace) %{_sysconfdir}/sysconfig/arpwatch
  109. %defattr(-,pcap,pcap)
  110. %dir %{_vararpwatch}
  111. %config %{_vararpwatch}/arp.dat
  112. %config %{_vararpwatch}/ethercodes.dat
  113. #config %{_vararpwatch}/missingcodes.txt
  114. %{_vararpwatch}/*.awk
  115. %{_vararpwatch}/arp2ethers
  116. %{_vararpwatch}/arpfetch
  117. %{_vararpwatch}/massagevendor
  118. %{_vararpwatch}/massagevendor-old
  119. %changelog
  120. * Sun Sep 2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.1a15-0vl1
  121. - s/Serial/Epoch/
  122. - s/Copyright/License/
  123. - updated to 2.1a15
  124. - dropped Patch5 (merged into new upstream)
  125. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.1a11-13vl3
  126. - arpwatch standalone package splitted from tcpdump.
  127. - merge 2.1a11-9vl2 changes
  128. * Thu May 21 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.6.2-9vl2
  129. change arpwatch.init to use /etc/sysconfig/arpwatch
  130. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
  131. - update to new upstream release tcpdump 3.7.1
  132. - drop unneeded patches
  133. - use autoconf213, automake14
  134. - split arpwatch from tcpdump package
  135. * Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
  136. - add patch16 to fix print_bgp security bug
  137. - errata 20030221-3
  138. * Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
  139. - merged with 3.6.2-13
  140. - fix buffer overflow for errata
  141. * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
  142. - added official 3.6.3 fix
  143. - fixed 6.2 compat #63113
  144. * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
  145. - tcpdump-3.6.2-snaplen.patch added to fix #55145
  146. * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
  147. - took old purge patch for filters
  148. - fixed #54225,#58346
  149. - drop root by default #49635
  150. - fixed #54593
  151. - fixed #57711
  152. * Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  153. - 3.6.2-9vl1
  154. - used PRM macros
  155. - changed File Name to Package Name in Prereq tag
  156. - marged 3.6.2-9 (RedHat7.2)
  157. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  158. - 3.4-19vl2
  159. - use better macros
  160. * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
  161. - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
  162. - add Japanese summarys and descriptions
  163. - modify spec file to build as a normal user
  164. * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  165. - Compile shared libpcap with -fPIC (Bug #6342)
  166. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  167. - fix descriptions
  168. - man pages are compressed
  169. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  170. - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
  171. - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
  172. - add getprotobyname lookup (#6725).
  173. - getservbyname port lookup appears functional (#7569).
  174. - remove uid 2090 backdoor (sorry Dave) (#7116).
  175. * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
  176. - fox the pcap.h header
  177. * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
  178. - prevent segfault on obscure spoofed ip header (#4634).
  179. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  180. - add defattr to arpwatch (#4591).
  181. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  182. - initscript munging
  183. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  184. - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
  185. * Tue Aug 3 1999 Jeff Johnson <jbj@redhat.com>
  186. - include A. Kuznetsov's patches to libpcap/tcpdump.
  187. - added arpsnmp to package (#3258).
  188. - arp2ethers written for different of awk (#4326).
  189. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  190. - auto rebuild in the new build environment (release 10)
  191. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  192. - strip binaries.
  193. * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
  194. - autoconf fixes for arm
  195. * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
  196. - libpcap description typo.
  197. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  198. - fix arpwatch summary line.
  199. * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
  200. - enable arpwatch
  201. * Mon Aug 3 1998 Jeff Johnson <jbj@redhat.com>
  202. - separate package for libpcap.
  203. - update tcpdump to 3.4, libpcap to 0.4.
  204. - added arpwatch (but disabled for now)
  205. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  206. - translations modified for de, fr, tr
  207. * Sat May 2 1998 Alan Cox <alan@rehat.com>
  208. - Added the SACK printing fix so you can dump Linux 2.1+.
  209. * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
  210. - updated to release 3.4a5
  211. - uses a buildroot and %attr
  212. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  213. - built against glibc
  214. * Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
  215. - took better fix for #52654 from tcpdump cvs
  216. * Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
  217. - fixed #52654
  218. * Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
  219. - added shared library to libpcap (#47174)
  220. - afs printing security patch (#49294)
  221. * Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
  222. - use initgroups, instead of setgroups
  223. * Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
  224. - added dropgroup patches (#44563)
  225. * Mon May 07 2001 Harald Hoyer <harald@redhat.de>
  226. - switched to Pekka's tcpdump-3.6.2 package
  227. - incremented epoch
  228. * Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
  229. - fix building of tcpslice on glibc 2.2.2 (time.h)
  230. - disable /etc/init.d requirement and fix %post scripts in arpwatch
  231. * Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
  232. - glibc sys/time -> time include patch
  233. * Wed Feb 7 2001 Trond Eivind Glomsr <teg@redhat.com>
  234. - Add space to this check
  235. * Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
  236. - added check for presence of /etc/sysconfig/arpwatch (#23172)
  237. * Wed Feb 7 2001 Pekka Savola <pekkas@netcore.fi>
  238. - update to 3.6.2, 0.6.2 and new CVS of tcpslice.
  239. - i18n'ize arpwatch init script
  240. * Fri Feb 2 2001 Trond Eivind Glomsr <teg@redhat.com>
  241. - i18nize initscript
  242. * Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
  243. - fixed EINTR stopping for e.g. SIGSTOP. (#22008)
  244. - added -u option for tcpdump (#20231)
  245. - new arpwatch version (#23172)
  246. - added "all" and "one" interface for -i (#20907)
  247. - added arpwatch sysconfig (#23172)
  248. * Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
  249. - more (potential) overflows in libpcap. #21373
  250. - documentation fix for #20906
  251. * Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
  252. - use --enable-ipv6
  253. - Add two patches from CVS to enhance 802.2 printing, and more importantly,
  254. to be able to specify 'no stp'
  255. * Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
  256. - Make SMB printing output a lot more quiet unless in verbose mode.
  257. - Make -n resolve port/protocol numbers but not hostnames, -nn for no
  258. resolving at all
  259. - Separate droproot patch from a more generic man/usage fix one
  260. - Add non-promiscuous mode -by default patch, but don't apply it by default
  261. * Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
  262. - Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
  263. * Mon Jan 8 2001 Pekka Savola <pekkas@netcore.fi>
  264. - Update to 20010108 CVS, disable some upstreamed patches.
  265. - Change some additional .1 pages to .8.
  266. - Add droproot patch, some --usage and man page fixes.
  267. * Mon Jan 1 2001 Pekka Savola <pekkas@netcore.fi>
  268. - Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
  269. - add earlier print-domain.c, the latest is segfaulting
  270. - don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
  271. - don't use savestr, require openssl, tweak tweak tweak
  272. - add tcpslice, patch it a bit for egcs detection
  273. * Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
  274. - tcpdump: spice up the manpage about interfaces
  275. - tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
  276. - upgrade arpwatch to 2.1a10
  277. * Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
  278. - more (potential) overflows in libpcap.
  279. * Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
  280. - eliminate still more buffer overflows (from FreeBSD) (#20069).
  281. * Thu Nov 2 2000 Jeff Johnson <jbj@redhat.com>
  282. - eliminate more buffer overflows (from FreeBSD) (#20069).
  283. - 802.1q ether type incorrect (#19850).
  284. - add -u flag to drop arpwatch privs (#19696).
  285. * Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
  286. - updated ethercodes.dat
  287. * Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
  288. - fix arpwatch tmp race (#18943).
  289. * Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
  290. - fix condrestart
  291. * Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
  292. - correct arpsnmp man pages (#15442).
  293. - don't print harmless ENOPROTOOPT message (#13518).
  294. * Fri Aug 4 2000 Jeff Johnson <jbj@redhat.com>
  295. - rebuild with final kernel headers (#13518).
  296. * Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
  297. - add STP patch (#14112).
  298. * Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
  299. - source /etc/init.d/functions
  300. - back out /etc/init.d/arpwatch, place file in /etc/rc.d
  301. - move initscript to /etc/init.d
  302. - changed initscript to use start() and stop() functions
  303. - added condrestart to init script
  304. - added %%post %%preun %%postun scripts to register arpwatch script
  305. - added Prereq: for all things needed in post/preun/postun
  306. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  307. - automatic rebuild
  308. * Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
  309. - updated man page and help (pekkas@netcore.fi) (#10739 et al).
  310. * Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
  311. - FHS packaging.
  312. * Tue May 9 2000 Bill Nottingham <notting@redhat.com>
  313. - minor tweaks for ia64 (prototypes)
  314. * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  315. - Compile shared libpcap with -fPIC (Bug #6342)
  316. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  317. - fix descriptions
  318. - man pages are compressed
  319. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  320. - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
  321. - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
  322. - add getprotobyname lookup (#6725).
  323. - getservbyname port lookup appears functional (#7569).
  324. - remove uid 2090 backdoor (sorry Dave) (#7116).
  325. * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
  326. - fox the pcap.h header
  327. * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
  328. - prevent segfault on obscure spoofed ip header (#4634).
  329. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  330. - add defattr to arpwatch (#4591).
  331. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  332. - initscript munging
  333. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  334. - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
  335. * Tue Aug 3 1999 Jeff Johnson <jbj@redhat.com>
  336. - include A. Kuznetsov's patches to libpcap/tcpdump.
  337. - added arpsnmp to package (#3258).
  338. - arp2ethers written for different of awk (#4326).
  339. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  340. - auto rebuild in the new build environment (release 10)
  341. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  342. - strip binaries.
  343. * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
  344. - autoconf fixes for arm
  345. * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
  346. - libpcap description typo.
  347. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  348. - fix arpwatch summary line.
  349. * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
  350. - enable arpwatch
  351. * Mon Aug 3 1998 Jeff Johnson <jbj@redhat.com>
  352. - separate package for libpcap.
  353. - update tcpdump to 3.4, libpcap to 0.4.
  354. - added arpwatch (but disabled for now)
  355. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  356. - translations modified for de, fr, tr
  357. * Sat May 2 1998 Alan Cox <alan@rehat.com>
  358. - Added the SACK printing fix so you can dump Linux 2.1+.
  359. * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
  360. - updated to release 3.4a5
  361. - uses a buildroot and %attr
  362. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  363. - built against glibc