asymptote-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define texmf %{_datadir}/texmf
  4. %define build_texmf %{buildroot}%{texmf}
  5. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  6. %define emacspkg asy-mode
  7. Name: asymptote
  8. Version: 2.38
  9. Release: 3%{?_dist_release}
  10. Summary: Descriptive vector graphics language
  11. Summary(ja): MetaPost に触発されたスクリプトベースのベクターグラフィック言語
  12. Group: Applications/Publishing
  13. License: GPLv3+
  14. URL: http://asymptote.sourceforge.net/
  15. Source0: http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
  16. Source1: asy.gif
  17. Source2: xasy.desktop
  18. #Source3: asymptote.sty.204
  19. Source11: %{emacspkg}-install.sh
  20. Source12: %{emacspkg}-remove.sh
  21. #Source13: %{name}-init.el
  22. #Patch0: asymptote-2.00-settings.patch
  23. %if %{?_dist_release} == "vl6"
  24. Patch0: asymptote-2.00-settings-vine-vl6.patch
  25. %else
  26. Patch0: asymptote-2.00-settings-vine-vl7.patch
  27. %endif
  28. Patch2: asymptote-1.91-fix-implicit-DSO-linking-libGL.patch
  29. # This doesn't need to go upstream. We put the info file in the topdir, not a subdir, so we need this fix.
  30. Patch3: asymptote-2.08-info-path-fix.patch
  31. # https://bugs.archlinux.org/task/60678
  32. # https://github.com/vectorgraphics/asymptote/commit/38a59370dc5ac720c29e1424614a10f7384b943f
  33. Patch4: asymptote-gc-fix.patch
  34. # https://github.com/vectorgraphics/asymptote/issues/47
  35. Patch5: asymptote-bfnnconv.pl.patch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  37. BuildRequires: ncurses-devel
  38. BuildRequires: readline-devel
  39. BuildRequires: fftw3-devel >= 3.0
  40. BuildRequires: gc-devel >= 6.8
  41. BuildRequires: gsl-devel
  42. BuildRequires: texlive-common
  43. %if %{?_dist_release} == "vl6"
  44. BuildRequires: texlive-collection-texinfo
  45. BuildRequires: texlive-collection-genericrecommended
  46. %else
  47. BuildRequires: texlive-collection-plaingeneric
  48. BuildRequires: texlive-collection-fontsrecommended
  49. BuildRequires: texlive-collection-latexrecommended
  50. %endif
  51. BuildRequires: ghostscript >= 9.14
  52. BuildRequires: texinfo
  53. BuildRequires: ImageMagick
  54. BuildRequires: desktop-file-utils
  55. BuildRequires: freeglut-devel
  56. BuildRequires: zlib-devel
  57. BuildRequires: libtool
  58. BuildRequires: mesa-libEGL-devel
  59. Requires: texlive-common
  60. Requires(post): desktop-file-utils
  61. Requires(postun): desktop-file-utils
  62. # for /usr/bin/texhash and /sbin/install-info
  63. Requires(post): texlive, info
  64. Requires(postun): texlive, info
  65. Vendor: Project Vine
  66. Distribution: Vine Linux
  67. %define texpkgdir %{texmf}/tex/latex/%{name}
  68. %description
  69. Asymptote is a powerful descriptive vector graphics language for technical
  70. drawings, inspired by MetaPost but with an improved C++-like syntax.
  71. Asymptote provides for figures the same high-quality level of typesetting
  72. that LaTeX does for scientific text.
  73. This package is custmized for Japanese.
  74. - added eplatex, platex to latex engines
  75. - use pdvips as dvips command
  76. %description -l ja
  77. Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
  78. テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
  79. Asymptote は科学的なテキストに対して LaTeX がしている組版のと
  80. 同じくらい高品質なレベルの図を提供します.
  81. このパッケージは日本語向けにカスタマイズされています.
  82. - latex エンジンに eplatex, platex を追加
  83. - dvips コマンドとして pdvips を使う
  84. %package gui
  85. Summary: A graphical interface for Asymptote
  86. Summary(ja): Asymptote のためのグラフィカルインターフェース
  87. Group: Applications/Graphics
  88. Requires: %{name} = %{version}-%{release}
  89. Requires: tkinter
  90. Requires: python-imaging
  91. BuildArch: noarch
  92. %description gui
  93. A graphical interface for Asymptote
  94. %package -n %{emacspkg}
  95. Summary: Emacs mode for editing Asymptote source code
  96. Summary(ja): Asymptote ソースコードを編集するための Emacs モード
  97. Group: Applications/Editors/Emacs
  98. Requires: %{name} = %{version}-%{release}
  99. BuildRequires: emacsen
  100. %prereq_ge emacsen-common
  101. BuildArch: noarch
  102. %description -n %{emacspkg}
  103. Emacs mode for editing Asymptote source code
  104. %prep
  105. %setup -q
  106. %patch0 -b .settings
  107. %patch2 -p1 -b .DSO
  108. %patch3 -p1 -b .path-fix
  109. %if %{?_dist_release} >= "vl7"
  110. %patch4 -b .gc-fix
  111. %patch5 -b .manual-fix
  112. %endif
  113. %{__sed} -i 's/\r//' doc/CAD1.asy
  114. # convert to UTF-8
  115. iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
  116. %__mv examples/interpolate1.asy{.utf8,}
  117. autoreconf -i
  118. %build
  119. %configure \
  120. --enable-gc=system \
  121. --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
  122. --with-latex=%{texmf}/tex/latex \
  123. --with-context=%{texmf}/tex/context \
  124. ;
  125. %__make %{?_smp_mflags}
  126. cd doc/
  127. %__make asy-latex.pdf
  128. %__make all
  129. %install
  130. %__rm -rf $RPM_BUILD_ROOT
  131. %__make install DESTDIR=%{buildroot} mandir=%{buildroot}%{_mandir}
  132. %__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
  133. $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
  134. # # Vim syntax file
  135. # for vimver in 63 64 70 71 ; do
  136. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  137. # cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  138. # ln -s ../../../%{name}/asy.vim .
  139. # done
  140. # Move info file
  141. %__mv %{buildroot}%{_infodir}/asymptote/asymptote.info %{buildroot}%{_infodir}/asymptote.info
  142. # copy icon to pixmaps dir
  143. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  144. %__cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  145. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
  146. desktop-file-install --vendor "vine" \
  147. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  148. %{SOURCE2}
  149. # Clean up symlink
  150. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
  151. cd $RPM_BUILD_ROOT%{_bindir}
  152. %__ln_s ../share/%{name}/GUI/xasy.py xasy
  153. ## <asy-mode>
  154. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
  155. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  156. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  157. #
  158. # install el files
  159. #
  160. # install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  161. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}
  162. # ln -s ../../%{name}/asy-{mode,keywords}.el .
  163. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  164. # ln -s ../../../%{name}/asy-init.el .
  165. %__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
  166. $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
  167. #
  168. # install script (bytecompile el and install elc, remove)
  169. #
  170. %_installemacsenscript %{name} %{SOURCE11}
  171. %_removeemacsenscript %{name} %{SOURCE12}
  172. ## </asy-mode>
  173. %clean
  174. %__rm -rf $RPM_BUILD_ROOT
  175. %post
  176. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
  177. /sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
  178. %{exec_texhash}
  179. %post -n %{emacspkg}
  180. if [ "$1" = 2 ]; then
  181. %_emacsenPackageRemove %{name}
  182. fi
  183. %_addemacsenlist %{name}
  184. %_emacsenPackageInstall %{name}
  185. %postun
  186. if [ $1 = 0 ]; then
  187. /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
  188. /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
  189. %{exec_texhash}
  190. fi
  191. %preun -n %{emacspkg}
  192. if [ "$1" = 0 ]; then
  193. %_emacsenPackageRemove %{name}
  194. %_removeemacsenlist %{name}
  195. fi
  196. %files
  197. %defattr(-,root,root,-)
  198. %doc %{_defaultdocdir}/%{name}-%{version}/
  199. %{_bindir}/asy
  200. %{_datadir}/%{name}/
  201. %exclude %{_datadir}/asymptote/GUI/
  202. %{texpkgdir}/
  203. %{texmf}/tex/context/
  204. %{_mandir}/man1/*.1*
  205. %{_infodir}/*.info*
  206. ##%{_datadir}/vim/vim*/syntax/asy.vim
  207. %files gui
  208. %{_bindir}/xasy
  209. %{_datadir}/applications/vine-xasy.desktop
  210. %{_datadir}/pixmaps/asy.gif
  211. %{_datadir}/asymptote/GUI/
  212. %{_mandir}/man*/xasy.*
  213. %files -n %{emacspkg}
  214. %defattr(-,root,root)
  215. %{_datadir}/emacs/site-lisp/%{name}
  216. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  217. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  218. %changelog
  219. * Mon Oct 14 2019 Toshiaki Ara <ara_t@384.jp> 2.38-3
  220. - rebuild under current VineSeed environment
  221. - add BuildRequires: mesa-libEGL-devel
  222. - change BuildRequires: texlive-collection-plainextra to texlive-collection-plaingeneric
  223. - add Patch4 for 'GC_throw_bad_alloc()'
  224. - add Patch5 for building manuals
  225. * Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 2.38-2
  226. - build under gsl-2.4
  227. * Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 2.38-1
  228. - new upstream release
  229. - renew Patch0: asymptote-2.00-settings-vine-vl7.patch
  230. - build under gsl-2.2.1
  231. - add BuildRequires:
  232. texlive-collection-{plainextra,fontsrecommended,latexrecommended}
  233. for VineSeed instead of texlive-collection-texinfo for Vine6
  234. - add Vendor and Distribution
  235. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15-1
  236. - new upstream release
  237. - added asymptote-2.00-settings-vine-vl7.patch (vl7)
  238. - For vl6, renamed asymptote-2.00-settings-vine.patch as
  239. asymptote-2.00-settings-vine-vl6.patch
  240. - TeX Live 2011
  241. * Sat Jun 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 2.10-1
  242. - new upstream release
  243. * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
  244. - TeX Live 2009
  245. * Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
  246. - rebuilt with new toolchain, libsigsegv-2.8
  247. - appled Patch1 again
  248. * Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
  249. - don't apply Patch1 until gcc44 comes to VineSeed
  250. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
  251. - separated Xasy to gui subpackage
  252. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
  253. - initial build based on Fedora Development (fc11) package
  254. - applied asymptote-1.70-settings-vine.patch
  255. * Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
  256. - update to 1.70
  257. * Tue Apr 7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
  258. - update to 1.69
  259. * Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
  260. - update to 1.68
  261. * Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
  262. - update to 1.67
  263. * Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
  264. - update to 1.66
  265. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
  266. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  267. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
  268. - more gcc44 fixes with BIG_ENDIAN platforms
  269. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
  270. - fix gcc44 issue with BIG_ENDIAN platforms
  271. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
  272. - forgot to put in new source
  273. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
  274. - 1.63
  275. * Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
  276. - 1.60
  277. * Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
  278. - 1.59
  279. * Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
  280. - 1.58
  281. * Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
  282. - 1.57
  283. * Tue Dec 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
  284. - 1.56
  285. * Tue Dec 2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
  286. - 1.54
  287. * Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
  288. - 1.52
  289. * Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
  290. - update to 1.51
  291. * Mon Nov 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
  292. - update to 1.49
  293. * Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
  294. - update to 1.47
  295. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
  296. - update to 1.46
  297. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
  298. - add missing BuildRequires
  299. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
  300. - update to 1.44
  301. * Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
  302. - update to 1.43
  303. * Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
  304. - explicitly call "make asymptote.pdf" in doc/
  305. * Fri Apr 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
  306. - fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
  307. * Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
  308. - update to 1.42
  309. * Wed Feb 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
  310. - update to 1.41
  311. - enable desktop file for xasy
  312. * Thu Jan 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
  313. - bump to 1.37
  314. - fix gcc43 failures
  315. - drop triggers
  316. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
  317. - Rebuild for selinux ppc32 issue.
  318. * Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
  319. - Update 1.33.
  320. * Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
  321. - Update to 1.32.
  322. - vim-common triggers: correction and improvements (#246131).
  323. * Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
  324. - Update to 1.31.
  325. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
  326. - Update to 1.30.
  327. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
  328. - Using "evince" as the default PS and PDF viewers (#244151).
  329. (patch file: asymptote-1.29-settings.patch)
  330. - Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
  331. - Use relative symbolic links in the vim-common triggers.
  332. * Sat Jun 2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
  333. - Add asy-faq to install-info (#155750).
  334. - Add support for vim 7.1.
  335. * Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
  336. - Update to 1.29.
  337. * Tue May 8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
  338. - Update to 1.28.
  339. * Sat May 5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
  340. - Update to 1.27.
  341. * Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
  342. - Update to 1.26.
  343. * Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
  344. - Update to 1.25.
  345. * Sun Apr 1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
  346. - Update to 1.24.
  347. * Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
  348. - Update to 1.23.
  349. * Tue Mar 6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
  350. - Update to 1.22.
  351. * Sat Mar 3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
  352. - Update to 1.21.
  353. * Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
  354. - Update to 1.20.
  355. * Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
  356. - Update to 1.19.
  357. * Sun Nov 5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
  358. - Update to 1.18.
  359. * Wed Nov 1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
  360. - Update to 1.17.
  361. * Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
  362. - Update to 1.16.
  363. * Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
  364. - Update to 1.15.
  365. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
  366. - Update to 1.13.
  367. * Thu Aug 3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
  368. - Update to 1.12.
  369. * Thu Jul 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
  370. - Update to 1.11.
  371. * Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
  372. - Update to 1.10.
  373. * Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
  374. - Update to 1.09.
  375. * Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
  376. - Update to 1.08.
  377. - Also installs the info file.
  378. * Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
  379. - Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
  380. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
  381. - Group: Development/Tools -> Applications/Publishing (#193154).
  382. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
  383. - Emacs/Xemacs init file (#193154 comment 6).
  384. * Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
  385. - Directories ownership (#193154).
  386. * Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
  387. - Update to 1.06.
  388. - Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
  389. * Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
  390. - Update to 1.05.
  391. * Sun May 7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
  392. - Update to 1.04.
  393. * Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
  394. - Update to 1.03.
  395. * Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
  396. - First build.
  397. # vim:set ai ts=4 sw=4 sts=4 et: