at-spi-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define atk_version 1.32.0
  3. %define gtk2_version 2.22.0
  4. %define libbonobo_version 2.32.0
  5. %define orbit2_version 2.14.19
  6. %define pango_version 1.28.3
  7. %define gconf2_version 2.32.0
  8. %define dbus_glib_version 0.88
  9. Summary: Assistive Technology Service Provider Interface
  10. Name: at-spi
  11. Version: 1.32.0
  12. Release: 5%{?_dist_release}
  13. URL: http://developer.gnome.org/projects/gap/
  14. Source0: http://download.gnome.org/sources/at-spi/1.32/%{name}-%{version}.tar.bz2
  15. License: LGPLv2+
  16. Group: System Environment/Libraries
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: pango-devel >= %{pango_version}
  19. BuildRequires: gtk2-devel >= %{gtk2_version}
  20. BuildRequires: libbonobo-devel >= %{libbonobo_version}
  21. BuildRequires: ORBit2-devel >= %{orbit2_version}
  22. BuildRequires: atk-devel >= %{atk_version}
  23. BuildRequires: GConf2-devel >= %{gconf2_version}
  24. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  25. BuildRequires: popt-devel
  26. BuildRequires: fontconfig
  27. BuildRequires: gettext
  28. BuildRequires: intltool
  29. BuildRequires: perl(XML::Parser)
  30. BuildRequires: libX11-devel
  31. BuildRequires: libXtst-devel
  32. BuildRequires: libXi-devel
  33. BuildRequires: libXevie-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: desktop-file-utils
  36. Patch2: at-spi-silence-no-event-spew.patch
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. %description
  40. at-spi allows assistive technologies to access GTK-based
  41. applications. Essentially it exposes the internals of applications for
  42. automation, so tools such as screen readers, magnifiers, or even
  43. scripting interfaces can query and interact with GUI controls.
  44. %package devel
  45. Summary: Development libraries and headers for at-spi
  46. Group: Development/Libraries
  47. Requires: %name = %{version}-%{release}
  48. Requires: atk-devel
  49. Requires: gtk2-devel
  50. Requires: libbonobo-devel
  51. Requires: ORBit2-devel
  52. Requires: pkgconfig
  53. %description devel
  54. Libraries and header files allowing compilation of apps that use at-spi.
  55. %package python
  56. Summary: Python bindings for at-spi
  57. Group: Development/Libraries
  58. Requires: %name = %{version}-%{release}
  59. Requires: python
  60. %description python
  61. Python bindings allowing to use at-spi in python programs.
  62. %prep
  63. %setup -q
  64. ## %patch2 -p1 -b .spew
  65. %build
  66. %configure --disable-gtk-doc --disable-static --enable-relocate
  67. make
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. make install DESTDIR=$RPM_BUILD_ROOT
  71. %find_lang at-spi
  72. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  73. %post
  74. /sbin/ldconfig
  75. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  76. gconftool-2 --makefile-install-rule \
  77. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  78. %pre
  79. if [ "$1" -gt 1 ]; then
  80. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  81. gconftool-2 --makefile-uninstall-rule \
  82. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  83. fi
  84. %preun
  85. if [ "$1" -eq 0 ]; then
  86. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  87. gconftool-2 --makefile-uninstall-rule \
  88. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  89. fi
  90. %postun -p /sbin/ldconfig
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %files -f at-spi.lang
  94. %defattr(-,root,root)
  95. %doc AUTHORS COPYING NEWS README
  96. %{_sysconfdir}/gconf/schemas/at-spi.schemas
  97. %{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
  98. %{_libdir}/lib*.so.*
  99. %{_libdir}/bonobo/servers/*
  100. %{_libdir}/orbit-2.0/*
  101. %{_libdir}/gtk-2.0/modules/at-spi-corba
  102. %{_libexecdir}/*
  103. %files devel
  104. %defattr(-,root,root)
  105. %{_datadir}/gtk-doc/html/*
  106. %{_datadir}/idl/*
  107. %{_libdir}/lib*.so
  108. %{_libdir}/pkgconfig/*
  109. %{_includedir}/*
  110. %files python
  111. %defattr(-,root,root)
  112. %{python_sitearch}/pyatspi_corba
  113. %changelog
  114. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-5
  115. - remove *.la files
  116. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-4
  117. - rebuild with VineSeed environment
  118. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-3
  119. - rebuild with python-2.7.2
  120. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-2
  121. - add configure option (--enable-relocate)
  122. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
  123. - new upstream release
  124. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-2
  125. - rebuild with rpm-4.8.1 for pkg-config file
  126. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
  127. - new upstream release
  128. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  129. - new upstream release
  130. - drop Patch2
  131. - add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
  132. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
  133. - rebuild with python-2.6
  134. * Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
  135. - remove BuildRequires gail-devel
  136. (gtk2-2.14.x now includes/provides gail)
  137. * Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  138. - initial build for Vine Linux
  139. * Mon Sep 8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
  140. - Update to 1.23.92
  141. - Drop upstreamed patch
  142. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
  143. - Fix an evo crash caused by the greeter crash fix
  144. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
  145. - Fix a greeter crash
  146. * Tue Sep 2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
  147. - Update to 1.23.91
  148. * Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
  149. - Silence incessant atk-bridge spew filling xsession-errors (#459275)
  150. * Mon Aug 4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
  151. - Update to 1.23.6
  152. * Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
  153. - Update to 1.23.5
  154. * Tue Jun 3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
  155. - Update to 1.23.3
  156. * Mon May 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
  157. - Bump rev
  158. * Mon Apr 7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
  159. - Update to 1.22.1
  160. * Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
  161. - Update to 1.22.0
  162. * Wed Mar 5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
  163. - Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
  164. * Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
  165. - Update to 1.21.92
  166. * Fri Feb 8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
  167. - Rebuild for gcc 4.3
  168. * Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
  169. - Update to 1.21.5
  170. * Thu Dec 6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
  171. - Update to 1.21.3
  172. * Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
  173. - Update to 1.21.1
  174. * Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
  175. - Update to 1.20.1
  176. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
  177. - Update to 1.20.0
  178. * Mon Aug 6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
  179. - Update license field
  180. * Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
  181. - Update to 1.19.5
  182. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
  183. - Update to 1.19.3
  184. - Add a -python subpackage
  185. * Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
  186. - Update to 1.19.1
  187. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
  188. - Don't ship .la files
  189. * Mon Apr 9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
  190. - Update to 1.18.1, which includes the previous patch
  191. - Drop obsolete patch
  192. - Fix a small memory leak
  193. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
  194. - Backport a patch to fix deadlocks in applications
  195. * Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
  196. - Update to 1.18.0
  197. - Drop obsolete patch
  198. * Thu Mar 8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
  199. - add a patch that might fix some deadlock issues (bug 329454)
  200. * Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
  201. - Update to 1.17.2
  202. * Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
  203. - Update to 1.17.1
  204. * Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
  205. - Bump atk requirement
  206. * Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
  207. - Update to 1.17.0
  208. * Mon Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
  209. - Update to 1.7.16
  210. * Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
  211. - Update to 1.7.15
  212. * Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
  213. - Update to 1.7.14
  214. * Sat Dec 9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
  215. - Small spec file cleanups
  216. * Tue Nov 7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
  217. - Update to 1.7.13
  218. * Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
  219. - Update to 1.7.12
  220. * Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
  221. - Remove debug spew
  222. * Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
  223. - Update to 1.7.11
  224. - Drop upstreamed patch
  225. - Require pkgconfig in the -devel package
  226. * Wed Aug 2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
  227. - Update to 1.7.10
  228. * Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
  229. - Fix segfault if a11y enabled on x86-64 (#196063)
  230. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
  231. - Rebuild
  232. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
  233. - Update to 1.7.9
  234. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
  235. - Update to 1.7.8
  236. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
  237. - rebuild
  238. * Thu Jun 8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
  239. - Add a BuildRequires
  240. * Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
  241. - Make it build in mock
  242. * Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
  243. - Revert the previous change
  244. * Tue Apr 4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
  245. - Fix a missing declaration
  246. - Fix segfaults on x86_64
  247. * Tue Apr 4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
  248. - Update to 1.7.7
  249. * Thu Mar 9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
  250. - Fix a crash on x86_64
  251. * Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
  252. - Update to 1.7.6
  253. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
  254. - Update to 1.7.5
  255. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
  256. - bump again for double-long bug on ppc(64)
  257. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
  258. - rebuilt for new gcc4.1 snapshot and glibc changes
  259. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
  260. - Update to 1.7.4
  261. * Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
  262. - Update to 1.7.3
  263. * Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
  264. - Update to 1.7.2
  265. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  266. - rebuilt
  267. * Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
  268. - Switch requires to modular X
  269. * Wed Sep 7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
  270. - Update to 1.6.6
  271. * Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
  272. - Rebuilt
  273. * Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
  274. - Update to 1.6.4
  275. * Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
  276. - Update to 1.6.3
  277. * Wed Mar 2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
  278. - Rebuilt with gcc4
  279. * Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
  280. - Update to 1.6.2
  281. * Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
  282. - Remove dependency on linc-devel
  283. * Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
  284. - Fix some random spec file issues (fixes #133430?)
  285. * Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
  286. - bump version
  287. * Wed Aug 4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
  288. - Update to 1.5.3
  289. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  290. - rebuilt
  291. * Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
  292. - Update to 1.4.0
  293. * Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
  294. - Update to 1.3.15
  295. * Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
  296. - Update to 1.3.14
  297. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  298. - rebuilt
  299. * Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
  300. - update to 1.3.13
  301. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  302. - rebuilt
  303. * Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
  304. - new version
  305. * Thu Oct 2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
  306. - new version
  307. * Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
  308. - Fix rebuild failure (stderr.patch)
  309. * Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
  310. - disable gtk doc
  311. * Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
  312. - automated rebuild
  313. * Mon Jul 7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
  314. - 1.1.9
  315. - remove multilib patch fixed upstream
  316. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  317. - rebuilt
  318. * Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
  319. - kill Xft buildreq
  320. * Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
  321. - rebuild to fix self-dependency
  322. * Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
  323. - extend multilib patch to cover -lXi
  324. * Tue Feb 4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
  325. - 1.1.8
  326. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  327. - rebuilt
  328. * Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
  329. - Add patch to help multilib systems find libXtst
  330. * Fri Dec 6 2002 Havoc Pennington <hp@redhat.com>
  331. - rebuild
  332. * Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
  333. - rebuild with new libbonobo and gail
  334. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  335. - automated rebuild
  336. * Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
  337. - add libatk-bridge.so to the file list
  338. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  339. - 1.0.1
  340. - add at-spi-registryd to file list
  341. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  342. - rebuild in different environment
  343. * Tue Jun 4 2002 Havoc Pennington <hp@redhat.com>
  344. - 1.0.0
  345. - add post/postun ldconfig
  346. * Wed May 29 2002 Bill Nottingham <notting@redhat.com>
  347. - rebuild again?
  348. * Tue May 28 2002 Havoc Pennington <hp@redhat.com>
  349. - rebuild in different environment
  350. * Tue May 28 2002 Havoc Pennington <hp@redhat.com>
  351. - 0.12.1
  352. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  353. - Version 0.0.6
  354. * Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
  355. - rebuild in rawhide, seems to have been linked incorrectly
  356. * Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
  357. - rebuild in rawhide, upgrade to 0.0.5
  358. - add gail deps
  359. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  360. - Initial build.