at-spi2-core-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320
  1. %bcond_with systemd
  2. %bcond_with firstbuild
  3. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  4. %define _unpackaged_files_terminate_build 1
  5. Name: at-spi2-core
  6. Summary: Protocol definitions and daemon for D-Bus at-spi
  7. Version: 2.40.1
  8. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  9. Group: desktop-gnome,accessibility
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: LGPLv2+
  13. URL: https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/
  14. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  15. Source0: https://download.gnome.org/sources/at-spi2-core/%{shortver}/%{name}-%{version}.tar.xz
  16. BuildRequires: meson
  17. BuildRequires: dbus-devel
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: glib2-devel
  20. %{!?with_firstbuild:BuildRequires: gobject-introspection-devel}
  21. BuildRequires: libXtst-devel
  22. BuildRequires: libXevie-devel
  23. BuildRequires: libXext-devel
  24. BuildRequires: libXi-devel
  25. BuildRequires: libSM-devel
  26. BuildRequires: autoconf automake libtool
  27. BuildRequires: intltool
  28. BuildRequires: gtk-doc
  29. %{!?with_firstbuild:BuildRequires: at-spi2-core-devel}
  30. Requires: dbus
  31. %description
  32. at-spi allows assistive technologies to access GTK-based
  33. applications. Essentially it exposes the internals of applications for
  34. automation, so tools such as screen readers, magnifiers, or even
  35. scripting interfaces can query and interact with GUI controls.
  36. This version of at-spi is a major break from previous versions.
  37. It has been completely rewritten to use D-Bus rather than
  38. ORBIT / CORBA for its transport protocol.
  39. %package devel
  40. Summary: Development files and headers for at-spi2-core
  41. Group: programming
  42. Requires: %{name} = %{version}-%{release}
  43. %description devel
  44. The at-spi2-core-devel package includes the header files and
  45. API documentation for libatspi.
  46. # compat32
  47. %package -n compat32-%{name}
  48. Summary: Protocol definitions and daemon for D-Bus at-spi
  49. Group: desktop-gnome,accessibility,legacy
  50. Requires: %{name} = %{version}-%{release}
  51. %description -n compat32-%{name}
  52. at-spi allows assistive technologies to access GTK-based
  53. applications. Essentially it exposes the internals of applications for
  54. automation, so tools such as screen readers, magnifiers, or even
  55. scripting interfaces can query and interact with GUI controls.
  56. This version of at-spi is a major break from previous versions.
  57. It has been completely rewritten to use D-Bus rather than
  58. ORBIT / CORBA for its transport protocol.
  59. %package -n compat32-%{name}-devel
  60. Summary: Development files and headers for at-spi2-core
  61. Group: programming,legacy
  62. Requires: compat32-%{name} = %{version}-%{release}
  63. Requires: %{name}-devel = %{version}-%{release}
  64. %description -n compat32-%{name}-devel
  65. The at-spi2-core-devel package includes the header files and
  66. API documentation for libatspi.
  67. %debug_package
  68. %prep
  69. %setup -q
  70. %meson -Denable_docs=false
  71. %meson_build
  72. %install
  73. %meson_install
  74. %{find_lang} %{name}
  75. %if ! %{with systemd}
  76. rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
  77. %endif
  78. %files -f %{name}.lang
  79. %license COPYING
  80. %doc AUTHORS README
  81. %{_libexecdir}/at-spi2-registryd
  82. %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
  83. %{_libdir}/libatspi.so.*
  84. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Atspi-2.0.typelib}
  85. %{_libexecdir}/at-spi-bus-launcher
  86. %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
  87. %{_datadir}/dbus-1/services/org.a11y.Bus.service
  88. %{_datadir}/defaults/at-spi2/accessibility.conf
  89. %if %{with systemd}
  90. %{_userunitdir}/*
  91. %endif
  92. %files devel
  93. %{_libdir}/libatspi.so
  94. %{!?with_firstbuild:%{_datadir}/gir-1.0/Atspi-2.0.gir}
  95. %{_includedir}/at-spi-2.0
  96. %{_libdir}/pkgconfig/atspi-2.pc
  97. # compat32
  98. %if %{build_compat32}
  99. %files -n compat32-%{name}
  100. %defattr(-,root,root,-)
  101. %{_libdir}/libatspi.so.*
  102. %files -n compat32-%{name}-devel
  103. %defattr(-,root,root,-)
  104. %{_libdir}/libatspi.so
  105. %endif
  106. %changelog
  107. * Tue May 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-1
  108. - new upstream release.
  109. * Fri Apr 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.0-1
  110. - new upstream release.
  111. - added systemd support (disabled as default).
  112. - dropped ldconfig scriptlets.
  113. * Sat Aug 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.36.0-1
  114. - new upstream release.
  115. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.27.1-1
  116. - new upstream release.
  117. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.20.2-1
  118. - new upstream release
  119. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.3-1
  120. - new upstream release
  121. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.1-1
  122. - new upstream release
  123. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-1
  124. - new upstream release
  125. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.1-1
  126. - new upstream release
  127. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.0-1
  128. - new upstream release
  129. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.0-1
  130. - new upstream release
  131. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.2-1
  132. - new upstream release
  133. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.1-1
  134. - new upstream release
  135. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  136. - new upstream release
  137. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  138. - new upstream release
  139. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  140. - new upstream release
  141. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
  142. - new upstream release
  143. * Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-2
  144. - create compat32 sub packages
  145. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
  146. - new upstream release
  147. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-1
  148. - new upstream release
  149. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.1-1
  150. - new upstream release
  151. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.2-1
  152. - new upstream release
  153. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-1
  154. - new upstream release
  155. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
  156. - new upstream release
  157. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.92-1
  158. - initial build for Vine Linux
  159. * Tue Sep 6 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.91-1
  160. - Update to 2.1.91
  161. * Mon Jul 25 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.4-1
  162. - Update to 2.1.4
  163. * Thu Jun 16 2011 Tomas Bzatek <tbzatek@redhat.com> - 2.1.2-1
  164. - Update to 2.1.2
  165. * Wed May 11 2011 Tomas Bzatek <tbzatek@redhat.com> - 2.1.1-1
  166. - Update to 2.1.1
  167. * Tue Apr 26 2011 Matthias Clasen <mclasen@redhat.com> - 2.0.1-1
  168. - Update to 2.0.1
  169. * Mon Apr 4 2011 Matthias Clasen <mclasen@redhat.com> - 2.0.0-1
  170. - Update to 2.0.0
  171. * Fri Apr 1 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.93-2
  172. - Fix 30 second wait during login (#691995)
  173. * Fri Mar 25 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.93-1
  174. - Update to 1.91.93
  175. * Mon Mar 21 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.92-1
  176. - Update to 2.91.92
  177. * Wed Mar 9 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.91-2
  178. - Fix a crash on logout
  179. * Mon Mar 7 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.91-1
  180. - Update to 1.91.91
  181. * Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.90-1
  182. - Update to 1.91.90
  183. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.91.6.1-2
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  185. * Wed Feb 2 2011 Christopher Aillon <caillon@redhat.com> - 1.91.6.1-1
  186. - Update to 1.91.6.1
  187. * Tue Feb 1 2011 Christopher Aillon <caillon@redhat.com> - 1.91.6-1
  188. - Update to 1.91.6
  189. * Fri Jan 21 2011 Christopher Aillon <caillon@redhat.com> - 1.91.5-2
  190. - Add gobject-introspection support
  191. * Mon Jan 10 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.5-1
  192. - Update to 1.91.5
  193. * Thu Nov 11 2010 Matthias Clasen <mclasen@redhat.com> - 1.91.2-1
  194. - Update 1.91.2
  195. * Mon Oct 4 2010 Matthias Clasen <mclasen@redhat.com> - 1.91.0-1
  196. - Update to 1.91.0
  197. * Wed Sep 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
  198. - Update to 0.4.0
  199. * Tue Aug 31 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
  200. - Update to 0.3.91
  201. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
  202. - Update to 0.3.90
  203. * Tue Jun 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  204. - Update to 0.3.4
  205. * Tue Jun 8 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
  206. - Update to 0.3.3
  207. * Tue Jun 1 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
  208. - Don't relocate the dbus a11y stack
  209. * Fri May 28 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  210. - Update to 0.3.2
  211. * Sat May 15 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.1-1
  212. - Update to 0.3.1
  213. * Tue Mar 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.8-1
  214. - Update to 0.1.8
  215. * Sat Feb 20 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.7-1
  216. - Update to 0.1.7
  217. * Wed Feb 10 2010 Tomas Bzatek <tbzatek@redhat.com> - 0.1.6-1
  218. - Update to 0.1.6
  219. * Wed Jan 20 2010 Matthias Clasen <mlasen@redhat.com> - 0.1.5-2
  220. - Specify the right location for the dbus daemon
  221. * Sat Jan 16 2010 Matthias Clasen <mlasen@redhat.com> - 0.1.5-1
  222. - Update to 0.1.5
  223. * Tue Dec 22 2009 Matthias Clasen <mlasen@redhat.com> - 0.1.4-1
  224. - Update to 0.1.4
  225. * Fri Dec 4 2009 Matthias Clasen <mlasen@redhat.com> - 0.1.3-1
  226. - Initial packaging