attr-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Utilities for managing filesystem extended attributes
  3. Name: attr
  4. Version: 2.4.48
  5. Release: 2%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: http://oss.sgi.com/projects/xfs/
  11. Source: http://download.savannah.nongnu.org/releases/attr/attr-%{version}.tar.gz
  12. # fix test-suite failure with perl-5.26.0 (#1473853)
  13. Patch1: 0001-attr-2.4.48-test-suite-perl.patch
  14. # fix conflict with fakechroot (https://github.com/dex4er/fakechroot/issues/57)
  15. Patch2: 0002-attr-2.4.48-switch-back-to-syscall.patch
  16. # xattr.conf: remove entries for NFSv4 ACLs namespaces (#1031423)
  17. # https://lists.nongnu.org/archive/html/acl-devel/2019-03/msg00000.html
  18. # https://lists.nongnu.org/archive/html/acl-devel/2019-03/msg00001.html
  19. # https://lists.nongnu.org/archive/html/acl-devel/2019-05/msg00000.html
  20. Patch3: 0003-attr-2.4.48-xattr-conf-nfs4-acls.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: gettext
  23. BuildRequires: libtool
  24. Requires: libattr = %{version}-%{release}
  25. Conflicts: xfsdump < 2.0.0
  26. %description
  27. A set of tools for manipulating extended attributes on filesystem
  28. objects, in particular getfattr(1) and setfattr(1).
  29. An attr(1) command is also provided which is largely compatible
  30. with the SGI IRIX tool of the same name.
  31. %package -n libattr
  32. Summary: Dynamic library for extended attribute support
  33. Group: system
  34. License: LGPLv2+
  35. %description -n libattr
  36. This package contains the libattr.so dynamic library which contains
  37. the extended attribute system calls and library functions.
  38. %package -n libattr-devel
  39. Summary: Extended attribute static libraries and headers
  40. Group: programming
  41. License: LGPLv2+
  42. Requires: libattr = %{version}-%{release}
  43. %description -n libattr-devel
  44. This package contains the libraries and header files needed to
  45. develop programs which make use of extended attributes.
  46. For Linux programs, the documented system call API is the
  47. recommended interface, but an SGI IRIX compatibility interface
  48. is also provided.
  49. Currently only ext2, ext3 and XFS support extended attributes.
  50. The SGI IRIX compatibility API built above the Linux system calls is
  51. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  52. You should install libattr-devel if you want to develop programs
  53. which make use of extended attributes. If you install libattr-devel,
  54. you'll also want to install attr.
  55. # compat32
  56. %package -n compat32-libattr
  57. Summary: Dynamic library for extended attribute support
  58. Group: system,legacy
  59. License: LGPLv2+
  60. %description -n compat32-libattr
  61. This package contains the libattr.so dynamic library which contains
  62. the extended attribute system calls and library functions.
  63. %package -n compat32-libattr-devel
  64. Summary: Extended attribute static libraries and headers
  65. Group: programming,legacy
  66. License: LGPLv2+
  67. Requires: libattr-devel = %{version}-%{release}
  68. Requires: compat32-libattr = %{version}-%{release}
  69. %description -n compat32-libattr-devel
  70. This package contains the libraries and header files needed to
  71. develop programs which make use of extended attributes.
  72. For Linux programs, the documented system call API is the
  73. recommended interface, but an SGI IRIX compatibility interface
  74. is also provided.
  75. Currently only ext2, ext3 and XFS support extended attributes.
  76. The SGI IRIX compatibility API built above the Linux system calls is
  77. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  78. You should install libattr-devel if you want to develop programs
  79. which make use of extended attributes. If you install libattr-devel,
  80. you'll also want to install attr.
  81. %debug_package
  82. %prep
  83. %setup -q
  84. %autopatch -p1
  85. %build
  86. # attr abuses libexecdir
  87. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  88. %make_build
  89. %install
  90. rm -rf %{buildroot}
  91. %make_install
  92. # get rid of libattr.a and libattr.la
  93. rm -f $RPM_BUILD_ROOT/%{_lib}/libattr.{l,}a
  94. rm -f $RPM_BUILD_ROOT%{_libdir}/libattr.{l,}a
  95. # fix links to shared libs and permissions
  96. rm -f %{buildroot}%{_libdir}/libattr.so
  97. mkdir -p %{buildroot}%{_libdir}
  98. ln -sf ../../%{_lib}/libattr.so %{buildroot}%{_libdir}/libattr.so
  99. chmod 0755 %{buildroot}/%{_lib}/libattr.so.*.*.*
  100. # remove documents without version
  101. rm -rf %{buildroot}%{_datadir}/doc/attr
  102. mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
  103. %find_lang %{name}
  104. %check
  105. if ./setfattr -n user.name -v value .; then
  106. make tests || exit $?
  107. else
  108. echo '*** xattrs are probably not supported by the file system,' \
  109. 'the test-suite will NOT run ***'
  110. fi
  111. %clean
  112. rm -rf %{buildroot}
  113. %files -f %{name}.lang
  114. %defattr(-,root,root)
  115. %doc doc/CHANGES
  116. %license doc/COPYING*
  117. %{_bindir}/attr
  118. %{_bindir}/getfattr
  119. %{_bindir}/setfattr
  120. %{_mandir}/man1/attr.1*
  121. %{_mandir}/man1/getfattr.1*
  122. %{_mandir}/man1/setfattr.1*
  123. %files -n libattr-devel
  124. %defattr(-,root,root)
  125. /%{_lib}/libattr.so
  126. %{_includedir}/attr
  127. %{_libdir}/libattr.*
  128. %{_libdir}/pkgconfig/*.pc
  129. %{_mandir}/man3/attr_*.3.*
  130. %files -n libattr
  131. /%{_lib}/libattr.so.*
  132. %config(noreplace) %{_sysconfdir}/xattr.conf
  133. # compat32
  134. %if %{build_compat32}
  135. %files -n compat32-libattr-devel
  136. %defattr(-,root,root)
  137. /%{_lib}/libattr.so
  138. %{_libdir}/libattr.*
  139. %{_libdir}/pkgconfig/*.pc
  140. %files -n compat32-libattr
  141. /%{_lib}/libattr.so.*
  142. %config(noreplace) %{_sysconfdir}/xattr.conf
  143. %endif
  144. %changelog
  145. * Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.48-2
  146. - dropped scriptlets.
  147. - imported Patch1-3 from rawhide.
  148. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.48-1
  149. - new upstream release.
  150. - dropped Patch1, 2.
  151. * Fri Sep 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-2
  152. - removed a manpage (attr.5).
  153. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-1
  154. - new upstream release.
  155. - replaced patches to the newest rawhide's.
  156. * Sat Apr 9 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.44-1
  157. - new upstream release
  158. - remove static library from devel package
  159. - added Patch2-9
  160. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.44-8
  161. - fix typos in attr(1) man page (#669095)
  162. * Wed Dec 22 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-6
  163. - setfattr.1: document supported encodings of values (#587516)
  164. - getfattr: encode NULs properly with --encoding=text (#650539)
  165. - getfattr: return non-zero exit code on failure (#660619)
  166. - walk_tree: do not follow symlink to directory with -h (#660613)
  167. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-5
  168. - let attr depend on the same version of libattr (#595689)
  169. - silence compile-time warnings
  170. * Wed Feb 18 2009 Zdenek Prikryl <zprikryl@redhat.com> 2.4.43-2
  171. - Fixed memory leaks (#485473)
  172. * Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
  173. - added compat32 package for x86_64 arch support
  174. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
  175. - new upstream release
  176. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
  177. - initial build for Vine Linux
  178. * Wed Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
  179. - New version 2.4.41
  180. - Removed useless attr-2.0.8-docperms.patch
  181. * Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
  182. - New version 2.4.39
  183. - Resolves #284121
  184. * Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
  185. - Removed explicit Requires(post + postun)
  186. - Resolves #225290
  187. * Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
  188. - New version 2.4.38
  189. - Resolves #245415
  190. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
  191. - add disttag
  192. - remove trailing dot from summary
  193. - fix buildroot
  194. - -devel package requires same libattr version
  195. - change prereq to Requires(post)
  196. - escape macro in changelog
  197. - replace absolute link with relative link (libattr.so)
  198. - use %%doc macro
  199. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
  200. - rebuild
  201. * Wed Jul 5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
  202. - new version 2.4.32
  203. - fixes segmentation fault in attr, which affects #189106
  204. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
  205. - rebuild for -devel deps
  206. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
  207. - bump again for double-long bug on ppc(64)
  208. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
  209. - rebuilt for new gcc4.1 snapshot and glibc changes
  210. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
  211. - new version 2.4.28
  212. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  213. - rebuilt
  214. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
  215. - spec file cleanup
  216. - mark po files as lang specific
  217. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  218. - 2.4.24
  219. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
  220. - update to 2.4.23
  221. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
  222. - get rid of *.la files
  223. - remove duplicate doc files
  224. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
  225. - Rebuild
  226. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
  227. - Build requires libtool >= 1.5
  228. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
  229. - Make libattr.so.* executable.
  230. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
  231. - Update to latest upstream version.
  232. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
  233. - Fix bug #125304 (Steve Grubb: build requires gettext)
  234. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  235. - rebuilt
  236. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
  237. - Add missing %%defattr
  238. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
  239. - Add /usr/include/attr to files manifest
  240. - Fix location of doc files, add main doc dir to files manifest
  241. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  242. - rebuilt
  243. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  244. - rebuilt
  245. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
  246. - Fix libtool
  247. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
  248. - update to attr-2.4.1
  249. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
  250. - update/rebuild
  251. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
  252. - set execute bits on library so that requires are generated.
  253. * Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
  254. - Redo multilib patch to work everywhere
  255. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
  256. - Added fix to install libs in correct directory on 64bit machine
  257. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
  258. - Made the package only own the one directory that is unique to it:
  259. /usr/include/attr
  260. * Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
  261. - get perl out of base with attr-2.0.8-docperms.patch
  262. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
  263. - Initial Red Hat package
  264. Made as few changes as possible relative to upstream packaging to
  265. make it easier to maintain long-term. This means that some of
  266. the techniques used here are definitely not standard Red Hat
  267. techniques. If you are looking for an example package to fit
  268. into Red Hat Linux transparently, this would not be the one to
  269. pick.
  270. - attr-devel -> libattr-devel