audit-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define _unpackaged_files_terminate_build 1
  4. Summary: User space tools for 2.6 kernel auditing
  5. Name: audit
  6. Version: 3.0.1
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. License: GPLv2+
  9. Group: system,admin-tools
  10. Distribution: Vine Linux
  11. Vendor: Project Vine
  12. URL: http://people.redhat.com/sgrubb/audit/
  13. Source0: https://github.com/linux-audit/audit-userspace/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. Patch1: audit-3.0.2-sockaddr.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: gettext intltool libtool swig
  17. BuildRequires: python-devel python-rpm-macros
  18. BuildRequires: python3-devel python3-rpm-macros
  19. BuildRequires: openldap-devel
  20. BuildRequires: krb5-devel
  21. BuildRequires: kernel-headers >= 2.6.18
  22. BuildRequires: libcap-ng-devel
  23. BuildRequires: automake >= 1.9
  24. BuildRequires: autoconf >= 2.59
  25. %if %{with systemd}
  26. %{?systemd_requires}
  27. %else
  28. Requires(post): /sbin/chkconfig
  29. Requires(preun): /sbin/chkconfig
  30. Requires(preun): /sbin/service
  31. Requires(postun): /sbin/service
  32. %endif
  33. Requires: %{name}-libs = %{version}-%{release}
  34. Requires(pre): coreutils
  35. %description
  36. The audit package contains the user space utilities for
  37. storing and searching the audit records generate by
  38. the audit subsystem in the Linux 2.6 kernel.
  39. %package libs
  40. Summary: Dynamic library for libaudit
  41. License: LGPLv2+
  42. Group: system
  43. %description libs
  44. The audit-libs package contains the dynamic libraries needed for
  45. applications to use the audit framework.
  46. %package libs-devel
  47. Summary: Header files and static library for libaudit
  48. License: LGPLv2+
  49. Group: programming
  50. Requires: %{name}-libs = %{version}-%{release}
  51. Requires: kernel-headers >= 2.6.18
  52. %description libs-devel
  53. The audit-libs-devel package contains the static libraries and header
  54. files needed for developing applications that need to use the audit
  55. framework libraries.
  56. %package libs-python
  57. Summary: Python2 bindings for libaudit
  58. License: LGPLv2+
  59. Group: programming
  60. Requires: %{name}-libs = %{version}-%{release}
  61. %description libs-python
  62. The audit-libs-python package contains the bindings so that libaudit
  63. and libauparse can be used by python2.
  64. %package libs-python3
  65. Summary: Python3 bindings for libaudit
  66. License: LGPLv2+
  67. Group: programming
  68. Provides: python-audit = %{version}-%{release}
  69. Requires: %{name}-libs = %{version}-%{release}
  70. %description libs-python3
  71. The audit-libs-python3 package contains the bindings so that libaudit
  72. and libauparse can be used by python3.
  73. %package -n audispd-plugins
  74. Summary: Plugins for the audit event dispatcher
  75. Group: system
  76. License: GPLv2+
  77. Provides: python3-audit = %{version}-%{release}
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: %{name}-libs = %{version}-%{release}
  80. %description -n audispd-plugins
  81. The audispd-plugins package provides plugins for the real-time
  82. interface to the audit system, audispd. These plugins can do things
  83. like relay events to remote machines or analyze events for suspicious
  84. behavior.
  85. %package -n audispd-plugins-zos
  86. Summary: z/OS plugin for the audit event dispatcher
  87. Group: system
  88. License: GPLv2+
  89. Requires: %{name}%{?_isa} = %{version}-%{release}
  90. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  91. Requires: openldap
  92. %description -n audispd-plugins-zos
  93. The audispd-plugins-zos package provides a plugin that will forward all
  94. incoming audit events, as they happen, to a configured z/OS SMF (Service
  95. Management Facility) database, through an IBM Tivoli Directory Server
  96. (ITDS) set for Remote Audit service.
  97. %package -n compat32-%{name}-libs
  98. Summary: Dynamic library for libaudit
  99. License: LGPLv2+
  100. Group: system
  101. %description -n compat32-%{name}-libs
  102. The audit-libs package contains the dynamic libraries needed for
  103. applications to use the audit framework.
  104. %debug_package
  105. %prep
  106. %setup -q -n audit-userspace-%{version}
  107. %patch1 -p1
  108. autoreconf -vif
  109. # Remove the ids code, its not ready
  110. sed -i 's/ ids / /' audisp/plugins/Makefile.in
  111. %build
  112. %configure --sbindir=/sbin --libdir=/%{_lib} \
  113. --with-python=yes --with-python3=yes \
  114. --with-libcap-ng=yes --enable-gssapi-krb5=yes \
  115. --enable-zos-remote \
  116. --enable-experimental \
  117. %if %{with systemd}
  118. --enable-systemd
  119. %else
  120. %{nil}
  121. %endif
  122. make CFLAGS="%{optflags}" %{?_smp_mflags}
  123. %install
  124. rm -rf $RPM_BUILD_ROOT
  125. mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audit/plugins.d,rc.d/init.d,audit/rules.d}}
  126. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
  127. mkdir -p $RPM_BUILD_ROOT/%{_lib}
  128. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
  129. mkdir -p --mode=0700 $RPM_BUILD_ROOT/%{_var}/log/audit
  130. mkdir -p $RPM_BUILD_ROOT/%{_var}/spool/audit
  131. make DESTDIR=$RPM_BUILD_ROOT install
  132. mkdir -p $RPM_BUILD_ROOT/%{_libdir}
  133. # This winds up in the wrong place when libtool is involved
  134. mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
  135. mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
  136. curdir=`pwd`
  137. cd $RPM_BUILD_ROOT/%{_libdir}
  138. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
  139. ln -s ../../%{_lib}/$LIBNAME libaudit.so
  140. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
  141. ln -s ../../%{_lib}/$LIBNAME libauparse.so
  142. cd $curdir
  143. # Remove these items so they don't get picked up.
  144. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
  145. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
  146. find $RPM_BUILD_ROOT -name '*.la' -delete
  147. find $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages -name '*.a' -delete
  148. # Move the pkgconfig file
  149. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
  150. # On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
  151. touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
  152. touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
  153. %if %{with systemd}
  154. rm -rf %{buildroot}%{_libexecdir}/initscripts
  155. mkdir -p %{buildroot}%{_unitdir}
  156. mv %{buildroot}/usr/lib/systemd/system/auditd.service %{buildroot}%{_unitdir}/
  157. %endif
  158. %clean
  159. rm -rf $RPM_BUILD_ROOT
  160. rm -rf zos-remote-policy
  161. %post
  162. # This is to migrate users from audit-1.0.x installations
  163. if [ -f /etc/auditd.conf ]; then
  164. mv /etc/auditd.conf /etc/audit/auditd.conf
  165. fi
  166. if [ -f /etc/audit.rules ]; then
  167. mv /etc/audit.rules /etc/audit/audit.rules
  168. fi
  169. # This is to enable the dispatcher option which was commented out
  170. if [ -f /etc/audit/auditd.conf ]; then
  171. grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
  172. if [ $? -eq 1 ] ; then
  173. tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
  174. if [ -n $tmp ]; then
  175. sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
  176. cat $tmp > /etc/audit/auditd.conf
  177. rm -f $tmp
  178. fi
  179. fi
  180. fi
  181. # Copy default rules into place on new installation
  182. files=`ls /etc/audit/rules.d/ 2>/dev/null | wc -w`
  183. if [ "$files" -eq 0 ] ; then
  184. # FESCO asked for audit to be off by default. #1117953
  185. if [ -e %{_datadir}/%{name}/sample-rules/10-no-audit.rules ] ; then
  186. cp %{_datadir}/%{name}/sample-rules/10-no-audit.rules /etc/audit/rules.d/audit.rules
  187. else
  188. touch /etc/audit/rules.d/audit.rules
  189. fi
  190. chmod 0600 /etc/audit/rules.d/audit.rules
  191. fi
  192. %if %{with systemd}
  193. %systemd_post auditd.service
  194. %else
  195. /sbin/chkconfig --add auditd
  196. %endif
  197. %preun
  198. %if %{with systemd}
  199. %systemd_preun auditd.service
  200. %else
  201. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  202. /sbin/service auditd stop > /dev/null 2>&1
  203. /sbin/chkconfig --del auditd
  204. fi
  205. %endif
  206. %postun
  207. %if %{with systemd}
  208. %systemd_postun_with_restart auditd.service
  209. %else
  210. if [ $1 -ge 1 ]; then
  211. /sbin/service auditd condrestart > /dev/null 2>&1 || :
  212. fi
  213. %endif
  214. %post libs -p /sbin/ldconfig
  215. %postun libs -p /sbin/ldconfig
  216. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  217. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  218. %files libs
  219. %defattr(-,root,root)
  220. %{!?_licensedir:%global license %%doc}
  221. %license COPYING.LIB
  222. /%{_lib}/libaudit.*
  223. /%{_lib}/libauparse.*
  224. %config(noreplace) %attr(640,root,root) /etc/libaudit.conf
  225. %{_mandir}/man5/libaudit.conf.5.gz
  226. %files libs-devel
  227. %defattr(-,root,root)
  228. %{!?_licensedir:%global license %%doc}
  229. %license COPYING.LIB
  230. %doc contrib/skeleton.c contrib/plugin
  231. %{_libdir}/libaudit.a
  232. %{_libdir}/libauparse.a
  233. %{_libdir}/libaudit.so
  234. %{_libdir}/libauparse.so
  235. %{_includedir}/libaudit.h
  236. %{_includedir}/auparse.h
  237. %{_includedir}/auparse-defs.h
  238. %{_datadir}/aclocal/audit.m4
  239. %{_libdir}/pkgconfig/audit.pc
  240. %{_libdir}/pkgconfig/auparse.pc
  241. %{_mandir}/man3/*
  242. %files libs-python
  243. %defattr(-,root,root)
  244. %attr(755,root,root) %{python_sitearch}/_audit.so
  245. %attr(755,root,root) %{python_sitearch}/auparse.so
  246. %{python_sitearch}/audit.py*
  247. %files libs-python3
  248. %defattr(-,root,root,-)
  249. %attr(755,root,root) %{python3_sitearch}/*
  250. %files
  251. %defattr(-,root,root,-)
  252. %doc README ChangeLog rules init.d/auditd.cron
  253. %{!?_licensedir:%global license %%doc}
  254. %license COPYING
  255. %dir %{_datadir}/%{name}
  256. %dir %{_datadir}/%{name}/sample-rules
  257. %attr(644,root,root) %{_datadir}/%{name}/sample-rules/*
  258. %attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
  259. %attr(644,root,root) %{_mandir}/man8/auditd.8.gz
  260. %attr(644,root,root) %{_mandir}/man8/aureport.8.gz
  261. %attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
  262. %attr(644,root,root) %{_mandir}/man8/autrace.8.gz
  263. %attr(644,root,root) %{_mandir}/man8/aulast.8.gz
  264. %attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
  265. %attr(644,root,root) %{_mandir}/man8/auvirt.8.gz
  266. %attr(644,root,root) %{_mandir}/man8/augenrules.8.gz
  267. %attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
  268. %attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
  269. %attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
  270. %attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
  271. %attr(644,root,root) %{_mandir}/man5/auditd-plugins.5.gz
  272. %attr(750,root,root) /sbin/auditctl
  273. %attr(750,root,root) /sbin/auditd
  274. %attr(755,root,root) /sbin/ausearch
  275. %attr(755,root,root) /sbin/aureport
  276. %attr(750,root,root) /sbin/autrace
  277. %attr(750,root,root) /sbin/augenrules
  278. %attr(750,root,root) %{_bindir}/aulastlog
  279. %attr(750,root,root) %{_bindir}/aulast
  280. %attr(755,root,root) %{_bindir}/ausyscall
  281. %attr(755,root,root) %{_bindir}/auvirt
  282. %attr(750,root,root) %dir %{_var}/log/audit
  283. %attr(750,root,root) %dir /etc/audit
  284. %attr(750,root,root) %dir /etc/audit/rules.d
  285. %attr(750,root,root) %dir /etc/audit/plugins.d
  286. %config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
  287. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
  288. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
  289. %config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
  290. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/af_unix.conf
  291. %if %{with systemd}
  292. %attr(644,root,root) %{_unitdir}/auditd.service
  293. %else
  294. %config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
  295. %attr(755,root,root) /etc/rc.d/init.d/auditd
  296. %endif
  297. %files -n audispd-plugins
  298. %defattr(-,root,root,-)
  299. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-remote.conf
  300. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-remote.conf
  301. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/syslog.conf
  302. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-statsd.conf
  303. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-statsd.conf
  304. %attr(750,root,root) /sbin/audisp-remote
  305. %attr(750,root,root) /sbin/audisp-syslog
  306. %attr(750,root,root) /sbin/audisp-statsd
  307. %attr(700,root,root) %dir %{_var}/spool/audit
  308. %attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
  309. %attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
  310. %attr(644,root,root) %{_mandir}/man8/audisp-syslog.8.gz
  311. %attr(644,root,root) %{_mandir}/man8/audisp-statsd.8.gz
  312. %files -n audispd-plugins-zos
  313. %attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
  314. %attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
  315. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/audispd-zos-remote.conf
  316. %config(noreplace) %attr(640,root,root) /etc/audit/zos-remote.conf
  317. %attr(750,root,root) /sbin/audispd-zos-remote
  318. %if %{build_compat32}
  319. %files -n compat32-%{name}-libs
  320. %{!?_licensedir:%global license %%doc}
  321. %license COPYING.LIB
  322. %defattr(-,root,root)
  323. %attr(755,root,root) /%{_lib}/libaudit.*
  324. %attr(755,root,root) /%{_lib}/libauparse.*
  325. %endif
  326. %changelog
  327. * Fri Feb 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  328. - new upstream release.
  329. - dropped Patch1.
  330. - imported Patch1 from rawhide.
  331. * Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.5-1
  332. - new upstream release.
  333. - imported Patch1 from rawhide.
  334. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.7-1
  335. - new upstream release.
  336. - dropped all patches.
  337. - dropped system-config-audit.
  338. - added python3 bindings.
  339. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
  340. - fix sca_release
  341. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
  342. - create compat32-audit-libs subpackage
  343. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
  344. - rebuild with python-2.7.2
  345. - add Patch12 (audit-1.7.18-libaudit.patch)
  346. * Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
  347. - new upstream release
  348. - rebuild with krb5-1.8.2
  349. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
  350. - forgot to increment sca_release macro (why on earth is sca_release
  351. individually defined from main package's release number anyway?)
  352. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
  353. - rebuilt with gcc-4.4.3-3 on ppc
  354. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
  355. - rebuilt with rpm-4.8.0-3 (on ppc)
  356. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
  357. - rebuild with python-2.6
  358. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
  359. - rebuild with openldap-2.4.11
  360. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  361. - initial build for Vine Linux
  362. - disable krb5, prelude and selinux
  363. - add ja.po (XXX: minimal)
  364. * Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
  365. - Add subject to audit daemon events (Chu Li)
  366. - Add tcp_wrappers support for auditd
  367. - Updated syscall tables for 2.6.27 kernel
  368. - Audit connect/disconnect of remote clients
  369. - Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
  370. * Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
  371. - Update system-config-audit to 0.4.8
  372. - Whole lot of bug fixes - see ChangeLog for details
  373. - Reimplement auditd main loop using libev
  374. - Add TCP listener to auditd to receive remote events
  375. - Fix scheduler problem (#457061)
  376. * Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
  377. - Move ausearch-expression to main package (#453437)
  378. * Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
  379. - Fix interpreting of keys in syscall records
  380. - Don't error on name=(null) PATH records in ausearch/report
  381. - Add key report to aureport
  382. - Update system-config-audit to 0.4.7 (Miloslav Trmac)
  383. - Add support for the filetype field option in auditctl new to 2.6.26 kernels
  384. * Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
  385. - Fix output of keys in ausearch interpretted mode
  386. - Fix ausearch/report --start now to not be reset to midnight
  387. - audispd now has a priority boost config option
  388. - Look for laddr in avcs reported via prelude
  389. - Detect page 0 mmaps and alert via prelude
  390. * Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
  391. - Fix overflow in audit_log_user_command, better (#438840)
  392. - ausearch was not matching path in avc records
  393. - audisp-prelude attempt to reposition index after examining each type
  394. - correct building of mls policy
  395. - Fix auparse iterating in auparse_find_field and next_field
  396. - Don't alert on USER_AVC's - they are not quite right
  397. * Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
  398. - Fix buffer overflow in audit_log_user_command, again (#438840)
  399. - Fix memory leak in EOE code in auditd (#440075)
  400. - In auditctl, don't use new operators in legacy rule format
  401. - Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
  402. * Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
  403. - Fix memleak in auditd eoe code
  404. * Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
  405. - Remove LSB headers from init scripts
  406. - Fix buffer overflow in audit_log_user_command again
  407. * Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
  408. - Handle user space avcs in prelude plugin
  409. - Fix watched account login detection for some failed login attempts
  410. - Couple fixups in audit logging functions (Miloslav Trmac)
  411. - Add support in auditctl for virtual keys
  412. - auparse_find_field_next was not iterating correctly, fixed it
  413. - Add idmef alerts for access or execution of watched file
  414. - Fix buffer overflow in audit_log_user_command
  415. - Add basic remote logging plugin - only sends & no flow control
  416. - Update ausearch with interpret fixes from auparse
  417. * Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
  418. - Apply hidden attribute cleanup patch (Miloslav Trmac)
  419. - Apply auparse expression interface patch (Miloslav Trmac)
  420. - Fix potential memleak in audit event dispatcher
  421. - Update system-config-audit to version 0.4.6 (Miloslav Trmac)
  422. - audisp-prelude alerts now controlled by config file
  423. - Updated syscall table for 2.6.25 kernel
  424. - Apply patch correcting acct field being misencoded (Miloslav Trmac)
  425. - Added watched account login detection for prelude plugin
  426. * Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
  427. - Update for gcc 4.3
  428. - Cleanup descriptors in audispd before running plugin
  429. - Fix 'recent' keyword for aureport/search
  430. - Fix SE Linux policy for zos_remote plugin
  431. - Add event type for group password authentication attempts
  432. - Couple of updates to the translation tables
  433. - Add detection of failed group authentication to audisp-prelude
  434. * Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
  435. - In ausearch/report, prefer -if to stdin
  436. - In ausearch/report, add new command line option --input-logs (#428860)
  437. - Updated audisp-prelude based on feedback from prelude-devel
  438. - Added prelude alert for promiscuous socket being opened
  439. - Added prelude alert for SE Linux policy enforcement changes
  440. - Added prelude alerts for Forbidden Login Locations and Time
  441. - Applied patch to auparse fixing error handling of searching by
  442. interpreted value (Miloslav Trmac)
  443. * Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
  444. - Add prelude IDS plugin for IDMEF alerts
  445. - Add --user option to aulastlog command
  446. - Use desktop-file-install for system-config-audit
  447. - Avoid touching auditd.conf most of the time (#408501)
  448. * Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
  449. - Updates for spec file review
  450. - Adjust permission on selinux policy file
  451. * Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
  452. - Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
  453. - Check for audit log being writable by owner in auditd
  454. - If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
  455. - Updated CAPP, LSPP, and NISPOM rules for new capabilities
  456. - Added aulastlog utility
  457. * Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
  458. - Allow 0600 file perms for audit logs
  459. * Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
  460. - fchmod of log file was on wrong variable (#426934)
  461. - Allow use of errno strings for exit codes in audit rules
  462. * Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
  463. - Don't fchmod() /dev/null to mode 0400 (#426934)
  464. * Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
  465. - Add kernel release string to DEAMON_START events
  466. - Fix keep_logs when num_logs option disabled (#325561)
  467. - Fix auparse to handle node fields for syscall records
  468. - Update system-config-audit to version 0.4.5 (Miloslav Trmac)
  469. - Add keyword week-ago to aureport & ausearch start/end times
  470. - Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
  471. - Add RACF zos remote audispd plugin (Klaus Kiwi)
  472. - Add event queue overflow action to audispd
  473. * Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
  474. - Don't retry if the rt queue is full.
  475. * Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
  476. - Add support for searching by posix regular expressions in auparse
  477. - Route DEAMON events into rt interface
  478. - If event pipe is full, try again after doing local logging
  479. - Optionally add node/machine name to records in audit daemon
  480. - Update ausearch/aureport to specify nodes to search on
  481. - Fix segfault interpretting saddr fields in avcs
  482. * Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
  483. - Fix uninitialized variable in auparse (John Dennis)
  484. * Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
  485. - External plugin support in place
  486. - Fix reference counting in auparse python bindings (#263961)
  487. - Moved default af_unix plugin socket to /var/run/audispd_events
  488. * Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
  489. - Add newline to audispd string formatted events
  490. * Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
  491. - spec file cleanups
  492. - Update to s-c-audit 0.4.3
  493. * Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
  494. - Update Licence tags
  495. - Adding perm field should not set syscall added flag in auditctl
  496. - Fix segfault when aureport -if option is used
  497. - Fix auditctl to better check keys on rule lines
  498. - Add support for audit by TTY and other new event types
  499. - Auditd config option for group permission of audit logs
  500. - Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
  501. - New audit event dispatcher
  502. - Update syscall tables for 2.6.23 kernel
  503. * Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
  504. - Fix potential buffer overflow in print clone flags of auparse
  505. - Fix python traceback parsing watches without perm statement (Miloslav Trmac)
  506. - Update auditctl to handle legacy kernels when putting a watch on a dir
  507. - Fix acct interpretation in auparse
  508. * Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
  509. - Fix a double free when auditd receives SIGHUP
  510. - Move the system-config-audit menu entry to the Administration menu
  511. * Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
  512. - Add system-config-audit (Miloslav Trmac)
  513. - Correct bug in audit_make_equivalent function (Al Viro)
  514. * Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
  515. - Add feed interface to auparse library (John Dennis)
  516. - Apply patch to libauparse for unresolved symbols (#241178)
  517. - Apply patch to add line numbers for file events in libauparse (John Dennis)
  518. - Change seresults to seresult in libauparse (John Dennis)
  519. - Add unit32_t definition to swig (#244210)
  520. - Add support for directory auditing
  521. - Update acct field to be escaped
  522. * Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
  523. - Change buffer size to prevent truncation of DAEMON events with large labels
  524. - Fix memory leaks in auparse (John Dennis)
  525. - Update syscall tables for 2.6.21 kernel
  526. - Update capp & lspp rules
  527. - New python bindings for libauparse (John Dennis)
  528. * Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
  529. - New event dispatcher (James Antill)
  530. - Apply patches fixing man pages and Makefile.am (Philipp Hahn)
  531. - Apply patch correcting python libs permissions (Philipp Hahn)
  532. - Fix auditd segfault on reload
  533. - Fix bug in auparse library for file pointers and descriptors
  534. - Extract subject information out of daemon events for ausearch
  535. * Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
  536. - Remove requires kernel-headers for python-libs
  537. - Apply patch to prevent segfaults on auditd reload
  538. * Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
  539. - Updated autrace to monitor *at syscalls
  540. - Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
  541. - Finish reworking auditd config parser
  542. - In auparse, interpret open, fcntl, and clone flags
  543. - In auparse, when interpreting execve record types, run args through unencode
  544. - Add support for OBJ_PID message type
  545. - Event dispatcher updates
  546. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
  547. - rebuild
  548. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
  549. - NEW audit dispatcher program & plugin framework
  550. - Correct hidden variables in libauparse
  551. - Added NISPOM sample rules
  552. - Verify accessibility of files passed in auparse_init
  553. - Fix bug in parser library interpreting socketcalls
  554. - Add support for stdio FILE pointer in auparse_init
  555. - Adjust init script to allow anyone to status auditd (#230626)
  556. * Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  557. - Add man pages
  558. - Reduce text relocations in parser library
  559. - Add -n option to auditd for no fork
  560. - Add exec option to space_left, admin_space_left, disk_full,
  561. and disk_error - eg EXEC /usr/local/script
  562. * Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  563. - updated audit_rule_fieldpair_data to handle perm correctly (#226780)
  564. - Finished search options for audit parsing library
  565. - Fix ausearch -se to work correctly
  566. - Fix auditd init script for /usr on netdev (#228528)
  567. - Parse avc seperms better when there are more than one
  568. * Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
  569. - New report about authentication attempts
  570. - Updates for python 2.5
  571. - update autrace to have resource usage mode
  572. - update auditctl to support immutable config
  573. - added audit_log_user_command function to libaudit api
  574. - interpret capabilities
  575. - added audit event parsing library
  576. - updates for 2.6.20 kernel
  577. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
  578. - Make more adjustments for python 2.5
  579. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  580. - Fix a couple parsing problems (#217952)
  581. - Add tgkill to S390* syscall tables (#218484)
  582. - Fix error messages in ausearch/aureport
  583. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
  584. - rebuild against python 2.5
  585. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
  586. - Fix timestamp for libaudit.conf (#218053)
  587. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
  588. - Fix minor parsing problem and add new msg types
  589. * Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
  590. - ausearch & aureport implement uid/gid caching
  591. - In ausearch & aureport, extract addr when hostname is unknown
  592. - In ausearch & aureport, test audit log presence O_RDONLY
  593. - New ausearch/aureport time keywords: recent, this-week, this-month, this-year
  594. - Added --add & --delete option to aureport
  595. - Update res parsing in config change events
  596. - Increase the size on audit daemon buffers
  597. - Parse avc_path records in ausearch/aureport
  598. - ausearch has new output mode, raw, for extracting events
  599. - ausearch/aureport can now read stdin
  600. - Rework AVC processing in ausearch/aureport
  601. - Added long options to ausearch and aureport
  602. * Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
  603. - In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
  604. - Fix some defines in libaudit.h
  605. - Some auditd config strings were not initialized in aureport (#211443)
  606. - Updated man pages
  607. - Add Netlabel event types to libaudit
  608. - Update aureports to current audit event types
  609. - Update autrace a little
  610. - Deprecated all the old audit_rule functions from public API
  611. - Drop auparse library for the moment
  612. * Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
  613. - Add dist tag and bump version (#208532)
  614. - Make internal auditd buffers bigger for context info
  615. - Correct address resolving of hostname in logging functions
  616. - Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
  617. - Only =, != operators for arch & inode fields in auditctl (#206427)
  618. - Updated audit message type table
  619. - Remove watches from aureport since FS_WATCH is deprecated
  620. - Add audit_log_avc back temporarily (#208152)