authconfig-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732
  1. Summary: Command line tool for setting up authentication from network services
  2. Summary(ja): ネットワークサービスからの認証を設定するためのコマンドラインツール
  3. Name: authconfig
  4. Version: 7.0.1
  5. Release: 3%{?_dist_release}
  6. Group: admin-tools
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: https://pagure.io/authconfig
  11. Source: https://releases.pagure.org/%{name}/%{name}-%{version}.tar.bz2
  12. # fedora patches
  13. Patch1: authconfig-6.2.6-gdm-nolastlog.patch
  14. Patch2: authconfig-7.0.1-nss-update.patch
  15. # remove selinux stuff
  16. Patch100: authconfig-7.0.1-noselinux.patch
  17. # elogind patch
  18. Patch1000: authconfig-7.0.1-elogind.patch
  19. # stop warning flood by tempfile in python3.5
  20. Patch1001: authconfig-7.0.1-fix-temp-warning.patch
  21. ExclusiveOS: Linux
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: glib2-devel
  24. BuildRequires: python3-devel
  25. BuildRequires: intltool, gettext
  26. Requires: pam
  27. Requires: openssl
  28. Conflicts: samba-common < 3.0, samba-client < 3.0
  29. Conflicts: nss_ldap < 254
  30. Obsoletes: authconfig-gtk < 7.0.0
  31. %description
  32. Authconfig is a command line utility which can configure a workstation
  33. to use shadow (more secure) passwords. Authconfig can also configure a
  34. system to be a client for certain networked user information and
  35. authentication schemes.
  36. %description -l ja
  37. authconfig はシャドウ(よりセキュリティーが高い)パスワードの設定をおこなう
  38. コマンドラインプログラムです。また、ネットワークを介したユーザ情報と認証
  39. サービスを利用するように設定することもできます。
  40. %prep
  41. %setup -q -n %{name}-%{version}
  42. %patch1 -p1
  43. %patch2 -p1
  44. %patch1000 -p1
  45. %patch1001 -p1
  46. %patch100 -p1
  47. perl -pi -e 's|/usr/lib|/lib|' authinfo.py
  48. %build
  49. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  50. %configure --with-python-rev=3
  51. make
  52. %install
  53. rm -rf $RPM_BUILD_ROOT
  54. make install DESTDIR=$RPM_BUILD_ROOT
  55. rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutil.a
  56. rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutil.la
  57. %find_lang %{name}
  58. find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %post
  62. authconfig --updateall --nostart &>/dev/null ||:
  63. %triggerin -- authconfig <= 6.2.3
  64. if [ ! -e %{_sysconfdir}/pam.d/postlogin-ac ]; then
  65. authconfig --updateall --nostart >/dev/null 2>&1 || :
  66. fi
  67. if [ ! -e %{_sysconfdir}/pam.d/postlogin ]; then
  68. cd %{_sysconfdir}/pam.d; \
  69. ln -s postlogin-ac postlogin > /dev/null 2>&1 || :
  70. fi
  71. %files -f %{name}.lang
  72. %defattr(-,root,root,-)
  73. %license COPYING
  74. %doc NOTES TODO HOWTO.AD-client
  75. %ghost %config(noreplace) %{_sysconfdir}/sysconfig/authconfig
  76. %ghost %config(noreplace) %{_sysconfdir}/pam.d/system-auth-ac
  77. %ghost %config(noreplace) %{_sysconfdir}/pam.d/password-auth-ac
  78. %ghost %config(noreplace) %{_sysconfdir}/pam.d/fingerprint-auth-ac
  79. %ghost %config(noreplace) %{_sysconfdir}/pam.d/smartcard-auth-ac
  80. %ghost %config(noreplace) %{_sysconfdir}/pam.d/postlogin-ac
  81. %{_sbindir}/cacertdir_rehash
  82. %{_sbindir}/authconfig
  83. %{_mandir}/man8/*
  84. %{_mandir}/man5/*
  85. %{_libdir}/python*/site-packages/acutil.so
  86. %dir %{_datadir}/%{name}
  87. %{_datadir}/%{name}/authconfig.py*
  88. %{_datadir}/%{name}/authinfo.py*
  89. %{_datadir}/%{name}/shvfile.py*
  90. %{_datadir}/%{name}/dnsclient.py*
  91. %attr(700,root,root) %dir %{_localstatedir}/lib/%{name}
  92. %changelog
  93. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-3
  94. - rebuilt with python-3.8.
  95. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-2
  96. - updated Patch100.
  97. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  98. - new upstream release.
  99. - switched to python3.
  100. - updated Patch100.
  101. - added elogind support.
  102. - dropped Patch10 and 11.
  103. - dropped a subpackage "gtk": no longer supported in the upstream.
  104. * Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.2.8-2
  105. - add Patch100 to remove selinux staff (again)
  106. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.8-1
  107. - update to 6.2.8
  108. - remove Patch101 (authconfig-6.2.3-authinfo-vine.patch)
  109. * Sat Oct 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.4-1
  110. - update to 6.2.4
  111. - run "authconfig --updateall --nostart" on %%post script
  112. * Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.3-1
  113. - update to 6.2.3
  114. - update Patch10 (authconfig-6.2.3-fprintd-pam.patch)
  115. - update Patch11 (authconfig-6.2.3-fix-broken-strings.patch)
  116. - add Patch101 (authconfig-6.2.3-authinfo-vine.patch)
  117. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.4.10-6
  118. - rebuild with python-2.7.2
  119. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.10-5
  120. - rebuilt with rpm-4.8.1-3
  121. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.10-4
  122. - rebuilt with python-2.6.4
  123. * Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-3
  124. - update Patch11
  125. - old patch does not fix problem on some environment..
  126. * Fri Aug 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-2
  127. - add Patch10
  128. - Fingerprint auth requires fprintd-pam package not pam_fprintd
  129. - add Patch11 to fix broken help messages on some locale.
  130. * Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-1
  131. - new upstream release
  132. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.4-1
  133. - new upstream release
  134. - historical changelogs are following:
  135. * Tue Apr 05 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl4
  136. - added authconfig-4.6.1-authinfo.patch, by HOTTA Michihide <hotta@net-newbie.com>
  137. - added BuildRequires: desktop-file-utils
  138. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl3
  139. - rebuilt with python-2.4.1-0vl1
  140. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl2
  141. - rebuilt with python-2.3.3-0vl1
  142. * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl1.1
  143. - rebuilt with python-2.3.3-0vl0.3 (for TestPkg)
  144. * Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1vl1
  145. - updated to 4.6.1
  146. - updated Patch0 and Source1
  147. - rebuild with new toolchains
  148. - Reqyires: glib2, BuildRequires: glib2-devel
  149. * Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl2
  150. - add vinized color palette
  151. * Thu Jul 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl1
  152. - rebuild for Vine Linux
  153. - based on Red Hat Linux 7.2, merged with Vine Linux package.
  154. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  155. - 3.0.3-1vl5
  156. - change checkbox color
  157. * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 3.0.3-1vl4
  158. - add %patch1 to fix mandir
  159. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.0.3-1vl3
  160. - build with gcc-2.95.3
  161. - partially used rpmmacros
  162. * Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  163. - 3.0.3-1vl2
  164. - modified %files section to handle compressed man page
  165. * Thu May 11 2000 Jun Nishii <jun@vinelinux.org>
  166. - 3.0.3-1vl1
  167. - build for Vine
  168. * Tue Aug 5 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.4-1
  169. - do not call domainname when run with --nostart (#457697)
  170. * Fri Jun 6 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.3-1
  171. - remove the --enableldapssl alias and add some help to GUI tooltips
  172. to clear up some confusion (#220973)
  173. - add option --enablepreferdns to prefer DNS over NIS or WINS in
  174. hostname resolution
  175. * Tue Apr 8 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.2-1
  176. - read wins setting from nsswitch.conf correctly (#440459)
  177. - do not ignore --enablemd5/--disablemd5 options
  178. * Tue Mar 11 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.1-1
  179. - fixed backup directory in Makefile and spec (#437040)
  180. * Mon Mar 10 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.0-1
  181. - include config-util in console.apps files
  182. - add support for saving/restoring backups of configuration
  183. files affected by authconfig (#433776)
  184. - improve the authconfig manual page (#432023, #432938)
  185. * Tue Jan 29 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.21-1
  186. - correct the fix for bug #237956
  187. * Fri Jan 18 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.20-1
  188. - update translations
  189. * Wed Jan 9 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.19-1
  190. - support new sha256 and sha512 password hash algorithms
  191. - add support for pam_mkhomedir (#212790)
  192. - do not crash in authconfig --help (#237956) - thanks to Andy Shevchenko for
  193. the idea how to fix that
  194. - setup password hash algorithm in /etc/login.defs (#218652)
  195. - update translations
  196. * Tue Sep 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.18-1
  197. - improve krb5.conf handling (#238766)
  198. * Fri Aug 24 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.17-1
  199. - remove obsolete pam_krb5afs support (#250704)
  200. - add support for pam_access (#251360)
  201. - update translations
  202. * Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-3
  203. - license tag fix
  204. * Thu Aug 9 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-2
  205. - require newt-python (#251359)
  206. * Wed Jul 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-1
  207. - add support for winbind offline login (#232955)
  208. * Wed Jul 18 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.15-1
  209. - dnsclient fixes by Simo Sorce
  210. - add Categories to .desktop file (#245868)
  211. - fixed traceback when calling joinDomain (#245374)
  212. - disable smart card action setting when gnome-screensaver
  213. not installed (#209643)
  214. - do not change protocols and services in nsswitch.conf (#236669)
  215. * Tue Jun 12 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.14-1
  216. - authconfig.8 synopsis fixed (patch by Eric Raymond) (#220574)
  217. - drop explicit requirement on python version as it is now
  218. generated automatically
  219. - improve writing /etc/samba/smb.conf (based on patch by
  220. Simo Sorce)
  221. - merge changes upstream
  222. * Fri May 4 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-4
  223. - local nis domain is obtained from sysconfig/network (#235927)
  224. - set "local authorization is sufficient" on by default
  225. * Thu Apr 5 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-3
  226. - minor changes and cleanups for merge review (#225293)
  227. * Mon Mar 19 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-2
  228. - nss_ldap is now in /usr/lib (#232975)
  229. * Tue Dec 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.13-1
  230. - another traceback in --probe and other fixes (#218874)
  231. - make smbRealm a default realm when appropriate (#219300)
  232. - added missing languages in LINGUAS
  233. * Wed Nov 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.12-1
  234. - when pam_krb5 auth fails with smartcard login don't enforce it
  235. in the account stack (#214931)
  236. - updated translations (#216570)
  237. - winbind should be added only to user tables (#216862)
  238. * Fri Oct 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.11-1
  239. - fixed --smartcardaction command line option (#211552)
  240. * Fri Oct 6 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.10-1
  241. - fixed passwd PAM stack when PKCS11 enabled (#195960)
  242. - make authconfig --probe work again (#209676)
  243. * Mon Oct 2 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.9-1
  244. - updated translations (#207095)
  245. - correctly write pam_smb.conf with only one server specified (#208365)
  246. * Thu Sep 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.8-1
  247. - move options to another tab to fit on 800x600 screen (#207357)
  248. * Tue Sep 19 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.7-1
  249. - improve PAM setup for smart card login
  250. - support smart card login with kerberos (PKINIT)
  251. - add pam_pkcs11 to password PAM stack
  252. * Mon Sep 4 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.6-1
  253. - skip pam_unix for session for crond service
  254. - fixed a bug in saving when smartcard settings changed (#204838)
  255. - removed allow_ypbind setsebool as it is now handled in ypbind
  256. * Tue Aug 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.5-1
  257. - improve smart card related UI strings
  258. - removed possibility to set smart card type from authconfig-gtk
  259. as only coolkey will be supported for now
  260. * Thu Aug 24 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.4-1
  261. - pass options given to authconfig-gtk to authconfig (#203955)
  262. * Sun Jul 23 2006 Ray Strode <rstrode@redhat.com> - 5.3.3-2
  263. - write out new "wait_for_card" config option if we're
  264. forcing smart card authentication
  265. - add "use_uid" option to smart card pam_succeed_if line to
  266. work around bug where pam_succeed_if checks user information
  267. even in cases where the conditional doesn't depend on it.
  268. - remove unimplemented "logout" smart card removal action from
  269. settings
  270. - remove unnecessary "card_only" argument
  271. * Fri Jul 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.3-1
  272. - don't start sceventd when smartcard login is enabled
  273. - improve pam config for smartcard login
  274. * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.2-1
  275. - don't require pam_pkcs11 to run
  276. * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.1-1
  277. - screensavers should be authenticated by smartcard too
  278. - add feature to download a CA certificate for LDAP from
  279. an URL (#197103)
  280. - add pam_keyinit session module to the PAM configuration (#198638)
  281. * Fri Jul 7 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.0-1
  282. - added support for smartcard authentication
  283. - fixed parsing kerberos realms
  284. * Thu May 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.5-1
  285. - write ldap servers as URIs and not HOSTs (#191842)
  286. - fix a typo in --test output
  287. - updated summary, converted changelog to UTF-8
  288. * Fri May 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.4-1
  289. - added crond to the services restarted after firstboot (#187334)
  290. - when checking nscd status redirect output to /dev/null (#188555)
  291. * Tue Mar 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.3-1
  292. - make smb.conf and krb5.conf loading more robust (#185766)
  293. * Mon Feb 27 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.2-1
  294. - add try_first_pass option to pam_unix for better integration
  295. with individual service configurations (#182350)
  296. - updated translations
  297. * Mon Feb 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.1-1
  298. - don't crash in TUI when some options aren't set (#182151)
  299. * Fri Feb 3 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.0-1
  300. - redesigned GUI (#178112)
  301. - added man page for system-config-ac (#179584)
  302. - disable authentication of system accounts by network services
  303. by default, added option for changing that (#179009)
  304. - updated translations, new languages
  305. * Mon Jan 9 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.2-1
  306. - fixed regression when saving nsswitch.conf
  307. * Fri Jan 6 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.1-1
  308. - print warning if PAM module is missing when the PAM configuration
  309. is saved (#168880)
  310. * Fri Dec 23 2005 Tomas Mraz <tmraz@redhat.com>
  311. - make child dialog preset code more robust (#176462)
  312. * Sat Dec 17 2005 Tomas Mraz <tmraz@redhat.com> - 5.1.0-1
  313. - update only configuration files which settings were modified (#72290)
  314. * Mon Dec 5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.4-1
  315. - don't ignore krb5realm command line option (#174838)
  316. - read dns_lookup_realm and dns_lookup_kdc values correctly
  317. - the PAM configuration is now written in system-auth-ac file
  318. which is then symlinked from system-auth, the symlink is not
  319. overwritten so local PAM configuration is now possible (#165342)
  320. * Mon Nov 7 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.3-1
  321. - add symlinks to python scripts in sbindir
  322. - don't override nullok setting from system-auth (#96996)
  323. * Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.2-1
  324. - authinfo-tui.py is now symlink
  325. - reword the CA certificate message (#154317)
  326. - use include instead of pam_stack in pam config
  327. - don't break yp.conf with multiple domains (#127306)
  328. * Mon Sep 5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.1-1
  329. - fixed a few errors catched by pychecker
  330. * Sat Sep 3 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.0-1
  331. - C code completely rewritten in Python
  332. - some bugs fixed in the process (and no doubt new introduced)
  333. - TUI deprecated, opens only when run as authconfig-tui
  334. * Mon Jun 20 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.13-1
  335. - set domain and ypserver option correctly when multiple servers
  336. specified in kickstart (#159214)
  337. * Tue Apr 12 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.12-1
  338. - replaced deprecated gtk.TRUE/FALSE (#153034)
  339. - updated translations
  340. * Mon Mar 14 2005 Tomas Mraz <tmraz@redhat.com>
  341. - propagate the --enablewinbindauth option to the configuration (#151018)
  342. * Fri Mar 4 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.11-1
  343. - changed version propagation
  344. * Thu Mar 3 2005 Tomas Mraz <tmraz@redhat.com>
  345. - updated translations
  346. - fixed build on gcc4
  347. * Wed Feb 23 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.10-1
  348. - updated translations
  349. * Thu Feb 10 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.9-1
  350. - improved the code that writes tls_cacertdir to ldap.conf
  351. * Tue Jan 25 2005 Tomas Mraz <tmraz@redhat.com>
  352. - renamed functions in authconfigmodule to be more clear
  353. - implemented cacertdir for LDAP with TLS
  354. * Mon Jan 24 2005 Tomas Mraz <tmraz@redhat.com>
  355. - fixed a bug in authinfo_differs when called from python
  356. * Fri Dec 17 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.8-1
  357. - add option for making local authorization sufficient for local users
  358. this is attempt to 'solve/workaround' the problem with blocking local logins by
  359. pulling out network cable (#115181)
  360. * Wed Dec 15 2004 Tomas Mraz <tmraz@redhat.com>
  361. - remove dependency on nscd
  362. - don't show warning messages when switching options off
  363. * Mon Dec 6 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.7-1
  364. - updated translations
  365. - winbind in authconfig-gtk.py was setting the nsswitch.conf on the auth tab
  366. - use GtkComboBox instead of deprecated GtkOptionMenu
  367. - disable options with not installed binaries, remove unnecessary deps of
  368. authconfig-gtk
  369. * Thu Nov 18 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.6-1
  370. - merged patches from dist
  371. - fix versioning
  372. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 4.6.5-6
  373. - rebuild against python 2.4
  374. * Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
  375. - Fix setsebool patch to turn off boolean
  376. * Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
  377. - Add setsebool for NIS
  378. * Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
  379. - force broken_shadow option on network auth (#136760)
  380. * Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
  381. - force restart of autofs on firstboot call when using NIS (#133035, #124498)
  382. * Thu Oct 07 2004 Tomas Mraz <tmraz@redhat.com>
  383. - require python to install (#134654)
  384. * Mon Oct 04 2004 Jindrich Novy <jnovy@redhat.com> 4.6.5-1
  385. - updated translations from upstream
  386. - autogeneration of build stripts in prep phase
  387. * Thu Sep 30 2004 Jindrich Novy <jnovy@redhat.com>
  388. - fixed man page
  389. - added dependency on nscd
  390. * Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-6
  391. - regenerated build scripts
  392. * Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-5
  393. - fixed all po files to translate correctly messages with modified accelerators (#133742)
  394. - added translations for Arabic, Bulgarian and other languages (#133716, #133158)
  395. * Wed Sep 22 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-4
  396. - added "quiet" option to pam_success_if PAM module in sytem-auth (#133179)
  397. * Mon Sep 13 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-3
  398. - corrected package dependencies #132411
  399. - regenerated glade.strings.h #132369
  400. * Wed Aug 25 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-2
  401. - modified authconfig-gtk interface to fit lower resolution screens (#127175)
  402. - modified accelerators in authconfig-gtk (#125797)
  403. - updated package dependencies (#125306)
  404. * Tue Aug 24 2004 Jindrich Novy <jnovy@redhat.com>
  405. - updated configure scripts
  406. - warnfixes and minor hacks
  407. * Mon Jun 7 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.4-1
  408. - tweak account management to fix #55193 correctly
  409. - require anything we might want to run in the gui subpackage because it
  410. doesn't warn about missing things and you don't have a terminal to see
  411. error messages about missing commands
  412. - properly display the domain in the GUI join dialog (#124621)
  413. * Tue May 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.3-1
  414. - omit the "ads" or "rpc" when calling "net join", Samba's smarter now (#122802)
  415. - properly warn about missing "net" (samba-client) and libnss_winbind and
  416. pam_winbind (samba-common) in text mode (#122802)
  417. * Wed Apr 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.2-1
  418. - learn all about pam_passwdqc
  419. - preserve arguments to pam_cracklib and pam_passwdqc
  420. - short-circuit PAM authorization checks for users with UID < 100
  421. - remove redhat-config-authentication as a way to invoke the GUI tool (#115977)
  422. * Fri Feb 6 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.1-1
  423. - fix man page: --enableldapssl should be --enableldaptls
  424. - make --enableldapssl an alias for --enableldaptls
  425. * Thu Jan 8 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6-1
  426. - authconfig-gtk.py: require rhpl, which is required by the script (#104209)
  427. - both: require usermode (authconfig-gtk transitively), else leave a dangling
  428. symlink (#104209)
  429. - the great redhat-config-authentication/system-config-authentication renaming,
  430. as was foretold in the fedora-config-list archives
  431. * Wed Jan 7 2004 Nalin Dahyabhai <nalin@redhat.com>
  432. - preserve "compat" if it's used in /etc/nsswitch.conf
  433. * Tue Nov 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.4-1
  434. - add options for toggling krb5's use of DNS
  435. * Mon Nov 17 2003 Nalin Dahyabhai <nalin@redhat.com>
  436. - rework tui to include winbind options. there wasn't enough room in the old
  437. dialog to include the important options, so the whole thing's been reworked
  438. * Thu Nov 13 2003 Nalin Dahyabhai <nalin@redhat.com>
  439. - conflict with older versions of samba which expect different configuration
  440. * Mon Nov 10 2003 Nalin Dahyabhai <nalin@redhat.com>
  441. - initial support for configuring winbind
  442. * Tue Oct 28 2003 Nalin Dahyabhai <nalin@redhat.com>
  443. - make pam_cracklib requisite instead of required in generated PAM configs
  444. * Wed Oct 22 2003 Bill Nottingham <notting@redhat.com> 4.3.8-1
  445. - rebuild with current translations
  446. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-2
  447. - make the tarball name include the release number
  448. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-1
  449. - authconfig-gtk: condrestart certain additional services if invoked with
  450. the --firstboot flag (half of #91268, needs cooperating firstboot)
  451. - translation updates
  452. * Mon Jul 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.6-1
  453. - translation updates
  454. * Mon Jun 30 2003 Nalin Dahyabhai <nalin@redhat.com>
  455. - add 'redhat-config-authentication' as an alias for authconfig-gtk
  456. - make authconfig-gtk exec authconfig if gui startup fails and it looks like
  457. we're connected to a tty
  458. * Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
  459. - rebuilt
  460. * Mon May 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.5-1
  461. - translation updates
  462. - close unusable file descriptors if locking fails
  463. * Tue Feb 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.4-1
  464. - learn how to toggle defaults/crypt_style in /etc/libuser.conf (#79337)
  465. * Fri Feb 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.3-1
  466. - look in /lib64 for modules for nsswitch and PAM by default on
  467. x86_64, ppc64, and s390x (#83049)
  468. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  469. - rebuilt
  470. * Mon Nov 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-1
  471. - update translations
  472. - update copyright strings (only took 10 months!)
  473. * Wed Oct 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.1-1
  474. - require a version of PAM (0.75-43) which supports $ISA
  475. - use $ISA in our own PAM config files
  476. * Tue Oct 22 2002 Nalin Dahyabhai <nalin@redhat.com>
  477. - add $ISA to the name of the directory in which we expect PAMs to be stored
  478. * Fri Sep 20 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3-1
  479. - build with -fPIC, necessary on some arches
  480. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-3
  481. - update translations
  482. * Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.2.12-2
  483. - Update translations
  484. * Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-1
  485. - modify spacing and layout in authconfig-gtk
  486. * Thu Aug 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-4
  487. - translation updates
  488. - rebuild to pick up dependency changes
  489. * Mon Jul 29 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-3
  490. - include the userhelper configuration file
  491. - require sufficiently-new pam package in the gui subpackage
  492. * Fri Jul 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-2
  493. - actually include the icon in the package
  494. - translation updates
  495. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-1
  496. - use desktop-file-install (#69376)
  497. - include an icon for the menu item (#68577)
  498. * Wed Jul 17 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-2
  499. - own the pkgdatadir
  500. - pull in translation updates
  501. * Mon Jun 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-1
  502. - add --enable-experimental to enable some of that experimental code
  503. - add --enable-local to enable local policies
  504. - update translations
  505. * Thu May 30 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-7
  506. - use the current revision of python by default
  507. - get the intltool/gettext situation sorted out
  508. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  509. - automated rebuild
  510. * Fri May 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-5
  511. - remove bogus buildrequires left over from when authconfig-gtk was C code
  512. - buildrequires python-devel in addition to python (to build the python module,
  513. but we still need python to byte-compile the python script)
  514. * Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-4
  515. - add missing translations back in
  516. - convert .mo files at install-time
  517. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-3
  518. - refresh translations
  519. * Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-2
  520. - actually add the .desktop files
  521. * Tue Apr 9 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-1
  522. - refresh translations
  523. - destroy the python object correctly
  524. * Tue Mar 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-2
  525. - add the .desktop file
  526. * Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-1
  527. - rework the auth stack logic to require all applicable auth modules
  528. * Fri Mar 1 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.6-1
  529. - allow pam_krb5afs to be used for account management, too
  530. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-3
  531. - refresh translations
  532. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-2
  533. - refresh translations
  534. * Tue Feb 12 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-1
  535. - actually free authInfo structures when asked to
  536. - use pam_krb5's account management facilities
  537. - conflict with versions of pam_krb5 which don't offer account management
  538. * Mon Feb 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.4-1
  539. - add python bindings for the back-end
  540. - redo the gui so that it exercises the python bindings
  541. - take a shot at getting authconfig to work in a firstboot container
  542. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-4
  543. - rebuild again
  544. * Wed Jan 30 2002 Tim Powers <timp@redhat.com> 4.2.3-3
  545. - rebuilt against new glib
  546. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-2
  547. - rebuild in new environment
  548. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-1
  549. - add some more experimental options
  550. - clean up the glade files a bit
  551. - don't destroy a garbage pointer on main cancel, destroy the main dialog
  552. * Thu Jan 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-2
  553. - bump release and rebuild
  554. * Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-1
  555. - make setting of experimental options only possible through
  556. /etc/sysconfig/authconfig, to keep accidents from happening
  557. - add some more support for experimental stuff
  558. * Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.1-1
  559. - fix setting of LDAP TLS option in authconfig-gtk
  560. - change Apply to Ok, Close to Cancel, because that's how they work
  561. * Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-2
  562. - add the glade XML file to the -gtk subpackage (fix from katzj)
  563. * Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-1
  564. - port to glib2
  565. - move post code to the back-end
  566. - add a libglade GUI in a -gtk subpackage
  567. - set up to use userhelper