autoconf-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370
  1. # run "make check" by default
  2. %bcond_without check
  3. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  4. Summary: A GNU tool for automatically configuring source code.
  5. Summary(ja): ソースコードを自動的に設定するための GNU ツール
  6. Name: autoconf
  7. Version: 2.71
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: GPL
  13. URL: http://www.gnu.org/software/autoconf/
  14. Source: http://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.xz
  15. Patch2: autoconf-test38.patch
  16. # Vine Source(s)
  17. Source10: autoconf-mode-install.sh
  18. Source11: autoconf-mode-remove.sh
  19. Requires(post,preun): /sbin/install-info
  20. Requires: gawk, m4, mktemp, perl, textutils
  21. Obsoletes: autoconf253 < 2.54
  22. BuildArch: noarch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. %description
  25. GNU's Autoconf is a tool for configuring source code and Makefiles.
  26. Using Autoconf, programmers can create portable and configurable
  27. packages, since the person building the package is allowed to
  28. specify various configuration options.
  29. You should install Autoconf if you are developing software and
  30. would like to create shell scripts that configure your source code
  31. packages. If you are installing Autoconf, you will also need to
  32. install the GNU m4 package.
  33. Note that the Autoconf package is not required for the end-user who
  34. may be configuring software with an Autoconf-generated script;
  35. Autoconf is only required for the generation of the scripts, not
  36. their use.
  37. %description -l ja
  38. GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
  39. です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
  40. 作ることができます.そのため,パッケージ作成者はさまざまな設定
  41. オプションを指定できます。
  42. ソフトウェアを開発していてソースコードパッケージを設定するシェル
  43. スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
  44. Autoconf をインストールするためには GNU m4 パッケージもインストールする
  45. 必要があります.
  46. Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
  47. エンドユーザには Autoconf パッケージが必要ないことに注目してください.
  48. Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
  49. 必要ありません.
  50. %package mode
  51. Summary: Emacs-lisp autoconf-mode for autoconf/autotest
  52. Group: programming
  53. BuildRequires: emacs
  54. %prereq_ge emacsen-common
  55. Requires: emacsen
  56. %description mode
  57. Emacs-lisp autoconf-mode for autoconf/autotest
  58. %prep
  59. %setup -q -n autoconf-%{version}
  60. %patch2 -p1
  61. %build
  62. %configure
  63. make %{?_smp_mflags}
  64. %install
  65. rm -rf ${RPM_BUILD_ROOT}
  66. %makeinstall
  67. gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
  68. # We don't want to include the standards.info stuff in the package,
  69. # because it comes from binutils...
  70. rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
  71. # cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
  72. # remove info dir file since it isn't packaged
  73. rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  74. # move elisp files
  75. pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
  76. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
  77. mv *.el autoconf-mode/
  78. popd
  79. # emacsen-common-ize
  80. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
  81. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  82. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  83. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
  84. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
  85. %_installemacsenscript autoconf-mode %{SOURCE10}
  86. %_removeemacsenscript autoconf-mode %{SOURCE11}
  87. rm -f %{buildroot}%{_datadir}/emacs/site-lisp/auto*-mode.elc
  88. %check
  89. %if %{with check}
  90. make check %{?_smp_mflags}
  91. %endif
  92. %clean
  93. rm -rf ${RPM_BUILD_ROOT}
  94. %post
  95. /sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
  96. %post mode
  97. if [ "$1" = 2 ]; then
  98. %_emacsenPackageRemove autoconf-mode
  99. fi
  100. %_addemacsenlist autoconf-mode
  101. %_emacsenPackageInstall autoconf-mode
  102. %preun
  103. if [ "$1" = 0 ]; then
  104. /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
  105. fi
  106. %preun mode
  107. if [ "$1" = 0 ]; then
  108. %_emacsenPackageRemove autoconf-mode
  109. %_removeemacsenlist autoconf-mode
  110. fi
  111. %files
  112. %defattr(-,root,root)
  113. %doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
  114. %{_bindir}/*
  115. %{_infodir}/*.info*
  116. %{_datadir}/autoconf
  117. %{_mandir}/man1/*
  118. %files mode
  119. %defattr(-,root,root)
  120. %{_datadir}/emacs/site-lisp/autoconf-mode/
  121. #/usr/lib/emacsen-common/packages/install/autoconf-mode
  122. #/usr/lib/emacsen-common/packages/remove/autoconf-mode
  123. %{emacsen_pkgdir}/install/autoconf-mode
  124. %{emacsen_pkgdir}/remove/autoconf-mode
  125. %changelog
  126. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.71-1
  127. - updated to 2.71.
  128. - dropped Patch1 and 3: fixed in upstream.
  129. - updated Patch2.
  130. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.69-2
  131. - added Patch1-3.
  132. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.69-1
  133. - update to 2.69
  134. * Sun Nov 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.68-1
  135. - new upstream release
  136. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.65-2
  137. - rebuilt with rpm-4.8.1-3
  138. * Sun Apr 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.65-1
  139. - new upstream release
  140. * Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
  141. - new upstream release
  142. - dropped Patch0 (merged into upstream)
  143. * Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
  144. - added %%emacsen_pkgdir macro
  145. - spec in utf-8
  146. * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
  147. - import Patch0 from Fedora 2.62-2
  148. * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
  149. - add upstream fix from Eric Blake for #449973,
  150. m4_if releated error message from autotest
  151. * Sun May 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
  152. - new upstream release
  153. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
  154. - new upstream release
  155. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
  156. - changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  157. - added Japanese summary and description from vinedocs.sourceforge.jp
  158. - s/Copyright/License/
  159. * Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
  160. - rebuild
  161. * Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
  162. - rebuild
  163. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
  164. - update to 2.59 bugfix release
  165. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
  166. - new upstream release
  167. * Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
  168. - source update
  169. * Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
  170. - don't show annoying messages during elisp compilation
  171. * Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
  172. - based on 2.56-1 from Rawhide and built for Vine Linux
  173. - emacsen-common-ize
  174. * Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
  175. - update to 2.56
  176. - obsolete autoheader-warn patch
  177. - no longer provide autoconf253
  178. - include site-lisp and man files
  179. - remove info dir which is not in the manifest
  180. - do not version suffix bin files for now
  181. * Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
  182. - make check
  183. * Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
  184. - update url (#66840)
  185. - added doc files
  186. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
  187. - automated rebuild
  188. * Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
  189. - automated rebuild
  190. * Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
  191. - provide autoconf253
  192. * Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
  193. - obsolete autoconf253
  194. * Wed May 8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
  195. - patch autoheader so that --warnings=CATEGORY works (#64566)
  196. [reported with fix by hjl@gnu.org]
  197. * Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
  198. - update to autoconf-2.53
  199. - drop mawk patch again
  200. - version suffix bindir files and add symlinks to unversioned names
  201. * Fri Feb 1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
  202. - revert to 2.52 (also fixes #58210!)
  203. - remove relversion variable
  204. - bring back mawk -> gawk patch
  205. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
  206. - automated rebuild
  207. * Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
  208. - update to 2.52f
  209. - add URL
  210. - minor description improvements
  211. - define relversion to carry version number
  212. - mawk.patch no longer needed
  213. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
  214. - rebuild
  215. * Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
  216. - restore patch to prefer gawk to mawk
  217. * Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
  218. - update to 2.52d
  219. * Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
  220. - update to 2.52
  221. - remove obsolete patches, since already new version
  222. - dont install install-sh
  223. * Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
  224. - add patch to include various standard C headers as needed
  225. by various autoconf tests (#19114)
  226. - add patch to autoscan.pl to get a better choice of init
  227. file (#42071), to test for CPP after CC (#42072) and to
  228. detect C++ source and g++ (#42073).
  229. * Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
  230. - Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
  231. from version 2.50 to make detection of C++ exit()
  232. declaration prototype platform independent. The check is
  233. done in AC_PROG_CXX with the result stored in "confdefs.h".
  234. The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
  235. (fixes #18829)
  236. * Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  237. - Fix up interoperability with glibc 2.2 and gcc 2.96:
  238. AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
  239. the test code without throwing an exception, causing a conflict
  240. with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
  241. always failed, returning wrong results
  242. * Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  243. - add textutils as a dependency (#14439)
  244. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  245. - automatic rebuild
  246. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  247. - FHS packaging.
  248. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  249. - fix preun
  250. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  251. - add patch to help autoconf clean after itself and not leave /tmp clobbered
  252. with acin.* and acout.* files (can you say annoying?)
  253. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  254. - auto rebuild in the new build environment (release 4)
  255. - use gawk, not mawk
  256. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  257. - moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
  258. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  259. - Injected new description and group.
  260. * Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
  261. - update to 2.13.
  262. * Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
  263. - build against glibc 2.1
  264. * Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
  265. - requires perl
  266. * Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
  267. - patch for fixing /tmp race conditions
  268. * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
  269. - spec file cleanups
  270. - made a noarch package
  271. - uses autoconf
  272. - uses install-info
  273. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  274. - built with glibc