avant-window-navigator-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261
  1. # -*- coding: utf-8-unix -*-
  2. %global bzr bzr830
  3. Name: avant-window-navigator
  4. Version: 0.4.1
  5. Release: 1%{?bzr:.%bzr}%{?_dist_release}
  6. Summary: Fully customisable dock-like window navigator for GNOME
  7. Group: User Interface/Desktops
  8. #libawn is LGPLv2+, rest is GPLv2+
  9. License: GPLv2+ and LGPLv2+
  10. URL: https://launchpad.net/awn
  11. # upstream snapshot:
  12. # bzr branch lp:awn
  13. # bzr export --root=avant-window-navigator-0.4.1-bzr830 avant-window-navigator-0.4.1-bzr830.tar.gz
  14. #
  15. Source0: %{name}-%{version}-%{bzr}.tar.gz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: libwnck-devel
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: pygtk2-devel
  20. BuildRequires: pycairo-devel
  21. BuildRequires: GConf2-devel
  22. BuildRequires: startup-notification-devel
  23. BuildRequires: gnome-desktop-devel libgnome-devel gnome-python
  24. BuildRequires: libXdamage-devel libXcomposite-devel libXres-devel
  25. BuildRequires: gettext, intltool
  26. BuildRequires: desktop-file-utils
  27. BuildRequires: pyxdg libgtop2-devel
  28. BuildRequires: libdesktop-agnostic-bin >= 0.3.91
  29. BuildRequires: libdesktop-agnostic-devel >= 0.3.91
  30. BuildRequires: vala
  31. BuildRequires: libtool
  32. Requires: gnome-python, gnome-python-gnomedesktop, pyxdg
  33. Requires: libdesktop-agnostic-bin >= 0.3.91
  34. Requires: python-desktop-agnostic >= 0.3.91
  35. Requires(pre): GConf2
  36. Requires(post): GConf2
  37. Requires(preun): GConf2
  38. %description
  39. Avant Window Navgator (Awn) is a dock-like bar which sits at the bottom of
  40. the screen (in all its composited-goodness) tracking open windows.
  41. %package devel
  42. Summary: Fully customisable dock-like window navigator for GNOME
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. This package includes all header files and library of AWN for development.
  47. %prep
  48. %setup -q -n %{name}-%{version}%{?bzr:-%{bzr}}
  49. %build
  50. intltoolize --copy --force --automake
  51. gtkdocize --copy
  52. autoreconf --force --install
  53. %configure \
  54. --disable-static \
  55. --with-gnu-ld \
  56. --with-vala \
  57. --disable-shave \
  58. ;
  59. %__sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  60. %__sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  61. %__make %{?_smp_mflags}
  62. %install
  63. %__rm -rf $RPM_BUILD_ROOT
  64. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  65. %__make install DESTDIR=$RPM_BUILD_ROOT
  66. find ${RPM_BUILD_ROOT} -name '*.la' | xargs %__rm
  67. #remove shebangs
  68. %__sed -i -e '/^#!\//, 1d' $RPM_BUILD_ROOT%{_datadir}/avant-window-navigator/awn-settings/awnSettings.py
  69. %__sed -i -e '/^#!\//, 1d' $RPM_BUILD_ROOT%{_datadir}/avant-window-navigator/awn-settings/awnSettingsHelper.py
  70. %find_lang %{name}
  71. desktop-file-install --vendor vine --delete-original \
  72. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  73. --remove-category Application \
  74. $RPM_BUILD_ROOT%{_datadir}/applications/avant-window-navigator.desktop
  75. desktop-file-install --vendor vine --delete-original \
  76. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  77. --remove-category Application \
  78. $RPM_BUILD_ROOT%{_datadir}/applications/awn-settings.desktop
  79. %pre
  80. ##obsolete schemas: awn awn-applets-shared
  81. for schema in awn awn-applets-shared; do
  82. if [ -f %{_sysconfdir}/gconf/schemas/${schema}.schemas ]; then
  83. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  84. gconftool-2 --makefile-uninstall-rule \
  85. %{_sysconfdir}/gconf/schemas/${schema}.schemas >/dev/null || :
  86. fi
  87. done
  88. %post
  89. ##upgrade schemas:
  90. ##avant-window-navigator awn-applet-taskmanager awn-applet-simple-launcher
  91. for schema in avant-window-navigator \
  92. awn-applet-taskmanager \
  93. awn-applet-simple-launcher; do
  94. if [ -f %{_sysconfdir}/gconf/schemas/${schema}.schemas ]; then
  95. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  96. gconftool-2 --makefile-install-rule \
  97. %{_sysconfdir}/gconf/schemas/${schema}.schemas >/dev/null || :
  98. fi
  99. done
  100. /sbin/ldconfig
  101. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  102. %preun
  103. if [ "$1" -eq 0 ]; then
  104. for schema in avant-window-navigator \
  105. awn-applet-taskmanager \
  106. awn-applet-simple-launcher; do
  107. if [ -f %{_sysconfdir}/gconf/schemas/${schema}.schemas ]; then
  108. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  109. gconftool-2 --makefile-uninstall-rule \
  110. %{_sysconfdir}/gconf/schemas/${schema}.schemas >/dev/null || :
  111. fi
  112. done
  113. fi
  114. %postun
  115. /sbin/ldconfig
  116. if [ $1 -eq 0 ] ; then
  117. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  118. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  119. %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  120. fi
  121. fi
  122. %posttrans
  123. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  124. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  125. fi
  126. %clean
  127. %__rm -rf $RPM_BUILD_ROOT
  128. %files -f %{name}.lang
  129. %defattr(-,root,root,-)
  130. %doc AUTHORS COPYING COPYING.LIB ChangeLog README
  131. #%doc %{_datadir}/gtk-doc/html/libawn
  132. %{_bindir}/*
  133. %{_libdir}/libawn*.so.*
  134. %dir %{_libdir}/awn
  135. %dir %{_libdir}/awn/applets
  136. %{_libdir}/awn/applets/*/*.so
  137. %config(noreplace) %{_sysconfdir}/gconf/schemas/avant-window-navigator.schemas
  138. %config(noreplace) %{_sysconfdir}/gconf/schemas/awn-applet-taskmanager.schemas
  139. %config(noreplace) %{_sysconfdir}/gconf/schemas/awn-applet-simple-launcher.schemas
  140. %{_datadir}/applications/*
  141. %dir %{_datadir}/avant-window-navigator
  142. %{_datadir}/avant-window-navigator/*
  143. %{_datadir}/icons/hicolor/*/apps/*
  144. %{_datadir}/icons/hicolor/scalable/categories/awn-plugins.svg
  145. %dir %{python_sitearch}/awn
  146. %{python_sitearch}/awn/*
  147. %files devel
  148. %defattr(-,root,root,-)
  149. %doc AUTHORS COPYING COPYING.LIB ChangeLog README
  150. %dir %{_includedir}/libawn
  151. %{_includedir}/libawn/*
  152. %{_libdir}/libawn*.so
  153. %{_libdir}/pkgconfig/*.pc
  154. %{_datadir}/pygtk/2.0/defs/awn.defs
  155. %{_datadir}/vala/vapi/awn.*
  156. %changelog
  157. * Sat Jun 18 2011 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.1-1.bzr830
  158. - updated to source 0.4.1 (bzr830) based on Fedora rawhide
  159. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.6-3
  160. - rebuild with gnome-desktop-2.26.0
  161. * Mon Feb 16 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.2.6-2
  162. - corrected *.desktop
  163. * Mon Feb 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.2.6-1
  164. - initial build
  165. * Sat Dec 20 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-14
  166. - Add missing libXres buildrequires
  167. * Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.6-13
  168. - Rebuild for Python 2.6
  169. * Thu Dec 04 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-12
  170. - Add patch to fix metacity sticky bug, #469032
  171. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.6-11
  172. - Rebuild for Python 2.6
  173. * Fri Nov 28 2008 Caol叩n McNamara <caolanm@redhat.com - 0.2.6-10
  174. - rebuild for dependencies
  175. * Sun Aug 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-9
  176. - Add patch to fix empty string in schemas file. #457683
  177. * Sat Mar 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-8
  178. - Add missing pyxdg requires
  179. * Tue Mar 20 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-6
  180. - Incorparate the python package in main, #438411
  181. * Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-3
  182. - Fix python package
  183. * Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-2
  184. - Add missing pyxdg build depenency
  185. * Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-1
  186. - New release
  187. - Re-enable gconf scriplets
  188. - Add missing scriplets
  189. - Update license
  190. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.1-3
  191. - Autorebuild for GCC 4.3
  192. * Thu Nov 04 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.2.1-2
  193. - New Release
  194. * Wed Oct 21 2007 Huang Peng <phuang@redhat.com> - 0.2-1
  195. - Update to 0.2
  196. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.1.1-4
  197. - Rebuild for selinux ppc32 issue.
  198. * Tue Jun 05 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-3
  199. - Own %%{_datadir}/avant-window-navigator
  200. * Tue Jun 05 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-2
  201. - Add missing BRs
  202. - Fix gconf scriplets
  203. * Thu May 01 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-1
  204. - Initial build