avogadro-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
  2. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  3. %define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
  4. Name: avogadro
  5. Summary: An advanced molecular editor for chemical purposes
  6. Version: 1.1.1
  7. Release: 5%{?_dist_release}
  8. Group: Applications/Editors
  9. License: GPLv2
  10. URL: http://avogadro.openmolecules.net/
  11. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  12. Patch0: avogadro-1.0.3-mkspecs-dir.patch
  13. Patch1: avogadro-1.1.1-cmake-3.x.patch
  14. Patch2: avogadro-1.1.1-Q_MOC_RUN.patch
  15. Patch3: avogadro-1.1.1-python_openbabel.patch
  16. BuildRequires: cmake >= 2.6.0
  17. BuildRequires: qt4-devel >= 4.5.1
  18. BuildRequires: qt4-tools
  19. BuildRequires: eigen2-devel >= 2.0.3
  20. BuildRequires: openbabel-devel >= 2.2.2
  21. BuildRequires: libboost-devel >= 1.35
  22. BuildRequires: libboost-python >= 1.35
  23. BuildRequires: glew-devel >= 1.5.0
  24. BuildRequires: desktop-file-utils
  25. BuildRequires: docbook-utils
  26. BuildRequires: sip-devel >= 4.11
  27. BuildRequires: numpy
  28. Requires: %{name}-libs = %{version}-%{release}
  29. %description
  30. An advanced molecular editor designed for
  31. cross-platform use in computational chemistry,
  32. molecular modeling, bioinformatics, materials science,
  33. and related areas, which offers flexible rendering and
  34. a powerful plugin architecture.
  35. %package libs
  36. Summary: Shared libraries for Avogadro
  37. Summary(ja): Avogadro の共用ライブラリ
  38. Group: System Environment/Libraries
  39. Requires: sip
  40. %description libs
  41. This package contains the shared libraries for the
  42. molecular editor Avogadro.
  43. %package devel
  44. Summary: Development files for Avogadro
  45. Summary(ja): Avogadro の開発用ファイル
  46. Group: Development/Libraries
  47. Requires: %{name}-libs = %{version}-%{release}
  48. Requires: qt4-devel = %{_qt4_version}
  49. Requires: eigen2-devel >= 2.0.3
  50. Requires: glew-devel >= 1.5.0
  51. Requires: pkgconfig
  52. %description devel
  53. This package contains files to develop applications using
  54. Avogadros libraries.
  55. %prep
  56. %setup -q
  57. %patch0 -p1 -b .mkspecs-dir
  58. %patch1 -p1 -b .cmake3x
  59. %patch2 -p1 -b .Q_MOC_RUN
  60. %patch3 -p1 -b .python_openbabel
  61. %build
  62. mkdir -p %{_target_platform}
  63. pushd %{_target_platform}
  64. %cmake -Wno-dev \
  65. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  66. -DBIN_INSTALL_DIR:PATH=bin \
  67. -DLIB_INSTALL_DIR:PATH=%{_lib} \
  68. -DENABLE_GLSL:BOOL=ON \
  69. -DENABLE_PYTHON:BOOL=ON \
  70. -DENABLE_RPATH:BOOL=OFF \
  71. -DENABLE_VERSIONED_PLUGIN_DIR:BOOL=OFF \
  72. %{?ENABLE_TESTS} ..
  73. popd
  74. make %{?_smp_mflags} -C %{_target_platform}
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  78. %check
  79. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
  80. # all of these currently require an active X session, so will fail
  81. # in mock
  82. %{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
  83. %post libs -p /sbin/ldconfig
  84. %postun libs -p /sbin/ldconfig
  85. %files
  86. %defattr(-,root,root,-)
  87. %doc AUTHORS ChangeLog COPYING
  88. %{_bindir}/avogadro
  89. %{_bindir}/avopkg
  90. # TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
  91. %{_datadir}/avogadro/
  92. %{_datadir}/pixmaps/avogadro-icon.png
  93. %{_datadir}/applications/avogadro.desktop
  94. %{_mandir}/man1/avogadro.1*
  95. %{_mandir}/man1/avopkg.1*
  96. %files devel
  97. %defattr(-,root,root,-)
  98. %{_includedir}/avogadro/
  99. %{_libdir}/libavogadro.so
  100. %{_libdir}/libavogadro_OpenQube.so
  101. %{_libdir}/avogadro/*.cmake
  102. %{_libdir}/avogadro/cmake/
  103. %{_libdir}/pkgconfig/avogadro.pc
  104. %{_qt4_prefix}/mkspecs/features/avogadro.prf
  105. %files libs
  106. %defattr(-,root,root,-)
  107. %{python_sitearch}/Avogadro.so
  108. %{_datadir}/libavogadro/
  109. %{_libdir}/libavogadro.so.*
  110. %{_libdir}/libavogadro_OpenQube.so.*
  111. %dir %{_libdir}/avogadro/
  112. %{_libdir}/avogadro/colors/
  113. %{_libdir}/avogadro/extensions/
  114. %{_libdir}/avogadro/engines/
  115. %{_libdir}/avogadro/tools/
  116. %changelog
  117. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 1.1.1-5
  118. - rebuild with libboost-1.66.0
  119. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-4
  120. - rebuild with gcc-5.4.0
  121. - add patches from fc
  122. - Patch2 (avogadro-1.1.1-Q_MOC_RUN.patch)
  123. - Patch3 (avogadro-1.1.1-python_openbabel.patch)
  124. * Thu May 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-3
  125. - rebuild with qt4-4.8.7
  126. - add Patch1 (avogadro-1.1.1-cmake-3.x.patch)
  127. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-2
  128. - rebuild with glew-1.13.0
  129. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
  130. - update to 1.1.1
  131. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
  132. - update to 1.0.3
  133. - remove old patches
  134. - add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
  135. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
  136. - rebuild with qt4-4.8.5
  137. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
  138. - rebuild with qt4-4.8.3
  139. * Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
  140. - rebuild with qt4-4.8.2
  141. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
  142. - rebuild with python-2.7.2
  143. * Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
  144. - rebuild with qt4-4.8.0 and glew-1.7.0
  145. * Wed Mar 9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
  146. - rebuilt with qt4-4.7.2
  147. - BR: qt4-tools instead of qt4-designer
  148. * Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
  149. - added BR: libboost-python
  150. - added R: glew-devel, eigen2-devel to devel package
  151. * Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
  152. - rebuilt with qt4-4.7.1
  153. - added Patch0 and 1 from Fedora
  154. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
  155. - rebuilt with libboost-1.45.0
  156. * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
  157. - Initial build for Vine Linux
  158. * Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
  159. - Rebuild for Boost soname bump
  160. - Update to match current guidelines
  161. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
  162. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  163. * Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
  164. - avogadro-1.0.1
  165. - -devel: move cmake-related files here
  166. - -devel: Req: qt4-devel
  167. - %%files: track lib sonames
  168. - %%check section
  169. * Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
  170. - reenable plugin builds and libs subpackage
  171. - fix their build with sip 4.10
  172. * Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
  173. - disable plugin builds and libs subpackage
  174. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
  175. - rebuild (sip)
  176. * Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
  177. - rebuild (for qt-4.6.0-rc1, f13+)
  178. * Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
  179. - -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
  180. - Requires: %%{name}-libs ...
  181. * Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
  182. - update to new upstream release
  183. * Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
  184. - rebuild (eigen2)
  185. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
  186. - fix typo in file list
  187. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
  188. - update to new upstream release
  189. - enable python and glsl support again
  190. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  192. * Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
  193. - new upstream release to fix issue with qt 4.5.0 and earlier
  194. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
  195. - remove remaining python parts
  196. - fix files section finally
  197. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
  198. - disable python and glsl for now
  199. - fix files section
  200. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
  201. - update to new release
  202. * Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
  203. - update to new release
  204. * Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
  205. - update to new release
  206. * Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
  207. - get desktop file properly installed
  208. * Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
  209. - update to new release
  210. * Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
  211. - update to new release
  212. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
  213. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  214. * Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
  215. - update to new release
  216. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
  217. - add handbook to docs
  218. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
  219. - add build requirements and fix group names
  220. * Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
  221. - fix typos
  222. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
  223. - reorganize spec file
  224. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
  225. - rename shared library package and structure spec file
  226. * Sun Aug 3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
  227. - initial pacakging release based on PackMan release