bash-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610
  1. %define bashversion 5.0
  2. %define patchlevel 18
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: daisuke
  12. License: GPLv3+
  13. Source0: http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-001
  17. Patch2: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-002
  18. Patch3: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-003
  19. Patch4: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-004
  20. Patch5: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-005
  21. Patch6: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-006
  22. Patch7: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-007
  23. Patch8: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-008
  24. Patch9: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-009
  25. Patch10: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-010
  26. Patch11: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-011
  27. Patch12: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-012
  28. Patch13: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-013
  29. Patch14: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-014
  30. Patch15: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-015
  31. Patch16: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-016
  32. Patch17: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-017
  33. Patch18: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-018
  34. # Other patches
  35. #Patch101: bash-2.02-security.patch
  36. Patch102: bash-2.03-paths.patch
  37. Patch103: bash-2.03-profile.patch
  38. Patch104: bash-2.05a-interpreter.patch
  39. Patch105: bash-2.05b-debuginfo.patch
  40. #Patch106: bash-2.05b-manso.patch
  41. Patch107: bash-2.05b-pgrp_sync.patch
  42. #Patch108: bash-2.05b-readline-oom.patch
  43. #Patch109: bash-2.05b-xcc.patch
  44. Patch110: bash-3.2-audit.patch
  45. Patch111: bash-3.2-ssh_source_bash.patch
  46. #Patch112: bash-bashbug.patch
  47. Patch113: bash-infotags.patch
  48. Patch114: bash-requires.patch
  49. Patch115: bash-setlocale.patch
  50. Patch116: bash-tty-tests.patch
  51. # 484809, check if interp section is NOBITS
  52. Patch117: bash-4.0-nobits.patch
  53. # Do the same CFLAGS in generated Makefile in examples
  54. Patch118: bash-4.1-examples.patch
  55. # Builtins like echo and printf won't report errors
  56. # when output does not succeed due to EPIPE
  57. Patch119: bash-4.1-broken_pipe.patch
  58. # Enable system-wide .bash_logout for login shells
  59. Patch120: bash-4.2-rc2-logout.patch
  60. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  61. Patch121: bash-4.2-coverity.patch
  62. # Don't call malloc in signal handler
  63. #Patch122: bash-4.1-defer-sigchld-trap.patch
  64. # 799958, updated info about trap
  65. Patch123: bash-4.2-manpage_trap.patch
  66. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  67. Patch125: bash-4.2-size_type.patch
  68. # 1112710 - mention ulimit -c and -f POSIX block size
  69. Patch128: bash-4.3-man-ulimit.patch
  70. # A series of patches emitted by upstream since 4.3-18
  71. #Patch134: bash-4.3-pathexp-globignore-delim.patch
  72. # 1102815 - fix double echoes in vi visual mode
  73. Patch135: bash-4.3-noecho.patch
  74. # 1182278 - bash crashes on `select' if REPLY is readonly
  75. #Patch137: bash-4.3-select-readonly.patch
  76. #1241533,1224855 - bash leaks memory when LC_ALL set
  77. Patch138: bash-4.3-memleak-lc_all.patch
  78. #1245233 - old memleak reappeared, taken from upstream
  79. #Patch139: bash-4.3-old-memleak.patch
  80. # bash-4.4 builds loadable builtin examples by default
  81. # this patch disables it
  82. Patch140: bash-4.4-no-loadable-builtins.patch
  83. Buildroot: %{_tmppath}/%{name}-%{version}-root
  84. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  85. Obsoletes: bash <= 1.14.7
  86. Obsoletes: bash2
  87. %description
  88. Bash is a GNU project sh-compatible shell or command language
  89. interpreter. Bash (Bourne Again shell) incorporates useful features
  90. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  91. can be run by bash without modification.
  92. Bash offers several improvements over sh, including command line
  93. editing, unlimited size command history, job control, shell
  94. functions and aliases, indexed arrays of unlimited size and
  95. integer arithmetic in any base from two to 64. Bash is ultimately
  96. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  97. Tools standard.
  98. %package doc
  99. Summary: Documentation for the GNU Bourne Again shell (bash).
  100. Summary(ja): GNU Bourne Again シェル向けドキュメント
  101. Group: documentation
  102. Requires: %{name} = %{version}-%{release}
  103. Obsoletes: bash2-doc
  104. %description doc
  105. This is a separate documentation package for the GNU Bourne
  106. Again shell.
  107. %debug_package
  108. %prep
  109. %setup -q -n %{name}-%{bashversion}
  110. # Official upstream patches
  111. %patch1 -p0 -b .001
  112. %patch2 -p0 -b .002
  113. %patch3 -p0 -b .003
  114. %patch4 -p0 -b .004
  115. %patch5 -p0 -b .005
  116. %patch6 -p0 -b .006
  117. %patch7 -p0 -b .007
  118. %patch8 -p0 -b .008
  119. %patch9 -p0 -b .009
  120. %patch10 -p0 -b .010
  121. %patch11 -p0 -b .011
  122. %patch12 -p0 -b .012
  123. %patch13 -p0 -b .013
  124. %patch14 -p0 -b .014
  125. %patch15 -p0 -b .015
  126. %patch16 -p0 -b .016
  127. %patch17 -p0 -b .017
  128. %patch18 -p0 -b .018
  129. # Other patches
  130. %patch102 -p1 -b .paths
  131. %patch103 -p1 -b .profile
  132. %patch104 -p1 -b .interpreter
  133. %patch105 -p1 -b .debuginfo
  134. %patch107 -p1 -b .pgrp_sync
  135. %patch110 -p1 -b .audit
  136. %patch111 -p1 -b .ssh_source_bash
  137. %patch113 -p1 -b .infotags
  138. %patch114 -p1 -b .requires
  139. %patch115 -p1 -b .setlocale
  140. %patch116 -p1 -b .tty_tests
  141. %patch117 -p1 -b .nobits
  142. %patch118 -p1 -b .examples
  143. %patch119 -p1 -b .broken_pipe
  144. %patch120 -p1 -b .logout
  145. %patch121 -p1 -b .coverity
  146. %patch123 -p1
  147. %patch125 -p1 -b .size_type
  148. %patch128 -p1 -b .ulimit
  149. %patch135 -p1 -b .noecho
  150. %patch138 -p1 -b .lc_all
  151. %patch140 -p1 -b .no_loadable_builtin
  152. echo %{version} > _distribution
  153. echo %{release} |sed 's/vl.*//' > _patchlevel
  154. %build
  155. %configure --with-bash-malloc=no
  156. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  157. %install
  158. rm -rf %{buildroot}
  159. # Fix bug #83776
  160. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  161. make DESTDIR=$RPM_BUILD_ROOT install
  162. pushd $RPM_BUILD_ROOT
  163. mkdir ./bin
  164. mv ./usr/bin/bash ./bin/bash
  165. ln -s bash ./bin/sh
  166. rm -f .%{_infodir}/dir
  167. popd
  168. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  169. # make manpages for bash builtins as per suggestion in DOC/README
  170. pushd doc
  171. sed -e '
  172. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  173. /^\.SH NAME/d
  174. s/^bash, //
  175. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  176. s/,//g
  177. b
  178. }
  179. d
  180. ' builtins.1 > man.pages
  181. for i in echo pwd test kill; do
  182. perl -pi -e "s,$i,,g" man.pages
  183. perl -pi -e "s, , ,g" man.pages
  184. done
  185. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  186. for i in `cat man.pages` ; do
  187. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  188. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  189. done
  190. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  191. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  192. # Not for printf, false and true (conflict with coreutils)
  193. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  194. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  195. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  196. popd
  197. %find_lang %{name}
  198. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  199. %clean
  200. rm -rf %{buildroot}
  201. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  202. # to prevent prereq loops
  203. # post is in lua so that we can run it without any external deps. Helps
  204. # for bootstrapping a new install.
  205. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  206. %post -p <lua>
  207. bashfound = false;
  208. shfound = false;
  209. f = io.open("/etc/shells", "r");
  210. if f == nil
  211. then
  212. f = io.open("/etc/shells", "w");
  213. else
  214. repeat
  215. t = f:read();
  216. if t == "/bin/bash"
  217. then
  218. bashfound = true;
  219. end
  220. if t == "/bin/sh"
  221. then
  222. shfound = true;
  223. end
  224. until t == nil;
  225. end
  226. f:close()
  227. f = io.open("/etc/shells", "a");
  228. if not bashfound
  229. then
  230. f:write("/bin/bash\n")
  231. end
  232. if not shfound
  233. then
  234. f:write("/bin/sh\n")
  235. end
  236. f:close()
  237. %files -f %{name}.lang
  238. %defattr(-,root,root)
  239. %license COPYING
  240. %doc CHANGES
  241. %doc examples
  242. %config(noreplace) /etc/bashrc
  243. /bin/bash
  244. /bin/sh
  245. %{_infodir}/bash.info*
  246. %{_mandir}/*/*
  247. %{_mandir}/*/..1*
  248. %{_bindir}/bashbug
  249. %files doc
  250. %defattr(-,root,root)
  251. %doc COMPAT NEWS NOTES POSIX RBASH
  252. %doc examples/functions/ examples/misc/
  253. %doc examples/scripts*/
  254. %doc examples/startup-files/ examples/complete/ examples/loadables/
  255. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  256. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  257. %changelog
  258. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.18-1
  259. - updated to 5.0 patch level 18.
  260. * Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  261. - updated to 5.0 patch level 16.
  262. * Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
  263. - updated to 5.0 patch level 11.
  264. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  265. - updated to 5.0 patch level 9.
  266. - dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
  267. - imported Patch140 from rawhide.
  268. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
  269. - updated to 4.3 patch level 46.
  270. * Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
  271. - updated to 4.3 patch level 42.
  272. - imported patch 128-139 from RawHide.
  273. * Fri Oct 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
  274. - updated to 4.3 patch level 29.
  275. - removed patch1000 (included in 4.3.26).
  276. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
  277. - added patch1000 to fix CVE-2014-7169.
  278. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  279. - updated to 4.3 patch level 25.
  280. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  281. - update to 4.3 patch level 18
  282. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  283. - update to 4.3 patch level 11
  284. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  285. - update to 4.2 patch level 45
  286. - import some patch from fedora package (122-127)
  287. - patch122: Don't call malloc in signal handler
  288. - patch123: #799958, updated info about trap
  289. - patch124: #695656, block the signal and unblock it after the
  290. new handler is installed
  291. - patch125: Use unsigned type for size
  292. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  293. - patch126: #903833, Fix missing close(), fixes fd leaks
  294. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  295. - remove postun lua script because bash will be never uninstalled
  296. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  297. - update to 4.2 patch level 37
  298. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  299. - update to 4.2 patch level 20
  300. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  301. - update to 4.2 patch level 8
  302. - use lua script in post/postun
  303. - update patches from fedora
  304. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  305. - update to 4.1 patch level 7
  306. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  307. - check if /bin/grep exists on %%post script
  308. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  309. - rebuilt with gcc-4.4.3-3 on ppc
  310. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  311. - rebuilt with new toolchain
  312. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  313. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  314. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  315. - add Requires(post): grep
  316. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  317. - remove obsolete /bin/bash2 entry from /etc/shells
  318. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  319. - add Requires(post): ncurses (should be added by find-requires..)
  320. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  321. - add upstream patch (from 040 to 048)
  322. - build against ncurses-devel (libtinfo)
  323. - spec in utf-8
  324. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  325. - added upstream patch (from 026 to 039)
  326. - added Japanese summary
  327. - applied new versioning policy
  328. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  329. - rebuilt with libtermcap-devel
  330. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  331. - new upstream release
  332. - add upstream patch (from 001 to 025)
  333. - remove Provides: bash2
  334. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  335. - rebuilt with new toolchain
  336. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  337. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  338. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  339. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  340. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  341. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  342. - update to 2.05b
  343. - rebuild with new toolchains
  344. - add make check
  345. - add %postun script based on Fedora development
  346. - README file moved doc package
  347. - update Patch5 and Patch8 from Fedora development
  348. - change Patch6
  349. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  350. - add Patch11--39 from Fedora development 2.05b-36
  351. * Tim Waugh <twaugh@redhat.com>
  352. - Fix parameter expansion in multibyte locales (bug #112657).
  353. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  354. bug #110777).
  355. - Apply upstream patches (bug #109269 among others).
  356. - Fix bash.info (bug #83776).
  357. - Add bash205b-007 patch to fix bug #106876.
  358. - Avoid crashing on multibyte input when locale is set incorrectly
  359. (bug #74266).
  360. - LFS support (bug #103627).
  361. - Fix completion display when multibyte or control characters are to be
  362. shown (bug #90201).
  363. - Fix a warning message (bug #79629).
  364. - Don't build with AFS support (bug #86514).
  365. - Don't explicitly strip binaries (bug #85995).
  366. - Really fix bug #83331 for good.
  367. - Fix builtins.1.
  368. - Actually apply the patch (bug #83331).
  369. - Fix history/UTF-8 bug (bug #83331).
  370. - More tab-completion fixing (bug #72512).
  371. - Force pgrp synchronization (bug #81653).
  372. - Prevent prompt overwriting output (bug #74383).
  373. - Fix '-rbash' (bug #78455).
  374. - Add readline-init patch (bug #74925).
  375. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  376. - Ship '.' man page, which doesn't get picked up by glob.
  377. - Locale shell variables fix (bug #74701).
  378. * Elliot Lee <sopwith@redhat.com>
  379. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  380. cross compiles.
  381. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  382. - update to 2.05
  383. - add README.jpatch to %doc
  384. - remove patch4 (bash2): revert command name in man pages to "bash"
  385. - fix perl command to remove man pages conflict with sh-utils
  386. - remove section of config.h.in from patch0 to prevent remake of configure
  387. - change patch9: define in config-top.h to avoid conflict with patch100
  388. - remove patches 7, 10 & 101
  389. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  390. - made a link for man sh
  391. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  392. - added missing %%post and %%triggerpostun section
  393. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  394. - 2.04-1vl12
  395. - now bash2 is finally bash
  396. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  397. - build for Playstation2
  398. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  399. - 2.04-1vl10
  400. - Provides: bash = %%{version}
  401. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  402. - added Provides: bash
  403. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  404. - Obsoletes: bash
  405. - changed Copyright to License
  406. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  407. - 2.04-1vl7
  408. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  409. - corrected: bashrc-vine -> bashrc
  410. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  411. - combined bash-1.x and bash-2.x packages
  412. - added some patches from bash-2.04-13mdk
  413. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  414. - fix spec macros
  415. - added tests
  416. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  417. - build with gcc-2.95.3
  418. - partially used rpmmacros
  419. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  420. - minor bug fix in spec file
  421. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  422. - 2.04-1vl3
  423. - modified %install and %files section to handle compressed man page(s)
  424. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  425. - added pcomplete patch to fix complete if the candidate list is NULL.
  426. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  427. - updated to 2.04
  428. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  429. - Remove annoying ^H's from documentation
  430. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  431. - patch to detect what executables are required by a script.
  432. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  433. - auto rebuild in the new build environment (release 4)
  434. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  435. - strip binaries.
  436. - include bash-doc correctly.
  437. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  438. - fixed post/postun /etc/shells work.
  439. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  440. - updated again text in the spec file
  441. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  442. - updated text in spec file.
  443. - update to 2.03.
  444. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  445. - build it as bash2 instead of bash
  446. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  447. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  448. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  449. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  450. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  451. - patch for the arm
  452. - use $RPM_ARCH-redhat-linux as the build target
  453. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  454. - rewrite %pre, axe %postun (to avoid prereq loops)
  455. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  456. - resurrect for RH 6.0.
  457. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  458. - update to 2.02.1
  459. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  460. - Package for 5.2.
  461. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  462. - added POSIX.NOTES doc file
  463. - some extraneous doc files removed
  464. - minor .spec file changes
  465. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  466. - upgraded to version 2.02
  467. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  468. - glibc & signal patches no longer required
  469. - added documentation subpackage (doc)
  470. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  471. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  472. is based on a change made in bash 2.0. Should fix some early exit
  473. problems with suspends and fg.
  474. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  475. - added %clean
  476. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  477. - added comment explaining why install-info isn't used
  478. - added mips patch
  479. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  480. - added BuildRoot
  481. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  482. - built against glibc