bbdb-vl.spec 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  4. Summary: Rolodex-like database program for GNU Emacs
  5. Summary(ja): Emacs 用のローロデックス風データベースプログラム
  6. Name: bbdb
  7. Version: 2.32
  8. Release: 1%{?_dist_release}
  9. Source0: ftp://ftp.win.or.jp/pub/word/elisp/%{name}-%{version}.tar.gz
  10. Source1: %{name}-install.sh
  11. Source2: %{name}-remove.sh
  12. Source3: emacs-wl-bbdb.sample
  13. Patch0: bbdb-2.32-misc.patch
  14. Patch1: bbdb-2.32-emacsen.patch
  15. License: GPL
  16. Group: Applications/Editors/Emacs
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildArch: noarch
  19. PreReq: emacsen, make, install-info
  20. %prereq_ge emacsen-common
  21. BuildRequires: emacsen-common
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  25. %description
  26. BBDB is a rolodex-like database program for GNU Emacs. BBDB stands
  27. for Insidious Big Brother Database, and is not, repeat, *not* an
  28. obscure reference to the Buck Rogers TV series.
  29. %prep
  30. %setup -q
  31. %patch0 -p1
  32. %patch1 -p1
  33. cp %{SOURCE3} .
  34. find . -type f -name .cvsignore -print | xargs rm -f
  35. find . -type f -name *.orig -print | xargs rm -f
  36. %build
  37. ./configure --with-package-dir=""
  38. chmod -x utils/*.pl
  39. %install
  40. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  41. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  42. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  43. #mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/{install,remove}
  44. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/{install,remove}
  45. mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
  46. #
  47. # install el files
  48. #
  49. cp -af Makefile lisp tex utils \
  50. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  51. rm -f ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/*/Makefile.in
  52. #
  53. # install info
  54. #
  55. install -m 644 texinfo/bbdb.info* ${RPM_BUILD_ROOT}%{_infodir}
  56. gzip -9 ${RPM_BUILD_ROOT}%{_infodir}/bbdb.info*
  57. #
  58. # install script( bytecompile el and install elc , remove )
  59. #
  60. %_installemacsenscript %{name} %{SOURCE1}
  61. %_removeemacsenscript %{name} %{SOURCE2}
  62. %post
  63. #
  64. # bytecompile and install
  65. #
  66. if [ "$1" = 2 ]; then
  67. %_emacsenPackageRemove %{name}
  68. fi
  69. %_addemacsenlist %{name}
  70. %_emacsenPackageInstall %{name}
  71. /sbin/install-info --info-file=%{_infodir}/bbdb.info.gz --info-dir=%{_infodir} --section="Emacs"
  72. %preun
  73. if [ "$1" = 0 ]; then
  74. %_emacsenPackageRemove %{name}
  75. %_removeemacsenlist %{name}
  76. /sbin/install-info --delete %{_infodir}/bbdb.info.gz %{_infodir}/dir
  77. fi
  78. %clean
  79. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  80. %files
  81. %defattr(-,root,root)
  82. %doc ChangeLog INSTALL emacs-wl-bbdb.sample
  83. %{_datadir}/emacs/site-lisp/%{name}/
  84. %{emacsen_pkgdir}/install/%{name}
  85. %{emacsen_pkgdir}/remove/%{name}
  86. %{_infodir}/*
  87. %changelog
  88. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.32-1vl5
  89. - applied new versioning policy, spec in utf-8
  90. - added macro %%emacsen_pkgdir
  91. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.32-0vl3
  92. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  93. - s/Copyright/License/
  94. * Sun May 26 2002 MATUBARA Kazuyuki <matubara@kamome.or.jp> 2.32-0vl2
  95. - delete xemacs message to ddskk-install.sh
  96. * Sun Mar 03 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 2.32-0vl1
  97. - 1st packageing