bcel-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272
  1. # Copyright (c) 2000-2007, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. Name: bcel
  31. Version: 5.2
  32. Release: 8%{?_dist_release}
  33. Summary: Byte Code Engineering Library
  34. License: ASL 2.0
  35. Group: Development/Libraries
  36. URL: http://commons.apache.org/proper/commons-bcel/
  37. Source0: %{name}-%{version}.tar.gz
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. BuildArch: noarch
  40. Requires: regexp
  41. #Requires(post): javapackages-tools >= 1.7.2
  42. #Requires(postun): javapackages-tools >= 1.7.2
  43. %description
  44. The Byte Code Engineering Library (formerly known as JavaClass) is
  45. intended to give users a convenient possibility to analyze, create, and
  46. manipulate (binary) Java class files (those ending with .class). Classes
  47. are represented by objects which contain all the symbolic information of
  48. the given class: methods, fields and byte code instructions, in
  49. particular. Such objects can be read from an existing file, be
  50. transformed by a program (e.g. a class loader at run-time) and dumped to
  51. a file again. An even more interesting application is the creation of
  52. classes from scratch at run-time. The Byte Code Engineering Library
  53. (BCEL) may be also useful if you want to learn about the Java Virtual
  54. Machine (JVM) and the format of Java .class files. BCEL is already
  55. being used successfully in several projects such as compilers,
  56. optimizers, obsfuscators and analysis tools, the most popular probably
  57. being the Xalan XSLT processor at Apache.
  58. %package javadoc
  59. Summary: Javadoc for %{name}
  60. Summary(ja): %{name} の Javadoc
  61. Group: Documentation
  62. %description javadoc
  63. %{summary}.
  64. %package manual
  65. Summary: Manual for %{name}
  66. Summary(ja): %{name} のマニュアル
  67. Group: Documentation
  68. %description manual
  69. %{summary}.
  70. %prep
  71. %setup -q
  72. #cat <<EOT
  73. #
  74. # This is initial build for Vine Linux.
  75. # Binary archive is provided.
  76. #
  77. #EOT
  78. # fix wrong-file-end-of-line-encoding
  79. #sed -i 's/\r//' docs/verifier/V_API_SD.eps docs/eps/classloader.fig
  80. %build
  81. # nothing to do
  82. %install
  83. rm -rf %{buildroot}
  84. # jars
  85. mkdir -p %{buildroot}%{_javadir}
  86. install -m 0644 %{name}-%{version}.jar \
  87. %{buildroot}%{_javadir}/%{name}-%{version}.jar
  88. (
  89. cd %{buildroot}%{_javadir}
  90. for jar in *-%{version}*; do
  91. ln -s ${jar} `echo $jar | %{__sed} "s|-%{version}||g"`
  92. done
  93. )
  94. # javadoc
  95. mkdir -p %{buildroot}%{_javadocdir}/%{name}-%{version}
  96. cp -pr docs/apidocs/* %{buildroot}%{_javadocdir}/%{name}-%{version}
  97. rm -rf docs/apidocs
  98. ln -s %{name}-%{version} %{buildroot}%{_javadocdir}/%{name}
  99. # manual
  100. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}
  101. cp -pr docs/* %{buildroot}%{_docdir}/%{name}-%{version}
  102. #cp -p LICENSE.txt %{buildroot}%{_docdir}/%{name}-%{version}
  103. %clean
  104. rm -rf %{buildroot}
  105. %files
  106. %defattr(0644,root,root,0755)
  107. %doc LICENSE.txt
  108. #doc %{_docdir}/%{name}-%{version}
  109. #doc %{_docdir}/%{name}-%{version}/LICENSE.txt
  110. %{_javadir}/*
  111. #{_datadir}/maven2/poms/*
  112. #{_mavendepmapfragdir}
  113. %files javadoc
  114. %defattr(0644,root,root,0755)
  115. %{_javadocdir}/%{name}-%{version}
  116. %doc %{_javadocdir}/%{name}
  117. %files manual
  118. %defattr(0644,root,root,0755)
  119. %doc %{_docdir}/%{name}-%{version}
  120. %changelog
  121. * Fri Mar 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.2-8
  122. - Initial build for Vine Linux
  123. * Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 0:5.2-7.2
  124. - Rebuilt for RHEL 6
  125. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:5.2-7.1
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  127. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:5.2-6.1
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  129. * Thu Dec 04 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-5.1
  130. - Do not install poms in /usr/share/maven2/default_poms
  131. * Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:5.2-5
  132. - drop repotag
  133. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:5.2-4jpp.2
  134. - Autorebuild for GCC 4.3
  135. * Tue Jan 22 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-3jpp.1
  136. - Merge with upstream
  137. * Mon Jan 07 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-2jpp.2
  138. - Fixed unowned directory (Bugzilla 246185)
  139. * Fri Nov 16 2007 Ralph Apel <r.apel@r-apel.de> 0:5.2-3jpp
  140. - Install poms unconditionally
  141. - Add pom in ./maven2/default_poms
  142. - Add org.apache.bcel:bcel depmap frag
  143. * Wed Sep 19 2007 Permaine Cheung <pcheung at redhat.com> 0:5.2-2jpp.1
  144. - Update to 5.2 in Fedora
  145. * Mon Sep 4 2007 Jason Corley <jason.corley@gmail.com> 0:5.2-2jpp
  146. - use official 5.2 release tarballs and location
  147. - change vendor and distribution to macros
  148. - add missing requires on and maven-plugin-test, maven-plugins-base, and
  149. maven-plugin-xdoc
  150. - macro bracket fixes
  151. - remove demo subpackage (examples are not included in the distribution tarball)
  152. - build in mock
  153. * Wed Jun 27 2007 Ralph Apel <r.apel@r-apel.de> 0:5.2-1jpp
  154. - Upgrade to 5.2
  155. - Drop bootstrap option: not necessary any more
  156. - Add pom and depmap frags
  157. * Fri Feb 09 2007 Ralph Apel <r.apel@r-apel.de> 0:5.1-10jpp
  158. - Fix empty-%%post and empty-%%postun
  159. - Fix no-cleaning-of-buildroot
  160. * Fri Feb 09 2007 Ralph Apel <r.apel@r-apel.de> 0:5.1-9jpp
  161. - Optionally build without maven
  162. - Add bootstrap option
  163. * Thu Aug 10 2006 Matt Wringe <mwringe at redhat.com> 0:5.1-8jpp
  164. - Add missing requires for Javadoc task
  165. * Sun Jul 23 2006 Matt Wringe <mwringe at redhat.com> 0:5.1-7jpp
  166. - Add conditional native compilation
  167. - Change spec file encoding from ISO-8859-1 to UTF-8
  168. - Add missing BR werken.xpath and ant-apache-regexp
  169. * Tue Apr 11 2006 Ralph Apel <r.apel@r-apel.de> 0:5.1-6jpp
  170. - First JPP-1.7 release
  171. - Use tidyed sources from svn
  172. - Add resources to build the manual
  173. - Add examples to -demo subpackage
  174. - Build with maven by default
  175. - Add option to build with straight ant
  176. * Fri Nov 19 2004 David Walluck <david@jpackage.org> 0:5.1-5jpp
  177. - rebuild to fix packager
  178. * Sat Nov 06 2004 David Walluck <david@jpackage.org> 0:5.1-4jpp
  179. - rebuild with javac 1.4.2
  180. * Sat Oct 16 2004 David Walluck <david@jpackage.org> 0:5.1-3jpp
  181. - rebuild for JPackage 1.6
  182. * Fri Aug 20 2004 Ralph Apel <r.apel at r-apel.de> 0:5.1-2jpp
  183. - Build with ant-1.6.2
  184. * Sun May 11 2003 David Walluck <david@anti-microsoft.org> 0:5.1-1jpp
  185. - 5.1
  186. - update for JPackage 1.5
  187. * Mon Mar 24 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> - 5.0-6jpp
  188. - For jpackage-utils 1.5
  189. * Tue Feb 25 2003 Ville Skyttä <ville.skytta at iki.fi> - 5.0-5jpp
  190. - Rebuild to get docdir right on modern distros.
  191. - Fix License tag and source file perms.
  192. - Built with IBM's 1.3.1SR3 (doesn't build with Sun's 1.4.1_01).
  193. * Tue Jun 11 2002 Henri Gomez <hgomez@slib.fr> 5.0-4jpp
  194. - use sed instead of bash 2.x extension in link area to make spec compatible
  195. with distro using bash 1.1x
  196. * Tue May 07 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 5.0-3jpp
  197. - vendor, distribution, group tags
  198. * Wed Jan 23 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 5.0-2jpp
  199. - section macro
  200. - no dependencies for manual and javadoc package
  201. * Tue Jan 22 2002 Henri Gomez <hgomez@slib.fr> 5.0-1jpp
  202. - bcel is now a jakarta apache project
  203. - dependency on jakarta-regexp instead of gnu.regexp
  204. - created manual package
  205. * Sat Dec 8 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.1-2jpp
  206. - javadoc into javadoc package
  207. - Requires: and BuildRequires: gnu.regexp
  208. * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 4.4.1-1jpp
  209. - removed packager tag
  210. - new jpp extension
  211. - 4.4.1
  212. * Thu Oct 11 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.0-2jpp
  213. - first unified release
  214. - used lower case for name
  215. - used original tarball
  216. - s/jPackage/JPackage
  217. * Mon Aug 27 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.0-1mdk
  218. - first Mandrake release