beecrypt-vl.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define with_python --with-python
  3. %define with_python_version %(echo `python -c "import sys; print sys.version[:3]"`)
  4. #define with_java --with-java
  5. Summary: An open source cryptography library.
  6. Name: beecrypt
  7. Version: 4.2.1
  8. Release: 1%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: LGPL
  11. URL: http://sourceforge.net/projects/beecrypt
  12. Source0: http://prdownloads.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
  13. Source1: http://prdownloads.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz.sig
  14. Patch0: beecrypt-4.1.2-biarch.patch
  15. Patch1: beecrypt-4.2.1-no-c++.patch
  16. #BuildRequires: doxygen
  17. %if %{?with_python:1}0
  18. BuildRequires: python-devel >= %{with_python_version}
  19. %endif
  20. BuildRoot: %{_tmppath}/%{name}-root
  21. Obsoletes: beecrypt-java =< 4.1.2-2
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. Beecrypt is a general-purpose cryptography library.
  26. %package devel
  27. Summary: Files needed for developing applications with beecrypt.
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. %description devel
  31. Beecrypt is a general-purpose cryptography library. This package contains
  32. files needed for developing applications with beecrypt.
  33. ## to build compat32 for x86_64 architecture support
  34. %package -n compat32-%{name}
  35. Summary: An open source cryptography library.
  36. Group: System Environment/Libraries
  37. #BuildPreReq: doxygen
  38. %description -n compat32-%{name}
  39. Beecrypt is a general-purpose cryptography library.
  40. %package -n compat32-%{name}-devel
  41. Summary: Files needed for developing applications with beecrypt.
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. %description -n compat32-%{name}-devel
  45. Beecrypt is a general-purpose cryptography library. This package contains
  46. files needed for developing applications with beecrypt.
  47. %if %{?with_python:1}0
  48. %package python
  49. Summary: Files needed for python applications using beecrypt.
  50. Group: Development/Libraries
  51. Requires: python >= %{with_python_version}
  52. Requires: %{name} = %{version}-%{release}
  53. %description python
  54. Beecrypt is a general-purpose cryptography library. This package contains
  55. files needed for using python with beecrypt.
  56. %endif
  57. %if %{?with_java:1}0
  58. %package java
  59. Summary: Files needed for java applications using beecrypt.
  60. Group: Development/Libraries
  61. Requires: %{name} = %{version}-%{release}
  62. %description java
  63. Beecrypt is a general-purpose cryptography library. This package contains
  64. files needed for using java with beecrypt.
  65. %endif
  66. %prep
  67. %setup -q
  68. %patch0 -p1 -b .biarch
  69. %patch1 -p1 -b .no-c++
  70. libtoolize
  71. autoreconf -i
  72. %build
  73. export PYTHON=`which python`
  74. %configure \
  75. %{?with_python}%{!?with_python:--with-python=no} \
  76. %{?with_java}%{!?with_java:--with-java=no} \
  77. --with-cplusplus=no
  78. make %{?_smp_mflags} \
  79. %{?with_python:pythondir="%{python_sitelib}"}
  80. #doxygen
  81. %check
  82. make check || :
  83. %install
  84. rm -fr $RPM_BUILD_ROOT
  85. make install DESTDIR=$RPM_BUILD_ROOT \
  86. %{?with_python:pythondir="%{python_sitelib}"}
  87. iconv -f ISO-8859-1 -t UTF-8 CONTRIBUTORS -o CONTRIBUTORS.utf8
  88. mv -f CONTRIBUTORS.utf8 CONTRIBUTORS
  89. rm -f $RPM_BUILD_ROOT{%{_libdir},%{python_sitelib}}/*.{a,la}
  90. #cat /proc/cpuinfo
  91. #make bench || :
  92. ## remove unuse files
  93. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  94. %clean
  95. rm -fr $RPM_BUILD_ROOT
  96. %post -p /sbin/ldconfig
  97. %postun -p /sbin/ldconfig
  98. %post -n compat32-%{name} -p /sbin/ldconfig
  99. %postun -n compat32-%{name} -p /sbin/ldconfig
  100. %files
  101. %defattr(-,root,root)
  102. %doc AUTHORS BENCHMARKS CONTRIBUTORS
  103. %doc COPYING COPYING.LIB NEWS README
  104. %{_libdir}/libbeecrypt.so.*
  105. %files devel
  106. %defattr(-,root,root)
  107. %doc BUGS
  108. %{_includedir}/%{name}
  109. %{_libdir}/libbeecrypt.so
  110. %if %{?with_python:1}0
  111. %files python
  112. %defattr(-,root,root)
  113. %{python_sitelib}/_bc.so
  114. %endif
  115. %if %{?with_java:1}0
  116. %files java
  117. %defattr(-,root,root)
  118. %{_libdir}/libbeecrypt_java.a
  119. %{_libdir}/libbeecrypt_java.so*
  120. %endif
  121. ## to build compat32 for x86_64 architecture support
  122. %if %{build_compat32}
  123. %files -n compat32-%{name}
  124. %defattr(-,root,root)
  125. %{_libdir}/libbeecrypt.so.*
  126. %files -n compat32-%{name}-devel
  127. %defattr(-,root,root)
  128. %{_libdir}/libbeecrypt.so
  129. %endif
  130. %changelog
  131. * Wed Jun 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.2.1-1
  132. - new upstream release.
  133. - removed all patches.
  134. - imported Patch0 and Patch1 from rawhide.
  135. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.1.2-15
  136. - rebuild with python-2.7.2
  137. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 4.1.2-14
  138. - rebuilt with rpm-4.8.1-3
  139. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.2-13
  140. - rebuilt with gcc-4.4.3-3 on ppc
  141. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.2-12
  142. - rebuilt with rpm-4.8.0-3 (on ppc)
  143. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 4.1.2-11
  144. - rebuild with python-2.6
  145. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.2-10vl5
  146. - applied new versioning policy
  147. - removed *.la
  148. * Sat Dec 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 4.1.2-9vl5
  149. - removed %%if !%%{build_compat32} case condition
  150. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.2-9vl4
  151. - rebuilt with new toolchain
  152. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-9vl3
  153. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  154. * Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-9vl2
  155. - added compat32-* packages for x86_64 architecture support
  156. - dropt doxygen
  157. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1,2-9vl1
  158. - initial build for Vine Linux based on FC-devel
  159. * Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
  160. - Use -with-cplusplus=no. The libs still require libstdc++, so
  161. this needs further cleanup.
  162. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-8
  163. - Remove dependencies on private symbols not present in Python 2.4 from
  164. beecrypt-python
  165. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-7
  166. - Doh, actually apply the patch
  167. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 4.1.2-6
  168. - Fix b64encode() for data starting with NUL (#123650)
  169. * Fri Apr 01 2005 Warren Togami <wtogami@redhat.com> 4.1.2-5
  170. - remove huge API docs
  171. * Fri Apr 01 2005 Paul Nasrat <pnasrat@redhat.com> 4.1.2-4
  172. - Obsolete older beecrypt-java
  173. * Tue Mar 29 2005 Paul Nasrat <pnasrat@redhat.com> 4.1.2-3
  174. - Disable beecrypt-java (#151294)
  175. * Fri Mar 4 2005 Jeff Johnson <jbj@redhat.com> 4.1.2-2
  176. - rebuild with gcc4.
  177. * Sat Feb 5 2005 Jeff Johnson <jbj@jbj.org> 4.1.2-1
  178. - upgrade to 4.1.2
  179. - put java components in sub-package.
  180. - check that /usr/lib64 is not used on alpha (#146583).
  181. * Fri Feb 4 2005 Miloslav Trmac <mitr@redhat.com> - 3.1.0-7
  182. - Rebuild against Python 2.4
  183. * Sun Aug 08 2004 Alan Cox <alan@redhat.com> 3.1.0-6
  184. - Build requires libtool (Steve Grubb)
  185. * Fri Jul 02 2004 Elliot Lee <sopwith@redhat.com> 3.1.0-5
  186. - rebuilt
  187. - Add _smp_mflags
  188. * Wed Mar 24 2004 Jeff Johnson <jbj@redhat.com> 3.1.0-3
  189. - fix: extgcd_w problem fixed by upgrading from CVS.
  190. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  191. - rebuilt
  192. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  193. - rebuilt
  194. * Mon Dec 22 2003 Jeff Johnson <jbj@jbj.org> 3.1.0-1
  195. - upgrade to 3.1.0.
  196. - recompile against python-2.3.3.
  197. * Mon Jun 30 2003 Jeff Johnson <jbj@redhat.com> 3.0.1-0.20030630
  198. - upstream fixes for DSA and ppc64.
  199. * Mon Jun 23 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-2
  200. - upgrade to 3.0.0 final.
  201. - fix for DSA (actually, modulo inverse) sometimes failing.
  202. * Fri Jun 20 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030619
  203. - avoid asm borkage on ppc64.
  204. * Thu Jun 19 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030618
  205. - rebuild for release bump.
  206. * Tue Jun 17 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030616
  207. - try to out smart libtool a different way.
  208. - use $bc_target_cpu, not $bc_target_arch, to detect /usr/lib64.
  209. * Mon Jun 16 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030615
  210. - use -mcpu=powerpc64 on ppc64.
  211. * Fri Jun 13 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030613
  212. - upgrade to latest snapshot.
  213. * Fri Jun 6 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-1.20030605
  214. - rebuild into another tree.
  215. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  216. - rebuilt
  217. * Tue Jun 3 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030603
  218. - update to 3.0.0 snapshot, fix mpmod (and DSA) on 64b platforms.
  219. * Mon Jun 2 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030602
  220. - update to 3.0.0 snapshot, merge patches, fix gcd rshift and ppc problems.
  221. * Thu May 29 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030529
  222. - update to 3.0.0 snapshot, fix ia64/x86_64 build problems.
  223. * Wed May 28 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030528
  224. - upgrade to 3.0.0 snapshot, adding rpm specific base64.[ch] changes.
  225. - add PYTHONPATH=.. so that "make check" can test the just built _bc.so module.
  226. - grab cpuinfo and run "make bench".
  227. - continue ignoring "make check" failures, LD_LIBRARY_PATH needed for _bc.so.
  228. - skip asm build failure on ia64 for now.
  229. - ignore "make bench" exit codes too, x86_64 has AES segfault.
  230. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030521
  231. - upgrade to 3.0.0 snapshot, including python subpackage.
  232. - ignore "make check" failure for now.
  233. * Fri May 16 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030516
  234. - upgrade to 3.0.0 snapshot, including ia64 and x86_64 fixes.
  235. - add %%check.
  236. - ignore "make check" failure on ia64 for now.
  237. * Mon May 12 2003 Jeff Johnson <jbj@redhat.com> 3.0.0-0.20030512
  238. - upgrade to 3.0.0 snapshot.
  239. - add doxygen doco.
  240. - use /dev/urandom as default entropy source.
  241. - avoid known broken compilation for now.
  242. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  243. - rebuilt
  244. * Tue Nov 19 2002 Tim Powers <timp@redhat.com>
  245. - rebuild on all arches
  246. * Fri Aug 2 2002 Jeff Johnson <jbj@redhat.com> 2.2.0-6
  247. - install types.h (#68999).
  248. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  249. - automated rebuild
  250. * Wed Jun 5 2002 Jeff Johnson <jbj@redhat.com>
  251. - run ldconfig when installing/erasing (#65974).
  252. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  253. - automated rebuild
  254. * Mon May 13 2002 Jeff Johnson <jbj@redhat.com>
  255. - upgrade to latest 2.2.0 (from cvs.rpm.org).
  256. * Mon Jan 21 2002 Jeff Johnson <jbj@redhat.com>
  257. - use the same beecrypt-2.2.0 that rpm is using internally.
  258. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 2.1.0-1
  259. - initial package