beepmp-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223
  1. %define srcname bmp
  2. #%%define extraver rc2
  3. # build ALSA output plugin
  4. %define with_alsa 1
  5. Summary: Beep Media Player
  6. Name: beepmp
  7. Version: 0.9.7.1
  8. Release: 1%{?_dist_release}
  9. License: GPL
  10. Group: Applications/Multimedia
  11. URL: http://bmp.beep-media-player.org/
  12. Source: http://prdownloads.sourceforge.net/beepmp/bmp-%{version}%{?extraver:%extraver}.tar.gz
  13. Source1: %{name}.desktop
  14. # based on bmp-%{version}'s ja.po
  15. Source2: beepmp-0.9.7.1-ja.po
  16. Patch2: beepmp-0.9.7-except-flac.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: gtk2 >= 2.4.0, libglade2 >= 2.3.1
  19. Requires: esound >= 0.2, libvorbis, id3lib
  20. BuildRequires: gtk2-devel >= 2.4.0, libglade2-devel >= 2.3.1
  21. BuildRequires: esound-devel >= 0.2, libvorbis-devel, id3lib-devel
  22. Requires(post): ldconfig, desktop-file-utils
  23. Requires(postun): ldconfig, desktop-file-utils
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. Beep Media Player (BMP) is a GTK2 port of the popular X Multimedia
  28. System (XMMS) and more.
  29. %description -l ja
  30. Beep Media Player (BMP) は定番の X Multimedia System (XMMS) を GTK2 に
  31. 移植したメディアプレイヤーです。
  32. %package devel
  33. Summary: BMP - Static libraries and header files.
  34. Summary(ja): BMP - 静的ライブラリ及びヘッダファイル
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}, gtk2-devel
  37. %description devel
  38. Static libraries and header files required for compiling Beep Media Player
  39. plugins.
  40. %description -l ja devel
  41. Beep Media Player のプラグインをコンパイルするのに必要な静的ライブラリ
  42. 及びヘッダファイルです。
  43. %if %{with_alsa}
  44. %package alsa
  45. Summary: BMP - ALSA output plugin
  46. Summary(ja): BMP - ALSA 出力プラグイン
  47. Group: Applications/Multimedia
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: alsa-lib >= 1.0.0
  50. BuildRequires: alsa-lib-devel >= 1.0.0
  51. %description alsa
  52. Output plugin for Beep Media Player to use with the Advanced Linux Sound
  53. Architecture (ALSA).
  54. %description -l ja alsa
  55. Beep Media Player で Advanced Linux Sound Architecture (ALSA) を用いて
  56. 音声を出力するためのプラグインです。
  57. %endif
  58. %prep
  59. %setup -q -n %{srcname}-%{version}%{?extraver:%extraver}
  60. %patch2 -p1 -b .ex-flac
  61. %__cp -f %{SOURCE2} po/ja.po
  62. %build
  63. %configure \
  64. %if ! %{with_alsa}
  65. --disable-alsa \
  66. %endif
  67. --disable-gconf \
  68. --disable-gnome-vfs
  69. %__make %{_smp_mflags}
  70. ( cd po ; %__make update-gmo )
  71. %install
  72. %__rm -rf %{buildroot}
  73. %__make DESTDIR=%{buildroot} install
  74. %find_lang %{srcname}
  75. %__rm -f %{buildroot}%{_libdir}/bmp/*/*.la
  76. %__rm -f %{buildroot}%{_datadir}/applications/bmp.desktop
  77. %__install -p -m644 %{SOURCE1} %{buildroot}%{_datadir}/applications
  78. %__mv -f %{buildroot}%{_datadir}/pixmaps/bmp.png %{buildroot}%{_datadir}/pixmaps/beepmp.png
  79. %post
  80. %{_syssbindir}/ldconfig
  81. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  82. %postun
  83. %{_syssbindir}/ldconfig
  84. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  85. %clean
  86. %__rm -rf %{buildroot}
  87. %files -f %{srcname}.lang
  88. %defattr(-,root,root,-)
  89. %doc AUTHORS COPYING ChangeLog NEWS README FAQ
  90. %{_bindir}/beep-media-player
  91. %{_datadir}/bmp
  92. %{_datadir}/pixmaps/*
  93. %{_datadir}/applications/%{name}.desktop
  94. %dir %{_libdir}/bmp
  95. %dir %{_libdir}/bmp/Input
  96. %{_libdir}/bmp/Input/libcdaudio.so
  97. %{_libdir}/bmp/Input/libwav.so
  98. %{_libdir}/bmp/Input/libmpg123.so
  99. %{_libdir}/bmp/Input/libvorbis.so
  100. %dir %{_libdir}/bmp/Output
  101. %{_libdir}/bmp/Output/*.so
  102. %if %{with_alsa}
  103. %exclude %{_libdir}/bmp/Output/libALSA.*
  104. %endif
  105. %{_libdir}/bmp/Visualization
  106. %{_libdir}/lib*.so.*
  107. %{_mandir}/man1/*
  108. %files devel
  109. %defattr(-,root,root,-)
  110. %{_includedir}/bmp
  111. %{_libdir}/lib*.so
  112. %{_libdir}/lib*.la
  113. #%{_libdir}/lib*.a
  114. %{_libdir}/pkgconfig/*.pc
  115. %if %{with_alsa}
  116. %files alsa
  117. %defattr(-,root,root,-)
  118. %{_libdir}/bmp/Output/libALSA.so
  119. %endif
  120. %changelog
  121. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.9.7.1-1vl5
  122. - applied new versioning policy, spec in utf-8
  123. * Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7.1-0vl3
  124. - rebuilt with new toolchain
  125. * Sat Jan 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7.1-0vl2
  126. - fix %%files
  127. * Wed Jan 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7.1-0vl1
  128. - upstream release
  129. - drop obsolete patches
  130. - update ja.po
  131. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl5
  132. - rebuild with alsa support
  133. - remove %%{_libdir}/bmp/*/*.la
  134. * Fri Apr 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl4
  135. - add beepmp.png (source3)
  136. - update desktop file
  137. - add application/ogg
  138. - use beepmp.png
  139. - run update-desktop-database at post/postun
  140. - add Requires(post/postun): ldconfig, desktop-file-utils
  141. * Thu Feb 10 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl3
  142. - add except-flac.patch (patch2)
  143. to prevent mpg123 plugin's hijacking FLAC stream
  144. (ref. http://bugs.xmms.org/show_bug.cgi?id=2038)
  145. * Sat Jan 29 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl2
  146. - use correct field name "date" in vorbis plugin (patch1)
  147. - thanks, MVA [VinePlus:02251]
  148. - fix typo in ja.po
  149. * Sun Dec 12 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl1
  150. - upstream release
  151. - update ja.po
  152. * Fri Nov 12 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl0.rc2.2
  153. - update ja.po
  154. * Sun Nov 07 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl0.rc2.1
  155. - update ja.po
  156. - add playlist-drawstring-utf8.patch (patch1)
  157. * Fri Nov 05 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.7-0vl0.rc2
  158. - initial build for Vine Linux
  159. * Tue Jul 6 2004 Chong Kai Xiong <descender@phreaker.net> 0:0.9.7-1
  160. - fixed file list to own package-specific directories
  161. - remove vendor, add epoch tag, explicit requires, add unzip to requires
  162. - force version match between plugins and main package
  163. - use %find_lang
  164. - don't install INSTALL
  165. * Thu Jun 24 2004 Chong Kai Xiong <descender@phreaker.net> 0.9.7-3
  166. - added support for GConf and GNOME VFS
  167. - fixed file list
  168. * Fri May 28 2004 Chong Kai Xiong <descender@phreaker.net> 0.9.7-2
  169. - require libglade 2.0
  170. * Sun Apr 05 2004 Chong Kai Xiong <descender@phreaker.net> 0.9.7-1
  171. - require GTK 2.4 and ALSA 1.0
  172. * Tue Jan 13 2004 David Lau <coder_sku@sourceforge.net> 0.9.6-3
  173. - removes plugin .la's
  174. * Wed Dec 24 2003 Chong Kai Xiong <descender@phreaker.net> 0.9.6-2
  175. - first fully usable version
  176. * Tue Nov 29 2003 Chong Kai Xiong <descender@phreaker.net> 0.9.6-1
  177. - added support for --with switches
  178. * Tue Nov 11 2003 Chong Kai Xiong <descender@phreaker.net> 1.0.0pre6
  179. - initial build