bind-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830
  1. %bcond_with systemd
  2. %bcond_with python
  3. %define python_executable %{__python}
  4. %define _localstatedir /var
  5. %define _unpackaged_files_terminate_build 1
  6. %define sname bind
  7. %define pname bind
  8. # example: 9.9.13.P1
  9. %define pversion 9.11.31
  10. # example: 9.9.13-P1
  11. %define sversion 9.11.31
  12. %define bind_epoch 1
  13. # fixed <BTS:VineLinux:1139>
  14. %define old_bind_version 1:9.9.2p2-1vl7
  15. %define bind_uid 25
  16. %define bind_gid 25
  17. %bcond_with readline
  18. Summary: A DNS (Domain Name System) server.
  19. Summary(ja): DNS (Domain Name System) サーバ
  20. Name: %{pname}
  21. Epoch: %{bind_epoch}
  22. Version: %{pversion}
  23. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  24. Group: servers
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: daisuke
  28. License: ISC and BSD and Public Domain
  29. URL: http://www.isc.org/bind.html
  30. Source: https://downloads.isc.org/isc/bind9/%{sversion}/bind-%{sversion}.tar.gz
  31. Source1: bind-manpages.tar.bz2
  32. Source2: named.sysconfig
  33. Source3: named.init
  34. Source4: named.logrotate
  35. Source5: keygen.c
  36. Source100: named.service
  37. Source101: named-setup-rndc.service
  38. Source102: named.sysconfig.systemd
  39. Source103: bind.tmpfiles.d
  40. Source104: named.conf
  41. Patch1: bind-9.11.5-rndckey.patch
  42. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  43. %if %{with python}
  44. BuildRequires: python
  45. BuildRequires: python-rpm-macros
  46. BuildRequires: python-ply
  47. %endif
  48. BuildRequires: openssl-devel glibc-devel libtool
  49. BuildRequires: libxml2-devel
  50. BuildRequires: libcap-devel
  51. %if %{with readline}
  52. BuildRequires: readline-devel
  53. %endif
  54. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  55. Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  56. Requires(pre): shadow-utils
  57. Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  58. Requires(post): coreutils
  59. %if %{with systemd}
  60. %{?systemd_requires}
  61. %else
  62. Requires(post): chkconfig
  63. Requires(preun): chkconfig
  64. %endif
  65. Conflicts: bind9 <= 9.2.1-0vl5, bind-current
  66. Obsoletes: bind9 <= 9.2.1-0vl5
  67. Obsoletes: bind-current < 1:9.9.4-1
  68. %description
  69. BIND (Berkeley Internet Name Domain) is an implementation of the DNS
  70. (Domain Name System) protocols. BIND includes a DNS server (named),
  71. which resolves host names to IP addresses, and a resolver library
  72. (routines for applications to use when interfacing with DNS). A DNS
  73. server allows clients to name resources or objects and share the
  74. information with other network machines. The named DNS server can be
  75. used on workstations as a caching name server, but is generally only
  76. needed on one machine for an entire network. Note that the
  77. configuration files for making BIND act as a simple caching nameserver
  78. are included in the caching-nameserver package.
  79. Install the bind package if you need a DNS server for your network. If
  80. you want bind to act a caching name server, you will also need to install
  81. the caching-nameserver package.
  82. %package libs
  83. Summary: Libraries used by various DNS packages
  84. Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
  85. Group: system
  86. Obsoletes: bind-current-libs <= %{old_bind_version}
  87. %description libs
  88. Contains libraries used by both the bind server package as well as the utils packages.
  89. %package utils
  90. Summary: Utilities for querying DNS name servers.
  91. Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
  92. Group: admin-tools
  93. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  94. Conflicts: bind9-utils <= 9.2.1-0vl5
  95. Conflicts: bind-current-utils
  96. Obsoletes: bind9-utils <= 9.2.1-0vl5
  97. Obsoletes: bind-current-utils <= %{old_bind_version}
  98. %description utils
  99. Bind-utils contains a collection of utilities for querying DNS (Domain
  100. Name Service) name servers to find out information about Internet hosts.
  101. These tools will provide you with the IP addresses for given host names,
  102. as well as other information about registered domains and network
  103. addresses.
  104. You should install bind-utils if you need to get information from DNS name
  105. servers.
  106. %package devel
  107. Summary: Include files and libraries needed for bind DNS development.
  108. Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
  109. Group: programming
  110. Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
  111. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  112. Conflicts: bind9-devel <= 9.2.1-0vl5
  113. Conflicts: bind-current-devel
  114. Obsoletes: bind9-devel <= 9.2.1-0vl5
  115. Obsoletes: bind-current-devel <= %{old_bind_version}
  116. %description devel
  117. The bind-devel package contains all the include files and the
  118. library required for DNS (Domain Name Service) development for
  119. BIND versions 9.x.x.
  120. You should install bind-devel if you want to develop bind DNS
  121. applications. If you install bind-devel, you'll also need to install
  122. bind.
  123. #'
  124. %debug_package
  125. %prep
  126. %setup -n bind-%{sversion} -q
  127. %patch1 -p1 -b .key
  128. perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
  129. %build
  130. libtoolize --copy --force
  131. aclocal
  132. autoconf
  133. %configure \
  134. --with-libtool \
  135. --with-openssl=/usr \
  136. %if %{without readline}
  137. --without-readline \
  138. %endif
  139. --disable-openssl-version-ceck \
  140. --enable-threads \
  141. --enable-ipv6 \
  142. --with-pic \
  143. --with-dlz-dlopen \
  144. %if %{with python}
  145. --with-python=%{python_executable} \
  146. %else
  147. --with-python=no \
  148. %endif
  149. --enable-filter-aaaa \
  150. --enable-fixed-rrset
  151. make %{?_smp_mflags}
  152. %install
  153. rm -rf %{buildroot}
  154. mkdir -p %{buildroot}%{_sysconfdir}/{logrotate.d,sysconfig}
  155. mkdir -p %{buildroot}/usr/{bin,lib,sbin,include}
  156. mkdir -p %{buildroot}/var/named/data
  157. mkdir -p %{buildroot}%{_mandir}/{man1,man5,man8}
  158. mkdir -p %{buildroot}/var/run/named
  159. make DESTDIR=%{buildroot} install
  160. install -c -m 640 bin/rndc/rndc.conf %{buildroot}/etc
  161. install -c -m 644 %SOURCE4 %{buildroot}%{_sysconfdir}/logrotate.d/named
  162. touch %{buildroot}%{_sysconfdir}/rndc.key
  163. gcc %{optflags} -o %{buildroot}/usr/sbin/dns-keygen %{SOURCE5}
  164. cd %{buildroot}%{_mandir}
  165. tar xjf %{SOURCE1}
  166. # newer version is contained in source
  167. rm -f man5/named.conf.5.gz
  168. install -m 644 %{SOURCE104} %{buildroot}%{_sysconfdir}/named.conf
  169. %if %{with systemd}
  170. # Systemd unit files
  171. mkdir -p %{buildroot}%{_unitdir}
  172. install -m 644 %{SOURCE100} %{buildroot}%{_unitdir}
  173. install -m 644 %{SOURCE101} %{buildroot}%{_unitdir}
  174. install -m 644 %{SOURCE102} %{buildroot}%{_sysconfdir}/sysconfig/named
  175. mkdir -p %{buildroot}%{_tmpfilesdir}
  176. install -m 644 %{SOURCE103} %{buildroot}%{_tmpfilesdir}/named.conf
  177. %else
  178. mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
  179. install -c -m 755 %SOURCE3 %{buildroot}%{_sysconfdir}/rc.d/init.d/named
  180. cp %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/named
  181. %endif
  182. chmod +x %{buildroot}%{_libdir}/*.so.*
  183. rm -f %{buildroot}%{_libdir}/*.la
  184. %clean
  185. rm -rf %{buildroot} ${RPM_BUILD_DIR}/%{name}-%{version}
  186. %pre
  187. if [ "$1" -eq 1 ]; then
  188. /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
  189. /usr/sbin/useradd -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
  190. fi;
  191. :;
  192. %post
  193. /sbin/ldconfig
  194. if [ "$1" -eq 1 ]; then
  195. if [ ! -e /etc/rndc.key ]; then
  196. /usr/sbin/rndc-confgen -a > /dev/null 2>&1
  197. fi
  198. [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
  199. # rndc.key has to have correct perms and ownership, CVE-2007-6283
  200. [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
  201. [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
  202. # Check DNSSEC settings if this is a fresh install
  203. if [ -r /etc/sysconfig/dnssec ]; then
  204. . /etc/sysconfig/dnssec
  205. [ -x /usr/sbin/dnssec-configure ] && \
  206. dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
  207. /dev/null 2>&1
  208. fi;
  209. fi
  210. %if %{with systemd}
  211. %systemd_post named.service
  212. %else
  213. if [ "$1" -eq 1 ]; then
  214. /sbin/chkconfig --add named
  215. fi
  216. %endif
  217. :;
  218. %preun
  219. %if %{with systemd}
  220. # Package removal, not upgrade
  221. %systemd_preun named.service
  222. %else
  223. if [ "$1" -eq 0 -o -x /sbin/systemctl ]; then
  224. /sbin/service named stop >/dev/null 2>&1 || :
  225. /sbin/chkconfig --del named ||:
  226. fi
  227. %endif
  228. exit 0
  229. %postun
  230. /sbin/ldconfig
  231. %if %{with systemd}
  232. # Package upgrade, not uninstall
  233. %systemd_postun_with_restart named.service
  234. %else
  235. if [ "$1" -ge 1 ]; then
  236. %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
  237. fi
  238. %endif
  239. exit 0
  240. %triggerpostun -- bind < 8.2.2_P5-15
  241. /sbin/chkconfig --add named
  242. /sbin/ldconfig
  243. %triggerpostun -- bind-current < 1:9.9.4-1
  244. /sbin/chkconfig --add named
  245. /sbin/ldconfig
  246. %ldconfig_scriptlets libs
  247. %files
  248. %defattr(-,root,root)
  249. %license COPYRIGHT
  250. %doc CHANGES README*
  251. %doc doc/arm doc/misc
  252. %config(noreplace) %{_sysconfdir}/named.conf
  253. %config(noreplace) %{_sysconfdir}/logrotate.d/named
  254. %if %{with systemd}
  255. %{_unitdir}/named.service
  256. %{_unitdir}/named-setup-rndc.service
  257. %{_tmpfilesdir}/named.conf
  258. %else
  259. %config %{_sysconfdir}/rc.d/init.d/named
  260. %attr(-,named,named) %dir %{_var}/run/named
  261. %endif
  262. %config(noreplace) %{_sysconfdir}/sysconfig/named
  263. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
  264. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
  265. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
  266. %attr(-,named,named) %dir %{_var}/named
  267. %attr(-,named,named) %dir %{_var}/named/data
  268. %{_sbindir}/dnssec*
  269. %{_sbindir}/lwresd
  270. %{_sbindir}/named
  271. %{_sbindir}/named-check*
  272. %{_sbindir}/named-compilezone
  273. %{_sbindir}/rndc*
  274. %{_sbindir}/dns-keygen
  275. %{_bindir}/arpaname
  276. %{_sbindir}/ddns-confgen
  277. %{_sbindir}/genrandom
  278. %{_sbindir}/isc-hmac-fixup
  279. %{_sbindir}/named-journalprint
  280. %{_sbindir}/nsec3hash
  281. %{_sbindir}/tsig-keygen
  282. %if %{with python}
  283. %{python_sitelib}/*
  284. %endif
  285. %{_mandir}/man1/arpaname.1*
  286. %{_mandir}/man5/resolv.conf.5*
  287. %{_mandir}/man5/named.conf.5*
  288. %{_mandir}/man5/rndc.conf.5*
  289. %{_mandir}/man8/rndc.8*
  290. %{_mandir}/man8/named.8*
  291. %{_mandir}/man8/lwresd.8*
  292. %{_mandir}/man8/dnssec*.8*
  293. %{_mandir}/man8/named-checkconf.8*
  294. %{_mandir}/man8/named-checkzone.8*
  295. %{_mandir}/man8/named-compilezone.8*
  296. %{_mandir}/man8/rndc-confgen.8*
  297. %{_mandir}/man8/ddns-confgen.8*
  298. %{_mandir}/man8/genrandom.8*
  299. %{_mandir}/man8/isc-hmac-fixup.8*
  300. %{_mandir}/man8/named-journalprint.8*
  301. %{_mandir}/man8/nsec3hash.8*
  302. %{_mandir}/man8/tsig-keygen.8*
  303. %files libs
  304. %defattr(-,root,root)
  305. %{_libdir}/*.so.*
  306. %files utils
  307. %defattr(-,root,root)
  308. %{_bindir}/delv
  309. %{_bindir}/dig
  310. %{_bindir}/host
  311. %{_bindir}/mdig
  312. %{_bindir}/named-rrchecker
  313. %{_bindir}/nslookup
  314. %{_bindir}/nsupdate
  315. %{_mandir}/man1/delv.1*
  316. %{_mandir}/man1/dig.1*
  317. %{_mandir}/man1/host.1*
  318. %{_mandir}/man1/mdig.1*
  319. %{_mandir}/man1/named-rrchecker.1*
  320. %{_mandir}/man1/nslookup.1*
  321. %{_mandir}/man1/nsupdate.1*
  322. %{_mandir}/man5/resolver.5*
  323. %{_mandir}/man8/nslookup.8*
  324. %files devel
  325. %defattr(-,root,root)
  326. %{_libdir}/*.so
  327. %{_libdir}/*.a
  328. %{_includedir}/*
  329. %{_mandir}/man3/*
  330. %{_mandir}/man1/bind9-config.1*
  331. %{_mandir}/man1/isc-config.sh.1*
  332. %{_bindir}/bind9-config
  333. %{_bindir}/isc-config.sh
  334. %changelog
  335. * Fri May 14 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.31-1
  336. - updated to 9.11.31.
  337. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.28-1
  338. - updated to 9.11.28.
  339. * Thu Sep 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.22-1
  340. - updated to 9.11.22.
  341. * Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-2
  342. - added systemd support (disabled as default).
  343. * Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-1
  344. - updated to 9.11.20.
  345. * Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.12-1
  346. - updated to 9.11.12.
  347. * Wed Oct 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.11-1
  348. - updated to 9.11.11.
  349. * Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.5-1
  350. - updated to 9.11.5 (new ESV).
  351. - updated Patch1.
  352. * Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
  353. - updated to 9.9.13.P1.
  354. - updated Patch1.
  355. * Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
  356. - update to 9.9.9.P8
  357. * Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
  358. - new upstream release.
  359. * Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
  360. - new upstream release.
  361. * Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
  362. - new upstream release.
  363. * Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
  364. - new upstream release with secrity fix (CVE-2016-1285,1286)
  365. - built with openssl 1.0.2g
  366. * Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
  367. - new upstream release with secrity fix (CVE-2015-4620)
  368. * Thu Jul 9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
  369. - new upstream release with secrity fix (CVE-2015-4620)
  370. * Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
  371. - rebuilt without readline to avoid GPL infection
  372. * Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
  373. - new upstream release with secrity fix (CVE-2015-1349)
  374. - added BR: readline-devel
  375. * Fri Feb 6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
  376. - new upstream release with secrity fix (CVE-2014-8500)
  377. - used "3" as release number because of being newer than Vine Linux/6 updates
  378. * Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
  379. - update to 9.9.4(ESV)
  380. * Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
  381. - update to 9.9.2-P2
  382. - remove .la
  383. - remove Conflicts/Obsoletes from libs subpackage.
  384. - add configure options
  385. --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
  386. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
  387. - new upstream release.
  388. - added an option "--with-dlz-dlopen".
  389. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
  390. - Obosoletes: bind.* < 1:9.6.ESV.R1
  391. - fixed <BTS:VineLinux:1139>
  392. * Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
  393. - new upstream release with security fix (CVE-2011-1910)
  394. * Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
  395. - add BuildRequires: libxml2-devel, libcap-devel
  396. * Mon May 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
  397. - new upstream release with security fix (CVE-2011-1907)
  398. - fix changelog typo
  399. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
  400. - Obosoletes: bind.* < 1:9.6.ESV.R1
  401. * Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
  402. - update to 9.8.0
  403. - remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
  404. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
  405. - rebuild with openssl-1.0.0c
  406. * Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
  407. - fix Req: in bind package
  408. * Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
  409. - change package name bind -> bind-current
  410. - add epoch 1
  411. - new upstream release
  412. * Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
  413. - new upstream release
  414. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
  415. - rebuilt with gcc-4.4.3-3 on ppc
  416. * Sat Feb 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
  417. - rebuilt with new toolchains (for VineSeed)
  418. - s/BuildPrereq/BuildRequires/
  419. * Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
  420. - add man1/isc-config.sh.1 into devel file list
  421. * Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
  422. - new upstream release with security fix (CVE-2009-4022, 2010-0097)
  423. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
  424. - new upstream release with security fix (CVE-2009-4022)
  425. * Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
  426. - new upstream release with security fix
  427. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
  428. - new upstream release
  429. - clean up %%post/%%pre scriptlet
  430. - create named user and group in %%pre
  431. - don't remove named user/group in %%preun
  432. - use rndc-confgen to create rndc.key
  433. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
  434. - new upstream release
  435. - drop patch0 and patch14, merged in upstream
  436. * Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
  437. - new upstream release with security fix
  438. * Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
  439. - new upstream release with security fix
  440. - new versioning policy
  441. * Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
  442. - new upstream release with security fix
  443. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
  444. - new upstream release
  445. - build with new openssl/toolchain
  446. * Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
  447. - new upstream release with security fix
  448. * Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
  449. - new upstream release
  450. * Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
  451. - add Prereq sed
  452. * Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
  453. - new upstream release for security fix (CVE-2006-4095,4096)
  454. * Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
  455. - separate -libs package
  456. - remove old named.conf.5.gz
  457. - newer version is contained in source
  458. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
  459. - add bsdcompat patch (Patch4)
  460. - add fix_h_errno patch from FC
  461. - h_errno not being accessed / set correctly in libbind
  462. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
  463. - new upstream release
  464. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
  465. - added PreReq to bind-utils (see: [VineSeed:09555])
  466. * Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
  467. - new upstream release
  468. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
  469. - fix /etc/init.d/named to use rndc
  470. * Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
  471. - rebuild to remove unneeded dependancy
  472. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
  473. - new upstream release
  474. * Tue Mar 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
  475. - new upstream release
  476. * Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
  477. - fix dependancies.
  478. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
  479. - add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
  480. - change package name to bind for VineSeed.
  481. - use more macros.
  482. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
  483. - fixed some macros
  484. - add conflicts: to bind-* in bind9-devel and bind9-utils
  485. - add provides: bind = %%{version}
  486. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
  487. - use %%configure macros
  488. * Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
  489. - fixed inconsistent dependency
  490. * Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
  491. - updated to 9.2.2rc1
  492. * Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
  493. - updated to bind9(9.2.1), test packages ;)
  494. -- based on Rawhide's bind-9.2.0-8
  495. -- changed name bind9
  496. -- added Conflicts: bind
  497. * Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
  498. - release 8.3.1 includes security fixes
  499. * Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
  500. - Upgraded to current stable release 8.3.0
  501. * Mon Oct 8 2001 <zn@mbf.nifty.com>
  502. - 8.2.5-0vl0: Upgraded to new upstream version.
  503. * Thu May 24 2001 <sagami@vinelinux.org>
  504. - 8.2.4-0vl1: eliminate CVS related files from %%doc
  505. * Thu May 17 2001 <sagami@vinelinux.org>
  506. - 8.2.4-0vl0
  507. * Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  508. - 8.2.3-1vl2
  509. - built on VineSeed
  510. * Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
  511. - add doc/old
  512. - build for Vine 2.1
  513. * Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  514. - 8.2.3, fixes several security problems
  515. * Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
  516. - static libraries may be used in shared objects. Build with -fPIC on ia64
  517. * Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  518. - 8.2.2-P7 (fixes Bug #20546)
  519. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  520. - condrestart fixes
  521. * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  522. - change the init script to take condrestart, not cond-restart
  523. - add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
  524. the %pre and %post scripts
  525. * Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  526. - Don't prereq /etc/init.d
  527. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  528. - move initscript back
  529. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  530. - automatic rebuild
  531. * Sun Jul 9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  532. - add "exit 0" for uninstall case
  533. * Fri Jul 7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  534. - add prereq init.d and cleanup install section
  535. * Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  536. - fix the init script
  537. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  538. - make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
  539. * Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  540. - Fix up the initscript (Bug #13033)
  541. - Fix build with current glibc (Bug #12755)
  542. - /etc/rc.d/init.d -> /etc/init.d
  543. - use %%{_mandir} rather than /usr/share/man
  544. * Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
  545. - fix conflict with man-pages
  546. - remove compatibilty chkconfig links
  547. - initscript munging
  548. * Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  549. - modify logrotate setup to use PID file
  550. - temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
  551. - actually bump the release this time
  552. * Sun Jun 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  553. - FHS compliance
  554. * Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  555. - clean up restart patch
  556. * Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
  557. - provide /var/named (fix for bugs #9847, #10205)
  558. - preserve args when restarted via ndc(8) (bug #10227)
  559. - make resolv.conf(5) a link to resolver(5) (bug #10245)
  560. - fix SYSTYPE bug in all makefiles
  561. - move creation of named user from %%post into %%pre
  562. * Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  563. - Fix TTL (patch from ISC, Bug #9820)
  564. * Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  565. - fix typo in spec (it's %post, without a leading blank) introduced in -6
  566. - change SYSTYPE to linux
  567. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  568. - pick a standard < 100 uid/gid for named
  569. * Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
  570. - Pass named a '-u named' parameter by default, and add/remove user.
  571. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  572. - fix host mx bug (Bug #9021)
  573. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  574. - rebuild to fix dependencies
  575. - man pages are compressed
  576. * Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  577. - It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
  578. * Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  579. - Fix up location of named-bootconf.pl and make it executable
  580. (Bug #8028)
  581. - bind-devel requires bind
  582. * Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  583. - update to 8.2.2-P5
  584. * Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
  585. - update to 8.2.2-P3
  586. * Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
  587. - add patch to stop a cache only server from complaining about lame servers
  588. on every request.
  589. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  590. - use real stop and start in named.init for restart, not ndc restart, it has
  591. problems when named has changed during a package update... (# 4890)
  592. * Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
  593. - chkconfig --del in %preun, not %postun
  594. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  595. - initscript munging
  596. * Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
  597. - fix installed chkconfig links to match init file
  598. * Sat Jul 3 1999 Jeff Johnson <jbj@redhat.com>
  599. - conflict with new (in man-1.24) man pages (#3876,#3877).
  600. * Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
  601. - fix named.logrotate (wrong %SOURCE)
  602. * Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
  603. - update to 8.2.1.
  604. - add named.logrotate (#3571).
  605. - hack around egcs-1.1.2 -m486 bug (#3413, #3485).
  606. - vet file list.
  607. * Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
  608. - don't run by default
  609. * Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
  610. - nslookup fixes (#2463).
  611. - missing files (#3152).
  612. * Sat May 1 1999 Stepan Kasal <kasal@math.cas.cz>
  613. - nslookup patched:
  614. to count numRecords properly
  615. to fix subsequent calls to ls -d
  616. to parse "view" and "finger" commands properly
  617. the view hack updated for bind-8 (using sed)
  618. * Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
  619. - add ISC patch
  620. - add quick hack to make host not crash
  621. - add more docs
  622. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  623. - add probing information in the init file to keep linuxconf happy
  624. - dont strip libbind
  625. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  626. - auto rebuild in the new build environment (release 3)
  627. * Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
  628. - removed 'done' output at named shutdown.
  629. * Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
  630. - version 8.2
  631. * Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
  632. - patch to use the __FDS_BITS macro
  633. - build for glibc 2.1
  634. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  635. - change named.restart to /usr/sbin/ndc restart
  636. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  637. - install man pages correctly.
  638. - change K10named to K45named.
  639. * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
  640. - don't start if /etc/named.conf doesn't exist.
  641. * Sat Aug 8 1998 Jeff Johnson <jbj@redhat.com>
  642. - autmagically create /etc/named.conf from /etc/named.boot in %post
  643. - remove echo in %post
  644. * Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
  645. - merge in 5.1 mods
  646. * Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
  647. - Several essential modifications to build and install correctly.
  648. - Modified 'ndc' to avoid deprecated use of '-'
  649. * Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
  650. - Used buildroot
  651. - patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
  652. on Redhat 5.0 instead of <nlist.h>