bluefish-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332
  1. Name: bluefish
  2. Version: 2.2.7
  3. Release: 1%{?_dist_release}
  4. Summary: Web development application for experienced users
  5. Summary(ja): 経験豊富なユーザー向けの Web 開発アプリケーション
  6. Group: Applications/Editors
  7. License: GPLv3+
  8. URL: http://bluefish.openoffice.nl/
  9. Source0: http://www.bennewitz.com/bluefish/stable/source/%{name}-%{version}.tar.bz2
  10. # Upstream source contains non-free jsmin.py
  11. # To generate clean source, simply rm -rf data/jsmin.py
  12. # We provide a replacement in Source1.
  13. Source1: https://raw.github.com/v8/v8/master/tools/jsmin.py
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: enchant-devel >= 1.4.2
  17. BuildRequires: gettext
  18. BuildRequires: glib2-devel >= 2.24
  19. %if "%{?_dist_release}" < "vl7"
  20. BuildRequires: gtk2-devel >= 2.20
  21. BuildRequires: gucharmap-devel >= 2.20
  22. %else
  23. BuildRequires: gtk3-devel >= 3.2
  24. BuildRequires: gucharmap-devel >= 2.90
  25. %endif
  26. BuildRequires: intltool
  27. BuildRequires: libxml2-devel
  28. BuildRequires: python-devel
  29. # Needed to check man pages
  30. BuildRequires: /usr/bin/man
  31. # For the Advanced Open function
  32. Requires: findutils, grep
  33. Requires: %{name}-shared-data = %{version}-%{release}
  34. # Automatically upgrade bluefish-unstable
  35. Obsoletes: bluefish-unstable < %{version}-%{release}
  36. Provides: bluefish-unstable = %{version}-%{release}
  37. # XML Catalog registration
  38. Requires(post): /usr/bin/xmlcatalog, xml-common
  39. Requires(postun): /usr/bin/xmlcatalog, xml-common
  40. # Don't "provide" plugin shared objects
  41. #%{?filter_setup:
  42. #%filter_provides_in %{_libdir}/%{name}/.*\.so$
  43. #%filter_setup
  44. #}
  45. # Move to unversioned documentation directories from F-20
  46. # https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
  47. %global bluefish_docdir %{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}
  48. %description
  49. Bluefish is a powerful editor for experienced web designers and programmers.
  50. Bluefish supports many programming and markup languages, but it focuses on
  51. editing dynamic and interactive websites.
  52. %package shared-data
  53. Summary: Architecture-independent data for %{name}
  54. Summary(ja): アーキテクチャに依存しない %{name} 共用データ
  55. Group: Applications/Editors
  56. BuildArch: noarch
  57. # For ownership of %%{_datadir}/mime/packages
  58. Requires: shared-mime-info
  59. # For ownership of %%{_datadir}/icons/hicolor/*/{apps,mimetypes}
  60. Requires: hicolor-icon-theme
  61. # Automatically upgrade bluefish-unstable-shared-data
  62. Obsoletes: bluefish-unstable-shared-data < %{version}-%{release}
  63. Provides: bluefish-unstable-shared-data = %{version}-%{release}
  64. %description shared-data
  65. Files common to every architecture version of %{name}.
  66. %prep
  67. %setup -q -n %{name}-%{version}
  68. cp -a %{SOURCE1} data/
  69. sed -i 's|python2.4|python|g' data/jsmin.py
  70. %build
  71. %configure \
  72. --disable-dependency-tracking \
  73. --disable-static \
  74. --disable-update-databases \
  75. --disable-xml-catalog-update \
  76. --docdir=%{bluefish_docdir}
  77. make %{?_smp_mflags}
  78. %install
  79. rm -rf %{buildroot}
  80. mkdir -p %{buildroot}%{_datadir}/applications
  81. make install DESTDIR=%{buildroot} INSTALL="install -p"
  82. # Make zencoding plugin scripts executable to placate rpmlint
  83. find %{buildroot}%{_datadir}/bluefish/plugins/zencoding -name '*.py' |
  84. xargs awk '/^#!/ { print FILENAME }' |
  85. xargs chmod -c +x
  86. %find_lang %{name}
  87. %find_lang %{name}_plugin_about
  88. %find_lang %{name}_plugin_charmap
  89. %find_lang %{name}_plugin_entities
  90. %find_lang %{name}_plugin_htmlbar
  91. %find_lang %{name}_plugin_infbrowser
  92. %find_lang %{name}_plugin_snippets
  93. %find_lang %{name}_plugin_zencoding
  94. cat %{name}_plugin_{about,charmap,entities,htmlbar,infbrowser,snippets,zencoding}.lang >> \
  95. %{name}.lang
  96. desktop-file-validate \
  97. %{buildroot}%{_datadir}/applications/%{name}.desktop
  98. # Manually install docs so that they go into
  99. # %%{bluefish_docdir} even though we put them in the
  100. # shared-data subpackage
  101. install -m 644 -p -t %{buildroot}%{bluefish_docdir}/ \
  102. AUTHORS ChangeLog COPYING NEWS README TODO
  103. # Unpackaged files
  104. rm -f %{buildroot}%{_libdir}/%{name}/*.la
  105. %clean
  106. rm -rf %{buildroot}
  107. %post
  108. /usr/bin/update-mime-database %{_datadir}/mime &> /dev/null || :
  109. /usr/bin/update-desktop-database &> /dev/null || :
  110. /usr/bin/xmlcatalog --noout --add 'delegateURI' \
  111. 'http://bluefish.openoffice.nl/ns/bflang/2.0/' \
  112. '%{_datadir}/xml/%{name}' \
  113. %{_sysconfdir}/xml/catalog &> /dev/null || :
  114. %postun
  115. /usr/bin/update-mime-database %{_datadir}/mime &> /dev/null || :
  116. /usr/bin/update-desktop-database &> /dev/null || :
  117. if [ "$1" = 0 ]; then
  118. /usr/bin/xmlcatalog --noout --del \
  119. 'http://bluefish.openoffice.nl/ns/bflang/2.0/' \
  120. %{_sysconfdir}/xml/catalog &> /dev/null || :
  121. fi
  122. %files
  123. %defattr(-,root,root,-)
  124. %{_bindir}/%{name}
  125. %{_libdir}/%{name}/
  126. %files shared-data -f %{name}.lang
  127. %defattr(-,root,root,-)
  128. %doc %{bluefish_docdir}/
  129. %{_datadir}/%{name}/
  130. %{_datadir}/appdata/*.xml
  131. %{_datadir}/applications/%{name}.desktop
  132. %{_datadir}/mime/packages/%{name}.xml
  133. %{_datadir}/icons/hicolor/*/mimetypes/application-x-bluefish-project.png
  134. %{_datadir}/icons/hicolor/*/apps/%{name}.png
  135. %{_datadir}/icons/hicolor/scalable/mimetypes/bluefish-project.svg
  136. %{_datadir}/icons/hicolor/scalable/apps/bluefish-icon.svg
  137. %{_datadir}/pixmaps/application-x-bluefish-project.png
  138. %{_datadir}/pixmaps/%{name}.png
  139. %{_datadir}/xml/%{name}/
  140. %{_mandir}/man1/%{name}.1*
  141. %changelog
  142. * Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.7-1
  143. - new upstream release
  144. * Fri Nov 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.6-1
  145. - new upstream release
  146. - moved shared-data subpackage to Applications/Editors Group
  147. - updated Summary
  148. * Thu Jan 23 2014 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 2.2.4
  149. - all resources renew from fedora bluefish-2.2.4-3.fc20.src.rpm
  150. * Sun Aug 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.3-1
  151. - new upstream release
  152. - built without gucharmap (VineSeed)
  153. - added BR: libxml2-devel
  154. * Tue Oct 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
  155. - new upstream release
  156. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
  157. - new upstream release
  158. * Fri Mar 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
  159. - new upstream release
  160. - updated BR
  161. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.7-2
  162. - added Japanese description
  163. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.7-1vl5
  164. - applied new versioning policy, spec in utf-8
  165. * Tue Nov 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-0vl2
  166. - rebuilt for Vine Linux 4.0
  167. * Tue Nov 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-0vl1
  168. - new upstream release
  169. * Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl3
  170. - rebuild for VineSeed Plus
  171. * Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl2
  172. - rebuit for VinePlus/3.0
  173. - dropped Patch0 (fixed at upstream version)
  174. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
  175. - new upstream release
  176. * Tue Sep 6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl1.1
  177. - added Patch0 for disable PCRE_UTF8 in highlighting
  178. * Sat Sep 3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl1
  179. - new upstream release
  180. * Thu Aug 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
  181. - rebuild for VineSeed Plus
  182. * Thu Aug 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
  183. - new upstream release
  184. * Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl2
  185. - rebuild for VineSeed Plus
  186. * Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
  187. - new upstream release
  188. * Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl3
  189. - rebuild for VineSeed Plus
  190. * Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl2
  191. - rebuild for VinePlus/3.1
  192. - added BuildRequires: shared-mime-info
  193. * Sun Jun 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
  194. - new upstream release
  195. * Thu May 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0vl2
  196. - rebuild for VineSeed Plus
  197. - added --disable-update-databases option
  198. - run update-mime-database on %post
  199. - added Prereq: shared-mime-info
  200. * Sun Feb 6 2005 Masaki Shinomiya <shino@pos.to> 1.0-0vl1
  201. - new upstream release, make install, files. desktop, compile ja.po
  202. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.13-0vl1
  203. - new upstream release
  204. - dropped patch0
  205. * Mon Jul 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11-0vl1
  206. - new upstream release
  207. * Fri Jul 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10-0vl1
  208. - Rebuild with new toolchains and Gnome2 for VineSeedPlus
  209. - add makefile.patch to fix Makefile.in
  210. - modified encodings.default
  211. * Fri Aug 2 2002 Masaki Shinomiya <shino@pos.to>
  212. - 0.7-0vl1 for VinePllus2.1, 0.7-0vl2 for VinePlus2.5/VineSeedPlus
  213. - vine.patch, without perl
  214. * Fri Mar 1 2002 Shingo Akagaki <dora@kondara.org>
  215. - (0.7-8k)
  216. - fix file attributes
  217. * Thu Feb 21 2002 Shingo Akagaki <dora@kondara.org>
  218. - (0.7-6k)
  219. - rebuild against for db3,4
  220. * Thu Feb 07 2002 Motonobu Ichimura <famao@kondara.org>
  221. - (0.7-4k)
  222. - add perl,attrpage,internal-preview support
  223. * Thu Feb 07 2002 Motonobu Ichimura <famao@kondara.org>
  224. - (0.7-2k)
  225. - add xim patch
  226. - up to 0.7
  227. * Thu Oct 18 2001 Motonobu Ichimura <famao@kondara.org>
  228. - (0.6-4k)
  229. - not egcs, but gcc2.95.3
  230. * Thu Oct 18 2001 Motonobu Ichimura <famao@kondara.org>
  231. - (0.6-2k)
  232. - up to 0.6
  233. - add BuildRequires: egcs ...
  234. - include .desktop file
  235. * Wed Oct 17 2001 Toru Hoshina <t@kondara.org>
  236. - (0.4-10k)
  237. - rebuild against gettext 0.10.40.
  238. * Mon Oct 15 2001 Toru Hoshina <t@kondara.org>
  239. - (0.4-8k)
  240. - rebuild against libpng 1.2.0.
  241. * Sat Dec 2 2000 MATSUDA, Daiki <dyky@df-usa.com>
  242. - (0.4-4k)
  243. - modified spec file with macros
  244. * Thu Jul 13 2000 AYUHANA Tomonori <l@kondara.org>
  245. - (0.4-2k)
  246. - SPEC fixed ( BuildRoot )
  247. - missing bluefish.desktop!
  248. * Tue Jun 13 2000 haruka kusumi <haruka76@kondara.org>
  249. - changed some items for kondara
  250. * Fri May 5 2000 Bo Forslund <bo.forslund@abc.se>
  251. - fine tuning of the spec file
  252. - possible to build with all processors on smp machines
  253. - an entry for RedHats wmconfig
  254. * Tue Mar 21 2000 CW Zuckschwerdt <zany@triq.net>
  255. - complete rewrite of spec file
  256. - relocateable on build-time
  257. - no privileges required while building
  258. - fix for install_location (should really be $(LIBDIR)/bluefish!)
  259. - included man, locale and lib into RPM (was seriously broken)
  260. * Thu Jan 13 2000 Chris Lea <chrislea@luciddesigns.com>
  261. - Fixed up spec file some. bluefish-0.3.5
  262. * Wed Nov 17 1999 Chris Lea <chrislea@luciddesigns.com>
  263. - added spec file. this is my third RPM that I've made a spec
  264. file for, so please be merciful if I've screwed something up