bogofilter-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209
  1. Name: bogofilter
  2. Summary: fast anti-spam filtering by Bayesian statistical analysis
  3. Summary(ja): ベイジアン解析による高速アンチスパムフィルタリング
  4. Version: 1.2.4
  5. Release: 5%{?_dist_release}
  6. License: GPLv2
  7. Group: Applications/Internet
  8. URL: http://bogofilter.sourceforge.net/
  9. Source0: http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
  10. Source999: filter-requires-bogofilter.sh
  11. Patch10: http://www.c-wind.com/bogofilter/bogofilter-%{version}+mecab-0.1.patch.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libdb-devel
  14. BuildRequires: mecab-devel
  15. BuildRequires: gsl-devel
  16. BuildRequires: flex
  17. BuildRequires: xmlto
  18. %define __find_requires %{SOURCE999}
  19. %description
  20. Bogofilter is a Bayesian spam filter. In its normal mode of
  21. operation, it takes an email message or other text on standard input,
  22. does a statistical check against lists of "good" and "bad" words, and
  23. returns a status code indicating whether or not the message is spam.
  24. Bogofilter is designed with fast algorithms (including Berkeley DB system),
  25. coded directly in C, and tuned for speed, so it can be used for production
  26. by sites that process a lot of mail.
  27. %prep
  28. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  29. %setup -q
  30. %patch10 -p1 -b .mecab
  31. %build
  32. export CFLAGS="$RPM_OPT_FLAGS -DWAKATI"
  33. export LIBS="`mecab-config --libs`"
  34. %configure --program-prefix=
  35. %__make
  36. %install
  37. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  38. make install DESTDIR=$RPM_BUILD_ROOT
  39. %__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
  40. %{buildroot}%{_sysconfdir}/bogofilter.cf
  41. for n in xml html ; do
  42. %__install -d -m755 .inst/$n
  43. %__install -p -m644 doc/*.$n .inst/$n
  44. done
  45. #for d in contrib ; do
  46. # %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
  47. # for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
  48. # case $f in
  49. # *.c|*.o|*.obj|*/Makefile*)
  50. # continue
  51. # ;;
  52. # *.1)
  53. # %__cp -p $f %{buildroot}%{_mandir}/man1
  54. # ;;
  55. # *)
  56. # %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
  57. # ;;
  58. # esac
  59. # done
  60. #done
  61. %{__chmod} -x contrib/*
  62. for README in contrib randomtrain ; do
  63. %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
  64. done
  65. # drop executable bit from contrib/* to avoid unneeded dependencies
  66. #%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
  67. # -exec %__chmod -x '{}' \;
  68. %clean
  69. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  70. %files
  71. %defattr(-,root,root)
  72. %doc AUTHORS COPYING INSTALL NEWS
  73. %doc README* RELEASE.NOTES* TODO GETTING.STARTED
  74. %doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
  75. %doc doc/programmer
  76. %doc .inst/html .inst/xml
  77. %doc contrib
  78. %{_sysconfdir}/bogofilter.cf.example
  79. %config(noreplace) %{_sysconfdir}/bogofilter.cf
  80. %{_bindir}/bogofilter
  81. %{_bindir}/bogolexer
  82. %{_bindir}/bogotune
  83. %{_bindir}/bogoutil
  84. %{_bindir}/bogoupgrade
  85. %{_bindir}/bf_compact
  86. %{_bindir}/bf_copy
  87. %{_bindir}/bf_tar
  88. %{_mandir}/man1/bogofilter.1*
  89. %{_mandir}/man1/bogolexer.1*
  90. %{_mandir}/man1/bogotune.1*
  91. %{_mandir}/man1/bogoutil.1*
  92. %{_mandir}/man1/bogoupgrade.1*
  93. %{_mandir}/man1/bf_compact.1*
  94. %{_mandir}/man1/bf_copy.1*
  95. %{_mandir}/man1/bf_tar.1*
  96. %changelog
  97. * Mon Oct 14 2019 Toshiaki Ara <ara_t@384.jp> 1.2.4-5
  98. - rebuild under gsl-2.6
  99. * Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 1.2.4-4
  100. - rebuild under gsl-2.4
  101. * Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 1.2.4-3
  102. - rebuild under gsl-2.2.1
  103. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
  104. - rebuild with gcc-5.4.0
  105. * Thu Feb 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.4-1
  106. - update to 1.2.4
  107. - built with libdb 5.3.28
  108. - BR: xmlto
  109. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
  110. - update to 1.2.3
  111. - use mecab instead of kakasi
  112. - BR: mecab-devel
  113. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
  114. - rebuild with current VineSeed environment
  115. - fix perl requirements
  116. * Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
  117. - new upstream release
  118. - update Patch10
  119. - add Requires: kakasi (<BTS:VineLinux:852>)
  120. - updates Source999: add filtering string
  121. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
  122. - applied new versioning policy, spec in utf-8
  123. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
  124. - rebuild with gsl-1.9
  125. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
  126. - rebuild with db4-4.3
  127. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
  128. - add filter-requires-bogofilter.sh (source999)
  129. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  130. - rebuild
  131. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  132. - new upstream release
  133. - modified kakasi patch
  134. * Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
  135. - rebuild
  136. * Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
  137. - new upstream release
  138. - update kakasi patch
  139. - remove unneeded macro %%mydocdir
  140. - fix symlink
  141. - add Japanese summary
  142. - drop executable bit from contrib/*
  143. * Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
  144. - rebuild
  145. * Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
  146. - new upstream release
  147. - update and modify kakasi patch
  148. - fix dependencies
  149. - add BuildRequires: kakasi-devel, gsl-devel, flex
  150. - add Requires: gsl
  151. - update %%files
  152. - update %%doc
  153. - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
  154. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
  155. - rebuilt with db4-4.2.52
  156. * Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
  157. - new upstream release.
  158. - update kakasi patch.
  159. * Sun May 2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
  160. - new upstream release
  161. - add kakasi patch (http://www.ono.org/software/bogofilter/)
  162. * Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
  163. - upstream release
  164. - using --program-prefix option with configure script
  165. - update %%files section
  166. * Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
  167. - first release for Vine Linux