bonobo-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. # Note this is NOT a relocatable thing :)
  2. %define name bonobo
  3. %define ver 1.0.22
  4. %define rel 8%{?_dist_release}
  5. Summary: CORBA-based component system
  6. Summary(ja): CORBAベースのコンポーネントシステム
  7. Name: %{name}
  8. Version: %{ver}
  9. Release: %{rel}
  10. License: GPL
  11. Group: System Environment/Libraries
  12. Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.0/%{name}-%{ver}.tar.bz2
  13. URL: http://www.gnome.org/
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gnome-libs-devel >= 1.4.2-2vl5
  16. BuildRequires: ORBit-devel >= 0.5.8
  17. BuildRequires: oaf-devel
  18. BuildRequires: libxml-devel >= 1.8.15
  19. BuildRequires: gdk-pixbuf-devel >= 0.21.0-0vl2
  20. BuildRequires: gnome-print-devel >= 0.37-2vl5
  21. BuildRequires: openjade gtk+-devel glib-devel
  22. #BuildRequires: autoconf213, automake14
  23. Requires: gnome-libs >= 1.4.2-2vl5
  24. Requires: ORBit >= 0.5.8
  25. Requires: oaf >= 0.6.2
  26. Requires: libxml >= 1.8.15
  27. Requires: gdk-pixbuf >= 0.21.0-0vl2
  28. Requires: libgnomeprint15 >= 0.37-2vl5
  29. Patch0: bonobo-1.0.17-config.patch
  30. Patch1: bonobo-1.0.22-nonstatic.patch
  31. %description
  32. Bonobo is a library that provides the necessary framework for GNOME
  33. applications to deal with compound documents, i.e. those with a
  34. spreadsheet and graphic embedded in a word-processing document.
  35. %package devel
  36. Summary: Libraries and include files for the Bonobo document model
  37. Summary(ja): Bonobo の開発用ライブラリおよびヘッダファイル
  38. Group: Development/Libraries
  39. Requires: pkgconfig
  40. Requires: %{name} = %{version}
  41. %description devel
  42. This package provides the necessary development libraries and include
  43. files to allow you to develop programs using the Bonobo document model.
  44. %prep
  45. %setup -q
  46. %patch1 -p1 -b .nonstatic
  47. %build
  48. %configure --disable-gtk-doc --disable-static
  49. export tagname=CC
  50. make LIBTOOL=/usr/bin/libtool
  51. %install
  52. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  53. export tagname=CC
  54. %makeinstall LIBTOOL=/usr/bin/libtool
  55. %find_lang %{name}
  56. ## remove unuse files
  57. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  58. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.a
  59. #rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*.la
  60. rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*/*.la
  61. rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*/*.a
  62. %clean
  63. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  64. %post -p /sbin/ldconfig
  65. %postun -p /sbin/ldconfig
  66. %files -f %{name}.lang
  67. %defattr(-, root, root)
  68. %doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
  69. %{_bindir}/*
  70. %exclude %{_bindir}/libefs-config
  71. %{_libdir}/*.so.*
  72. %{_libdir}/bonobo/plugin/*.so
  73. %{_libdir}/bonobo/monikers/*.so
  74. %{_datadir}/bonobo/*
  75. %{_datadir}/gnome/*
  76. %{_datadir}/oaf/*
  77. #%{_datadir}/libefs/*
  78. %{_datadir}/idl/*
  79. %files devel
  80. %defattr (-, root, root)
  81. %{_bindir}/libefs-config
  82. %{_libdir}/*.so
  83. #{_libdir}/*.a
  84. #{_libdir}/*.la
  85. %{_libdir}/*.sh
  86. #%{_libdir}/bonobo/*/*.a
  87. #%{_libdir}/bonobo/*/*.la
  88. %{_libdir}/pkgconfig/*.pc
  89. %{_includedir}/*
  90. %changelog
  91. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.22-8
  92. - rebuilt with gnome-print-0.37-3
  93. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.22-7
  94. - rebuilt with rpm-4.8.1 for pkg-config
  95. * Sat May 2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-6
  96. - rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6)
  97. - remove *.a
  98. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.22-5vl5
  99. - applied new versioning policy, spec in utf-8
  100. - remove *.la
  101. * Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl3
  102. - rebuild with new toolchain
  103. - dropped Patch0
  104. - added Patch1 for compiling new toolchain
  105. * Tue Oct 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl2
  106. - rebuild with db4-4.2.52 and libgnomeprint-0.37
  107. - s/Copyright/License/
  108. - add Japanese summary
  109. - libefs-config moved to devel package
  110. * Sun May 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl1
  111. - 1.0.22 based on Redhat Rawhide 1.0.22-4
  112. - changed Summary and Source URL
  113. * Wed Mar 5 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-0vl3
  114. - rebuilt with new toolchains
  115. - rebuilt with gdk-pixbuf-0.21.0-0vl2
  116. - use legacy autoconf-2.13 and automake-1.4
  117. * Wed Mar 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.17-0vl2
  118. - rebuilt with gdk-pixbuf-0.16.0-0vl1
  119. * Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.17-0vl1
  120. - New upstream release.
  121. * Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.9-0vl1
  122. - updated to the new upstream 1.0.9 release
  123. * Sat Jul 28 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  124. - 1.0.7-0vl1
  125. - updated to new upstream release
  126. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.4-0vl1
  127. - New upstream release.
  128. - Fixed packaging mistake.
  129. * Tue May 8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl2
  130. - Fixed missing files.
  131. * Tue May 8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  132. - New upstream release.
  133. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.37-0vl2
  134. - Fixed defattr macro.
  135. * Tue Mar 13 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.37-0vl1
  136. - New upstream release.
  137. - Added relative execute for config.
  138. * Thu Dec 28 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.31.cvs20001221-0vl1
  139. - Build for Vine
  140. * Wed Oct 18 2000 Eskil Heyn Olsen <eskil@eazel.com>
  141. - Added requirements to the base package
  142. - Added bonobo-ui-extract to the file list of the base pacakge
  143. * Tue Feb 22 2000 Jens Finke <jens.finke@informatik.uni-oldenburg.de>
  144. - Added bonobo.h to the file list of devel package.
  145. * Wed Nov 10 1999 Alexander Skwar <ASkwar@DigitalProjects.com>
  146. - Updated to version 0.5
  147. - fixed spec file
  148. - Un-quiet things
  149. - stripped binaries
  150. - unsetted language environment variables
  151. * Sat Oct 2 1999 Gregory McLean <gregm@comstar.net>
  152. - Updated the spec for version 0.4
  153. - Updated the files section.
  154. * Sun Aug 1 1999 Gregory McLean <gregm@comstar.net>
  155. - Some updates. sysconfdir stuff, quiet down the prep/configure stage.
  156. * Sat May 1 1999 Erik Walthinsen <omega@cse.ogi.edu>
  157. - created spec file