boo-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275
  1. %define debug_package %{nil}
  2. %define monodir %{_prefix}/lib
  3. Summary: An OO statically typed language for CLI
  4. Summary(ja): CLI 用のオブジェクト指向静的型付け言語
  5. Name: boo
  6. Version: 0.9.4.9
  7. Release: 4%{?_dist_release}
  8. License: MIT
  9. Group: Development/Languages
  10. URL: http://boo.codehaus.org
  11. Source0: http://dist.codehaus.org/boo/distributions/%{name}-%{version}-src.tar.bz2
  12. Patch0: boo-pkgconfig_path_fix.patch
  13. Patch1: boo-gtksourceview.patch
  14. Patch3: mono-2.0.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: mono-devel
  17. BuildRequires: gtksourceview2-devel
  18. BuildRequires: shared-mime-info
  19. BuildRequires: pkgconfig
  20. BuildRequires: nant
  21. BuildArch: noarch
  22. Requires(post): shared-mime-info
  23. Requires(postun): shared-mime-info
  24. %description
  25. Boo is a new object oriented statically typed programming language for the
  26. Common Language Infrastructure with a python inspired syntax and a special
  27. focus on language and compiler extensibility.
  28. %package devel
  29. Summary: Development files for boo
  30. Summary(ja): boo の開発用ファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. Development files for boo
  35. %prep
  36. %setup -q
  37. %patch0 -p1 -b .pc-original
  38. %patch1 -p1 -b .sourceview
  39. %patch3 -p1 -b .mono-2.0.patch
  40. # Get rid of prebuilt dll files
  41. rm -rf bin/*.dll bin/pt/*.dll
  42. # fix end-of-line encoding
  43. perl -pi -e 's/\r//' $(find examples/ -type f)
  44. %build
  45. nant -nologo -D:install.prefix=%{_prefix} -D:install.libdir=%{monodir}
  46. %install
  47. rm -rf %{buildroot}
  48. nant -f:default.build install -D:install.buildroot=%{buildroot} -D:install.prefix=%{buildroot}%{_prefix} -D:install.share=%{buildroot}%{_datadir} -D:install.libdir=%{buildroot}%{monodir} -D:install.bindir=%{buildroot}%{_bindir} -D:fakeroot.sharedmime=%{buildroot}%{_datadir}/.. -D:fakeroot.gsv=%{buildroot}%{_prefix}
  49. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  50. #test "%{_libdir}" = "%{_prefix}/lib" || mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  51. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pkgconfig
  52. mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT/%{_datadir}/pkgconfig
  53. %clean
  54. rm -rf %{buildroot}
  55. %post
  56. update-mime-database %{_datadir}/mime &> /dev/null || :
  57. %postun
  58. update-mime-database %{_datadir}/mime &> /dev/null || :
  59. %files
  60. %defattr(-,root,root,-)
  61. %doc license.txt notice.txt readme.txt docs/BooManifesto.sxw
  62. %{monodir}/boo*/
  63. %exclude %{monodir}/boo/Boo.NAnt.Tasks.dll
  64. %exclude %{monodir}/boo/Boo.Microsoft.Build.*
  65. %dir %{monodir}/mono/boo
  66. %{monodir}/mono/boo/*.dll
  67. %{monodir}/mono/gac/Boo*/
  68. %{_bindir}/boo*
  69. %exclude %{_datadir}/gtksourceview-1.0/language-specs/boo.lang
  70. %{_datadir}/mime/packages/boo*
  71. %{_datadir}/mime-info/boo*
  72. %files devel
  73. %defattr(-,root,root,-)
  74. %{monodir}/boo/Boo.Microsoft.Build.*
  75. %{monodir}/boo/Boo.NAnt.Tasks.dll
  76. %{_datadir}/pkgconfig/boo.pc
  77. %changelog
  78. * Wed Apr 1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.4.9-4
  79. - fixed pkgconfig location
  80. * Tue Mar 31 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.4.9-3
  81. - added Patch3 to build with current VineSeed
  82. - built with nant 0.92+git20130131
  83. * Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.4.9-2
  84. - fix %%files
  85. * Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.4.9-1
  86. - initial build for Vine Linux
  87. * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4.9-4
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  89. * Mon Nov 21 2011 Christian Krause <chkr@fedoraproject.org> - 0.9.4.9-3
  90. - Change paths for mono assemblies according to updated packaging
  91. guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
  92. * Tue Apr 19 2011 Dan Horák <dan[at]danny.cz> - 0.9.4.9-2
  93. - updated the supported arch list
  94. * Fri Feb 18 2011 Paul Lange <palango@gmx.de> - 0.9.4.9-1
  95. - update to 0.9.4
  96. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.3.3457-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  98. * Thu Oct 14 2010 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.9.3.3457-1
  99. - Update to newest version
  100. - Alter BR nant to BR nant-devel
  101. * Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.9.2.3383-3
  102. - ExcludeArch sparc64
  103. * Tue Oct 06 2009 Paul Lange <palango@gmx.de> - 0.9.2.3383-2
  104. - Move Boo.NAnt.Tasks.dll to boo-devel
  105. * Wed Sep 16 2009 Paul Lange <palango@gmx.de> - 0.9.2.3383-1
  106. - Update to boo 0.9.2
  107. - remove libdir patch
  108. * Fri Aug 28 2009 Paul Lange <palango@gmx.de> - 0.9.1.3287-3
  109. - Fix executable paths
  110. * Thu Aug 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.9.1.3287-2
  111. - Fix libdir in boo.pc to use %{_libdir}
  112. - Summary no longer repeats package name
  113. * Sun Aug 02 2009 Paul Lange <palango@gmx.de> - 0.9.1.3287-1
  114. - Update to boo 0.9.1
  115. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1.2865-8
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  117. * Mon Jun 15 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 0.8.1.2865-7
  118. - Include missing directory entries (#473630).
  119. * Mon Apr 20 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.8.1.2865-6
  120. - Fix FTBFS: added boo-mono.patch
  121. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1.2865-5
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  123. * Sat Apr 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.8.1.2865-4
  124. - get rid of prebuilt binary files
  125. * Tue Mar 4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.8.1.2865-3
  126. - Rebuild for new nant (causes broken deps)
  127. * Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.8.1-2865-2
  128. - Nope, ppc still broken (#434631)
  129. * Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.8.1-2865-1
  130. - Bump to 0.8.1
  131. - Exclude Visual Studio Environment buildtarget
  132. - Reenable ppc
  133. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.8.0.2730-9
  134. - Autorebuild for GCC 4.3
  135. * Thu Jan 03 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-7
  136. - spec fix
  137. * Wed Dec 19 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-6
  138. - remove ppc build
  139. - fix libdir problem for pc file
  140. * Sun Dec 16 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-5
  141. - reenable ppc
  142. * Thu Nov 22 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-4
  143. - fixes to patches for corrected libdirs
  144. * Sat Nov 17 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-3
  145. - Added exclusivearch
  146. * Sun Nov 11 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.8.0-2730-2
  147. - large bump
  148. - removed fc5 and fc6 bit6
  149. - removed MS update builds from default build
  150. - fixed problem with the boo.pc file
  151. * Sun Feb 18 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6-2237-13
  152. - fix for correct libdir in bin scripts
  153. * Wed Dec 20 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6-2237-11
  154. - fix for correct libdir
  155. * Thu Sep 14 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-9
  156. - rebuild
  157. * Mon Aug 07 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-8
  158. - adds conditional for boo.lang - not required in FC6
  159. * Wed Jul 26 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-7
  160. - claims ownership of monodir-boo now
  161. * Tue Jul 25 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-6
  162. - replaced monodir for libdir in devel
  163. - fixed tab-spaces problem
  164. - removed rm rf from the prep step
  165. - added update-mime-database
  166. * Sun Jul 23 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-5
  167. - removed nodebug
  168. - removed redefine of libdir
  169. - removed buildarch
  170. - added BR nant
  171. * Sat Jun 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-3
  172. - removed exclusivearch
  173. - changed BR
  174. - removed R
  175. - altered nant to /usr/bin/nant
  176. * Thu Jun 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-1
  177. - Spec file fixes
  178. - Fix for gtksourceview-1.0 langspecs
  179. - Added fixed libdir
  180. - rebuild for mono 1.1.15
  181. * Thu Jun 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.6.2237-1
  182. - Bump to 0.7.6-2237
  183. - Added R nant
  184. - Multiple fixes to the install as it uses nant rather than make install
  185. - Removed some bits from the files section as they're no longer in boo
  186. * Wed May 31 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2013-7
  187. - Added devel files
  188. - Added doc to files section instead of adding the files manually
  189. - Added fix for x86_64
  190. * Mon May 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2013-6
  191. - Altered again for mock and x86_64
  192. * Fri Apr 28 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-5
  193. - added shared mime to satisfy mock
  194. * Sat Apr 22 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-4
  195. - Removal of the always usr-lib, but now use the system used in f-spot
  196. - include archs mono is available on
  197. - added requires: mono-core, gtksourceview
  198. - changed BR to include gtksourceview-sharp
  199. - removes the conflict in the language-specs with gtksourceview package
  200. * Tue Apr 18 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-3
  201. - Spec file tweaks
  202. - libdir is now usr-lib irrespective of hardware built on
  203. - Added docs to package
  204. * Mon Apr 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-2
  205. - Small fix to the spec file
  206. * Sat Apr 15 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7.5.2003-1
  207. - Initial import and debug for FE (spec file based on the mono project one)